Автор Тема: Debian 8.2.0 и Systemback проблема  (Прочитано 6155 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Psyside

Debian 8.2.0 и Systemback проблема
« : 20 Декабря 2015, 12:54:45 »
В продолжении своей темы пляски с бубном решил отдельно описать проблему по установке systemback
Установка "по человечески" в Debian 8 видимо отсутствуют.
Spoiler: ShowHide
ya@ya-PC:~$ sudo add-apt-repository ppa:nemh/systemback
You are about to add the following PPA to your system:
 Simple system backup and restore application with extra features

Systemback makes it easy to create backups of the system and the users configuration files. In case of problems you can easily restore the previous state of the system. There are extra features like system copying, system installation and Live system creation.

This PPA contain the stable version of Systemback.

Currently supported Ubuntu releases:
- 14.04.X LTS
- 15.04
- 15.10
- 16.04.X LTS (initial)
 More info: https://launchpad.net/~nemh/+archive/ubuntu/systemback
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: создана таблица ключей `/tmp/tmp_izst_nb/secring.gpg'
gpg: создана таблица ключей `/tmp/tmp_izst_nb/pubring.gpg'
gpg: запрашиваю ключ 73C62A1B с hkp сервера keyserver.ubuntu.com
gpg: /tmp/tmp_izst_nb/trustdb.gpg: создана таблица доверия
gpg: ключ 73C62A1B: импортирован открытый ключ "Launchpad PPA for Kendek"
gpg: Всего обработано: 1
gpg:                  импортировано: 1  (RSA: 1)
OK
ya@ya-PC:~$ sudo apt-get update
В кэше http://security.debian.org jessie/updates InRelease
Игн http://ppa.launchpad.net jessie InRelease                                 
Игн http://ppa.launchpad.net jessie Release.gpg                               
Игн http://ppa.launchpad.net jessie Release                                   
Игн http://httpredir.debian.org jessie InRelease                               
В кэше http://httpredir.debian.org jessie-updates InRelease                   
В кэше http://security.debian.org jessie/updates/main Sources                 
В кэше http://httpredir.debian.org jessie Release.gpg                         
В кэше http://security.debian.org jessie/updates/contrib Sources               
В кэше http://security.debian.org jessie/updates/main amd64 Packages           
В кэше http://security.debian.org jessie/updates/contrib amd64 Packages       
В кэше http://security.debian.org jessie/updates/main i386 Packages           
В кэше http://httpredir.debian.org jessie-updates/main Sources                 
В кэше http://security.debian.org jessie/updates/contrib i386 Packages         
В кэше http://httpredir.debian.org jessie-updates/contrib Sources             
В кэше http://security.debian.org jessie/updates/contrib Translation-en       
В кэше http://security.debian.org jessie/updates/main Translation-en           
Получено:1 http://httpredir.debian.org jessie-updates/main amd64 Packages/DiffIndex [367 B]
В кэше http://httpredir.debian.org jessie-updates/contrib amd64 Packages       
Получено:2 http://httpredir.debian.org jessie-updates/main i386 Packages/DiffIndex [367 B]
В кэше http://httpredir.debian.org jessie-updates/contrib i386 Packages       
В кэше http://httpredir.debian.org jessie-updates/contrib Translation-en       
В кэше http://httpredir.debian.org jessie-updates/main Translation-en         
В кэше http://httpredir.debian.org jessie Release                             
Ош  http://ppa.launchpad.net jessie/main amd64 Packages           
  404  Not Found
Ош  http://ppa.launchpad.net jessie/main i386 Packages
  404  Not Found
Игн http://ppa.launchpad.net jessie/main Translation-ru_RU                     
В кэше http://httpredir.debian.org jessie/main Sources                         
Игн http://ppa.launchpad.net jessie/main Translation-ru                       
В кэше http://httpredir.debian.org jessie/main amd64 Packages                 
Игн http://ppa.launchpad.net jessie/main Translation-en                       
В кэше http://httpredir.debian.org jessie/main i386 Packages                   
В кэше http://httpredir.debian.org jessie/main Translation-ru
В кэше http://httpredir.debian.org jessie/main Translation-en
Получено 734 Б за 3с (189 Б/c)
W: Не удалось получить http://ppa.launchpad.net/nemh/systemback/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found

W: Не удалось получить http://ppa.launchpad.net/nemh/systemback/ubuntu/dists/jessie/main/binary-i386/Packages  404  Not Found

E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.
ya@ya-PC:~$ sudo apt-get install systemback
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
E: Не удалось найти пакет systemback


Нашел вот такое решение http://unix.stackexchange.com/questions/215633/debians-corresponding-command-for-add-apt-repository
Мы ведь не ищем легких путей
Spoiler: ShowHide
ya@ya-PC:~$ sudo apt-get install systemback
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 systemback : Зависит: libqt5core5a (>= 5.4.0) но 5.3.2+dfsg-4+deb8u1 будет установлен
              Зависит: systemback-scheduler (= 1.7.301~ubuntu15.04.1) но он не будет установлен
              Рекомендует: grub-efi-amd64-bin
              Рекомендует: lupin-casper но он не может быть установлен
              Рекомендует: systemback-cli (= 1.7.301~ubuntu15.04.1) но он не будет установлен
              Рекомендует: systemback-locales (= 1.7.301~ubuntu15.04.1) но он не будет установлен
              Рекомендует: ttf-ubuntu-font-family но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
ya@ya-PC:~$ sudo apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
ya@ya-PC:~$ sudo apt-get install systemback
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 systemback : Зависит: libqt5core5a (>= 5.4.0) но 5.3.2+dfsg-4+deb8u1 будет установлен
              Зависит: systemback-scheduler (= 1.7.301~ubuntu15.04.1) но он не будет установлен
              Рекомендует: grub-efi-amd64-bin
              Рекомендует: lupin-casper но он не может быть установлен
              Рекомендует: systemback-cli (= 1.7.301~ubuntu15.04.1) но он не будет установлен
              Рекомендует: systemback-locales (= 1.7.301~ubuntu15.04.1) но он не будет установлен
              Рекомендует: ttf-ubuntu-font-family но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Куда копать дальше? На этом мое терпение заканчивается... Или debian 8 не пригодна для пользования обычных смертных??? Нужно всю жизнь посвятить изучению linux?
 >:( >:( >:(
 

Оффлайн Brainey

Re: Debian 8.2.0 и Systemback проблема
« Ответ #1 : 20 Декабря 2015, 13:28:19 »
"Коварный" Debian может ломаться от "человеческой" установки левых репозиториев от другого дистрибутива  :D
Тема PPA на форуме обсосана множество раз, так что повторяться больше не хочется.
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн Make_Believe

Re: Debian 8.2.0 и Systemback проблема
« Ответ #2 : 20 Декабря 2015, 13:55:15 »
"Коварный" Debian может ломаться от "человеческой" установки левых репозиториев от другого дистрибутива  :D
Тема PPA на форуме обсосана множество раз, так что повторяться больше не хочется.
Если знаешь, так напиши ну в крайнем случае дай ссылку на описание решения проблемы, пустые ответы писать ты мастак, вижу. Сам новичок в линукс(я о себе) и с такими как ты сталкиваюсь постоянно. Вспомни и ты с тупыми вопросами доставал всех и вся.

А ответ в этом:

Игн http://ppa.launchpad.net jessie Release

в ubuntu нет такого, измени в sources.list - jessie на имя дистрибутива ubuntu и все обновится на ура, а вот установишь или нет... это вопрос, у меня в последней версии полезли неразрешимые зависимоти. А до нее стояла какая-то предыдущая версия, работала. Но систему спасти не смогла, после восстановления так и не заработала. Считаю лучшим - tar или rsync.

В последний раз работала версия Systemback_Install_Pack_v1.5.101.tar.xz ставил из этого архива. Ищи ее если интересно.
« Последнее редактирование: 20 Декабря 2015, 14:00:33 от Make_Believe »
Есть, что сказать по теме, скажи. Нет, проходи мимо.
 
Пользователи, которые поблагодарили этот пост: Psyside

Оффлайн Psyside

Re: Debian 8.2.0 и Systemback проблема
« Ответ #3 : 20 Декабря 2015, 14:27:58 »
Make_Believe, спасибо за помощь и поддержку! Поменял на trusty. Вроде как все ок
Но проблема вида
Spoiler: ShowHide
пакеты, имеющие неудовлетворённые зависимости:
 systemback : Зависит: libsystemback (= 1.7.301~ubuntu14.04.1) но он не будет установлен
              Зависит: systemback-scheduler (= 1.7.301~ubuntu14.04.1) но он не будет установлен
              Рекомендует: lupin-casper но он не может быть установлен
              Рекомендует: systemback-cli (= 1.7.301~ubuntu14.04.1) но он не будет установлен
              Рекомендует: ttf-ubuntu-font-family но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

осталась  :'(
 

Оффлайн Make_Believe

Re: Debian 8.2.0 и Systemback проблема
« Ответ #4 : 20 Декабря 2015, 14:38:53 »

Я писал о неразрешимых зависимостях, если не изменяет память, то они потянут за собой еще кучу всякого хлама. Отказался от установки этой версии пакета. Если хочешь попробовать эту программу то скачай Systemback_Install_Pack_v1.5.101.tar.xz этот архив, там кажись все необходимые, левые, зависимости. Все устанавливается. Посмотри, попробуй. Только повторюсь, что у меня после сбоя, систему восстановить этой программой не удалось. Благо был архив системы сделанный tar.

« Последнее редактирование: 20 Декабря 2015, 14:42:54 от Make_Believe »
Есть, что сказать по теме, скажи. Нет, проходи мимо.
 
Пользователи, которые поблагодарили этот пост: Psyside

Оффлайн Psyside

Re: Debian 8.2.0 и Systemback проблема
« Ответ #5 : 20 Декабря 2015, 14:42:11 »
Make_Believe, поставил, все зависимости встали. с tar не знаком...
 Осталось испытать systemback
Эх почему все так сложно, даже какую то программульку чтоб поставить, чтолько телодвижений...
 

Оффлайн Make_Believe

Re: Debian 8.2.0 и Systemback проблема
« Ответ #6 : 20 Декабря 2015, 14:48:32 »
с tar не знаком...

Эх почему все так сложно, даже какую то программульку чтоб поставить, чтолько телодвижений...
tar - это просто архиватор. Архивируешь, что надо, хоть всю систему(это ведь не винда) а потом восстанавливаешься из архива. Все гениальное просто.
А мне нравится то что столько теледвижений. Раз занялся бэкапом системы, значит тебе интересно покопаться в системе... А раз так то без консоли не обойтись. А именно там решаются все вопросы)) В винде я этим вопросом не задавался, а после перехода на Debian, понял, чего мне не хватало... консоли:)

Cообщение объединено 20 Декабря 2015, 14:50:06
trusty
попробуй, если в репозитории есть, замени имя дистрибутива на более ранний. А вось прокатит.
« Последнее редактирование: 20 Декабря 2015, 14:50:06 от Make_Believe »
Есть, что сказать по теме, скажи. Нет, проходи мимо.
 

Оффлайн ZEN

Re: Debian 8.2.0 и Systemback проблема
« Ответ #7 : 20 Декабря 2015, 18:08:01 »
Без проблем собрал systemback из исходников. Вот действия пошагово:

zen@intel:~$ cd /tmp

zen@intel:/tmp$ sudo apt-get install devscripts dh-make build-essential
...

zen@intel:/tmp$ dget -x -u http://ppa.launchpad.net/nemh/systemback/ubuntu/pool/main/s/systemback/systemback_1.7.301~ubuntu14.04.1.dsc
...

zen@intel:/tmp$ cd systemback-1.7.301~ubuntu14.04.1/
...

zen@intel:/tmp/systemback-1.7.301~ubuntu14.04.1$ dpkg-checkbuilddeps
dpkg-checkbuilddeps: Неудовлетворённые сборочные зависимости: libblkid-dev libmount-dev libncursesw5-dev libparted0-dev qtbase5-dev qttools5-dev-tools

zen@intel:/tmp/systemback-1.7.301~ubuntu14.04.1$ sudo apt-get install libblkid-dev libmount-dev libncursesw5-dev libparted0-dev qtbase5-dev qttools5-dev-tools
...

zen@intel:/tmp/systemback-1.7.301~ubuntu14.04.1$ dpkg-buildpackage -rfakeroot -b
...
dpkg-buildpackage: ошибка: отказ при подписывании файла .changes

zen@intel:/tmp/systemback-1.7.301~ubuntu14.04.1$ ls ../*.deb -1
../libsystemback_1.7.301~ubuntu14.04.1_amd64.deb
../libsystemback-dbg_1.7.301~ubuntu14.04.1_amd64.deb
../systemback_1.7.301~ubuntu14.04.1_amd64.deb
../systemback-cli_1.7.301~ubuntu14.04.1_amd64.deb
../systemback-cli-dbg_1.7.301~ubuntu14.04.1_amd64.deb
../systemback-dbg_1.7.301~ubuntu14.04.1_amd64.deb
../systemback-efiboot-amd64_1.7.301~ubuntu14.04.1_all.deb
../systemback-locales_1.7.301~ubuntu14.04.1_all.deb
../systemback-scheduler_1.7.301~ubuntu14.04.1_amd64.deb
../systemback-scheduler-dbg_1.7.301~ubuntu14.04.1_amd64.deb

zen@intel:/tmp/systemback-1.7.301~ubuntu14.04.1$ sudo dpkg -i $(ls ../*systemback*.deb | grep -v dbg)
...
dpkg: зависимости пакетов не позволяют настроить пакет systemback:
 systemback зависит от casper | live-boot, однако:
  Пакет casper не установлен.
  Пакет live-boot не установлен.
 systemback зависит от genisoimage, однако:
  Пакет genisoimage не установлен.
 systemback зависит от squashfs-tools, однако:
  Пакет squashfs-tools не установлен.
 systemback зависит от syslinux, однако:
  Пакет syslinux не установлен.
 systemback зависит от syslinux (<< 3:5) | isolinux (>> 3:6), однако:
  Пакет syslinux не установлен.
  Пакет isolinux не установлен.
 systemback зависит от syslinux (<< 3:5) | syslinux-common (>> 3:6), однако:
  Пакет syslinux не установлен.
  Пакет syslinux-common не установлен.
 systemback зависит от syslinux (<
dpkg: ошибка при обработке пакета systemback (--install):
 проблемы зависимостей — оставляем не настроенным
...
При обработке следующих пакетов произошли ошибки:
 systemback
 
zen@intel:/tmp/systemback-1.7.301~ubuntu14.04.1$ sudo apt-get install -f
...

# PROFIT!
Crimea is Ukraine
 

Оффлайн Psyside

Re: Debian 8.2.0 и Systemback проблема
« Ответ #8 : 21 Декабря 2015, 11:46:24 »
Make_Believe, после установки архива и перезагрузки у меня слетел KDE. По незнанию в вопросах восстановления, предстоит переустановка системы.  ::)
 

Оффлайн RedEye

Re: Debian 8.2.0 и Systemback проблема
« Ответ #9 : 15 Мая 2017, 10:40:22 »
for Debian Jessie Stable v.8.8.0
1.скачать архив https://sourceforge.net/projects/systemback/files/latest/download?source=typ_redirect
2.распаковать архив
3.установка: в найденном распакованном архиве находим файл install.sh назначаем права sudo chmod 100 install.sh , делая его исполняемым и запускаем  sudo sh install.sh. После этого обновляем систему
apt-get update && apt-get upgrade -y

все должно работать.
 

Теги:
     

    Виснит Debian

    Автор zotov228

    Ответов: 5
    Просмотров: 876
    Последний ответ 30 Июня 2018, 21:00:58
    от vovan--vovan
    Flash на debian 6

    Автор YDen

    Ответов: 9
    Просмотров: 2483
    Последний ответ 26 Апреля 2012, 15:10:33
    от Brainey
    Не работает Telegram-desktop в Debian-Buster

    Автор dron79-79

    Ответов: 9
    Просмотров: 2206
    Последний ответ 25 Января 2020, 15:22:25
    от Modigar
    Боковая цифровая клавиатура не работает. Debian 7.

    Автор karlkorp

    Ответов: 3
    Просмотров: 3223
    Последний ответ 09 Апреля 2013, 11:56:27
    от karlkorp
    [Решено] Обновление debian 6 (squeeze) до 7 (wheezy). Вопросы.

    Автор Vic

    Ответов: 30
    Просмотров: 8290
    Последний ответ 06 Февраля 2014, 10:04:39
    от Malaheenee