Автор Тема: не могу установить драйвер mediatek  (Прочитано 3734 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн regina

  • Новичок форума
  • Сообщений: 7
не могу установить драйвер mediatek
« : 14 Февраля 2016, 18:46:31 »
    *
    Сообщений: 1
        Просмотр профиля Личное сообщение (Онлайн)

не могу установить драйвер для wi-fi адаптера
« : Сегодня в 16:56:57 »

    Удалить

помогите установить драйвер Mediatek MT7630E.скачала от сюда http://www.mediatek.com/en/downloads/mt7630-pcie/.использую (т.е пытаюсь использовать)Linux amnesia 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) x86_64 GNU/Linux.ПОЖАЛУЙСТА ОБРАТИТЕ ВНИМАНИЕ С LINUX СТАЛКНУЛАСЬ ПЕРВЫЙ РАЗ,ОЧЕНЬ РАСЧИТЫВАЮ НА ПОМОЩЬ И ПОНИМАНИЕ.Я СКАЧАЛА ДРАЙВЕР И РАСПОКАВАЛА ЕГО.ПОТОМ В ТЕРМИНАЛЕ ОТ С/П ВВОЖУ КОМАНДУ root@amnesia:/home/amnesia# apt-get install mt7630e
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
E: Не удалось найти пакет mt7630e
root@amnesia:/home/amnesia# do apt-get install '/home/amnesia/Persistent/Tor Browser/MT7630E_3.16-master.zip'
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
E: Не удалось найти пакет /home/amnesia/Persistent/Tor Browser
и много еще разных вариантов пробывала новсе ни так,предполагаю что не так распокавала или что то нужно сделать с этим драйвером типа компливировать или что типа этого.СКАЖИТЕ ЧТО Я НИТАК ДЕЛАЮ
* пользуйтесь тегами для оформления. endru
« Последнее редактирование: 15 Февраля 2016, 05:54:02 от endru »
 

Оффлайн alsoijw

Re: не могу установить драйвер mediatek
« Ответ #1 : 14 Февраля 2016, 18:53:48 »
regina, apt-get устанавливает программы из репозитория. В последних версиях он научился ставить изконкреный файл. В 8 дебиане надо ставить через dpkg -i имя пакета. У пакетов расширение .deb Что находится в архиве который ты скачал?
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Оффлайн regina

  • Новичок форума
  • Сообщений: 7
Re: не могу установить драйвер mediatek
« Ответ #2 : 14 Февраля 2016, 18:54:50 »
потом делаю так

oot@amnesia:/home/amnesia# cd Загрузки/MT7630E-release
root@amnesia:/home/amnesia/Загрузки/MT7630E-release# sudo chmod +x install
root@amnesia:/home/amnesia/Загрузки/MT7630E-release# sudo ./install
./install: line 8: make: команда не найдена
./install: line 9: make: команда не найдена
modprobe: FATAL: Module mt7630e not found.
modprobe: FATAL: Module mt76xx not found.
root@amnesia:/home/amnesia/Загрузки/MT7630E-release#


Cообщение объединено 14 Февраля 2016, 18:58:01
oot@amnesia:/home/amnesia/Загрузки/MT7630E-release# dpkg -i mt7630e.deb
dpkg: ошибка при обработке архива mt7630e.deb (--install):
 нет доступа к архиву: No such file or directory
При обработке следующих пакетов произошли ошибки:
 mt7630e.deb
root@amnesia:/home/amnesia/Загрузки/MT7630E-release# dpkg -i '/home/amnesia/Загрузки/MT7630E-release.zip'.deb
dpkg: ошибка при обработке архива /home/amnesia/Загрузки/MT7630E-release.zip.deb (--install):
 нет доступа к архиву: No such file or directory
При обработке следующих пакетов произошли ошибки:
 /home/amnesia/Загрузки/MT7630E-release.zip.deb
root@amnesia:/home/amnesia/Загрузки/MT7630E-release#

« Последнее редактирование: 15 Февраля 2016, 05:51:51 от endru »
 

Оффлайн alsoijw

Re: не могу установить драйвер mediatek
« Ответ #3 : 14 Февраля 2016, 19:10:28 »
regina, от того что ты допишешь deb zip не станет deb файлом. Тор емнип надо просто распаковать и он готов к запуску.
./install: line 8: make: команда не найдена
./install: line 9: make: команда не найдена
Надо установить make. Устанавливать надо либо от рута либо через sudo(если он установлен и настроен)
sudo apt install makeилиsu
apt install make
Кроме make скорее всего понадобятся другие инструменты. Приведите под спойлер README
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Оффлайн regina

  • Новичок форума
  • Сообщений: 7
Re: не могу установить драйвер mediatek
« Ответ #4 : 14 Февраля 2016, 19:19:18 »
не получается
root@amnesia:/home/amnesia# sudo apt install make
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 libxneur : Зависит: libxosd2 (>= 2.2.14) но он не будет установлен
 xneur : Зависит: libxosd2 (>= 2.2.14) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
root@amnesia:/home/amnesia# apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  libxosd2
НОВЫЕ пакеты, которые будут установлены:
  libxosd2
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 5 пакетов.
Необходимо скачать 0 B/24,9 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 67,6 kB.
Хотите продолжить? [Д/н] д
E: Неверная сигнатура архива
E: Внутренняя ошибка, не удалось найти составную часть control.tar.{gzbz2xzlzma}
E: Prior errors apply to /var/cache/apt/archives/libxosd2_2.2.14-2.1_i386.deb
debconf: ошибка при работе apt-extracttemplates: No such file or directory
dpkg-deb: ошибка: «/var/cache/apt/archives/libxosd2_2.2.14-2.1_i386.deb» не является архивом в формате debian
dpkg: ошибка при обработке архива /var/cache/apt/archives/libxosd2_2.2.14-2.1_i386.deb (--unpack):
 подпроцесс dpkg-deb --control возвратил код ошибки 2
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libxosd2_2.2.14-2.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@amnesia:/home/amnesia#



Cообщение объединено 14 Февраля 2016, 19:24:20
root@amnesia:/home/amnesia# su
root@amnesia:/home/amnesia# apt install make
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 libxneur : Зависит: libxosd2 (>= 2.2.14) но он не будет установлен
 xneur : Зависит: libxosd2 (>= 2.2.14) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
root@amnesia:/home/amnesia# apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  libxosd2
НОВЫЕ пакеты, которые будут установлены:
  libxosd2
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 5 пакетов.
Необходимо скачать 0 B/24,9 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 67,6 kB.
Хотите продолжить? [Д/н] д
E: Неверная сигнатура архива
E: Внутренняя ошибка, не удалось найти составную часть control.tar.{gzbz2xzlzma}
E: Prior errors apply to /var/cache/apt/archives/libxosd2_2.2.14-2.1_i386.deb
debconf: ошибка при работе apt-extracttemplates: No such file or directory
dpkg-deb: ошибка: «/var/cache/apt/archives/libxosd2_2.2.14-2.1_i386.deb» не является архивом в формате debian
dpkg: ошибка при обработке архива /var/cache/apt/archives/libxosd2_2.2.14-2.1_i386.deb (--unpack):
 подпроцесс dpkg-deb --control возвратил код ошибки 2
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libxosd2_2.2.14-2.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@amnesia:/home/amnesia#

« Последнее редактирование: 15 Февраля 2016, 05:52:23 от endru »
 

Оффлайн alsoijw

Re: не могу установить драйвер mediatek
« Ответ #5 : 14 Февраля 2016, 19:34:28 »
lsb_release -a
cat /etc/apt/source.list
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Оффлайн regina

  • Новичок форума
  • Сообщений: 7
Re: не могу установить драйвер mediatek
« Ответ #6 : 14 Февраля 2016, 19:39:50 »
root@amnesia:/home/amnesia# lsb_release -a
bash: lsb_release: команда не найдена
root@amnesia:/home/amnesia# cat /etc/apt/source.list
cat: /etc/apt/source.list: No such file or directory
 

Оффлайн alsoijw

Re: не могу установить драйвер mediatek
« Ответ #7 : 14 Февраля 2016, 19:54:14 »
cat /etc/apt/sources.list
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Оффлайн ferum

Re: не могу установить драйвер mediatek
« Ответ #8 : 14 Февраля 2016, 19:57:56 »
не получается
Детский сад штаны на лямках.... По идее модераторы должны вынести предупреждение. Вопрос же должен строиться примерно так: Нашла драйвер https://github.com/tobiasBora/MT7630E_3.16
Установила инструменты для сборки
su
# apt-get update
# apt-get install build-essential git
# cd /usr/src
# git clone https://github.com/tobiasBora/MT7630E_3.16.git
# cd MT7630E_3.16
# make compile
и вот если с этого момента пошли ошибки и не удаётся нагуглить их решения то вывод консоли под спойлер и мольбы о помощи.
« Последнее редактирование: 14 Февраля 2016, 20:00:07 от ferum »
Русские дебианщики против цифрового слабоумия !
 

Оффлайн regina

  • Новичок форума
  • Сообщений: 7
Re: не могу установить драйвер mediatek
« Ответ #9 : 14 Февраля 2016, 20:08:22 »
Извините плиз,давайте спишим на неопытность
 

Оффлайн ferum

Re: не могу установить драйвер mediatek
« Ответ #10 : 14 Февраля 2016, 20:22:59 »
Хм , ну я ошибся на пол минуты, пакет с основными инструментами build-essential
Странно почему у вас скачивание исходников обрывается. То что вы ещё используете тор для подключения к совершенно безобидному ресурсу ...возможно у вас проблемы с интернет провайдером. Я проверил исходники загружаются без проблем.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн regina

  • Новичок форума
  • Сообщений: 7
Re: не могу установить драйвер mediatek
« Ответ #11 : 14 Февраля 2016, 20:24:48 »
это tails я так понимаю что в обход тора не пускает,что посоветуете?


Cообщение объединено 14 Февраля 2016, 20:28:49
root@amnesia:/usr/src# apt-get install build-essential
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 build-essential : Зависит: gcc (>= 4:4.9.1) но он не будет установлен
                   Зависит: g++ (>= 4:4.9.1) но он не будет установлен
                   Зависит: make
                   Зависит: dpkg-dev (>= 1.17.11) но он не будет установлен
 libxneur : Зависит: libxosd2 (>= 2.2.14) но он не будет установлен
 xneur : Зависит: libxosd2 (>= 2.2.14) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
root@amnesia:/usr/src#


Cообщение объединено 14 Февраля 2016, 20:32:09
« Последнее редактирование: 15 Февраля 2016, 05:53:08 от endru »
 

Оффлайн ferum

Re: не могу установить драйвер mediatek
« Ответ #12 : 14 Февраля 2016, 20:37:35 »
Простите великодушно,но я не понимаю как на живом дистрибутиве вы вообще собираетесь что то устанавливать и запускать сторонние программы? По моему этого не предусмотрено, или я безнадёжно отстал?
Что посоветую... думаю все случаи когда необходима спешка вам известны. Если есть желание ставьте профильный дистрибутив (debian) и не спеша учитесь с ним работать. Удачи.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн regina

  • Новичок форума
  • Сообщений: 7
Re: не могу установить драйвер mediatek
« Ответ #13 : 14 Февраля 2016, 20:41:31 »
спасибо за помощь и терпение
 

Теги:
     

    [Решено]Не могу настроить Tablet Hardware Buttons на ThinkPad X61 tablet

    Автор svl

    Ответов: 1
    Просмотров: 3437
    Последний ответ 07 Февраля 2015, 20:21:53
    от svl
    Не могу настроить видео

    Автор aidyn

    Ответов: 2
    Просмотров: 1200
    Последний ответ 18 Марта 2017, 10:08:00
    от ihammers
    [Решено] Не могу настроить Wi-Fi Broadcom BCM4313

    Автор Hafu

    Ответов: 11
    Просмотров: 20336
    Последний ответ 16 Октября 2015, 22:15:10
    от Moonlight0x0
    Не могу подключиться с помощью USB-Serial

    Автор letnab

    Ответов: 0
    Просмотров: 1606
    Последний ответ 06 Февраля 2015, 13:54:15
    от letnab
    Не могу запустить сканер отпечатков пальцев

    Автор steier

    Ответов: 6
    Просмотров: 5046
    Последний ответ 29 Мая 2014, 18:09:39
    от dogsleg