Автор Тема: Теряется связь после перезагрузки ADSL-модема  (Прочитано 1530 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн amdir

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 81
Добрый день!

Проблема возникла давно, всё никак руки не доходили написать. Обычно, если связь с Интернетом пропадает, ADSL-модем сам разрывает соединение и пытается снова подключиться к сети. Но время от времени случается так, что на модеме индикаторы светятся, как будто всё в порядке, а связь пропадает. В такой ситуации приходится перезагружать модем, но после этого компьютер просто перестаёт его видеть, так что приходится вслед за модемом перезагружать и Debian. Нельзя ли это как-то исправить? AFAIR под Windows и в предыдущих версиях Debian такого не было.

Использую Debian 8 с KDE, провайдер - МТС (бывший "Стрим"), модем - ZTE ZXV10 W300, настроен как маршрутизатор.

Спасибо.
 

Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 3160
  • Linux Registered User #547151
настройку сетевых интерфейсов и маршрутизатора подробнее, пожалуйста.

Оффлайн amdir

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 81
Настройки модема прилагаю, а где сейчас хранятся настройки сетевых интерфейсов? Я их один раз задал при установке системы и больше ни разу к ним не возвращался. Ifconfig выводит следующее:

eth0      Link encap:Ethernet  HWaddr 90:2b:34:5c:c9:f6 
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::922b:34ff:fe5c:c9f6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:27531 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23724 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:29003499 (27.6 MiB)  TX bytes:3429465 (3.2 MiB)
          Interrupt:18

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:43025 errors:0 dropped:0 overruns:0 frame:0
          TX packets:43025 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:24853715 (23.7 MiB)  TX bytes:24853715 (23.7 MiB)

Ещё раз специально поэкспериментировал с перезагрузкой модема при заведомо нормально работающей связи - глюк случается не всегда, мне удалось его воспроизвести только со второй попытки; причём теряется не только связь с Интернетом, но и связь с самим модемом: не удаётся вызвать в браузере его веб-интерфейс, в выводе команды ifconfig исчезает строка с IP-адресом для интерфейса eth0. Перезапуск отдельных программ не помогает, только перезагрузка системы. В WinXP на том же компьютере проблем не возникает: раз пять или шесть перезагружал модем, связь всякий раз восстанавливалась корректно.

[вложение удалено администратором]
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3670
  • Buster TDE & KDE
Падение связи с модемом говорит о нарушении фильтрации в схеме питания модема или микросхемы сетевой карты. лечится заменой соответствующих конденсаторов.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн amdir

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 81
Проблема в том, что сбои случаются только в одной операционке из двух и только в том случае, когда я сам выключаю модем и включаю снова. Пока я этого не сделаю, связь компьютера с модемом не прерывается. Как-то это плохо похоже на аппаратный сбой, или я что-то недопонимаю?
 

Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 3160
  • Linux Registered User #547151
сеть в дебиане настраивается либо через конфигурационный файл /etc/network/interfaces, либо через гуишный настройщик сети соответсвующего ДЕ, обычно это network-manager.
в xml вашего модема не разобрался, да и разбираться если честно некогда. попробуйте словами описать настройки внутренней сети. то бишь настроен ли dhcp, фаервол, имеется ли резервирование IP за конкретным мак адресом и так далее.

Оффлайн amdir

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 81
Re: Теряется связь после перезагрузки ADSL-модема
« Ответ #6 : 30 Сентябрь 2016, 12:21:43 »
Добрый день!

Прошу прощения, что так долго не писал, - похоже, пропустил оповещение об ответе. В /etc/network/interfaces почти ничего нет:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

В каталоге /etc/network/interfaces.d/ пусто.

Диалогового интерфейса для настройки сети - честно - просто не могу найти. Перерыл всё меню (работаю в KDE) и весь модуль "Параметры системы" - пусто, настройку конкретных сетевых подключений так и не нашёл.

Настройки модема такие:

NAT включён
DHCP включён
LAN IP Address: 192.168.1.1
Subnet Mask: 255.255.255.0
DHCP Start IP Address: 192.168.1.2
DHCP End IP Address: 192.168.1.254
DNS Server1 IP Address: 192.168.1.1
Default Gateway: 192.168.1.1
брандмауэр отключен
IP-фильтр отключен
MAC-фильтр отключен
UPnP включён (но судя по поведению KTorrent, не работает; в предыдущей версии Debian работал)
Port Forwarding включён (порт 6881, протоколы TCP и UDP; судя по поведению KTorrent, тоже не работает)

Использую в основном только настольный компьютер, так что типичная конфигурация сети - это два узла, компьютер и модем, IP-адрес компьютера 192.168.1.2.
 

Теги:
 

После обновления теряется сеть

Автор dimitriy25

Ответов: 10
Просмотров: 1626
Последний ответ 18 Март 2020, 15:02:48
от dimitriy25