Автор Тема: xinit и xorg не стартуют просьба помочь  (Прочитано 2771 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн old

  • Новичок форума
  • Topic Author
  • Сообщений: 6
debian wheezy 7.4 LXDE
Начну с того что разными путями пытался установить modem-manager-GUI для запросов  USSD (проверка трафика).В итоге подключил репы ДЖЕЗИ и вот долгожданная установка софта завершена всё работало до перезагрузки... Апосля просто чёрный экран с моргающим курсором... нажимаем Alt+F1 поподаем в консоль вводим логин пароль startx и вот что пишет:
[  1259.509]
X.Org X Server 1.16.4
Release Date: 2014-12-20
[  1259.509] X Protocol Version 11, Revision 0
[  1259.509] Build Operating System: Linux 3.2.0-4-amd64 i686 Debian
[  1259.509] Current Operating System: Linux story 3.2.0-4-686-pae #1 SMP Debian 3.2.54-2 i686
[  1259.509] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-686-pae root=UUID=d42a809b-02bf-4bc8-85ff-71a5ef1fa29a ro quiet
[  1259.509] Build Date: 11 February 2015  01:14:26AM
[  1259.509] xorg-server 2:1.16.4-1 (http://www.debian.org/support)
[  1259.509] Current version of pixman: 0.32.6
[  1259.509] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[  1259.509] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1259.510] (==) Log file: "/var/log/Xorg.4.log", Time: Sat Jun  4 17:55:28 2016
[  1259.510] (==) Using config file: "/etc/X11/xorg.conf"
[  1259.510] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1259.511] (==) ServerLayout "Layout0"
[  1259.511] (**) |-->Screen "Screen0" (0)
[  1259.511] (**) |   |-->Monitor "Monitor0"
[  1259.511] (**) |   |-->Device "Device0"
[  1259.511] (**) |-->Input Device "Keyboard0"
[  1259.511] (**) |-->Input Device "Mouse0"
[  1259.511] (==) Automatically adding devices
[  1259.511] (==) Automatically enabling devices
[  1259.511] (==) Automatically adding GPU devices
[  1259.511] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  1259.511] Entry deleted from font path.
[  1259.511] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[  1259.511] (==) ModulePath set to "/usr/lib/xorg/modules"
[  1259.511] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1259.511] (WW) Disabling Keyboard0
[  1259.511] (WW) Disabling Mouse0
[  1259.511] (II) Loader magic: 0xb7720700
[  1259.511] (II) Module ABI versions:
[  1259.511] X.Org ANSI C Emulation: 0.4
[  1259.511] X.Org Video Driver: 18.0
[  1259.511] X.Org XInput driver : 21.0
[  1259.511] X.Org Server Extension : 8.0
[  1259.513] (--) PCI:*(0:1:0:0) 10de:0622:1682:2362 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf4000000/33554432, I/O @ 0x0000c000/128, BIOS @ 0x????????/524288
[  1259.513] (II) LoadModule: "glx"
[  1259.513] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  1259.560] (II) Module glx: vendor="NVIDIA Corporation"
[  1259.560] compiled for 4.0.2, module version = 1.0.0
[  1259.560] Module class: X.Org Server Extension
[  1259.560] (II) NVIDIA GLX Module  331.67  Fri Apr  4 11:46:43 PDT 2014

[45.003287] systemd-login[2360]:failed tostart user service:Unkown unit:user@1000.service

xinit:giving up
xinit:unable to connect to X server:Connection refused
xinit:error

пробывал aptitude install xorg вообщем он бы рад установить пару килобайт но интернет с консоли не пашет с USB модемом.
переустановка Nvidia ни к чему не привело.Nouavea как бы в блокировке как и раньше, когда нвидео работало.
Кто что подскажет?!

Пользуемся тегами для оформления постов, ogost
« Последнее редактирование: 05 Июнь 2016, 07:39:10 от ogost »
 

Оффлайн mrgoodvin

  • Местный житель
  • ***
  • Сообщений: 331
Re: xinit и xorg не стартуют просьба помочь
« Ответ #1 : 05 Июнь 2016, 00:16:27 »
Покажите команды ниже, может что увидим:
lsb_release -a
systemctl status user@1000.service
systemctl status systemd-logind.service
затем узнайте PID из systemctl status systemd-logind.service, и покажите journalctl _PID=<_pid_From_user@1000.service>
Под root'ом тоже ошибки? Как по мне, лучше не смешивать версии дистрибутива. Можно ведь было воспользоваться wheezy-backports (# apt-get -t wheezy-backports install "package"), и если не подходит вариант с backports смотреть пример - https://debianforum.ru/index.php?topic=5407.0
Еще вариант обновиться до jessie.
 

Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 3161
  • Linux Registered User #547151
Re: xinit и xorg не стартуют просьба помочь
« Ответ #2 : 05 Июнь 2016, 07:42:35 »
Смешивание веток - плохая идея. Надо было определять приоритет репозиториев посредством apt-pinning. Раз уж намешали - делайте апгрейд до Джесси.

Оффлайн old

  • Новичок форума
  • Topic Author
  • Сообщений: 6
Re: xinit и xorg не стартуют просьба помочь
« Ответ #3 : 05 Июнь 2016, 11:56:33 »
lsb команда не отработала, systemctl.... пишет: Faled to get D-Bus connection:Unknown error -1
Команда apt-get -t wheezy-backports install "package" дала понять что релиз и исходный код не соответствует... Б-е-да!!!
Как я так умудрился накрыть систему устоновив один пакет, хотя меня изначально в логах забеспокоило amd64, у меня изначально была установлена 32-битная система.Я так понимаю надо переустоновить, но как тогда устоновить злочастный modem-manager-gui...

(Пользуемся тегами для оформления постов, ogost) Как и где это делать... Знал бы сделал...
 

Оффлайн alsoijw

  • Fedora 25 GNOME 3 amd64
  • Ветеран
  • *****
  • Сообщений: 1231
Re: xinit и xorg не стартуют просьба помочь
« Ответ #4 : 05 Июнь 2016, 12:44:01 »
(Пользуемся тегами для оформления постов, ogost) Как и где это делать... Знал бы сделал...
В поле ответа(точнее над полем) есть кнопочки. Тебе нужны со значком # и значком радиации. Выдели текст, нажимай на значок.
Как я так умудрился накрыть систему устоновив один пакет,
Есть такое понятие как зависимости. Запросто могли помешать.
но как тогда устоновить злочастный modem-manager-gui...
Либо ставить версию где он есть в репозиториях, либо пытатся бекпортировать(может окончится провалом). Что выберешь?
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Оффлайн old

  • Новичок форума
  • Topic Author
  • Сообщений: 6
Re: xinit и xorg не стартуют просьба помочь
« Ответ #5 : 05 Июнь 2016, 19:33:58 »
Сам не знаю что теперь делать...
 

Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 3161
  • Linux Registered User #547151
Re: xinit и xorg не стартуют просьба помочь
« Ответ #6 : 05 Июнь 2016, 19:41:29 »
апгрейд до джесси - самый быстрый и безболезненный вариант. конечно, если некий специфичный софт не привязан к визи.

Оффлайн old

  • Новичок форума
  • Topic Author
  • Сообщений: 6
Re: xinit и xorg не стартуют просьба помочь
« Ответ #7 : 05 Июнь 2016, 20:41:28 »
До Джези это надо aptitude upgrade distr, правильно или нет?? И кстати как Джез не плющит эго, с Веззи проблем вообще никаких не знал кроме последних изысканий.
 

Оффлайн mrgoodvin

  • Местный житель
  • ***
  • Сообщений: 331
Re: xinit и xorg не стартуют просьба помочь
« Ответ #8 : 05 Июнь 2016, 20:51:47 »
Вот здесь более детально описано http://linux-notes.org/obnovlenie-debian-do-debian-8/. Вообще рекомендуют обновляться через apt: #apt-get dist-upgrade Проблем с jessie нет, но по отдельным пакетам могут быть :). Но в целом более менее все решаемо.
 

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
modem-manager-gui_0.0.17.1 для Wheezy
« Ответ #9 : 05 Июнь 2016, 20:56:31 »
подключил репы ДЖЕЗИ
У меня версия modem-manager-gui_0.0.17.1~precise2 из бунты precise работает прекрасно. В следующий раз прежде чем чтото устанавливать почитайте форум или спросите кого нибудь.
И перед экспериментами Clonezilla здесь https://debianforum.ru/index.php?topic=6879
Вот здесь https://debianforum.ru/index.php?topic=3834.msg85673#msg85673 выкладываю эксперименты с Wheezy (успешные).
« Последнее редактирование: 05 Июнь 2016, 22:40:13 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн old

  • Новичок форума
  • Topic Author
  • Сообщений: 6
Re: xinit и xorg не стартуют просьба помочь
« Ответ #10 : 05 Июнь 2016, 21:04:47 »
Так, почитал понял что ИНТЕРНЕТ нужен а как его подключить с консоли или может проще (хотя сам сомневаюсь), ставим уже имеющуюся семёрку с диска, а потом обновляемся...?
 

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
modem-manager-gui_0.0.17.1 для Wheezy
« Ответ #11 : 05 Июнь 2016, 21:21:39 »
Если у вас инет по кабелю то ничего подключать не надо когда вы войдёте в консоль он уже будет подключен. И если вы не Гэээээймэр то намного безопастнее пользоваться открытым драйвером nouveau (xserver-xorg-video-nouveau).
« Последнее редактирование: 05 Июнь 2016, 22:40:26 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн old

  • Новичок форума
  • Topic Author
  • Сообщений: 6
Re: xinit и xorg не стартуют просьба помочь
« Ответ #12 : 05 Июнь 2016, 22:17:47 »
Так ИНТЕРНЕТ только с USB модема.Но вообщем жаль конечно что не восстановить, но что теперь... Вообщем поставлю обратно семёрку а потом попробую как у Aalexeey подключить репы Убунты. Как тут тему закрыть(решено)
 

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
modem-manager-gui_0.0.17.1 для Wheezy
« Ответ #13 : 05 Июнь 2016, 22:32:40 »
подключить репы Убунты
В тех репах что у меня нет modem-manager-gui, прочитайте там внимательней мои коментарии. Вам надо найти и скачать modem-manager-gui_0.0.17.1~precise2_i386.deb или modem-manager-gui_0.0.17.1~precise2_amd64.deb , попытайтесь разобраться какие релизы "Дебиано" линуксов совместимы с Wheezy а какие нет.
Ещё раз повторюсь перед экспериментами по установке софта не из репов Wheezy (не родных) копируйте системные разделы, либо как я описал выше либо записав iso Clonezill'ы на CD/DVD. Русский язык и элементарно простой GUI в ней присутствуют.
Как тут тему закрыть(решено)
В вашем первом посту в "Тема:" написать: [Решено] xinit и xorg не стартуют просьба помочь
« Последнее редактирование: 05 Июнь 2016, 22:44:09 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн alsoijw

  • Fedora 25 GNOME 3 amd64
  • Ветеран
  • *****
  • Сообщений: 1231
Re: xinit и xorg не стартуют просьба помочь
« Ответ #14 : 06 Июнь 2016, 09:40:14 »
Вообщем поставлю обратно семёрку а потом попробую как у Aalexeey подключить репы Убунты.
И получится повт орение текущей истории... Нужно очень окуратно относится к этому, ведь испортить - проще простого.
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Теги: