Yandex.Browser and Debian Wheezy

Автор CommanderG6, 14 июня 2016, 14:33:46

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

CommanderG6

Нужно установить Yandex.Browser на Wheezy.  Вылетает ошибка... Что делать?
При выполнении "sudo dpkg -i Yandex.deb"
Открыть содержимое (спойлер)

Выбор ранее не выбранного пакета yandex-browser-beta.
(Чтение базы данных ... на данный момент установлено 120226 файлов и каталогов.)
Распаковывается пакет yandex-browser-beta (из файла Yandex.deb) ...
dpkg: зависимости пакетов не позволяют настроить пакет yandex-browser-beta:
yandex-browser-beta зависит от libpango-1.0-0 (>= 1.14.0), однако:
  Пакет libpango-1.0-0 не установлен.
yandex-browser-beta зависит от libpangocairo-1.0-0 (>= 1.14.0), однако:
  Пакет libpangocairo-1.0-0 не установлен.
yandex-browser-beta зависит от libstdc++6 (>= 4.8.0), однако:
  Версия libstdc++6:amd64 в системе 4.7.2-5.
yandex-browser-beta зависит от libcurl3, однако:
  Пакет libcurl3 не установлен.

dpkg: ошибка при обработке параметра yandex-browser-beta (--install):
проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для menu ...
Обрабатываются триггеры для man-db ...
Обрабатываются триггеры для desktop-file-utils ...
При обработке следующих пакетов произошли ошибки:
yandex-browser-beta
[свернуть]

vadd

а какие у вас еще варианты?   устанавливайте сначала  libpango, libpangocairo, libcurl3 и обновляйте libstdc++6

CommanderG6

#2
Обновлять - нет новых (подходящих) версий пакетов, а  libpango, libpangocairo - не устанавливаются (в репозиториях нет, а скачанные пакеты друг с другом конфликтуют { libpangocairo для Wheezy я не нашёл}). Минимальная версия libpangocairo, которую я находил - 1.36.3 - конфликтует со всем подряд... Версию бы пониже - проблема решилась бы...

vadd

может пора обновиться до jessie?  боюсь, проблема несовместимостей будет понемногу только нарастать

CoolAller

#4
CommanderG6,
Тут два ваианта, первый, если нужные пакеты с зависимостями отсутствуют в репах и второй вариант, если вы просто не установили эти зависимости, после запуска sudo dpkg -i Yandex.deb нужно запустить sudo apt-get -f install Либо установите и используйте gdebi, который все сделает за вас.

Если все же у вас первый вариант, то можно попробовать следующее:

1. Доустановить требуемые пакеты вручную, можно взять отсюда;
2. Перепаковать deb пакет с Yandex.Browser, поправив требуемые версии, если возникнет конфликт с более новыми;
3. Пробовать запустить.

sidbar

Чем этот бровзер хорош, что столько телодвижений?
Devuan GNU/Linux 4 Chimaera x86_64

CommanderG6

Цитата: CoolAller от 14 июня 2016, 16:17:30
CommanderG6,
Тут два ваианта, первый, если нужные пакеты с зависимостями отсутствуют в репах и второй вариант, если вы просто не установили эти зависимости, после запуска sudo dpkg -i Yandex.deb нужно запустить sudo apt-get -f install Либо установите и используйте gdebi, который все сделает за вас.

Если все же у вас первый вариант, то можно попробовать следующее:

1. Доустановить требуемые пакеты вручную, можно взять отсюда;
2. Перепаковать deb пакет с Yandex.Browser, поправив требуемые версии, если возникнет конфликт с более новыми;
3. Пробовать запустить.
Cкорее всего последую варианту 2, т.к. требуемые пакеты не устанавливаются...

ferum

Цитата: CommanderG6 от 14 июня 2016, 20:00:53Cкорее всего последую варианту 2, т.к. требуемые пакеты не устанавливаются...
Не стоит заниматься ерундой, хотя воткнуть пакет таким способом можно, работать  браузер не будет. Установочные зависимости сопровождающий писал всё же не от балды.
Русские дебианщики против цифрового слабоумия !

CommanderG6

Ну, естественно, я так же думаю...

Aalexeey

libstdc++6 бэкпортированный под precise и установленный у меня на wheezy есть здесь:
deb http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu/ precise main
подробней здесь: https://debianforum.ru/index.php?topic=3834.msg85673#msg85673
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"

CoolAller

ferum, несколько раз ставил таким образом пакеты, они работали, сказать точно можно только попробовав.

ferum

CoolAller,  Я знаю точно данная программа будет ругаться на устаревшую версию libc6, возможно ещё на что нибудь. Когда были бы исходники можно было бы попробовать скомпилировать на старых библиотеках и то не факт.
У меня opera-developer на wheezy  работает до 36 версии при попытке обновиться даже всё обновляется но программа версии 37+  (сейчас актуальная версия 39) не запускается а при попытке запуска из консоли вышеуказанная ошибка.
Русские дебианщики против цифрового слабоумия !

Aalexeey

#12
Цитата: ferum от 17 июня 2016, 09:50:21ругаться на устаревшую версию libc6
libc6 2.17 качественно бэкпортированный под Wheezy:
deb http://main.mepis-deb.org/mepiscr/experimental/ experimental test - взят у SteamOS и перепилен мистером Stevo
deb http://repo.steampowered.com/steamos/ alchemist main contrib non-free - ну очень стабильный и допиленный из SteamOS
подробней снова здесь: https://debianforum.ru/index.php?topic=3834.msg85673#msg85673
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"

ferum

#13
Aalexeey, Назовите хоть одну причину что бы так дорабатывать wheezy который уже находится в стадии LTS поддержки для того что бы поставить абсолютно ни чем не выдающийся проприаретарный браузер? Jessie уже более года в стабильном состоянии и уже слегка устаревает. Ну разве что железо безнадёжно старо, но в этом случае Yandex уже не поможет.
P.S. от безделья разобрал пакет, в wheezy нет libpango-1.0-0 (>= 1.14.0) и libpangocairo-1.0-0 (>= 1.14.0) а также нужна libstdc++6 (>= 4.8.0) а в wheezy 4.7.2-5
так что на счёт libc6 я оказался не прав но суть дела это не меняет.
Русские дебианщики против цифрового слабоумия !

Aalexeey

Уменя libstdc++6 версии 5.2.1, бэкпортированный libc6 позволит поставить много нового софта, libpango-1.0-0 и libpangocairo-1.0-0 я бы взял от туда где они есть и попробовал бы они на систему никак не влияют. Но мне не нужен вышеупомянутый броузер, всё ещё предпочитаю пока ещё ничем не заменимую Opera Presto.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"