Автор Тема: Проблема в виде областей залитых черным (контекстные меню, стартовое меню в КДЕ)  (Прочитано 2106 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alexus

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
Прошу простить если криво сформулировал заголовок.
Есть машина с Debian, amd64, intel gma 3150, суть проблемы такова: независимо от используемого DE через некоторое время работы происходит следующее: при открытии контекстных меню правой клавишей мыши вместо самого меню появляется аналогичных размеров черный прямоугольник, он работает если тыкать в него, но залит черным цветом, текста не видно. В КДЕ еще и стартовое меню выходит не черным правда, а прозрачным, без всякого содержимого, решается перезапуском ДЕ. Проявляется на всех ДЕ с небольшими отличиями. Прошу помощи, извелся уже перезапускать.

aptitude show xserver-xorg-video-intel: ShowHide

aptitude show xserver-xorg-video-intel
Пакет: xserver-xorg-video-intel                 
Состояние: установлен
Автоматически установлен: нет
Версия: 2:2.21.15-2+b2
Приоритет: необязательный
Раздел: x11
Сопровождающий: Debian X Strike Force <debian-x@lists.debian.org>
Архитектура: amd64
Размер в распакованном виде: 2 623 k
Зависимости: libc6 (>= 2.17), libdrm-intel1 (>= 2.4.38), libdrm2 (>= 2.4.30),
                        libpciaccess0 (>= 0.8.0+git20071002), libpixman-1-0 (>=
                        0.30.0), libudev1 (>= 183), libx11-6, libx11-xcb1,
                        libxcb-dri2-0, libxcb-util0 (>= 0.3.8), libxcb1, libxv1,
                        libxvmc1, xorg-video-abi-18, xserver-xorg-core (>=
                        2:1.15.99.903)
Конфликтуют: xserver-xorg-video-intel
Предоставляют: xorg-driver-video
Описание: драйвер видеокарт Intel i8xx, i9xx для графической подсистемы X.Org
 Этот пакет предоставляет драйвер видеокарт для чипсетов Intel семейств i8xx и
 i9xx, включающих в себя чипы серий i810, i815, i830, i845, i855, i865, i915,
 i945 и i965.
 
 Также этот пакет предоставляет драйверы XvMC (XVideo Motion Compensation) для
 чипсетов i810/i815, i9xx и более новых.
 
 Этот пакет собран из драйверного модуля X.org xf86-video-intel.
Сайт: http://www.x.org/

Метки: admin::hardware, hardware::video, implemented-in::c, role::plugin,
       use::driver, x11::xserver
 

Оффлайн ihammers

Установлены ли firmware-linux (free и non-free)? Какое ядро используется в системе?
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн alexus

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
Спасибо за отклик,  firmware-linux и free и non-free версии установлены, на данный момент переустановил систему ( до переустановки 64 бит, после- то есть в настоящий момент 32 бит) доустановил вышеуказанные пакеты, проблема сохранилась. Ядро 3.16.0-4-686-pae
Быть может аппаратная проблема?
 

Оффлайн Aalexeey

переустановил систему
Linux не надо навязчиво переустанавливать это не Винда. Попробуйте сторонние сборки xserver-xorg-video.... например здесь:
http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/pool/main/x/
для Wheezy
deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ precise main
deb http://repo.steampowered.com/steamos/ alchemist main contrib non-free
deb http://main.mepis-deb.org/mepiscr/experimental/ experimental test
для Jessie
deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ trusty main
deb http://repo.steampowered.com/steamos/ brewmaster main contrib non-free
У меня на нотбуке (Intel HD4000 - Ivy Bridge) с Wheezy установлен xserver-xorg-video-intel_2.99.917-1mcr120+1_amd64.deb
« Последнее редактирование: 28 Июнь 2016, 21:41:16 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 
Пользователи, которые поблагодарили этот пост: alexus

Оффлайн ihammers

Попробуйте сторонние сборки xserver-xorg-video.... например здесь:
На данном форуме советы установки пакетов с PPA попадают под пункт правил форума 2.6:
Цитировать
2.6 Не рекомендуется советовать установку пакетов из PPA (персональных архивов пакетов Ubuntu)

Спасибо за отклик,  firmware-linux и free и non-free версии установлены, на данный момент переустановил систему ( до переустановки 64 бит, после- то есть в настоящий момент 32 бит) доустановил вышеуказанные пакеты, проблема сохранилась. Ядро 3.16.0-4-686-pae
Быть может аппаратная проблема?
А по какой причине перешли на 32-х битное ядро, просто интересно? Как вариант попробовать поставить firmware, ядро и xserver-xorg-video-intel из backports.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 
Пользователи, которые поблагодарили этот пост: alexus

Оффлайн alexus

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
Linux не надо навязчиво переустанавливать это не Винда. Попробуйте сторонние сборки xserver-xorg-video.... например здесь:
А по какой причине перешли на 32-х битное ядро, просто интересно? Как вариант попробовать поставить firmware, ядро и xserver-xorg-video-intel из backports.

У меня установлено 2 гб оперативной памяти, посчитал, что на 32 системе будет комфортнее в плане оперативной памяти
Сделал так:
apt-get -t jessie-backports install linux-image-4.6.0-0.bpo.1-686-pae
apt-get -t jessie-backports install firmware-linux-free
apt-get -t jessie-backports install firmware-linux-nonfree
apt-get -t jessie-backports install xserver-xorg-video-intel

Всё верно? Еще что то требуется до установить?

* Используйте теги для оформления сообщения, ihammers.
« Последнее редактирование: 29 Июнь 2016, 04:02:53 от ihammers »
 

Оффлайн ihammers

Всё верно? Еще что то требуется до установить?
Да, всё верно. Получилось решить проблему?

И проверьте пакеты mesa:
$ dpkg -l \*mesa\* | grep ^i
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 
Пользователи, которые поблагодарили этот пост: alexus

Оффлайн alexus

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
Вывод
$ dpkg -l \*mesa\* | grep ^i
ii  libegl1-mesa:i386            10.3.2-1+deb8u1 i386         free implementation of the EGL API -- runtime
ii  libegl1-mesa-drivers:i386    10.3.2-1+deb8u1 i386         free implementation of the EGL API -- hardware drivers
ii  libgl1-mesa-dri:i386         10.3.2-1+deb8u1 i386         free implementation of the OpenGL API -- DRI modules
ii  libgl1-mesa-glx:i386         10.3.2-1+deb8u1 i386         free implementation of the OpenGL API -- GLX runtime
ii  libglapi-mesa:i386           10.3.2-1+deb8u1 i386         free implementation of the GL API -- shared library
ii  libgles1-mesa:i386           10.3.2-1+deb8u1 i386         free implementation of the OpenGL|ES 1.x API -- runtime
ii  libgles2-mesa:i386           10.3.2-1+deb8u1 i386         free implementation of the OpenGL|ES 2.x API -- runtime
ii  libglu1-mesa:i386            9.0.0-2         i386         Mesa OpenGL utility library (GLU)
ii  libopenvg1-mesa:i386         10.3.2-1+deb8u1 i386         free implementation of the OpenVG API -- runtime
ii  libwayland-egl1-mesa:i386    10.3.2-1+deb8u1 i386         implementation of the Wayland EGL platform -- runtime

Пока полёт нормальный, почти сутки без проблем. Спасибо за помощь!

Дополнение:
Пришло обновление ядра 3.16.0.4 а у меня уже 4.6.0-0.bpo.1
Как то возможно скрыть/настроить так чтобы не просил обновить?
« Последнее редактирование: 25 Июль 2016, 14:56:36 от alexus »
 

Оффлайн alexus

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
Поскольку моё дополнение поста осталось незамеченным, позволю себе повториться:
Пришло обновление ядра 3.16.0.4 а у меня уже 4.6.0-0.bpo.1
Как то возможно скрыть/настроить так чтобы не просил обновить на старую версию?
« Последнее редактирование: 25 Июль 2016, 14:56:11 от alexus »
 

Оффлайн ferum

Русские дебианщики против цифрового слабоумия !
 

Оффлайн alexus

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
apt-mark hold linux-image
при этом из бэкпорта обновления приходить тоже не будут?
 

Теги:
 

Проблема с кодировкой в Debian/пожалуйста, помогите

Автор kujirasan

Ответов: 10
Просмотров: 5415
Последний ответ 31 Январь 2012, 05:09:39
от kujirasan
проблема с enlightenment 0.20.3

Автор wild_blood

Ответов: 0
Просмотров: 1114
Последний ответ 31 Январь 2016, 20:19:35
от wild_blood
проблема Plymouth

Автор doctor@tardis

Ответов: 1
Просмотров: 1898
Последний ответ 23 Октябрь 2014, 19:49:44
от doctor@tardis
Проблема с заменой стандартных иконок приложений

Автор nihi1ist

Ответов: 9
Просмотров: 2281
Последний ответ 04 Октябрь 2016, 18:45:54
от Aalexeey
Проблема с клавиатурой в произвольной dm-чессии

Автор myt-newb

Ответов: 3
Просмотров: 1789
Последний ответ 23 Декабрь 2014, 15:53:52
от Malaheenee