Автор Тема: Развертка web сервера на Debian 8  (Прочитано 1768 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nivion

  • Новичок форума
  • Topic Author
  • Сообщений: 8
Развертка web сервера на Debian 8
« : 02 Июль 2016, 09:28:23 »
здравствуйте интересует пошаговое руководство по развертке веб сервера на базе debian.
https://habrahabr.ru/post/226971/ следуя данному руководству ломается apache и не понятно что делать.
 


Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 3149
  • Linux Registered User #547151
Re: Развертка web сервера на Debian 8
« Ответ #1 : 03 Июль 2016, 14:14:23 »
Уточните на каком именно этапе все ломается и какие ошибки выдаёт. А так же какую версию дебиана используете.

Оффлайн nivion

  • Новичок форума
  • Topic Author
  • Сообщений: 8
Re: Развертка web сервера на Debian 8
« Ответ #2 : 04 Июль 2016, 11:49:10 »
Результат uname -a:
Linux 3.16.0-4-586 Debian 3.16.7 i686 GNU/LinuxПри этапе установки софта перечисленного выше возникает проблема - Затем одной командой ставим весь необходимый софт:

apt-get install htop atop vsftpd exim4-base exim4-daemon-light mailutils rcconf apache2 apache2-mpm-itk nginx mysql-server-5.5
mysql-client-5.5 php5 php5-dev memcached libmysqlclient-dev apache2-utils libexpat1 ssl-cert libapache2-mod-php5
libapache2-mod-ruby php5-curl php5-gd php5-intl php-pear php5-imagick php5-imap php5-mcrypt php5-memcache php5-common
php5-ming php5-mysql php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl make automake checkinstall
gcc gzip libreadline-dev libssl-dev libncurses5-dev zlib1g-dev

E: Package 'libapache2-mod-ruby' has no installation candidate
E: Unable to locate package php5-ming

Убираем данные пакеты из установки, получаем:
160704  0:59:11 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
160704  0:59:11 [Note] /usr/sbin/mysqld (mysqld 5.5.49-0+deb8u1) starting as process 25956 ...
Job for mysql.service failed. See 'systemctl status mysql.service' and 'journalctl -xn' for details.
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.5 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up bzip2 (1.0.6-7+b3) ...
Setting up exim4-config (4.84.2-1) ...
Adding system-user for exim (v4)
debconf: DbDriver "templatedb": could not write /var/cache/debconf/templates.dat-new: No space left on device
dpkg: error processing package exim4-config (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of exim4-base:
 exim4-base depends on exim4-config (>= 4.82) | exim4-config-2; however:
  Package exim4-config is not configured yet.
  Package exim4-config-2 is not installed.
  Package exim4-config which provides exim4-config-2 is not configured yet.

dpkg: error processing package exim4-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of exim4-daemon-light:
 exim4-daemon-light depends on exim4-base (>= 4.84.2); however:
  Package exim4-base is not configured yet.

dpkg: error processing package exim4-daemon-light (--configure):
 dependency problems - leaving unconfigured
Setting up file (1:5.22+15-2+deb8u1) ...
dpkg: unrecoverable fatal error, aborting:
 unable to flush /var/lib/dpkg/updates/tmp.i after padding: No space left on device
E: Sub-process /usr/bin/dpkg returned an error code (2)
E: IO Error to output - fwrite (28: No space left on device)
E: IO Error to output - fwrite (28: No space left on device)
root@origami:/home/syger# apt-get install mousepad
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
root@origami:/home/syger# apt-get install mousepad
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
« Последнее редактирование: 04 Июль 2016, 12:09:22 от nivion »
 

Оффлайн ihammers

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1742
  • Debian GNU/Linux Stretch
    • Алтайская Группа Пользователей Linux
  • Jabber: ihammers@jabber.ru
Re: Развертка web сервера на Debian 8
« Ответ #3 : 05 Июль 2016, 03:54:18 »
Пакет libapache2-mod-ruby есть только в wheezy. Система вам говорит, что при конфигурировании пакетов произошла ошибка и просит запустить конфигурацию в ручную:
dpkg --configure -a
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Теги:
 

Развёртка request-tracker4

Автор letnab

Ответов: 1
Просмотров: 1984
Последний ответ 20 Сентябрь 2014, 10:45:52
от letnab