Автор Тема: [Решено] etc/init.d/squid status squid is not running failed! другая проблема  (Прочитано 2710 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mirus

Доброго времени суток, есть домен на Win 2003 + прокси на Debian.

Пользователи выходят в инет через логин пароль (добавляются через phpmyadmin) + внутренняя почта на exim4.

Рабочие станции перестали видеть прокси сервер (не дает ввести логин пароль для интернета) и одновременно перестала работать почта.

При перезагрузке Debian заметил эту ошибку (exim paniclog on has non-zero size mail system poss broken failed при запуске debian) до этого не обращал внимания, была эта ошибка или нет. Систему поднимал не я, осталась по наследству. В Debiane новичок.

Подскажите в какую сторону копать. ?

https://yadi.sk/d/BhDR2xQIswiXe    + долго висит на NTP  server

Заранее спасибо!!!
« Последнее редактирование: 05 Июля 2016, 18:50:46 от mirus »
 

Оффлайн mirus

Теперь и вовсе MySQL упал, Starting MYSQL database server: mysqld........failed!
 в var/run/mysqld ничего не стало......

Было изначально подозрение на (недостаточно места на диске) но df -h, говорит об обратном
« Последнее редактирование: 03 Июля 2016, 13:47:50 от mirus »
 

Оффлайн ogost

Поверьте почту от рута. Про смотрите логи в /var/log/, в частности syslog, messages и mail.err. последнее в зависимости от установленной системы может ещё exim.log называться. Так же уточнить версию дебиана и какой прокси используется.

Оффлайн mirus

1. В логах может подскажете что то конкретное посмотреть, потому что там очень много строк инфы?

2. Debian 5.0,   прокси squid
 

Оффлайн ogost

Наличие ошибок, попробуйте grep -IE 'error|warn' /var/log/имяфайла.
Почту рута проверили? От рута введите mail. Выходит почты - q
Систему лучше обновить, 5.0 не поддерживается.
К сожалению мне пора в офлайн. Может форумчане помогут.

Оффлайн mirus

 grep -IE 'error|warn' /var/log/syslog и grep -IE 'error|warn' /var/log/messages --  во вложении

Почту рута проверили? От рута введите mail. Выходит почты - q
Возвращает
No mail for root
« Последнее редактирование: 03 Июля 2016, 15:30:46 от mirus »
 

Оффлайн mirus

при проверке статуса squid , возвращается squid is not running failed!

cache.log во вложении
 

Оффлайн ihammers

Было изначально подозрение на (недостаточно места на диске) но df -h, говорит об обратном
У вас используется один раздел или несколько? Если несколько, то может место кончилось на другом разделе (/var/), а вы посмотрели для корня.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн mirus

Спасибо, а может быть переполнен /var/www/squid-reports  ?

и по этой причине /etc/init.d/sqid status

выдает   squid is not running failed!

Cообщение объединено 05 Июля 2016, 07:04:26
вот результат df -h
« Последнее редактирование: 05 Июля 2016, 07:04:27 от mirus »
 

Оффлайн ihammers

вот результат df -h
По результатам всё нормально.
Покажите права на файл:
~$ ls -anst /var/spool/squid/swap.state
Проверяли ли винт и память, если это не виртуальная машина? Машина сама в домене? Проверьте статус машины.

PS: Используйте WinSCP для передачи файлов с сервера на windows машину. Лучше текстовые файлы, а не фотографии.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн mirus

1) ls -anst /var/spool/squid/swap.state    выдает
    1428 -rw-r----- 1 0 13 1455048 Июл 1 08.20 /var/spool/squid/swap.state
2) Винт , память не проверял. Машина в домене. Может глупый вопрос : что подразумевается под статусом машины и как это сделать ?


Cообщение объединено 05 Июля 2016, 12:28:34
Почта заработала - решилось пополнением баланса , тупо не было денег на счету.......

Но пользователи все равно не могут подключиться к прокси-серверу, кстати в первом сообщении не верно написал, пользователь пароль добавляется не через phpmyadmin , а через команду в консоли -
htpasswd /etc/squid/user "имя пользователя"   затем два раза пароль.

Правильно ли я понимаю что проблема в squid?

Если /etc/init.d/squid status
squid is not running failed!


 

Cообщение объединено 05 Июля 2016, 12:29:38
ЕСТЬ КТО ЖИВОЙ ?????

Cообщение объединено 05 Июля 2016, 18:43:18
Проблема решилась.

cache_swap_log /var/log/squid/swap.log
в конфиг
и
удаление /var/spool/squid/swap.state

Только что из них конкретно помогло, не понял. Возможно оба.

Всем спасибо
« Последнее редактирование: 05 Июля 2016, 18:43:18 от mirus »
 

Теги:
     

    [РЕШЕНО] не берет пользователей из winbind

    Автор Andruha

    Ответов: 2
    Просмотров: 3288
    Последний ответ 14 Июля 2015, 09:19:03
    от Andruha
    [Решено]nginx и .php

    Автор redVi

    Ответов: 3
    Просмотров: 6741
    Последний ответ 29 Сентября 2012, 11:56:11
    от corner
    [РЕШЕНО] Возникла такая проблемка ввел команду mv * ../ в папке user/bin/ffmpeg

    Автор neformat

    Ответов: 11
    Просмотров: 2186
    Последний ответ 28 Декабря 2017, 09:45:03
    от neformat
    Подмена почтового адреса(решено)

    Автор Виктор

    Ответов: 3
    Просмотров: 1680
    Последний ответ 11 Сентября 2013, 11:10:29
    от qupl
    Упрямый iptables и ftp... [РЕШЕНО]

    Автор dsdsda

    Ответов: 7
    Просмотров: 1484
    Последний ответ 04 Декабря 2019, 15:36:15
    от dsdsda