Автор Тема: glibc required: 2.15  (Прочитано 1515 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nikanofff

glibc required: 2.15
« : 19 Июля 2016, 14:28:29 »
Доброго времени суток ГУРУ данного портала. Скажу честно уже весь инет обшарил. Не могу найти решения данной проблемки. Суть такова что что запускаю 1 штуку а она мне выдаёт:
Glibc fix: No Glibc fix available!

        * glibc required: 2.15
        * glibc installed: 2.13
Как я понял нужно обновить glibc до версии 2.15
До этого мне необходимо было вписывать такие команды:
sudo dpkg --add-architecture i386; sudo apt-get update; sudo apt-get install tmux mailutils postfix ca-certificates curl file lib32gcc1 libstdc++6 libstdc++6:i386У меня дэбиан 8 х64

Подскажите плиз как правильно обновить этот glibc до нужной мне версии. А то гугл мне пока не помог.


P.S За ранее спасибо!
 

Оффлайн ferum

Re: glibc required: 2.15
« Ответ #1 : 19 Июля 2016, 16:23:51 »
Что то не так в ваших показаниях  не сходится  glibs 2.13  это  wheezy  https://packages.debian.org/ru/wheezy/libc6   Проще всего обновиться до jessie.
Есть тут у нас любитель использования репозиториев дистрибутива mepis https://ru.wikipedia.org/wiki/MEPIS  который использует много бэкпортированных пакетов, есть ещё kanotix ,kwheezy и прочие частично совместимые дистрибутивы, но подключив их источники надо ещё уметь обновиться что бы не слетела половина пакетов. Весь вопрос какие у вас задачи.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн nikanofff

Re: glibc required: 2.15
« Ответ #2 : 19 Июля 2016, 16:31:09 »
Ну у меня задачи поставить игровые сервера. Ну у хостера было написано что Debian 8.14x64 при выборе дистра. Ну а в дальнейшем возможно планируется поднять веб+почтовый сервера.
 

Оффлайн ferum

Re: glibc required: 2.15
« Ответ #3 : 19 Июля 2016, 19:27:24 »
Хм уж не тот ли это случай когда в сарае написано...
Вот сейчас я работаю с debian 7 wheezy amd 64 с последними обновлениями.
Spoiler: ShowHide

alex@alex:~$ sudo aptitude versions glibc
[sudo] password for alex:
Пакет clisp-module-bindings-glibc:                 
p   1:2.49-8.1                                                                          oldstable                                                       500

Пакет clisp-module-bindings-glibc:i386:
p   1:2.49-8.1                                                                          oldstable                                                       500

Пакет eglibc-source:
p   2.13-38+deb7u10                                                                     oldstable                                                       500
p   2.13-38+deb7u11                                                                     oldstable                                                       500

Пакет glibc-doc:
p   2.13-38+deb7u10                                                                     oldstable                                                       500
p   2.13-38+deb7u11                                                                     oldstable                                                       500

Пакет glibc-doc-reference:
p   2.13-1                                                                              oldstable                                                       500
alex@alex:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 7.11 (wheezy)
Release:        7.11
Codename:       wheezy
alex@alex:~$ uname -r
3.2.0-4-amd64

Думаю что для сервера вам предоставили то же самое. Как вариант исправить репозитории на jessie и обновиться но я честно скажу не знаю на сколько это приемлемо для арендованного сервера. Вроде люди ставят самостоятельно систему какая им нужна.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн nikanofff

Re: glibc required: 2.15
« Ответ #4 : 21 Июля 2016, 01:25:49 »
Спасибо помогло! Но как я понимаю теперь и апач и мускул и всё остальное от 8ой версии?
 

Теги: