Автор Тема: Звук хрипит и эхо  (Прочитано 7203 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн BegU

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 33
Звук хрипит и эхо
« : 06 Август 2016, 17:42:37 »
Начал осваивать Debian, никак не могу настроить звук. Подключен по hdmi. При воспроизведении в любом приложении и даже просто при проверке динамиков, идет дикий хрип и эхо.
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3675
  • Buster TDE & KDE
Re: Звук хрипит и эхо
« Ответ #1 : 06 Август 2016, 19:20:38 »
Для начала
alsamixerпо F6 выберите свою карту с HDMI
# apt-get install pavucontrolВ мултимедия появится регулятор громкости pulseaudio выберите в нём свой звуковой выход.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн BegU

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 33
Re: Звук хрипит и эхо
« Ответ #2 : 06 Август 2016, 20:10:51 »
Для начала
Код: [Выделить]
alsamixer
по F6 выберите свою карту с HDMI
Код: [Выделить]
# apt-get install pavucontrol
В мултимедия появится регулятор громкости pulseaudio выберите в нём свой звуковой выход.

Все это уже делал, но безрезультатно. И треск остался и звук эхом, как в трубу.

Я так понимаю, что проблема в драйверах. Пока свободные или проприетарные не установишь, вообще никакого звука не добиться.

Cообщение объединено 07 Август 2016, 14:46:16
Проблему решил радикальным способом - вытащил внешнюю видеокарту и стартанул, так же по hdmi, на встроенной - звук чистый.
« Последнее редактирование: 07 Август 2016, 14:46:16 от BegU »
 

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
Re: Звук хрипит и эхо
« Ответ #3 : 07 Август 2016, 22:55:17 »
Недавно где-то обсуждали, мне это помогло:
https://debianforum.ru/index.php?topic=8527.msg82969#msg82969
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн BegU

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 33
Re: Звук хрипит и эхо
« Ответ #4 : 08 Август 2016, 00:28:29 »
Недавно где-то обсуждали, мне это помогло:
К сожалению не дало результатов.
Фиг с ним. Думал поставить Debian основной системой и выделить не большой диск винду для работы в максе, но похоже, и это даже лучше, придется под Debian новый системник собирать, оглядываясь, естественно, на опыт использования железа людьми.
 

Оффлайн BegU

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 33
Re: Звук хрипит и эхо
« Ответ #5 : 06 Октябрь 2016, 01:03:43 »
Итак, ситуация следующая. В наличии были установочные флешки с Debian, Linux Mint и Ubuntu. К системнику по HDMI подключен ТВ. Карта Gigabyte Radeon HD 7790.

Сначала запускаю LinuxMint - звуковое устройство не определено, после установки драйверов и перезагрузки, устройство появилось для выбора, но звук с хрипом и эхом. Шаманство с конфигами не помогло.

Ладно, удаляю Mint и ставлю Debian 8.6.0 (до этого ставил 8.5.0) - ситуация повторяется. Танцы с бубном опять не помогают.

Сношу Debian и ставлю Ubuntu - после установки, без всяких настроек, абсолютно идеальный звук.

Напрашивается вопрос, как узнать, что такого есть в Убунту (даже в лайф сд - с него тоже пробовал запускать) и нет в Дебиан и Минт и можно ли это перенести на Дебиан?
 

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
Re: Звук хрипит и эхо
« Ответ #6 : 07 Октябрь 2016, 08:45:20 »
как узнать, что такого есть в Убунту
Я бы сохранил и сравнил/подсунул конфиги alsa и pulse для начала проверил какие пакеты не установленны, затем попробовал бы установить самые новые firmware, ядро и кодеки  (бэкпорты, мультимедиа, mepis/mx15+ или steamos/brewmaster), тогда бы было видно откуда дует.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн BegU

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 33
Re: Звук хрипит и эхо
« Ответ #7 : 07 Октябрь 2016, 12:26:49 »
Я бы сохранил и сравнил/подсунул конфиги alsa и pulse для начала проверил какие пакеты не установленны, затем попробовал бы установить самые новые firmware, ядро и кодеки  (бэкпорты, мультимедиа, mepis/mx15+ или steamos/brewmaster), тогда бы было видно откуда дует.

Все бы хорошо, но дальше копирования конфигов мои знания пока не идут.

На сайте Debian написано, что некоторые микропрограммы отсутствуют в дистрибутиве и, чтобы они поставились при установке, надо их скачать и сунуть, либо в корень, либо в папку firmware. Я это проделал, но похоже, ничего не поставилось. Тот же firmware-linux-nonfree пришлось устанавливать уже после установки системы.
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3675
  • Buster TDE & KDE
Re: Звук хрипит и эхо
« Ответ #8 : 07 Октябрь 2016, 17:12:10 »
Всё есть в ветках репозитория contrib non-free
Русские дебианщики против цифрового слабоумия !
 

Оффлайн BegU

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 33
Re: Звук хрипит и эхо
« Ответ #9 : 09 Октябрь 2016, 14:32:24 »
Всё есть в ветках репозитория contrib non-free

Да, ставил с той ветки, тот же результат...
 

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
Re: Звук хрипит и эхо
« Ответ #10 : 09 Октябрь 2016, 17:22:15 »
Да, ставил с той ветки, тот же результат...
Для Wheezy:
deb http://main.mepis-deb.org/mepiscr/repo/ mepis12cr main non-free
deb http://main.mepis-deb.org/mepiscr/testrepo/ mepis12cr test
deb http://main.mepis-deb.org/mepiscr/experimental/ experimental test
deb http://repo.steampowered.com/steamos/ alchemist main contrib non-free
Для Jessie:
deb http://mxrepo.com/mx/repo/ mx15 main non-free
deb http://mxrepo.com/mx/testrepo/ mx15 test
deb http://repo.steampowered.com/steamos/ brewmaster main contrib non-free
Это последний шанс отделаться легко. Данный способ вы используете на свой страх и риск!
Перед экспериментами: https://debianforum.ru/index.php?topic=6879
« Последнее редактирование: 09 Октябрь 2016, 17:26:44 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн BegU

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 33
Re: Звук хрипит и эхо
« Ответ #11 : 22 Ноябрь 2016, 12:10:25 »
Зайдем с другого конца. Сейчас поставил чистую систему. Т.к. звука не было вообще, накатил firmware-linux-nonfree. Звук появился, но проблемы те же. Говорите, выводы каких команд и содержимое каких файлов присылать, выложу. Может таки удастся разобраться. А то винда, похоже, скоро сдохнет и ставить ее основной системой больше нет желания))

Вот вывод того, что обычно просят.

lspci

Spoiler: ShowHide
Цитировать
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] RS780 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 3)
00:0a.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 5)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode]
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 IDE Controller
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 5
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Bonaire XT [Radeon HD 7790/8770 / R9 260 OEM]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device aac0
02:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09)
04:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter (rev 10)


aplay -l

Spoiler: ShowHide
Цитировать
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: VT1708S Analog [VT1708S Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 3: VT1708S Digital [VT1708S Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


dpkg -l | grep -i firmw

Spoiler: ShowHide
Цитировать
ii  firmware-linux-nonfree                0.43                                 all          Binary firmware for various drivers in the Linux kernel
ii  firmware-realtek                      0.43                                 all          Binary firmware for Realtek wired and wireless network adapters


cat /proc/asound/cards

Spoiler: ShowHide
Цитировать
0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe8f4000 irq 16
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfe99c000 irq 52
 

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
Re: Звук хрипит и эхо
« Ответ #12 : 22 Ноябрь 2016, 15:45:52 »
BegU, поставьте самые свежие firmware весь набор (какие нужны а какие нет разберётесь позже) для Jessie с зависимостями если есть (если у вас Jessie) отсюда:
http://mxrepo.com/mx/testrepo/pool/test/f/firmware-nonfree/ или из бэкпортов.
Репо выше писал.
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
Что-то мне подсказывает про firmware-intel-sound.
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Bonaire XT [Radeon HD 7790/8770 / R9 260 OEM]
Возможно firmware-amd-graphics.
« Последнее редактирование: 22 Ноябрь 2016, 16:00:37 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн BegU

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 33
Re: Звук хрипит и эхо
« Ответ #13 : 22 Ноябрь 2016, 18:00:11 »
Возможно firmware-amd-graphics.

Вообще не поставилось...

Поставил, все, что поставилось. Результат тот же
 

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
Re: Звук хрипит и эхо
« Ответ #14 : 22 Ноябрь 2016, 18:56:33 »
Вообще не поставилось...
Оно не может не поставится! Все firmware из одного источника и одной версии не могут не поставится. У меня они все даже на Wheezy спокойно встали. Все firmware должны быть одной версии. Например все 20160824-1mx150+1 если они из MX 15, или все 20160824-1~bpo8+1 если они из бэкпортов Jessie.
вытащил внешнюю видеокарту и стартанул, так же по hdmi, на встроенной - звук чистый
Звук с какой карты и через какой выход у вас трещит? Установлен ли у вас Pulseaudio и пробовали ли вы совет про "Хрипы и прерывания звука" от сюда: https://wiki.debian.org/ru/PulseAudio 
« Последнее редактирование: 22 Ноябрь 2016, 19:16:52 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Теги:
 

В видеопроигрователе звук есть, а в Firefox на youtube нет

Автор IlyaLinux

Ответов: 0
Просмотров: 143
Последний ответ 24 Сентябрь 2020, 12:29:01
от IlyaLinux
Не работает звук в браузере

Автор Babss88

Ответов: 4
Просмотров: 2387
Последний ответ 13 Март 2011, 19:19:13
от Ghostdmn
Звук JACK.

Автор Borg

Ответов: 39
Просмотров: 7489
Последний ответ 03 Апрель 2014, 14:37:56
от Александр Кряжев
Как вывести звук на HDMI (телевизор)

Автор izamoo

Ответов: 11
Просмотров: 6766
Последний ответ 27 Февраль 2012, 08:07:03
от qupl
Debian testing HDMI звук

Автор pretender424

Ответов: 3
Просмотров: 2148
Последний ответ 10 Апрель 2014, 08:26:37
от qupl