Автор Тема: Как установить xfce4-windowck-plugin?  (Прочитано 2928 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дождь

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 22
  • Debian 9.1 XFCE
Как установить xfce4-windowck-plugin?
« : 04 Сентябрь 2016, 10:35:16 »
Абсолютный новичок в линукс.
Не знаю как установить xfce4-windowck-plugin с этой страницы:
http://ppa.launchpad.net/oiteam/xfce4/ubuntu/pool/main/x/xfce4-windowck-plugin/
В Xubuntu ставиться из deb без проблем, а в debian из xfce4-windowck-plugin_0.3.1-0ubuntu1~oiteam0.debian.tar.gz не знаю как провести установку плагина.
Плагин просто необходим.
Я делаю так:
Скачиваю архив.
Распаковываю архив в корень домашней директории.
Дальше как поступить я не имею ни малейшего понятия.
Там даже нет мне знакомого файла .sh
Помогите установить xfce4-windowck-plugin в Debian 8.5 XFCE x64

П.С. Английского языка не знаю совсем.
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3441
  • Buster TDE & Buster LXDE & stretch KDE
Re: Как установить xfce4-windowck-plugin?
« Ответ #1 : 04 Сентябрь 2016, 11:26:42 »
Дождь, хотя сообщество настоятельно не рекомендует установку из ppa ubuntu  в данном отдельно взятом случае можете спокойно скачать 64 битный deb  пакет и установить его, зависимости он не ломает я проверил.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Дождь

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 22
  • Debian 9.1 XFCE
Re: Как установить xfce4-windowck-plugin?
« Ответ #2 : 04 Сентябрь 2016, 11:30:23 »
ferum, дело в том что я так пробовал, вот результат:

Spoiler: ShowHide
 


Оффлайн duletant

  • Местный житель
  • ***
  • Сообщений: 128
Re: Как установить xfce4-windowck-plugin?
« Ответ #3 : 04 Сентябрь 2016, 11:55:44 »
Установка пакета через терминал.
# dpkg -i имя_пакета.debустановит указанный пакет.
# apt-get -f installустановит зависимости.
P.S. Про PPA вам уже сказали...
 

Оффлайн Дождь

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 22
  • Debian 9.1 XFCE
Re: Как установить xfce4-windowck-plugin?
« Ответ #4 : 04 Сентябрь 2016, 12:27:23 »
# dpkg -i имя_пакета.deb
Еще раз:

root@Home:/home/akb/Загрузки# dpkg -i 123.deb
Выбор ранее не выбранного пакета xfce4-windowck-plugin.
(Чтение базы данных … на данный момент установлено 138416 файлов и каталогов.)
Подготовка к распаковке 123.deb …
Распаковывается xfce4-windowck-plugin (0.3.1-0ubuntu1~oiteam0) …
dpkg: зависимости пакетов не позволяют настроить пакет xfce4-windowck-plugin:
 xfce4-windowck-plugin зависит от libwnck22 (>= 1:2.22), однако:
  Версия libwnck22 в системе — 2.30.7-2.
 xfce4-windowck-plugin зависит от libxfce4util7 (>= 4.9.0), однако:
  Пакет libxfce4util7 не установлен.
 xfce4-windowck-plugin зависит от xfce4-panel (>= 4.11), однако:
  Версия xfce4-panel в системе — 4.10.1-1.

dpkg: ошибка при обработке пакета xfce4-windowck-plugin (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для hicolor-icon-theme (0.13-1) …
При обработке следующих пакетов произошли ошибки:
 xfce4-windowck-plugin
 

Оффлайн duletant

  • Местный житель
  • ***
  • Сообщений: 128
Re: Как установить xfce4-windowck-plugin?
« Ответ #5 : 04 Сентябрь 2016, 13:04:45 »
А что говорит #apt-get -f installпосле выше описанных действий?
 

Оффлайн Дождь

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 22
  • Debian 9.1 XFCE
Re: Как установить xfce4-windowck-plugin?
« Ответ #6 : 04 Сентябрь 2016, 13:14:54 »
duletant, вот две команды:
root@Home:/home/akb/Загрузки# dpkg -i 123.deb
Выбор ранее не выбранного пакета xfce4-windowck-plugin.
(Чтение базы данных … на данный момент установлено 135102 файла и каталога.)
Подготовка к распаковке 123.deb …
Распаковывается xfce4-windowck-plugin (0.3.1-0ubuntu1~oiteam0) …
dpkg: зависимости пакетов не позволяют настроить пакет xfce4-windowck-plugin:
 xfce4-windowck-plugin зависит от libwnck22 (>= 1:2.22), однако:
  Версия libwnck22 в системе — 2.30.7-2.
 xfce4-windowck-plugin зависит от libxfce4util7 (>= 4.9.0), однако:
  Пакет libxfce4util7 не установлен.
 xfce4-windowck-plugin зависит от xfce4-panel (>= 4.11), однако:
  Версия xfce4-panel в системе — 4.10.1-1.

dpkg: ошибка при обработке пакета xfce4-windowck-plugin (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для hicolor-icon-theme (0.13-1) …
При обработке следующих пакетов произошли ошибки:
 xfce4-windowck-plugin
root@Home:/home/akb/Загрузки# apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1
  coinor-libcoinutils3 coinor-libosi1 crda cups-client cups-pk-helper
  dns-root-data dnsmasq-base espeak-data exfalso fonts-sil-gentium
  fonts-sil-gentium-basic gir1.2-atspi-2.0 gir1.2-clutter-1.0
  gir1.2-clutter-gst-2.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0
  gir1.2-evince-3.0 gir1.2-gnomekeyring-1.0 gir1.2-gtkclutter-1.0
  gir1.2-gtksource-3.0 gir1.2-javascriptcoregtk-3.0 gir1.2-json-1.0
  gir1.2-keybinder-3.0 gir1.2-notify-0.7 gir1.2-packagekitglib-1.0
  gir1.2-soup-2.4 gir1.2-webkit-3.0 gir1.2-wnck-3.0 gnome-accessibility-themes
  gnome-orca gnome-power-manager gnome-session-canberra gnome-themes-standard
  gnome-themes-standard-data gnote gstreamer0.10-alsa gstreamer0.10-gconf
  gstreamer0.10-x gstreamer1.0-x gtk2-engines-pixbuf gtk2-engines-xfce hddtemp
  hyphen-en-us iceweasel iputils-arping iw javascript-common libatk-adaptor
  libaudclient2 libbit-vector-perl libbrlapi0.6 libburn4 libcarp-clan-perl
  libcdparanoia0 libcdr-0.1-1 libclass-data-inheritable-perl
  libclass-method-modifiers-perl libclutter-gst-2.0-0 libcmis-0.4-4
  libcommon-sense-perl libcrypt-openssl-bignum-perl libcrypt-openssl-rsa-perl
  libdata-random-perl libdate-calc-perl libdate-calc-xs-perl libdiscid0
  libdotconf0 libdv4 libegl1-mesa-drivers libelfg0 libespeak1 libetpan17
  libextutils-depends-perl libextutils-pkgconfig-perl libfile-which-perl
  libfreehand-0.1-1 libgail-common libgd-perl libgjs0e libgltf-0.0-0
  libgnome2-canvas-perl libgnome2-gconf-perl libgnome2-perl libgnome2-vfs-perl
  libgoo-canvas-perl libgoocanvas-common libgoocanvas3 libgpod-common libgpod4
  libgstreamer-plugins-base0.10-0 libgtk2-imageview-perl libgtk2-unique-perl
  libgtkimageview0 libgtkspell3-3-0 libhttp-server-simple-perl libical1a
  libimage-magick-perl libimage-magick-q16-perl libisofs6 libiw30 libjs-jquery
  libjs-sphinxdoc libjs-underscore libjson-perl libjson-xs-perl libjte1
  libkeybinder0 liblightdm-gobject-1-0 liblockfile-bin liblockfile1
  liblouis-data liblouis2 libmouse-perl libmozjs-24-0 libmspack0
  libmspub-0.1-1 libmusicbrainz5-1 libndp0 libnet-dropbox-api-perl
  libnet-oauth-perl libnetfilter-conntrack3 libnl-route-3-200 libnm-glib-vpn1
  libnm-gtk-common libnm-gtk0 libopenvg1-mesa liborcus-0.8-0
  libpagemaker-0.0-0 libpath-class-perl libproc-processtable-perl
  libproc-simple-perl libqt4-dbus libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-calc libreoffice-draw
  libreoffice-gtk libreoffice-help-en-us libreoffice-impress
  libreoffice-report-builder-bin libsgutils2-2 libsidplay1 libsonic0
  libsort-naturally-perl libspeechd2 libteamdctl0 libtidy-0.99-0
  libunique-1.0-0 libuuid-perl libvisio-0.1-1 libwps-0.3-3
  libwww-mechanize-perl libxfce4ui-utils libxfcegui4-4 libxklavier16
  libxmmsclient6 libzeitgeist-1.0-1 lightdm lightdm-gtk-greeter lp-solve
  media-player-info mobile-broadband-provider-info mythes-en-us
  network-manager network-manager-gnome perlmagick python-cddb python-cups
  python-cupshelpers python-feedparser python-libxml2 python-musicbrainz2
  python-mutagen python-pycurl python-pyinotify python-smbc python-utidylib
  python3-brlapi python3-louis python3-pyatspi python3-speechd python3-xdg
  qdbus qt-at-spi qtchooser ristretto speech-dispatcher
  speech-dispatcher-audio-plugins system-config-printer
  system-config-printer-udev task-desktop wireless-regdb x11-apps
  x11-session-utils xbrlapi xfburn xfce4-appfinder xfce4-artwork xfce4-clipman
  xfce4-notes xfce4-power-manager xfce4-power-manager-data xfce4-screenshooter
  xfce4-settings xfce4-volumed xfdesktop4-data xinit xorg xsane xsane-common
  xscreensaver xscreensaver-data
Для их удаления используйте «apt-get autoremove».
Пакеты, которые будут УДАЛЕНЫ:
  xfce4-windowck-plugin
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 34 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
После данной операции, объём занятого дискового пространства уменьшится на 302 kB.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 135174 файла и каталога.)
Удаляется xfce4-windowck-plugin (0.3.1-0ubuntu1~oiteam0) …
Обрабатываются триггеры для hicolor-icon-theme (0.13-1) …
 

Оффлайн duletant

  • Местный житель
  • ***
  • Сообщений: 128
Re: Как установить xfce4-windowck-plugin?
« Ответ #7 : 04 Сентябрь 2016, 13:36:36 »
В таком случае - либо дождитесь товарища ferum, может он объяснит как у него там с зависимостями дело обстоит, либо дорога на github и самостоятельная сборка пакета.
https://github.com/cedl38/xfce4-windowck-plugin/releases
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3441
  • Buster TDE & Buster LXDE & stretch KDE
Re: Как установить xfce4-windowck-plugin?
« Ответ #8 : 04 Сентябрь 2016, 15:23:42 »
Дождь, Всё понятно, значит  debhelper при сборке для ubuntu автоматически вычислил и прописал зависимости надо просто пересобрать пакет, покурите немного я попробую, заодно посмотрю что это за приблуда.

Cообщение объединено 04 Сентябрь 2016, 16:17:47
В общем дольше было ставить сборочную машину, результат https://yadi.sk/d/95wcHo4HukwEV  себе я уже поставил только пока не пойму что от установки пакета у меня в крысе изменилось, где этот плагин надо искать и за чем он нужен?
[ot]Видите сколько у меня вопросов, гораздо больше чем у вас.[/ot]
Прошу по результатам отписаться можно с картинками.
« Последнее редактирование: 04 Сентябрь 2016, 16:17:47 от ferum »
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Дождь

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 22
  • Debian 9.1 XFCE
Re: Как установить xfce4-windowck-plugin?
« Ответ #9 : 04 Сентябрь 2016, 16:39:19 »
Прошу по результатам отписаться можно с картинками.
Плагин работает, спасибо огромное!!!
Spoiler: ShowHide

Spoiler: ShowHide

где этот плагин надо искать
В параметрах панели, добавить элемент Window Header - Buttons.
и за чем он нужен?
Это кнопки управления окнами (развернуть/свернуть/закрыть) размещаемые в панели.
Этот вариант для меня удобнее, совместно с удалением окон приложений и системы.
Так же вариант актуален для тех у кого маленькие экраны мониторов.
 

Оффлайн alsoijw

  • Fedora 25 GNOME 3 amd64
  • Ветеран
  • *****
  • Сообщений: 1231
Re: Как установить xfce4-windowck-plugin?
« Ответ #10 : 04 Сентябрь 2016, 20:52:10 »
Дождь, типа unity?
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Оффлайн Дождь

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 22
  • Debian 9.1 XFCE
Re: Как установить xfce4-windowck-plugin?
« Ответ #11 : 04 Сентябрь 2016, 23:32:56 »
alsoijw, нет, в системе напрочь отсутствуют заголовки окон, даже в панели/трее как это реализовано в юнити, только кнопки управления окнами присутствуют в панели.
 

Оффлайн Дождь

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 22
  • Debian 9.1 XFCE
Re: Как установить xfce4-windowck-plugin?
« Ответ #12 : 09 Октябрь 2018, 18:41:27 »
ferum, в девятом дебиане фича перестала устанавливаться.
Spoiler: ShowHide

Прошу помочь с пакетом...
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3441
  • Buster TDE & Buster LXDE & stretch KDE
Re: Как установить xfce4-windowck-plugin?
« Ответ #13 : 09 Октябрь 2018, 21:55:57 »
Старый пакет и не должен устанавливаться, исходники https://www.google.ru/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&ved=2ahUKEwi8vsqugvrdAhWDlIsKHcRfAzkQFjAAegQICRAB&url=https%3A%2F%2Fgithub.com%2Fcedl38%2Fxfce4-windowck-plugin&usg=AOvVaw05bJqvsCW0dBkIwuqDQCCr
а сборку пакета на заказ наверное правильно сделать коммерческой.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Дождь

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 22
  • Debian 9.1 XFCE
Re: Как установить xfce4-windowck-plugin?
« Ответ #14 : 09 Октябрь 2018, 22:52:50 »
а сборку пакета на заказ наверное правильно сделать коммерческой.
Я все понял, спасибо!!!
Тему можно закрыть или удалить.
 

Теги:
 

[Решено][xfce4.8]Стандартные иконки

Автор paulcarroty

Ответов: 5
Просмотров: 2731
Последний ответ 10 Сентябрь 2011, 00:30:26
от paulcarroty
Отключить XFCE4

Автор kyi

Ответов: 5
Просмотров: 4182
Последний ответ 28 Ноябрь 2013, 17:35:04
от Sergei_Alekseev
xfce4 вытеснил fluxbox

Автор andrei186

Ответов: 25
Просмотров: 3461
Последний ответ 19 Ноябрь 2014, 22:27:28
от andrei186
баги и лог в xfce4.12

Автор mixtape

Ответов: 5
Просмотров: 2545
Последний ответ 14 Январь 2016, 18:41:20
от doublemint
xfce4, какое потребление памяти?

Автор JoePass

Ответов: 17
Просмотров: 6480
Последний ответ 02 Июль 2012, 00:11:12
от Olej