Автор Тема: [РЕШЕНО] Драйвер для Mobility Radeon HD 3470  (Прочитано 5862 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Aleksey

  • Новичок форума
  • Topic Author
  • Сообщений: 4
[РЕШЕНО] Драйвер для Mobility Radeon HD 3470
« : 29 Октябрь 2016, 22:52:31 »
У меня такая проблема:
Уже несколько раз пытаюсь перейти на Debian, но проблема с драйвером видеокарты.
Ну очень не комфортно! Вместо разрешения 1280 х 800 (16:10), которое устанавливается в Linux Mint 18, получаю 1024 х 768 61 Гц

Установил:
debian-8.6.0-amd64-CD-1

Видеокарта:
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]

Скачал с сайта AMD:
http://support.amd.com/en-us/download

драйвер под Linux:
amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.zip
именно для моей видеокарты драйвера нет, на сайте AMD говорят, что она старая и не поддерживается для Linux

Запустил установку:
sudo sh amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run

В терминале:
 AMD Catalyst(TM) Proprietary Driver Installer/Packager
==========================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: X.Org 6.9 or later 64-bit

В открывшемся окне:
AMD Catalyst(TM) Proprietary Driver 8.97.100.7 Setup

Необходимо выбрать:
Install Driver 8.97.100.7 on X.Org 6.9 or latter 64-bit
или
Generate Distribution Specific Driver Package

при выборе 1 варианта выдаёт:
One or more tools required for installation cannot be faund on ther system.
Install ther  required tools before installing the fglrx driver.
Optionally, run ther installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make you system unstable.
Not recommended.
See /usr/share/ati/fglrx-install.log for more detalls.

Посмотрел содержание fglrx-install.log:
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers.  /lib/modules/3.16.0-4-amd64/build/include/linux/version.h cannot be found on this system.
fglrx installation requires that the system has gcc tool. gcc cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.

попытался выполнить программу с --force:
sudo sh --force amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run
ответ: Извините, попробуйте еще раз

при выборе 2 варианта выдаёт:
подтверждаю лицензионное соглашение
и необходимо выбрать:
RedHat Packages:
- RedHat/RHEL5_64a
- RedHat/RHEL6_64a
- RedHat/RHEL5
- RedHat/RHEL6
просто от потолка выбираю  RedHat/RHEL5_64a
в результате:
Package Generation Completed

After installation of the generated package? It is important to save you X Window cofiguration file? and then run `aticonfig --initial` (in a console window) to complete the basic configuration of the display settings.
For advanced configuration, please run aticonfig from a console window or AMD CCC:LE from the Desktop Manager Menu.
A reboot of the system is recommendet after running aticonfig.

После чего выдаёт ошибку установки и вот log file:
Package build failed!
Package build utility output:
./packages/RedHat/ati-packager.sh: 217: ./packages/RedHat/ati-packager.sh: rpmbuild: not found
[Error] Generate Package - error generating package : RedHat/RHEL5_64a

попытался выполнить команду:
sudo aticonfig --initial
но в ответ: bash: aticonfig: команда не найдена

пробовал установить другие пакеты RedHat Packages — всё одинаково неудачно.

На странице:
https://wiki.debian.org/ru/AtiHowTo#A.2BBBQEQAQwBDkEMgQ1BEAEMA-
описывается как установить пакет: xserver-xorg-video-ati
но вот дальше, переходя по ссылке на этот пакет, я не могу разобраться что именно надо скачать и установить — для меня пока связь зависимостей это проблема....

Что теперь с этим делать?
Почему в Linux Mint всё встаёт по умолчанию?
Может там можно что-то взять для подсказки к установке?
« Последнее редактирование: 03 Ноябрь 2016, 20:15:32 от Aleksey »
 

Оффлайн dimsat1

  • # Linux user
  • Местный житель
  • ***
  • Сообщений: 173
  • На компах установлены правильные ОСы(debian)
Re: Драйвер для Mobility Radeon HD 3470
« Ответ #1 : 30 Октябрь 2016, 03:56:49 »
Почему в Linux Mint всё встаёт по умолчанию?
Может там можно что-то взять для подсказки к установке?
драйвера лежат в /lib/firmware/  ;)
как-то было у меня похожее, на долбаный радеон дрова не ставились, долго недумаючи взял папку из минта и просто положил по такому-же пути  :)
debian(jessie) ...DE_Mate... LINUX - FOREVER!
Sams Smart IPTV nStreamLmod_v.3.х
 

Оффлайн Malaheenee

  • Ветеран
  • *****
  • Сообщений: 2565
  • Учтите, мы можем дать и вредный совет.
Re: Драйвер для Mobility Radeon HD 3470
« Ответ #2 : 30 Октябрь 2016, 13:18:58 »
Aleksey, Вы в игры рубитесь? Нет? Тогда ставьте свободный драйвер (работает без лагов, аппаратное декодирование видео есть).

apt-get install xserver-xorg-video-radeon firmware-amd-graphics libegl1-mesa libgl1-mesa-glx libgl1-mesa-dri mesa-vdpau-drivers vdpau-va-driver libvdpau-va-gl1
И создаете два файла:
/etc/X11/xorg.conf.d/20-ati-vga.conf
Section "Module"
Load  "dri2"
Load  "glamoregl"
EndSection

Section "Device"
Identifier  "Radeon"
Driver      "radeon"
Option      "AccelMethod"  "glamor"
EndSection

/etc/modprobe.d/radeon-kms.conf
options radeon modeset=1 dynclks=1 hw_i2c=1 aspm=1 dpm=1
Перезагрузка.
Все мы где-то, когда-то и в чем-то были новичками.
 
Пользователи, которые поблагодарили этот пост: Aleksey

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
Aleksey, у меня старый AGP адаптер от ASUS (ATI RV730 Pro AGP [Radeon HD 4600 Series]) прекрасно работает с открытыми дровами.

/etc/X11/xorg.conf
Section "Device"
    Identifier   "Device0"
    Driver       "radeon"
    Option       "MigrationHeuristic"  "greedy"
    Option       "EnablePageFlip"      "true"
EndSection

/etc/modprobe.d/radeon-kms.conf
options radeon modeset=1 gartsize=128 hw_i2c=1 dpm=1
options radeon agpmode=8     #если AGP и если оно 8X

Драйвер (Wheezy): xserver-xorg-video-radeon_7.5.0-1mcr120+1
Firmware (Wheezy): firmware-amd-graphics_20160824-1mcr120+1

Для Jessie:
http://mxrepo.com/mx/testrepo/pool/test/f/firmware-nonfree/
http://mxrepo.com/mx/testrepo/pool/test/x/xserver-xorg-video-ati/
deb http://mxrepo.com/mx/testrepo/ mx15 testОт туда вам нужны только xserver-xorg-video-radeon и firmware-amd-graphics с зависимостями, больше из этого репозитория (для решения вашей проблемы) ничего устанавливать/обновлять не надо, если конечно вы не гээээймер.
Перед обновлением сначала надо сделать копию системы: https://debianforum.ru/index.php?topic=6879
Данный способ вы используете на свой страх и риск!
« Последнее редактирование: 01 Ноябрь 2016, 19:43:12 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн Aleksey

  • Новичок форума
  • Topic Author
  • Сообщений: 4
Re: Драйвер для Mobility Radeon HD 3470
« Ответ #4 : 30 Октябрь 2016, 19:14:04 »
Почему в Linux Mint всё встаёт по умолчанию?
Может там можно что-то взять для подсказки к установке?
драйвера лежат в /lib/firmware/  ;)
как-то было у меня похожее, на долбаный радеон дрова не ставились, долго недумаючи взял папку из минта и просто положил по такому-же пути  :)


Спасибо! Как ни странно работает!!!
Хотя думаю не так уж и странно учитывая принцип построения самой системы Linux.

Cообщение объединено 30 Октябрь 2016, 19:18:30
Aleksey, у меня старый AGP адаптер от ASUS (ATI RV730 Pro AGP [Radeon HD 4600 Series]) прекрасно работает с открытыми дровами.

/etc/X11/xorg.conf
Section "Device"
    Identifier   "Device0"
    Driver       "radeon"
    Option       "MigrationHeuristic"  "greedy"
    Option       "EnablePageFlip"      "true"
EndSection

/etc/modprobe.d/radeon-kms.conf
options radeon modeset=1
options radeon agpmode=8     #если AGP и если оно 8X
options radeon gartsize=128

Драйвер (Wheezy): xserver-xorg-video-radeon_7.5.0-1mcr120+1
Firmware (Wheezy): firmware-amd-graphics_20160824-1mcr120+1

Для Jessie:
http://mxrepo.com/mx/testrepo/pool/test/f/firmware-nonfree/
http://mxrepo.com/mx/testrepo/pool/test/x/xserver-xorg-video-ati/
deb http://mxrepo.com/mx/testrepo/ mx15 testОт туда вам нужны только xserver-xorg-video-radeon и firmware-amd-graphics с зависимостями, больше из этого репозитория (для решения вашей проблемы) ничего устанавливать/обновлять не надо, если конечно вы не гээээймер.
Перед обновлением сначала надо сделать копию системы: https://debianforum.ru/index.php?topic=6879
Данный способ вы используете на свой страх и риск!

Спасибо, обязательно разберусь в этом!
Сейчас уже поздно - пора спать ложиться, завтра на работу.
Я могу задать Вам вопросы если буду тормозить и не пойму что-то?
« Последнее редактирование: 30 Октябрь 2016, 19:18:30 от Aleksey »
 

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
Re: Драйвер для Mobility Radeon HD 3470
« Ответ #5 : 30 Октябрь 2016, 20:22:18 »
Я могу задать Вам вопросы
Это ведь форум, конечно здесь задают вопросы. Работает и хорошо, перво наперво разберитесь с созданием резервной копии системных разделов, а потом уже можно эксперементировать.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3670
  • Buster TDE & KDE
Re: Драйвер для Mobility Radeon HD 3470
« Ответ #6 : 30 Октябрь 2016, 21:01:00 »
Aleksey, Думаю вы уже прочитали https://wiki.debian.org/ru/ATIProprietary
Имеющийся проприаретарный драйвер вашу карту не поддерживает и вам очевидно придётся использовать свободный а что бы разрешения экрана было правильным отступитесь от Gnome и его производных, используйте что то полегче например mate xfce lxde.... я вот страшно консервативен и по этому балдею от trinity.
Кстати любое из перечисленных окружений просто удобнее гнома.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн dimsat1

  • # Linux user
  • Местный житель
  • ***
  • Сообщений: 173
  • На компах установлены правильные ОСы(debian)
Re: Драйвер для Mobility Radeon HD 3470
« Ответ #7 : 31 Октябрь 2016, 06:07:23 »
любое из перечисленных окружений просто удобнее гнома
стопудов правильно.
Был-же хороший гном2, нет, сделали нехороший гном3..
Хорошо что хоть мэйт есть и другие лёгкие де :)
debian(jessie) ...DE_Mate... LINUX - FOREVER!
Sams Smart IPTV nStreamLmod_v.3.х
 

Оффлайн alsoijw

  • Fedora 25 GNOME 3 amd64
  • Ветеран
  • *****
  • Сообщений: 1231
Re: Драйвер для Mobility Radeon HD 3470
« Ответ #8 : 31 Октябрь 2016, 16:39:15 »
Народ, давайте обсуждать удобство/неудобство гнома в другой теме.
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Оффлайн Aleksey

  • Новичок форума
  • Topic Author
  • Сообщений: 4
Re: Драйвер для Mobility Radeon HD 3470
« Ответ #9 : 31 Октябрь 2016, 20:36:14 »
Aalexeey, спасибо за ссылки! Не знаю когда бы до них дошёл сам... Не поленился и заново уставил Debian, потом сразу эти пакеты и всё встало на места!!!
Сейчас надо будет разобраться с Wine. Нормально устанавливается из менеджера пакетов (стандартный пакет), но вот почему-то пока я его не вижу ни в приложениях, ни в контекстном меню.

Cообщение объединено 31 Октябрь 2016, 20:46:30
Aleksey ... отступитесь от Gnome и его производных, используйте что то полегче например mate xfce lxde.... я вот страшно консервативен и по этому балдею от trinity.

У меня система с Mate   ;)

Cообщение объединено 31 Октябрь 2016, 20:58:09
Aleksey, Вы в игры рубитесь? Нет? Тогда ставьте свободный драйвер (работает без лагов, аппаратное декодирование видео есть).

apt-get install xserver-xorg-video-radeon firmware-amd-graphics libegl1-mesa libgl1-mesa-glx libgl1-mesa-dri mesa-vdpau-drivers vdpau-va-driver libvdpau-va-gl1
И создаете два файла:
/etc/X11/xorg.conf.d/20-ati-vga.conf
Section "Module"
Load  "dri2"
Load  "glamoregl"
EndSection

Section "Device"
Identifier  "Radeon"
Driver      "radeon"
Option      "AccelMethod"  "glamor"
EndSection

/etc/modprobe.d/radeon-kms.conf
options radeon modeset=1 dynclks=1 hw_i2c=1 aspm=1 dpm=1
Перезагрузка.

Я обязательно это сохраню, возможно пригодится. Но т.к. видяху на ноуте менять не собираюсь (менять так весь ноут), то со скаченными deb-пакетам как то попроще получилось. Хотя и в этом решении ничего сложного не вижу. При очередной переустановке системы попробую этот вариант обязательно.

Cообщение объединено 31 Октябрь 2016, 21:00:34
Не нашёл как пометить тему "РЕШЕНО". Спасибо всем за помощь!!!
« Последнее редактирование: 31 Октябрь 2016, 21:00:34 от Aleksey »
 

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
Драйвер для Mobility Radeon HD 3470
« Ответ #10 : 31 Октябрь 2016, 21:28:24 »
как пометить тему "РЕШЕНО"
В вашем первом посте нажмите "изменить" и отредактируйте название на: [Решено] Драйвер для Mobility Radeon HD 3470
Не поленился и заново уставил Debian
Тут дело не в лени а во времени, разберитесь как делать архивы-копии системных разделов и про переустановки забудете совсем.
Я обязательно это сохраню, возможно пригодится
Параметры для xorg.conf надо проверять применимы они к вашей системе или нет, я вчера например проверил предоставленное от Malaheenee и оно у меня не работает, модуль glamoregl не загружается и соответсвенно AccelMethod glamor не работает.
« Последнее редактирование: 02 Ноябрь 2016, 20:31:24 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн CoolAller

  • Старожил
  • ****
  • Сообщений: 834
Re: Драйвер для Mobility Radeon HD 3470
« Ответ #11 : 02 Ноябрь 2016, 19:05:16 »
именно для моей видеокарты драйвера нет
Пакет: firmware-linux-nonfree (Radeon RV620 microcode)
« Последнее редактирование: 02 Ноябрь 2016, 19:08:55 от CoolAller »
 

Оффлайн Aalexeey

  • Местный житель
  • ***
  • Сообщений: 421
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
Re: Драйвер для Mobility Radeon HD 3470
« Ответ #12 : 02 Ноябрь 2016, 20:30:15 »
Пакет: firmware-linux-nonfree (Radeon RV620 microcode)
Оно там включено в firmware-amd-graphics (Заменяет: firmware-linux-nonfree <20151018-1~), если-бы человек знал что такое бэкпорты то было-бы всё попроще, разберётся.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 
Пользователи, которые поблагодарили этот пост: Aleksey

Теги:
 

Настройка вывода звука (Решено)

Автор Tammy

Ответов: 2
Просмотров: 2475
Последний ответ 20 Июнь 2013, 07:37:17
от Tammy
[Решено] Отвалилась запись с микрофона

Автор sidbar

Ответов: 2
Просмотров: 1079
Последний ответ 03 Февраль 2017, 12:43:24
от sidbar
Проблема при установке драйвера на видео карту Radeon HD 6700 Series

Автор qaohv

Ответов: 8
Просмотров: 3026
Последний ответ 27 Сентябрь 2011, 17:03:48
от SeHELLioN
[Решено] не воспроизводится онлайн видео

Автор nashkh

Ответов: 30
Просмотров: 32341
Последний ответ 29 Август 2015, 20:13:06
от sagara.deb
[РЕШЕНО]Тормоза в Firefox+youtube debian 9

Автор achirik

Ответов: 9
Просмотров: 3286
Последний ответ 01 Июль 2017, 05:32:24
от achirik