Автор Тема: Проблема при установке libapache2-mod-php5  (Прочитано 2636 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DJ Sergeich

Люди добрые, подскажите, как побороть такую ошибку:

# apt-get install  libapache2-mod-php5
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apache2.2-bin : Depends: libapr1 (>= 1.4.2) but it is not going to be installed
                 Depends: libaprutil1 (>= 1.4.0) but it is not going to be installed
                 Depends: libaprutil1-dbd-sqlite3 but it is not going to be installed or
                          libaprutil1-dbd-mysql but it is not going to be installed or
                          libaprutil1-dbd-odbc but it is not going to be installed or
                          libaprutil1-dbd-pgsql but it is not going to be installed or
                          libaprutil1-dbd-freetds but it is not going to be installed
                 Depends: libaprutil1-ldap but it is not going to be installed
                 Depends: libssl1.0.0 (>= 1.0.1) but it is not going to be installed
 apache2.2-common : Depends: apache2-utils but it is not going to be installed
                    Depends: procps but it is not going to be installed
                    Depends: perl but it is not going to be installed
                    Recommends: ssl-cert but it is not going to be installed
 libapache2-mod-php5 : Depends: libssl1.0.0 (>= 1.0.0) but it is not going to be installed
                       Depends: apache2-mpm-prefork (> 2.0.52) but it is not going to be installed or
                                apache2-mpm-itk but it is not going to be installed
                       Depends: php5-common (= 5.4.45-0+deb7u5) but it is not going to be installed
                       Depends: ucf but it is not going to be installed
                       Depends: tzdata but it is not going to be installed
                       Recommends: php5-cli but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
 

Оффлайн qupl

Re: Проблема при установке libapache2-mod-php5
« Ответ #1 : 03 Ноября 2016, 21:27:38 »
Мало информации. Вывод
cat /etc/apt/sources.list
uname -a
lsb_release -a

Оффлайн DJ Sergeich

Re: Проблема при установке libapache2-mod-php5
« Ответ #2 : 03 Ноября 2016, 23:18:49 »
# cat /etc/apt/sources.list

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb http://mirror.yandex.ru/debian/ wheezy main contrib non-free
НО! В процессе необдуманных экспериментов ранее были использованы и другие репозитории, в частности:
deb http://noc.netangels.ru/debian unstable main
deb http://noc.netangels.ru/debian wheezy main


# uname -a
Linux yankee.teran.pw 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1+deb7u1 x86_64 GNU/Linux

# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 7.11 (wheezy)
Release:        7.11
Codename:       wheezy
 

Оффлайн ogost

Re: Проблема при установке libapache2-mod-php5
« Ответ #3 : 04 Ноября 2016, 04:41:16 »
Сломаны зависимости. Вангую, что как раз из-за смешивания веток/сторонних репов. Обычно указанный пакет ставится совершенно без проблем.

Оффлайн DJ Sergeich

Re: Проблема при установке libapache2-mod-php5
« Ответ #4 : 04 Ноября 2016, 11:24:10 »
Сломаны зависимости. Вангую, что как раз из-за смешивания веток/сторонних репов. Обычно указанный пакет ставится совершенно без проблем.
Отлично. С первым классическим вопросом - "кто виноват?" - разобрались...
Остаётся второй классический вопрос - "что делать?"
 

Оффлайн ferum

Re: Проблема при установке libapache2-mod-php5
« Ответ #5 : 04 Ноября 2016, 11:53:58 »
Вопрос риторический , надо зависимости исправить а для этого некоторые пакеты придётся заместить версиями пакетов из стандартного репозитория и делается это принудительно через dpkg -i  скачанные пакеты. Первым делом естественно надо найти конец цепочки то есть момент установки/обновления пакетов со сторонних источников. Естественно вам виднее когда и с чем вы там экспериментировали. Логи изменения пакетной базы смотрят в /root/.synaptic/log/  там всё по датам.
Из вашего вывода неудачной установки я бы обратил внимание на пакет libssl1.0.0 (>= 1.0.0) что там за версия установлена и его зависимости.
Сторонние источники разумеется предварительно необходимо отключить.
Русские дебианщики против цифрового слабоумия !
 
Пользователи, которые поблагодарили этот пост: netaul

Теги:
 

Проблема с пакетами

Автор AkidSe

Ответов: 4
Просмотров: 1775
Последний ответ 14 Января 2014, 08:28:02
от qupl
Проблема с записью загрузочной флешки

Автор thzero

Ответов: 15
Просмотров: 4378
Последний ответ 09 Октября 2017, 13:10:34
от xandvik
[Решено] Непонятная проблема с запуском xfce и icewm.

Автор m90125

Ответов: 5
Просмотров: 2273
Последний ответ 07 Марта 2012, 21:42:24
от ihammers
Проблема со звуком в 8.1 xfce

Автор compiz

Ответов: 4
Просмотров: 1753
Последний ответ 18 Июня 2015, 08:20:04
от uncivil
Проблема с графикой после установки xfce

Автор Oknolaz

Ответов: 0
Просмотров: 299
Последний ответ 27 Мая 2020, 08:24:55
от Oknolaz