Автор Тема: Установка skype  (Прочитано 1642 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн frgt10

  • Новичок форума
  • Topic Author
  • Сообщений: 1
Установка skype
« : 23 Февраля 2017, 14:06:22 »
Пытаюсь установить skype на kali linux , ввожу следующие команды:
1 dpkg --add-acrhitecture i386
2 apt-get install libpulse0:i386
3  wget - O skype-install.deb http://www.skype.com/go/getskype-linux-deb
4 apt-get install -f
5 dpkg -i skype-install.deb

И в конце выходит :
dpkg: ошибка при обработке пакета skype:i386 (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для dbus (1.10.16-1) …
Обрабатываются триггеры для gnome-menus (3.13.3-8) …
Обрабатываются триггеры для desktop-file-utils (0.23-1) …
Обрабатываются триггеры для mime-support (3.60) …
Обрабатываются триггеры для hicolor-icon-theme (0.15-1) …
При обработке следующих пакетов произошли ошибки:
 skype:i386

Что делать?
 

Оффлайн amd_amd

Re: Установка skype
« Ответ #1 : 23 Февраля 2017, 14:32:22 »
Что делать?
# apt-get install -f
 

Оффлайн ferum

Re: Установка skype
« Ответ #2 : 23 Февраля 2017, 14:43:04 »
Да не проканает... Вообще предлагаю игнорировать вопросы про Kali linux так как это совершенно другой дистрибутив. На сколько мне известно он имеет сейчас форму роллинг релиза, то есть плавно обновляется а старый пакет skype уже давно не ставится не на тестинг не на последние бунты по простой причине несовместимости библиотек.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн amd_amd

Re: Установка skype
« Ответ #3 : 23 Февраля 2017, 15:55:35 »
это совершенно другой дистрибутив
да но он на основе: Debian (Testing)
 

Оффлайн alsoijw

Re: Установка skype
« Ответ #4 : 23 Февраля 2017, 16:38:30 »
бета версия тоже не ставится?
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Оффлайн Walter_322

Re: Установка skype
« Ответ #5 : 23 Февраля 2017, 20:04:08 »
Что если пробовать устанавливать с помощью gdebi? что ему не нравится с зависимостями?  в Debian Stretch ему не нравится, что скайп требует пакет libssl1.0.0:amd64, которого в репозиториях нет. решается пересборкой пакета с переписыванием зависимостей. вот скрипт, который поможет это сделать быстро:
#!/bin/bash

if [[ -z "$1" ]]; then
  echo "Syntax: $0 debfile"
  exit 1
fi

DEBFILE="$1"
TMPDIR=`mktemp -d /tmp/deb.XXXXXXXXXX` || exit 1
OUTPUT=`basename "$DEBFILE" .deb`.modfied.deb

if [[ -e "$OUTPUT" ]]; then
  echo "$OUTPUT exists."
  rm -r "$TMPDIR"
  exit 1
fi

dpkg-deb -x "$DEBFILE" "$TMPDIR"
dpkg-deb --control "$DEBFILE" "$TMPDIR"/DEBIAN

if [[ ! -e "$TMPDIR"/DEBIAN/control ]]; then
  echo DEBIAN/control not found.

  rm -r "$TMPDIR"
  exit 1
fi

CONTROL="$TMPDIR"/DEBIAN/control

MOD=`stat -c "%y" "$CONTROL"`
nano "$CONTROL"

if [[ "$MOD" == `stat -c "%y" "$CONTROL"` ]]; then
  echo Not modfied.
else
  echo Building new deb...
  dpkg -b "$TMPDIR" "$OUTPUT"
fi

rm -r "$TMPDIR"
 

Оффлайн robber

Re: Установка skype
« Ответ #6 : 13 Апреля 2017, 21:19:17 »
Хоть уже и не актуально, все же поправлю топикстартера... ему нужно поменять местами пункты 4 и 5 своей программы действий...
установка пакета:
dpkg -i skype-install.debрешение проблем с зависимостями:
apt-get install -f
« Последнее редактирование: 13 Апреля 2017, 21:38:36 от robber »
 

Теги:
 

Установка Wheezy.

Автор Sergey

Ответов: 8
Просмотров: 1969
Последний ответ 12 Апреля 2013, 21:51:44
от cinyflo
Установка Frontol xPOS на GNU/Lunix Debian 6

Автор Adil

Ответов: 10
Просмотров: 6713
Последний ответ 08 Ноября 2016, 15:23:52
от Adil
Установка на mdadm raid1

Автор debiandroid

Ответов: 2
Просмотров: 958
Последний ответ 01 Мая 2018, 13:56:51
от debiandroid
Установка apt в арче

Автор Ba4ChohL

Ответов: 3
Просмотров: 252
Последний ответ 19 Октября 2020, 06:14:54
от Ba4ChohL
Установка Debian на HTC Elf

Автор Scorpey

Ответов: 5
Просмотров: 2061
Последний ответ 10 Мая 2012, 21:05:32
от Василий