Автор Тема: Ошибка при обновлении Debian 8 до Debian 9  (Прочитано 1367 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ferox2017

  • Новичок форума
  • Topic Author
  • Сообщений: 2
Не могу обновить систему до Debian 9 , появляется такая ошибка:

This system has a graphics card which is no longer handled by the NVIDIA     
 │ driver (package nvidia-driver). You may wish to keep the package             
 │ installed - for instance to drive some other card - but the card with       
 │ the following chipset won't be usable:                                       
 │                                                                             
 │ 01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G96             
 │ [GeForce 9500 GT] [10de:0640] (rev a1)                                       
 │                                                                             
 │ The above card requires either the non-free legacy NVIDIA driver             
 │ (package nvidia-legacy-340xx-driver) or the free Nouveau driver (package     
 │ xserver-xorg-video-nouveau).                                                 
 │                                                                             
 │ Use the update-glx command to switch between different installed             
 │ drivers.       
После нее процесс апгрейда прекращается, ну а после перезагрузки система не стартует, приходится восстанавливать систему из резервной копии. Может кто-нибудь сталкивался с подобным?
 


Онлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4941
  • memento mori
  • Jabber: qupl@jabber.ru
Re: Ошибка при обновлении Debian 8 до Debian 9
« Ответ #1 : 20 Июнь 2017, 15:16:15 »
Все же написано, новый драйвер не поддерживает данную видеокарту, либо ставить legacy драйвер либо Nouveau.

Оффлайн Ferox2017

  • Новичок форума
  • Topic Author
  • Сообщений: 2
Re: Ошибка при обновлении Debian 8 до Debian 9
« Ответ #2 : 20 Июнь 2017, 15:41:33 »
Все же написано, новый драйвер не поддерживает данную видеокарту, либо ставить legacy драйвер либо Nouveau.
Ну я, конечно, прочитал, то что там написано... но, например, здесь: https://wiki.debian.org/ru/NvidiaGraphicsDrivers#A.2BBBIENQRABEEEOARP_340.96 описывается установка драйвера версии 340.96 (340xx, как мне советуют), и там этот драйвер ставится командой aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-driver, т е ставится пакет nvidia-driver, который и выдает у меня ошибку: This system has a graphics card which is no longer handled by the NVIDIA driver (package nvidia-driver).
« Последнее редактирование: 20 Июнь 2017, 15:46:06 от Ferox2017 »
 

Оффлайн Komorebi

  • @debian 8 GNOME
  • Пользователь
  • *
  • Сообщений: 34
Re: Ошибка при обновлении Debian 8 до Debian 9
« Ответ #3 : 21 Июнь 2017, 01:26:12 »
Хреново быть обладателем нвидии
 

Онлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4941
  • memento mori
  • Jabber: qupl@jabber.ru
Re: Ошибка при обновлении Debian 8 до Debian 9
« Ответ #4 : 21 Июнь 2017, 10:54:52 »
Ferox2017, так там описывается для Jessie (8 ). В Stretch этот же драйвер уже legacy, ищите его в репозитории.

Теги:
 

Ошибка linux-image-3.16.0-4-686-pae

Автор daemon89

Ответов: 10
Просмотров: 1794
Последний ответ 23 Март 2017, 07:04:05
от qupl
Google chrome ошибка сегментирования

Автор Ferox

Ответов: 24
Просмотров: 4301
Последний ответ 11 Октябрь 2014, 20:27:06
от kon-dv
[РЕШЕНО] Ошибка в kwrite или нет?

Автор Metrix

Ответов: 3
Просмотров: 2243
Последний ответ 08 Март 2011, 00:38:52
от Ghostdmn
При выполнении команды update-grub ошибка not foundrub-mkconfig: 5

Автор Bojokot

Ответов: 1
Просмотров: 1287
Последний ответ 24 Сентябрь 2017, 14:47:07
от Juriy
NetInstall. Ошибка при устновке Jessie [РЕШЕНО]

Автор sx88

Ответов: 1
Просмотров: 1021
Последний ответ 11 Май 2015, 21:46:19
от mrgoodvin