Автор Тема: Debian 9 + Viber Запуск....  (Прочитано 5680 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SatoshiNakamoto

  • Новичок форума
  • Topic Author
  • Сообщений: 8
Debian 9 + Viber Запуск....
« : 21 Июнь 2017, 10:31:13 »
Всем привет. Пробую запустить Viber на  Debian 9 и ничего не получается. Сам вайбер запускается но при попытке порохождения верификации выдает ошибку, что нет подключения к сети Интернет. Помогите  ???
 


Оффлайн edevyatkin

  • Новичок форума
  • Сообщений: 6
Re: Debian 9 + Viber Запуск....
« Ответ #1 : 21 Июнь 2017, 12:28:02 »
А я его вообще поставить не смог, не хватает по зависимостям libssl1.0.0.
« Последнее редактирование: 21 Июнь 2017, 12:37:39 от edevyatkin »
 

Оффлайн SatoshiNakamoto

  • Новичок форума
  • Topic Author
  • Сообщений: 8
Re: Debian 9 + Viber Запуск....
« Ответ #2 : 21 Июнь 2017, 12:43:09 »
Короче запустил я его ))))

1) Создаем в папке /usr/local/share/ca-certificates/mozilla файл thawte_Premium_Server_CA.pem и пихаем туда код с этого ресурса
https://www.thawte.com/roots/thawte_Premium_Server_CA.pem
Сохраняем файл

2) Создаем в папке /usr/local/share/ca-certificates/mozilla файл thawte_Premium_Server_CA.crt и пихаем туда код с этого ресурса
https://github.com/katmagic/https-everywhere/blob/master/cert-validity/mozilla/builtin-certs/Thawte_Premium_Server_CA.crt
Сохраняем файл

Дальше команда в терминале sudo update-ca-certificates или dpkg-reconfigure ca-certificates

После этого инсталлируем вайбер

dpkg -i /папка где сидит вайбер/viber.deb

Если при установке видим что вайбер инсталируется с ошибками из за зависимостей пакетов, так как в посте выше, устанавливаем эти пакеты отдельно и после этого снова устанавливаем вайбер.

Вот к примеру требуемый пакет
https://packages.debian.org/ru/jessie/amd64/libssl1.0.0/download
Качаем его и в терминале dpkg -i /папке где он сидит/libssl1.0.0_1.0.1t-1+deb8u6_amd64.deb
« Последнее редактирование: 21 Июнь 2017, 12:48:06 от SatoshiNakamoto »
 
Пользователи, которые поблагодарили этот пост: edevyatkin

Оффлайн ecc83

  • Ветеран
  • *****
  • Сообщений: 1354
  • Debian, Openbox
Re: Debian 9 + Viber Запуск....
« Ответ #3 : 21 Июнь 2017, 18:52:58 »
dpkg -i /папка где сидит вайбер/viber.deb
Если при установке видим что вайбер инсталируется с ошибками из за зависимостей пакетов, так как в посте выше, устанавливаем эти пакеты отдельно и после этого снова устанавливаем вайбер

Если известно, что для установки deb пакета нужны зависимости, то лучше устанавливать его при помощи утилиты gdebi.

sudo gdebi /папка где сидит вайбер/viber.deb
Она сама подтянет и установит необходимые зависимости. Разумеется они должны быть в репозитории.

Сама утилита также имеет и графический интерфейс. Устанавливается командой:

sudo apt install gdebi

 

Теги:
 

[РЕШЕНО] Debian 8 MATE. Не запускается Synaptic, не монтируются диски

Автор panzerfaust

Ответов: 20
Просмотров: 8368
Последний ответ 17 Апрель 2015, 14:27:08
от panzerfaust
Удаленное администрирование Windows машин на Debian в домене.

Автор Роман846

Ответов: 6
Просмотров: 1428
Последний ответ 18 Март 2016, 16:06:51
от Роман846
[Решено] Установка Debian

Автор ZanO

Ответов: 17
Просмотров: 3866
Последний ответ 18 Февраль 2012, 12:03:14
от ZanO
Debian LiveCD

Автор echo_alo

Ответов: 1
Просмотров: 963
Последний ответ 06 Март 2017, 18:17:33
от ogost
Как удалить Debian

Автор ilario

Ответов: 24
Просмотров: 11208
Последний ответ 17 Декабрь 2014, 22:21:31
от Гусак Игорь