Автор Тема: Черный экран при запуске системы  (Прочитано 3212 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн illigarium

  • Новичок форума
  • Topic Author
  • Сообщений: 9
Захожу в систему с LiveUSB(С меню самого загрузчика все нормально), пробегают надписи, а потом черный экран. Курсора нет, просто чистый черный экран. И еще бегает надпись монитора "неоптимизированный режим". В WMware все работает нормально. Если необходимо, могу снять видео с экрана и дать ссылку(YouTube). Компьютер: fx8300 и gtx1060, 8гб DDR3. Помогите чайнику пожалуйста.  :'(
« Последнее редактирование: 19 Июль 2017, 15:33:35 от illigarium »
 

Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 3160
  • Linux Registered User #547151
Re: Черный экран при запуске системы
« Ответ #1 : 19 Июль 2017, 17:50:57 »
Какой образ? Компакт диск, или флешка? Возможно проблема в отсутствии драйверов на видеокарту. Про gtx1060 не уверен, возможно к нему нет драйверов в вашем образе. По Ctrl+Alt+F1 выводит в консоль? Если да, то посмотреть логи, dmesg

Оффлайн illigarium

  • Новичок форума
  • Topic Author
  • Сообщений: 9
Re: Черный экран при запуске системы
« Ответ #2 : 19 Июль 2017, 17:53:19 »
Образ LiveUSB. Консоль, думаю, не выведет, потому что клавиатура и мышь отключаются(не горит подсветка). Если нет драйверов, можете посоветовать где почитать, как их встроить в LiveUSB?
 

Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 3160
  • Linux Registered User #547151
Re: Черный экран при запуске системы
« Ответ #3 : 20 Июль 2017, 05:41:31 »
Образов LiveUSB вагон и маленькая тележка, укажите точнее.
Консоль, думаю, не выведет, потому что клавиатура и мышь отключаются(не горит подсветка).
всё же попробуйте.

Оффлайн illigarium

  • Новичок форума
  • Topic Author
  • Сообщений: 9
Re: Черный экран при запуске системы
« Ответ #4 : 20 Июль 2017, 14:46:34 »
всё же попробуйте.
Образ debian-live-9.0.1-amd64-xfce. Пробовал образ с KDE - все так же. Консоль не выводится, хоть проблемы с клавиатурой и мышкой я исправил.
« Последнее редактирование: 20 Июль 2017, 23:20:06 от illigarium »
 

Онлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 5021
  • memento mori
  • Jabber: qupl@jabber.ru
Re: Черный экран при запуске системы
« Ответ #5 : 21 Июль 2017, 09:34:29 »
Видеокарт сколько? Первая консоль будет на выходе, который определился первым.

Оффлайн illigarium

  • Новичок форума
  • Topic Author
  • Сообщений: 9
Re: Черный экран при запуске системы
« Ответ #6 : 21 Июль 2017, 13:35:25 »
Видеокарт сколько? Первая консоль будет на выходе, который определился первым.
Видеокарта одна. К ее выходу через Hdmi->SVGA переходник подключен монитор.
 

Оффлайн mrgoodvin

  • Местный житель
  • ***
  • Сообщений: 331
Re: Черный экран при запуске системы
« Ответ #7 : 22 Июль 2017, 11:14:05 »
Надписи перед появлением черного экрана увидеть бы.
В WMware все работает нормально.
Имеется ввиду удачная загрузка под WMware самого образа или факт загрузки с флешки? 1-й факт в данной ситуации не несет полезной информации, 2-й - продолжать дальше читать это сообщение бессмысленно.
Консоль не выводится, хоть проблемы с клавиатурой и мышкой я исправил.
Можно поподробней, как исправили?
Не указан способ создания флешки, и возможно дело как раз в в этом. Если есть большие фалы на ней, а тем более если там iso тогда как вариант попробуйте ее дефрагментировать.
 

Оффлайн illigarium

  • Новичок форума
  • Topic Author
  • Сообщений: 9
Re: Черный экран при запуске системы
« Ответ #8 : 22 Июль 2017, 12:03:52 »
Все образы всех Linux'ов не видели у меня мышь и клавиатуру. Я их подключил к разным контроллерам матери и все заработало: у меня один контроллер на 2.0,другой на 3.0 и еще один на 3.1. Я подключил к 3.0 и 3.1.
Флешка создавалась руфусом из iso. Режим записи стандартный, не DD. Файловая система Fat32. Образ сам около 1.5гб, так что файлов больше 4 гб там нет скорее всего. Дефрагментировать попробую, записи запишу на видео.
Имеется ввиду удачная загрузка под WMware самого образа или факт загрузки с флешки? 1-й факт в данной ситуации не несет полезной информации, 2-й - продолжать дальше читать это сообщение бессмысленно.
Я запустил систему, а потом установил ее. Все прекрасно работало в обоих случаях.

 

Онлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 5021
  • memento mori
  • Jabber: qupl@jabber.ru
Re: Черный экран при запуске системы
« Ответ #9 : 22 Июль 2017, 14:10:58 »
Покажите /var/log/Xorg.0.log

Оффлайн mrgoodvin

  • Местный житель
  • ***
  • Сообщений: 331
Re: Черный экран при запуске системы
« Ответ #10 : 22 Июль 2017, 15:05:42 »
Есть две возможные ситуации: 1-я, не грузится live из-за проблем работы ядра_драйверов с железом (на переходнике видим начальную загрузку, следовательно поэтому сам переходник в состоянии ОК); 2-я, не правильно создана флешка, и у меня такое случалось (казалось бы идет загрузка, но а дальше стопориться на чем-то). Так вот, если бы была выполнена загрузка под WMware (я с ним не работал, но qemu позволяет это сделать) именно с флешки. Предполагаю что это можно сделать и в WMware, выбрав в качестве устройства на загрузку именно флешку, а не образ конкретно диска (это второй случай о котором указывалось выше). И если бы произошла удачная загрузка с флешки на виртуалке, то это означало бы что проблемы именно в железе в качестве работы ядра_драйверов с live носителем. Если были бы при загрузке с флешки на виртуалке те же проблемы, тогда проблемы с флешкой(ее методом создания). В моей ситуации помогла дефрагментация iso-образа, но это частный случай (обладатель особой загрузочной флешки). Или пробовать другие программы для записи образа на флешку, если аналогичные проблемы  - вывод очевиден. Работоспособность самого образа скаченного с оф. сайта, рассматриваю в последнюю очередь, и не исключаю. Но данный образ (debian-live-9.0.1-amd64-xfce) у меня грузится и работает.
« Последнее редактирование: 22 Июль 2017, 15:15:38 от mrgoodvin »
 

Оффлайн illigarium

  • Новичок форума
  • Topic Author
  • Сообщений: 9
Re: Черный экран при запуске системы
« Ответ #11 : 22 Июль 2017, 15:54:27 »
Есть две возможные ситуации: 1-я, не грузится live из-за проблем работы ядра_драйверов с железом (на переходнике видим начальную загрузку, следовательно поэтому сам переходник в состоянии ОК); 2-я, не правильно создана флешка, и у меня такое случалось (казалось бы идет загрузка, но а дальше стопориться на чем-то). Так вот, если бы была выполнена загрузка под WMware (я с ним не работал, но qemu позволяет это сделать) именно с флешки. Предполагаю что это можно сделать и в WMware, выбрав в качестве устройства на загрузку именно флешку, а не образ конкретно диска (это второй случай о котором указывалось выше). И если бы произошла удачная загрузка с флешки на виртуалке, то это означало бы что проблемы именно в железе в качестве работы ядра_драйверов с live носителем. Если были бы при загрузке с флешки на виртуалке те же проблемы, тогда проблемы с флешкой(ее методом создания). В моей ситуации помогла дефрагментация iso-образа, но это частный случай (обладатель особой загрузочной флешки). Или пробовать другие программы для записи образа на флешку, если аналогичные проблемы  - вывод очевиден. Работоспособность самого образа скаченного с оф. сайта, рассматриваю в последнюю очередь, и не исключаю. Но данный образ (debian-live-9.0.1-amd64-xfce) у меня грузится и работает.
Ошибка не в записи на флешку. Загрузился с нее в VMware, все нормально, в систему заходит, изображение есть.
Покажите /var/log/Xorg.0.log
Если вы о настоящем компьютере, а не ВМ, то систему я не устанавливал. Могу попробовать установить и стащить оттуда лог. Вы это имели в виду?
« Последнее редактирование: 22 Июль 2017, 17:21:21 от illigarium »
 

Оффлайн ioann.sys

  • Админ
  • Местный житель
  • ***
  • Сообщений: 164
  • всегда прав!
Re: Черный экран при запуске системы
« Ответ #12 : 22 Июль 2017, 22:55:02 »
Это еще может быть из-за старой версии ядра для такой видеокарты. По-сути, видеокарта топовая и поддержка в ядре началась с версии 4.12.
Debian GNU/Linux jessie/sid on notebook ASUS N750JK
 

Оффлайн illigarium

  • Новичок форума
  • Topic Author
  • Сообщений: 9
Re: Черный экран при запуске системы
« Ответ #13 : 23 Июль 2017, 14:55:28 »
При загрузке заметил строку от nouveau: unknown chipset. Это, случаем, не имеет отношения к делу? Есть какая-то возможность обновить версию ядра в системе, не заходя в нее? Например, из Ubuntu(он работает нормально) или вообще пересобрать сам liveUSB?  Я и искал, но найти не смог. Может, плохо искал. Попробую обновить, загрузившись с реального раздела в VMware, но программа говорит, что он после этого может не загрузиться.
« Последнее редактирование: 24 Июль 2017, 08:52:41 от illigarium »
 

Оффлайн mrgoodvin

  • Местный житель
  • ***
  • Сообщений: 331
Re: Черный экран при запуске системы
« Ответ #14 : 24 Июль 2017, 21:49:56 »
При загрузке заметил строку от nouveau: unknown chipset.
Скорее всего из-за этого. Заменить ядро думая возможно, но с live наверно буде затруднительно.
Можно попробовать эту сборку https://cdimage.debian.org/images/unofficial/non-free/images-including-firmware/weekly-live-builds/, но там ядро версии 4.11. Могут быть те же ошибки.
 
Пользователи, которые поблагодарили этот пост: illigarium

Теги:
 

Черный экран при загрузке ОС и мигающий курсов

Автор Gilekont

Ответов: 2
Просмотров: 1237
Последний ответ 22 Март 2015, 13:07:44
от Гусак Игорь
черный экран после установки драйвера видеокарты

Автор 380V

Ответов: 3
Просмотров: 786
Последний ответ 11 Июль 2019, 13:10:15
от 380V
Чёрный экран после установки

Автор Http55

Ответов: 20
Просмотров: 3080
Последний ответ 26 Март 2018, 05:57:51
от ogost
LMDE 2 Betsy 64. Черный экран.

Автор userman

Ответов: 24
Просмотров: 3862
Последний ответ 04 Декабрь 2015, 15:20:10
от alsoijw
Черный экран после запуска

Автор kitscribe

Ответов: 9
Просмотров: 1037
Последний ответ 15 Декабрь 2019, 20:04:36
от kitscribe