После обновления до 9-ки не прорисовывается графический интерфейс

Автор PbI6A, 07 августа 2017, 05:58:53

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

PbI6A

...в некоторых приложениях. Например:
- это remmina из пакетов 8-ки
- это virt-manager
Я так полагаю, не хватает каких-то компонент? Но каких?
LINUX means: Linux Is Not a UniX
Вернулся на Devuan. Счастлив!

Walter_322

Это проблемы с темами. Gtk 3.20 не совместим со старыми версиями. Вам нужно либо найти более свежую версию вашей темы gtk, либо поменять тему на другую (поддерживающую gtk 3.22).

PbI6A

Посмотрел - и правда! С другими темами стало нормально. Век живи, век учись, а всё одно - дураком помрёшь  :P
Спасибо, дружище!  ;)
LINUX means: Linux Is Not a UniX
Вернулся на Devuan. Счастлив!

sidbar

Подскажите, в некоторых программах, таких как Virtualbox, VLC, DjView4 шрифт отображается не так как в других программах, сильно мелкий, что надо сделать чтобы изменить его?
Devuan GNU/Linux 4 Chimaera x86_64

PbI6A

Если память не изменяет, графический интерфейс этих прог написан под Qt? Наверно надо корячить настройки Qt.
LINUX means: Linux Is Not a UniX
Вернулся на Devuan. Счастлив!

sidbar

Цитата: PbI6A от 12 августа 2017, 19:31:50Если память не изменяет, графический интерфейс этих прог написан под Qt? Наверно надо корячить настройки Qt.
Спасибо большое за ответ, подскажите где эти настройки храняться? В LibreOffic'e и SMPlayer я их нашел в интерфейсе, в этих программах есть возможность увеличить шрифт, а где в других не понятно.
Devuan GNU/Linux 4 Chimaera x86_64


sidbar

Подхватил настройки из Qt 4 config только VLC. А в qt5-default не находит config, не знаю где он есть.
Devuan GNU/Linux 4 Chimaera x86_64

sidbar

Нашел таки
Добавить в /etc/environment

QT_QPA_PLATFORMTHEME=gtk2
QT_STYLE_OVERRIDE=gtk2


Установить пакеты qt5-gtk-platformtheme и qt5-style-plugins
Devuan GNU/Linux 4 Chimaera x86_64