Не работает вай-фай на кедах

Автор ЦарьПушка, 10 ноября 2017, 13:06:20

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

ЦарьПушка

Пять лет сидел на Убунту и производныхх. Пришло время менять систему, так как Убунту 12.04 глючит последнее время по стращному, уже не поддерживаются некоторые программы.
Решил кардинально всё поменять и перейти на Дебиан, а так же решил поставить с Кедами - менять, так менять качественно.
Выкачал Лайв-СД Дебиана 9.2 с Кедами, и возникла проблема с вай-фай (у меня усб-адаптер)

Подключаюсь к сети,
Пишет сперва "Авторизация", потом долго секунд 40 примерно (специально не засекал) "Настройка интерфейса", а затем выходит "Сбой подключения".
И в конце 2 всплывающих:
"БЕСПРОВОДНЫЙ ИНТЕРФЕЙС.
Не удалось найти беспроводную сеть"
"Соединение отключено"

Гуглил решение проблемы, снес по наггуленному Валлет. Толку нет



Cообщение объединено 10 ноября 2017, 13:22:55

Флешка для интернета - TL-WN727N

ferum

В сети миллион инструкций как это делается и на нашем форуме есть. Единственное на live режиме он работать не будет а после установки  и компиляции модуля настраивать хоть через конфиги хоть через гномовский nm, последнее проще.
Русские дебианщики против цифрового слабоумия !

ek-nfn

Либо ручное подключение, либо уйти на Debian 8 или ubuntu 16.04. Проблема в версии NM. С версиями новее 1.2 именно такая картина с  usb wi-fi. В debian 9 версия 1.6, в debian 8 - 0.9, в ubuntu 16.04 - 1.2
Debian 11 xfce

ЦарьПушка

#3
Цитата: ferum от 10 ноября 2017, 14:26:32
В сети миллион инструкций как это делается и на нашем форуме есть. 
Прежде, чем открывать тему, я всё перепробовал, что есть в сети

Cообщение объединено 10 Ноября 2017, 17:58:04

Цитата: ferum от 10 ноября 2017, 14:26:32
Единственное на live режиме он работать не будет а после установки  и компиляции модуля настраивать хоть через конфиги хоть через гномовский nm, последнее проще.
Так вот в чём дело?
Просто я привык перед установкой подключать интернет и устанавливать с подкачкой из сети.
То есть, если я правильно понял, можно смело ставить без инета?
А настройкой wi-fi заняться после установки?

Cообщение объединено 10 ноября 2017, 17:59:35

Цитата: ek-nfn от 10 ноября 2017, 15:19:03
Либо ручное подключение, либо уйти на Debian 8 или ubuntu 16.04. Проблема в версии NM. С версиями новее 1.2 именно такая картина с  usb wi-fi. В debian 9 версия 1.6, в debian 8 - 0.9, в ubuntu 16.04 - 1.2
А как вариант установить рабочую версию?
Я читал, что в дебиане стейбл используются программы 1,2 летней давности, так почему в убунту, оснвоанной на дебиане анстейбл, постарее программа?

ferum

Цитата: ЦарьПушка от 10 ноября 2017, 17:56:08То есть, если я правильно понял, можно смело ставить без инета?
Ставить конечно можно но из коробки не будет инструментов разработки и исходников драйвера. Эти вопросы конечно решаемы но самый простой и удобный способ подоткнуть кабель или подключить другой источник инета, который поддерживается из коробки.
Версию программы входящюю в дистрибутив определяет сопровождающий. К тому же вы сравниваете два LTS дистрибутива, гонка за новизной больше удел роллинг релизов.
Русские дебианщики против цифрового слабоумия !

ek-nfn

#5
Цитата: ЦарьПушка от 10 ноября 2017, 17:56:08Я читал, что в дебиане стейбл используются программы 1,2 летней давности, так почему в убунту, оснвоанной на дебиане анстейбл, постарее программа?
Не знаю причин почему 16.04 сидит на версии 1.2, а debian 9 на 1.6, но сам решил проблему таким макаром - на одной из машин так и остался на debian 8, а на другой debian 9 заменил на ubuntu 16.04. Решений в сети не нашел окромя советов снести NM.
Причем, если на ubuntu повысить версию NM до 1.8-2.0, то проблема возникает и на ней. На ubuntu 17.04 уже версия 1.4, на 17.10 - 1.8
Кстати, на сколько понял и mint до сих пор сидит на версии 1.2
Debian 11 xfce

ЦарьПушка

#6
Цитата: ek-nfn от 10 ноября 2017, 19:24:41
Цитата: ЦарьПушка от 10 ноября 2017, 17:56:08Я читал, что в дебиане стейбл используются программы 1,2 летней давности, так почему в убунту, оснвоанной на дебиане анстейбл, постарее программа?
Не знаю причин почему 16.04 сидит на версии 1.2, а debian 9 на 1.6, но сам решил проблему таким макаром - на одной из машин так и остался на debian 8, а на другой debian 9 заменил на ubuntu 16.04. Решений в сети не нашел окромя советов снести NM.
Причем, если на ubuntu повысить версию NM до 1.8-2.0, то проблема возникает и на ней. На ubuntu 17.04 уже версия 1.4, на 17.10 - 1.8
Кстати, на сколько понял и mint до сих пор сидит на версии 1.2
А не пробовал поставить на дебиан 9 старую версию NM?

Cообщение объединено 11 ноября 2017, 12:21:20

А можно Wi-cd попробовать вместо NM на Live-DVD при том, что больше никаких вариантов, кроме как через wifi подключиться к инету нет?

ecc83

Цитата: ЦарьПушка от 11 ноября 2017, 12:13:05
А можно Wi-cd попробовать вместо NM на Live-DVD при том, что больше никаких вариантов, кроме как через wifi подключиться к инету нет?

Можно конечно. А можно вообще отключить все менеджеры сети и настроить systemd-networkd.
Если это обычный домашний комп и нет необходимости часто подключаться к разным другим сетям, то это самый безглючный вариант.

ek-nfn

#8
Цитата: ЦарьПушка от 11 ноября 2017, 12:13:05А не пробовал поставить на дебиан 9 старую версию NM?
Не знаю. Пробовал ставить deb пакет со старой версией, предупредило, что в системе есть более новая, не согласился, поставил старую, версия не поменялась. 2-й вариант не пробовал - через снос NM, чистку от невостребованных зависимостей и установку старой версии. Мне кажется тут будет проблема с конфликтующими пакетами зависимостей.

Если нет потребности в частом переподключении между роутерами, то проще отключить NM и подключиться вручную. С этим нет проблем в 9-м дебиане
Debian 11 xfce

ЦарьПушка

#9
на аск убунту ещё советуют  ConMan или Intel/Moblin Connection Manager как альтернативы NM

Cообщение объединено 11 Ноября 2017, 13:21:32

Скачал отсюда деб пакет https://packages.debian.org/sid/all/wicd/download
перезагружаюсь в лайв дебиана.
отпишусь позже, надеюсь, что уже с лайва

ЦарьПушка

если до установки хотя бы видело беспроводные сети, но не подключалось, то сейчас вовсе не видит.

#iwconfig
lo no wireless extensions
enp0s10 no wireless extensions

ecc83

ЦарьПушка, там сервисы нетворк менеджера нужно вручную остановить, а сервис wicd запустить.
У тебя по прежнему всем управляет нетворкменеджер.

А зачем скачивать deb пакет? Почему не устанавливаешь из репозитория?

ЦарьПушка

Цитата: ecc83 от 12 ноября 2017, 14:35:17
ЦарьПушка, там сервисы нетворк менеджера нужно вручную остановить, а сервис wicd запустить.
У тебя по прежнему всем управляет нетворкменеджер.

А зачем скачивать deb пакет? Почему не устанавливаешь из репозитория?
затем, что в лайв не работал интернет)

Ну я установил, подключил провод и всё настроил.
проблема решена