Автор Тема: Подскажите аналог Акробат Ридера для открытия определённого типа файлов.  (Прочитано 6716 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ЦарьПушка

Акробат Ридер почему-то не встаёт у меня в Дебиан 9
Но мне он необходим для работы с файлом.
http://www.echr.coe.int/Documents/Application_Form_RUS.pdf

В других программах выходит:
Цитировать
Please wait...
If this message is not eventually replaced by the proper contents of the document, your PDF
viewer may not be able to display this type of document.
You can upgrade to the latest version of Adobe Reader for Windows®, Mac, or Linux® by
visiting  http://www.adobe.com/go/reader_download.
For more assistance with Adobe Reader visit  http://www.adobe.com/go/acrreader.
Windows is either a registered trademark or a trademark of Microsoft Corporation in the United States and/or other countries. Mac is a trademark
of Apple Inc., registered in the United States and other countries. Linux is the registered trademark of Linus Torvalds in the U.S. and other
countries.
Подскажите свободный аналог Акробат Ридеру
 

Оффлайн ecc83

Акробат Ридер почему-то не встаёт у меня в Дебиан 9

Ты можешь объяснить, что значит "не встаёт"?
Как устанавливал, какие ошибки получал?
Как с ними боролся, кроме жалоб на форуме?

Просто у меня "встаёт", вот и интересуюсь
 

Оффлайн ЦарьПушка

Акробат Ридер почему-то не встаёт у меня в Дебиан 9

Ты можешь объяснить, что значит "не встаёт"?
Как устанавливал, какие ошибки получал?
Как с ними боролся, кроме жалоб на форуме?

Просто у меня "встаёт", вот и интересуюсь

# sudo apt-get update && sudo apt-get install acroread mozilla-acroread
Сущ:1 http://security.debian.org/debian-security stretch/updates InRelease
Пол:2 http://www.deb-multimedia.org stretch InRelease [33,4 kB]                       
Игн:3 http://deb.debian.org/debian stretch InRelease                                   
Сущ:5 http://deb.debian.org/debian stretch-updates InRelease                           
Сущ:6 http://deb.debian.org/debian stretch Release                                     
Игн:4 http://cdn-fastly.deb.debian.org/debian stretch InRelease                       
Сущ:7 http://cdn-fastly.deb.debian.org/debian stretch Release       
Игн:2 http://www.deb-multimedia.org stretch InRelease
Пол:8 http://www.deb-multimedia.org stretch/main amd64 Packages [150 kB]
Пол:11 http://www.deb-multimedia.org stretch/main i386 Packages [153 kB]
Пол:12 http://www.deb-multimedia.org stretch/non-free amd64 Packages [2 128 B]
Пол:13 http://www.deb-multimedia.org stretch/non-free i386 Packages [4 944 B]
Получено 344 kБ за 5с (65,0 kБ/c)                       
Чтение списков пакетов… Готово
W: Ошибка GPG: http://www.deb-multimedia.org stretch InRelease: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 5C808C2B65558117
W: Репозиторий «http://www.deb-multimedia.org stretch InRelease» не подписан.
N: Данные из этого репозитория нельзя аутентифицировать, и поэтому потенциально из небезопасно использовать.
N: Смотрите справочную страницу apt-secure(8) о создании репозитория и настройке пользователя.
W: Цель Packages (main/binary-amd64/Packages) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель Packages (main/binary-i386/Packages) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель Packages (main/binary-all/Packages) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель Translations (main/i18n/Translation-ru_RU) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель Translations (main/i18n/Translation-ru) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель Translations (main/i18n/Translation-en) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель DEP-11 (main/dep11/Components-amd64.yml) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель DEP-11 (main/dep11/Components-all.yml) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель DEP-11-icons (main/dep11/icons-64x64.tar) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель DEP-11-icons-hidpi (main/dep11/icons-128x128.tar) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель Packages (main/binary-amd64/Packages) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель Packages (main/binary-i386/Packages) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель Packages (main/binary-all/Packages) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель Translations (main/i18n/Translation-ru_RU) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель Translations (main/i18n/Translation-ru) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель Translations (main/i18n/Translation-en) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель DEP-11 (main/dep11/Components-amd64.yml) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель DEP-11 (main/dep11/Components-all.yml) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель DEP-11-icons (main/dep11/icons-64x64.tar) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
W: Цель DEP-11-icons-hidpi (main/dep11/icons-128x128.tar) настроена несколько раз в /etc/apt/sources.list:7 и /etc/apt/sources.list.d/base.list:1
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет mozilla-acroread:i386 недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «mozilla-acroread:i386» не найден кандидат на установку

Cообщение объединено [time]16 Ноября 2017, 18:07:10[/time]
устанавливал по ману - https://wiki.debian.org/PDF

архитектуру i386  не устанавливал, так как установил её раньше.

добавил репозитарий deb http://www.deb-multimedia.org squeeze main non-free

с него акробат ридер не встаёт.



Cообщение объединено 16 Ноября 2017, 18:17:57
Вот вывод при устанвоке пакета, скаченного с сайта акробат ридера
# dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb
Выбор ранее не выбранного пакета adobereader-enu:i386.
(Чтение базы данных … на данный момент установлено 236022 файла и каталога.)
Подготовка к распаковке AdbeRdr9.5.5-1_i386linux_enu.deb …
Распаковывается adobereader-enu:i386 (9.5.5) …
dpkg: зависимости пакетов не позволяют настроить пакет adobereader-enu:i386:
 adobereader-enu:i386 зависит от libgtk2.0-0 (>= 2.4).

dpkg: ошибка при обработке пакета adobereader-enu:i386 (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для man-db (2.7.6.1-2) …
При обработке следующих пакетов произошли ошибки:
 adobereader-enu:i386
« Последнее редактирование: 16 Ноября 2017, 18:17:57 от ЦарьПушка »
 

Оффлайн ferum

Русские дебианщики против цифрового слабоумия !
 

Оффлайн ЦарьПушка

добавил репозитарий deb http://www.deb-multimedia.org squeeze stretch main non-free
Ну, да, стретч.
Я в соеднйе теме давал вивод сорсе лит.
сейчас сюда продуюлирую

Cообщение объединено 16 Ноября 2017, 19:11:21
# cat /etc/apt/sources.list
#

# deb cdrom:[Official Debian GNU/Linux Live 9.2.0 kde 2017-10-07T13:21]/ stretch main

#deb cdrom:[Official Debian GNU/Linux Live 9.2.0 kde 2017-10-07T13:21]/ stretch main

deb http://deb.debian.org/debian/ stretch main
deb-src http://deb.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch-updates main
deb-src http://deb.debian.org/debian/ stretch-updates main

# Debian 9 "Stretch"
deb http://httpredir.debian.org/debian/ stretch main contrib non-free

# multimedia
deb http://www.deb-multimedia.org stretch main non-free
 

Оффлайн ecc83

ЦарьПушка, скажи пожалуйста, а ты сам читаешь - анализируешь то, то выводит терминал?
Или сразу сюда постишь, что бы остальные читали и говорили тебе что делать? :)

По прежнему у тебя бардак в /etc/apt/sources.list с дублирующимися записями.

Замени содержимое sources.list на вот это:

deb http://ftp.uk.debian.org/debian/ stretch main non-free contrib
#deb-src http://ftp.uk.debian.org/debian/ stretch main non-free contrib

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
#deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.uk.debian.org/debian/ stretch-updates main contrib non-free
#deb-src http://ftp.uk.debian.org/debian/ stretch-updates main contrib non-free

deb http://ftp.de.debian.org/debian/ stretch-proposed-updates non-free contrib main

deb http://www.deb-multimedia.org stretch main non-free
deb http://www.deb-multimedia.org stretch-backports main

После добавления репозитория http://www.deb-multimedia.org необходимо установить ключ. Там на сайте всё написано и есть ссылка на установку ключа.
Терминал ругается на отсутствие, но ты этого не замечаешь.

Без ключа этот репозиторий не имеет смысла.

wget http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/deb-multimedia-keyring_2016.8.1_all.debsudo dpkg -i deb-multimedia-keyring_2016.8.1_all.debsudo apt-get update
Установку акробат ридера попробуй таким образом:

sudo apt-get install gdebi -ywget -c ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.debecho д | sudo gdebi AdbeRdr9.5.5-1_i386linux_enu.deb
 
Пользователи, которые поблагодарили этот пост: ЦарьПушка

Оффлайн ЦарьПушка

ЦарьПушка, скажи пожалуйста, а ты сам читаешь - анализируешь то, то выводит терминал?
Или сразу сюда постишь, что бы остальные читали и говорили тебе что делать? :)

По прежнему у тебя бардак в /etc/apt/sources.list с дублирующимися записями.

Замени содержимое sources.list на вот это:

deb http://ftp.uk.debian.org/debian/ stretch main non-free contrib
#deb-src http://ftp.uk.debian.org/debian/ stretch main non-free contrib

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
#deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.uk.debian.org/debian/ stretch-updates main contrib non-free
#deb-src http://ftp.uk.debian.org/debian/ stretch-updates main contrib non-free

deb http://ftp.de.debian.org/debian/ stretch-proposed-updates non-free contrib main

deb http://www.deb-multimedia.org stretch main non-free
deb http://www.deb-multimedia.org stretch-backports main

После добавления репозитория http://www.deb-multimedia.org необходимо установить ключ. Там на сайте всё написано и есть ссылка на установку ключа.
Терминал ругается на отсутствие, но ты этого не замечаешь.

Без ключа этот репозиторий не имеет смысла.

wget http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/deb-multimedia-keyring_2016.8.1_all.debsudo dpkg -i deb-multimedia-keyring_2016.8.1_all.debsudo apt-get update
Установку акробат ридера попробуй таким образом:

sudo apt-get install gdebi -ywget -c ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.debecho д | sudo gdebi AdbeRdr9.5.5-1_i386linux_enu.deb
Вопрос, а зачем мне тогда нужен репозитарий eb-multimedia.org, если акробат ридер устанавливать с ftp://ftp.adobe.com?
 

Оффлайн ecc83

Вопрос, а зачем мне тогда нужен репозитарий deb-multimedia.org, если акробат ридер устанавливать с ftp://ftp.adobe.com?

Ну откуда мне знать, зачем тебе всякие репозитории? Вообще то этот репозиторий обычно ставят не ради акробат ридера, а ради мультимедии.
Свежих кодеков и всяких плееров. Так что тебе виднее зачем тебе всё это :)
 

Оффлайн ЦарьПушка

Вопрос, а зачем мне тогда нужен репозитарий deb-multimedia.org, если акробат ридер устанавливать с ftp://ftp.adobe.com?

Ну откуда мне знать, зачем тебе всякие репозитории? Вообще то этот репозиторий обычно ставят не ради акробат ридера, а ради мультимедии.
Свежих кодеков и всяких плееров. Так что тебе виднее зачем тебе всё это :)
Я написал в этой теме, что делал по ману для установки Акробат Ридера)
Кодеки и плееры не нужны. Комп для работы.
Там нужны Либре ОФис, Вай-фай, Акробат Ридер, Браузер, принтер, сканер.
 

Оффлайн ecc83

Кодеки и плееры не нужны. Комп для работы.

Ну извини  :-[

 

Оффлайн ЦарьПушка

Кодеки и плееры не нужны. Комп для работы.

Ну извини  :-[
Не стоит извинений)
Я же не написал, для чего мне нужен комп.
Я просто хотел услышать ответ на вопрос: "Нужен ли это реп, если я его установил исключительно для установки акробатридера, если акробат ридер лучше устанавливать не с репа, а сайта акробата?"

Лично я думаю, с репа лучше - будет обновляться.
Поэтому и уточняю.
Спасибо
 

Оффлайн ferum

ЦарьПушка Ваши действия вполне нормальны и логичны, репозиторий  deb-multimedia всегда считался полезным! К сожалению хотя наш любимый дистрибутив и становится всё более "юзерфрендли",  в нём всё ещё остаются проблемы с функционалом в некоторых специфичных сферах, возможно от того что дистрибутив поддерживается командой энтузиастов, а некоторые приложения этого энтузиазма не вызывают или такой порыв со временем исчезает. Тем не менее со всеми этими недостатками можно жить, на край большинство тех же продуктов adobe прекрасно работают в wine.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн ecc83

Лично я думаю, с репа лучше - будет обновляться.

Да, вот только акробат ридера под линукс это не касается.
 По ссылке что я дал, последняя версия ридера, которая написана под линукс. Больше не планируется.
Разве только если Земля налетит на небесную ось.

Запасайся пока не убрали. Скачай две копии :)
 

Оффлайн dmitry1903

Акробат - точно не единственная программа для просмотра PDF.
Есть Evince, который ставится вместе с Гномом:
https://packages.debian.org/stretch/evince
« Последнее редактирование: 16 Ноября 2017, 21:56:50 от dmitry1903 »
 

Оффлайн ecc83

Акробат - точно не единственная программа для просмотра PDF.

Никто и не говорит, что она единственная. Я автору эту предложил, но он не реагирует

https://packages.debian.org/stretch/qpdfview
 

Теги:
 

подскажите по установке airControl 2.1

Автор Palamar

Ответов: 4
Просмотров: 1923
Последний ответ 08 Декабря 2017, 14:47:00
от qupl
Подскажите где хранится pool.ntp

Автор simonflex

Ответов: 21
Просмотров: 2730
Последний ответ 23 Марта 2019, 15:41:26
от simonflex
Подскажите с ...

Автор Utility

Ответов: 0
Просмотров: 1017
Последний ответ 19 Июля 2015, 03:25:41
от Utility
Подскажите, как правильно создать патчи для исходников

Автор nihi1ist

Ответов: 7
Просмотров: 1902
Последний ответ 06 Сентября 2017, 14:00:11
от nihi1ist
Подскажите что это может быть

Автор simonflex

Ответов: 3
Просмотров: 1550
Последний ответ 03 Февраля 2019, 18:32:50
от gardarea51