Автор Тема: [РЕШЕНО]Сломанные зависимости mariadb server  (Прочитано 2192 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн seregareal2

  • Пользователь
  • *
  • Сообщений: 16
Spoiler: ShowHide

┌─[seregareal2@parrot]─[~]
└──╼ $su -
Пароль:
root@parrot:~# apt-get update
Hit:1 http://yandex-asia.archive.parrotsec.org/mirrors/parrot parrot InRelease
Err:2 http://repo.digital-forensic.org/debian jessie InRelease                 
  Could not connect to repo.digital-forensic.org:80 (51.15.12.80). - connect (111: Connection refused)
Ign:3 http://labs.seravo.fi/~otto/mariadb-repo MDEV-5977/ InRelease           
Hit:5 http://deb.parrotsec.org/parrot parrot InRelease                         
Ign:6 http://yandex-asia.archive.parrotsec.org/mirrors/parrot parrot-updates InRelease
Hit:7 http://ftp.debian.org/debian jessie-backports InRelease                 
Err:8 http://yandex-asia.archive.parrotsec.org/mirrors/parrot parrot-updates Release
  404  Not Found [IP: 213.180.204.183 80]
Err:9 http://labs.seravo.fi/~otto/mariadb-repo MDEV-5977/ Release             
  404  Not Found
Hit:10 http://repo.yandex.ru/yandex-disk/deb stable InRelease                 
Ign:12 http://dl.google.com/linux/chrome/deb stable InRelease                 
Hit:13 http://dl.google.com/linux/chrome/deb stable Release                   
Get:4 http://ppa.launchpad.net/webupd8team/java/ubuntu trusty InRelease [15.5 kB]
Hit:14 http://ftp.de.debian.org/debian sid InRelease                           
Get:11 http://ppa.launchpad.net/webupd8team/java/ubuntu precise InRelease [13.3 kB]
Err:4 http://ppa.launchpad.net/webupd8team/java/ubuntu trusty InRelease       
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C2518248EEA14886
Hit:16 http://security.debian.org/debian-security stretch/updates InRelease   
Err:11 http://ppa.launchpad.net/webupd8team/java/ubuntu precise InRelease     
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C2518248EEA14886
Hit:17 http://security.debian.org/debian-security wheezy/updates InRelease     
Hit:18 http://mirrors.dotsrc.org/kali kali-rolling InRelease                   
Reading package lists... Done
E: The repository 'http://yandex-asia.archive.parrotsec.org/mirrors/parrot parrot-updates Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://labs.seravo.fi/~otto/mariadb-repo MDEV-5977/ Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://ppa.launchpad.net/webupd8team/java/ubuntu trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C2518248EEA14886
E: The repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu trusty InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://ppa.launchpad.net/webupd8team/java/ubuntu precise InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C2518248EEA14886
E: The repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu precise InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
root@parrot:~# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  abiword abiword-common abiword-plugin-grammar alsa-base gfortran-mingw-w64
  gfortran-mingw-w64-i686 gfortran-mingw-w64-x86-64 gnat-mingw-w64
  gnat-mingw-w64-base gnat-mingw-w64-i686 gnat-mingw-w64-x86-64 libabiword-3.0
  libbind9-141 libcdio16 libcgal12 libchamplain-0.12-0 libchamplain-gtk-0.12-0
  libclang1-3.9 libdns-export190 libdns190 libebook-1.2-19 libecal-1.2-19
  libevent-2.0-5 libgcj-bc libirs-export141 libirs141 libisc-export189
  libisc189 libisccc140 libisccfg-export144 libisccfg144 libjs-angularjs
  libjs-lodash liblink-grammar5 liblivemedia58 libllvm3.9 libloudmouth1-0
  liblwres141 libnetcdf11 libntfs-3g872 libots0 libqcustomplot1.3
  libqgis-analysis2.14.20 libqgis-core2.14.20 libqgis-gui2.14.20
  libqgis-networkanalysis2.14.20 libqgis-server2.14.20 libqgispython2.14.20
  libradare2-2.0 libsac-java-gcj libsbsms10 libsfcgal1 libsox2 libwv-1.2-4
  libx265-130 libx265-130:i386 link-grammar-dictionaries-en
  linux-headers-4.13.0-parrot10-amd64 linux-headers-4.13.0-parrot10-common
  linux-image-4.13.0-parrot10-amd64 minisat python-qwt5-qt4
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up mariadb-server-10.1 (1:10.1.29-6) ...
dpkg: error processing package mariadb-server-10.1 (--configure):
 installed mariadb-server-10.1 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of mariadb-server:
 mariadb-server depends on mariadb-server-10.1 (>= 1:10.1.29-6); however:
  Package mariadb-server-10.1 is not configured yet.

dpkg: error processing package mariadb-server (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 mariadb-server-10.1
 mariadb-server
Configuring sandbox profiles....
Sandbox profiles updated!
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@parrot:~#





Снимок экрана в 2017-11-28 19-46-53.png
« Последнее редактирование: 29 Декабря 2017, 12:19:00 от seregareal2 »
 

Оффлайн ecc83

Re: Сломанные зависимости mariadb server
« Ответ #1 : 26 Декабря 2017, 19:09:52 »
Цитировать
http://ppa.launchpad.net/webupd8team/java/ubuntu

Вы перепутали форум. Тут Debian, а вам наверное вопросы по Ubuntu нужно решить.
 

Оффлайн seregareal2

  • Пользователь
  • *
  • Сообщений: 16
Re: Сломанные зависимости mariadb server
« Ответ #2 : 26 Декабря 2017, 23:20:52 »
Цитировать
http://ppa.launchpad.net/webupd8team/java/ubuntu

Вы перепутали форум. Тут Debian, а вам наверное вопросы по Ubuntu нужно решить.

нет
у меня Parrot, основан на Debian

Spoiler: ShowHide

$lsb_release -a
No LSB modules are available.
Distributor ID:   Parrot
Description:   Parrot 3.10 - Intruder
Release:   3.10
Codename:   intruder


$uname -r
4.14.0-parrot2-amd64


$uname -r
4.14.0-parrot2-amd64
[2]-  Завершён        cd=4
[4]+  Завершён        ct=clnk


$uname -a
Linux parrot 4.14.0-parrot2-amd64 #1 SMP Parrot 4.14.2-1parrot2 (2017-12-05) x86_64 GNU/Linux

 

Оффлайн ecc83

Re: Сломанные зависимости mariadb server
« Ответ #3 : 26 Декабря 2017, 23:44:27 »
нет
у меня Parrot, основан на Debian

Вы это всё серьёзно пишете или что бы потролить?

У вас "левые" репозитории подключены, в том числе убунтовский РРА, и вас беспокоят сломаные зависимости?
Чего бы им не быть сломаными?
 

symon2014

  • Гость
Re: Сломанные зависимости mariadb server
« Ответ #4 : 27 Декабря 2017, 01:47:29 »
Особенно умиляет сочетание репов stretch и precise
 

Оффлайн ecc83

Re: Сломанные зависимости mariadb server
« Ответ #5 : 27 Декабря 2017, 11:31:13 »
Особенно умиляет сочетание репов stretch и precise

Ну они же все основаны на Debian? Автор видимо считает, что этого достаточно.

 

Оффлайн endru

Re: Сломанные зависимости mariadb server
« Ответ #6 : 27 Декабря 2017, 11:34:41 »
а если посмотреть дерево, так вообще можно ужаснуться
картинка 2013 года: ShowHide

Оффлайн qupl

Re: Сломанные зависимости mariadb server
« Ответ #7 : 27 Декабря 2017, 12:03:08 »
а если посмотреть дерево, так вообще можно ужаснуться
картинка 2013 года: ShowHide

глаза сломал  :)

Теги: