Автор Тема: Пакет из jessie для stretch. Возможно?  (Прочитано 1602 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн a-lexx

Пакет из jessie для stretch. Возможно?
« : 04 Января 2018, 11:18:27 »
Пытаюсь поднять Ipsec туннель до vpn-сервера, сделал все по их инструкции, но что-то не все правильно у меня срабатывает и туннеля в итоге нет. Техпод предполагает, что все дело в несовпадении версий, их инструкция разработана для strongswan 5.2.1, а у меня установлена 5.5.1. Они мне предлагают переустановить пакет с более ранней версией. Однако я не могу найти strongswan 5.2.1 для своего stretch, но он есть для jessie. Могу ли я как-то адаптировать старый пакет под новый Debian? Если да, то как?
 

Оффлайн ferum

Re: Пакет из jessie для stretch. Возможно?
« Ответ #1 : 04 Января 2018, 12:50:12 »
Сошлитесь для начала на вашу инструкцию. Дело в том что названный вами пакет содержит в себе одну документацию но у него есть зависимости от чего вот просто так без вреда в систему его не поставишь. Однако если разобраться досконально в работе вашей программы, что и к чему то можно ведь пакет разобрать и поменять нужные файлы прямо в системе не ломая зависимости.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн a-lexx

Re: Пакет из jessie для stretch. Возможно?
« Ответ #2 : 04 Января 2018, 13:52:35 »
Спасибо за ответ!) Вот инструкция, а вот мое общение с техподдержкой
 

Оффлайн ferum

Re: Пакет из jessie для stretch. Возможно?
« Ответ #3 : 04 Января 2018, 15:25:42 »
Я не силён в серверах, тем более в rasbian но если вы пишите что пробуете на классическом  PC могу отметить что админ, с которым вы общаетесь сам этого не делал и валит с больной головы на здоровую. Думаю что версия пакета strongswan не критична, по крайней мере он свежее а не устаревший.
Я заметил в мануале два весьма сомнительных пункта
1 пункт 12 у нас давно systemd  а в инструкции команда для перезапуска init скрипта по этому надо уточнить глядя в вывод консоли.
По логике вещей должно быть что то вроде sudo systemctl restart xl2tpd.service но всё может быть...
2 пункт 18 по моим понятиям вообще не лезет не в одни ворота так как во первых по дефолту rc.local в девятке отключён https://softnastroy.com/content/vklyuchaem-rclocal-v-debian-9-stretch.html
а во вторых такой скрипт 100% будет валить сервис /etc/rc.local при старте через systemd
Вангую что надо вместо запуска через rc.local просто писать отдельный юнит, последовательно выполняющий эти две команды да ещё и в нужное время. На предмет такого юнита можно погуглить, думаю вы не первый столкнулись но к сожалению проверять придётся всё равно вам на практике.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн a-lexx

Re: Пакет из jessie для stretch. Возможно?
« Ответ #4 : 06 Января 2018, 11:34:42 »
Обратился в ТП вот с этой портянкой. Все идет ровно, но в последний момент сервер удаляет security accociation. Причина непонятна. На счет двух пунктов, спасибо, учту)
 

Теги:
 

Пакет есть а удаление не работает

Автор botbot

Ответов: 3
Просмотров: 1775
Последний ответ 11 Сентября 2013, 10:24:19
от endru
Пакет linux-image-3.16.0-8-amd64

Автор yumashka

Ответов: 5
Просмотров: 1520
Последний ответ 28 Марта 2019, 13:27:16
от yumashka