Автор Тема: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)  (Прочитано 2820 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dd4

Добрый день.
при выполнении команды sudo apt-get update  выдает вот такую ошибку 
Spoiler: ShowHide
E: Не удалось получить http://deb.debian.org/debian/dists/stable/main/i18n/Translation-en  BZ2_bzread: /var/lib/apt/lists/partial/deb.debian.org_debian_dists_stable_main_i18n_Translation-en.bz2 Ошибка чтения (-5: DATA_ERROR_MAGIC)
E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

вот полный вывод команды
Spoiler: ShowHide
sudo apt-get update
Сущ:1 http://repo.steampowered.com/steam precise InRelease
Игн:2 http://deb.debian.org/debian stable InRelease                           
Игн:3 http://dl.google.com/linux/chrome/deb stable InRelease                   
Сущ:4 http://download.virtualbox.org/virtualbox/debian stretch InRelease       
Сущ:5 http://deb.debian.org/debian stable-updates InRelease                   
Сущ:6 http://dl.google.com/linux/chrome/deb stable Release                     
Сущ:7 http://deb.debian.org/debian-security stable/updates InRelease
Пол:8 http://deb.debian.org/debian stable Release [118 kB]           
Сущ:9 https://deb.opera.com/opera-stable stable InRelease                     
Пол:10 http://deb.debian.org/debian stable Release.gpg [2.434 B]     
Сущ:11 https://www.deb-multimedia.org stable InRelease               
Сущ:12 https://repo.skype.com/deb stable InRelease
Сущ:14 https://dl.winehq.org/wine-builds/debian stretch InRelease
Пол:16 http://deb.debian.org/debian stable/main i386 Packages [7.103 kB]
Пол:17 http://deb.debian.org/debian stable/main Translation-en [5.393 kB]
Пол:17 http://deb.debian.org/debian stable/main Translation-en [5.393 kB]
Пол:17 http://deb.debian.org/debian stable/main Translation-en [5.393 kB]
Пол:17 http://deb.debian.org/debian stable/main Translation-en [5.393 kB]
Пол:17 http://deb.debian.org/debian stable/main Translation-en [5.393 kB]
Сущ:15 http://deb.debian.org/debian stable/main amd64 Packages                 
Сущ:17 http://deb.debian.org/debian stable/main Translation-en
Игн:15 http://deb.debian.org/debian stable/main amd64 Packages
Игн:17 http://deb.debian.org/debian stable/main Translation-en
Сущ:23 http://deb.debian.org/debian stable/main Translation-ru
Игн:23 http://deb.debian.org/debian stable/main Translation-ru
Сущ:24 http://deb.debian.org/debian stable/main amd64 DEP-11 Metadata
Сущ:25 http://deb.debian.org/debian stable/contrib amd64 Packages
Игн:24 http://deb.debian.org/debian stable/main amd64 DEP-11 Metadata
Игн:25 http://deb.debian.org/debian stable/contrib amd64 Packages
Сущ:26 http://deb.debian.org/debian stable/contrib Translation-en
Игн:26 http://deb.debian.org/debian stable/contrib Translation-en
Сущ:27 http://deb.debian.org/debian stable/contrib amd64 DEP-11 Metadata
Игн:27 http://deb.debian.org/debian stable/contrib amd64 DEP-11 Metadata
Сущ:28 http://deb.debian.org/debian stable/non-free amd64 Packages
Игн:28 http://deb.debian.org/debian stable/non-free amd64 Packages
Сущ:29 http://deb.debian.org/debian stable/non-free Translation-en
Игн:29 http://deb.debian.org/debian stable/non-free Translation-en
Сущ:30 http://deb.debian.org/debian stable/non-free amd64 DEP-11 Metadata
Игн:30 http://deb.debian.org/debian stable/non-free amd64 DEP-11 Metadata
Сущ:15 http://deb.debian.org/debian stable/main amd64 Packages                 
Игн:15 http://deb.debian.org/debian stable/main amd64 Packages                 
Сущ:17 http://deb.debian.org/debian stable/main Translation-en                 
Сущ:23 http://deb.debian.org/debian stable/main Translation-ru                 
Игн:17 http://deb.debian.org/debian stable/main Translation-en                 
Игн:23 http://deb.debian.org/debian stable/main Translation-ru                 
Сущ:24 http://deb.debian.org/debian stable/main amd64 DEP-11 Metadata         
Сущ:25 http://deb.debian.org/debian stable/contrib amd64 Packages             
Сущ:26 http://deb.debian.org/debian stable/contrib Translation-en             
Сущ:27 http://deb.debian.org/debian stable/contrib amd64 DEP-11 Metadata       
Игн:24 http://deb.debian.org/debian stable/main amd64 DEP-11 Metadata         
Сущ:28 http://deb.debian.org/debian stable/non-free amd64 Packages             
Игн:25 http://deb.debian.org/debian stable/contrib amd64 Packages             
Игн:26 http://deb.debian.org/debian stable/contrib Translation-en             
Игн:27 http://deb.debian.org/debian stable/contrib amd64 DEP-11 Metadata       
Игн:28 http://deb.debian.org/debian stable/non-free amd64 Packages             
Сущ:29 http://deb.debian.org/debian stable/non-free Translation-en             
Игн:29 http://deb.debian.org/debian stable/non-free Translation-en             
Сущ:30 http://deb.debian.org/debian stable/non-free amd64 DEP-11 Metadata     
Игн:30 http://deb.debian.org/debian stable/non-free amd64 DEP-11 Metadata     
Игн:15 http://deb.debian.org/debian stable/main amd64 Packages                 
Ошк:17 http://deb.debian.org/debian stable/main Translation-en                 
  BZ2_bzread: /var/lib/apt/lists/partial/deb.debian.org_debian_dists_stable_main_i18n_Translation-en.bz2 Ошибка чтения (-5: DATA_ERROR_MAGIC)
Игн:23 http://deb.debian.org/debian stable/main Translation-ru                 
Сущ:24 http://deb.debian.org/debian stable/main amd64 DEP-11 Metadata
Сущ:25 http://deb.debian.org/debian stable/contrib amd64 Packages
Игн:26 http://deb.debian.org/debian stable/contrib Translation-en
Сущ:27 http://deb.debian.org/debian stable/contrib amd64 DEP-11 Metadata
Сущ:28 http://deb.debian.org/debian stable/non-free amd64 Packages
Игн:29 http://deb.debian.org/debian stable/non-free Translation-en
Сущ:30 http://deb.debian.org/debian stable/non-free amd64 DEP-11 Metadata
Игн:15 http://deb.debian.org/debian stable/main amd64 Packages
Получено 2.434 Б за 26с (93 Б/c)
Чтение списков пакетов… Готово
E: Не удалось получить http://deb.debian.org/debian/dists/stable/main/i18n/Translation-en  BZ2_bzread: /var/lib/apt/lists/partial/deb.debian.org_debian_dists_stable_main_i18n_Translation-en.bz2 Ошибка чтения (-5: DATA_ERROR_MAGIC)
E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.


cat /etc/apt/sources.list /делал с помощью https://debgen.simplylinux.ch/index.php?generate/
Spoiler: ShowHide
#------------------------------------------------------------------------------#
#                   OFFICIAL DEBIAN REPOS                   
#------------------------------------------------------------------------------#

###### Debian Main Repos
deb http://deb.debian.org/debian/ stable main contrib non-free

deb http://deb.debian.org/debian/ stable-updates main contrib non-free

deb http://deb.debian.org/debian-security stable/updates main

#------------------------------------------------------------------------------#
#                      UNOFFICIAL  REPOS                       
#------------------------------------------------------------------------------#

###### 3rd Party Binary Repos
###Debian Multimedia
deb [arch=amd64,i386] https://www.deb-multimedia.org stable main non-free

###Google Chrome Browser
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

###Opera
deb [arch=amd64,i386] https://deb.opera.com/opera-stable/ stable non-free

###Skype
deb [arch=amd64] https://repo.skype.com/deb stable main

###Steam
deb [arch=i386,amd64] http://repo.steampowered.com/steam/ precise steam

###Virtualbox
deb [arch=i386,amd64] http://download.virtualbox.org/virtualbox/debian stretch contrib

###Wine
deb [arch=i386] https://dl.winehq.org/wine-builds/debian/ stretch main

ls /etc/apt/sources.list.d /здесь все закомментировано/
Spoiler: ShowHide
google-chrome.list       opera-stable.list       skype-stable.list
google-chrome.list.save  opera-stable.list.save  steam.list

подкажите, пожалуйста, что это за ошибка и как ее убрать?
 

Оффлайн qupl

Re: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)
« Ответ #1 : 28 Января 2018, 10:57:25 »
Убунтовский репозиторий я бы закомментировал, незачем постоянно рисковать из-за него.
Вывод
apt-get -f install

Оффлайн ferum

Re: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)
« Ответ #2 : 28 Января 2018, 11:31:27 »
###Opera
deb [arch=amd64,i386] https://deb.opera.com/opera-stable/ stable non-free
косяк
 и вообще посмотрите /etc/apt/sources.list.d
если после установки проприаретарных браузеров там появились их листы необходимо убрать соответствующие строки из основного sources.list
Русские дебианщики против цифрового слабоумия !
 

Оффлайн dd4

Re: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)
« Ответ #3 : 28 Января 2018, 15:41:12 »
Убунтовский репозиторий я бы закомментировал
это какой?

косяк
почему? объясните, пожалуйста, ведь эта строка сформирована с помощью https://debgen.simplylinux.ch/index.php?generate/

если после установки проприаретарных браузеров там появились их листы необходимо убрать соответствующие строки из основного sources.list
вот за это спасибо, что подсказали
« Последнее редактирование: 28 Января 2018, 15:47:24 от dd4 »
 

Оффлайн ferum

Re: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)
« Ответ #4 : 28 Января 2018, 19:27:43 »
Для браузера одна архитектура, только основная тем более его лист в /etc/apt/sources.list.d
Русские дебианщики против цифрового слабоумия !
 

Оффлайн dd4

Re: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)
« Ответ #5 : 29 Января 2018, 10:22:20 »
sudo apt-get -f install
Spoiler: ShowHide
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 12 пакетов не обновлено.

sudo apt-get update
Spoiler: ShowHide
Сущ:1 http://repo.steampowered.com/steam precise InRelease
Игн:2 http://deb.debian.org/debian stable InRelease                           
Сущ:3 http://deb.debian.org/debian stable-updates InRelease                   
Сущ:4 http://deb.debian.org/debian-security stable/updates InRelease
Пол:5 http://deb.debian.org/debian stable Release [118 kB]           
Пол:6 http://deb.debian.org/debian stable Release.gpg [2.434 B]     
Сущ:7 https://www.deb-multimedia.org stable InRelease
Пол:8 http://deb.debian.org/debian stable/main i386 Packages [7.103 kB]
Пол:9 http://deb.debian.org/debian stable/main amd64 Packages [7.123 kB]
Пол:9 http://deb.debian.org/debian stable/main amd64 Packages [7.123 kB]
Пол:9 http://deb.debian.org/debian stable/main amd64 Packages [7.123 kB]
Пол:9 http://deb.debian.org/debian stable/main amd64 Packages [7.123 kB]
Пол:14 http://deb.debian.org/debian stable/main Translation-ru [487 kB]
Сущ:9 http://deb.debian.org/debian stable/main amd64 Packages                 
Сущ:14 http://deb.debian.org/debian stable/main Translation-ru
Игн:9 http://deb.debian.org/debian stable/main amd64 Packages         
Игн:14 http://deb.debian.org/debian stable/main Translation-ru               
Сущ:16 http://deb.debian.org/debian stable/main Translation-en               
Игн:16 http://deb.debian.org/debian stable/main Translation-en
Сущ:17 http://deb.debian.org/debian stable/main amd64 DEP-11 Metadata
Сущ:18 http://deb.debian.org/debian stable/contrib amd64 Packages
Сущ:19 http://deb.debian.org/debian stable/contrib Translation-en
Сущ:20 http://deb.debian.org/debian stable/contrib amd64 DEP-11 Metadata
Игн:17 http://deb.debian.org/debian stable/main amd64 DEP-11 Metadata
Игн:18 http://deb.debian.org/debian stable/contrib amd64 Packages
Игн:19 http://deb.debian.org/debian stable/contrib Translation-en
Сущ:21 http://deb.debian.org/debian stable/non-free amd64 Packages
Игн:20 http://deb.debian.org/debian stable/contrib amd64 DEP-11 Metadata
Игн:21 http://deb.debian.org/debian stable/non-free amd64 Packages
Сущ:22 http://deb.debian.org/debian stable/non-free Translation-en
Игн:22 http://deb.debian.org/debian stable/non-free Translation-en
Сущ:23 http://deb.debian.org/debian stable/non-free amd64 DEP-11 Metadata
Игн:23 http://deb.debian.org/debian stable/non-free amd64 DEP-11 Metadata
Сущ:9 http://deb.debian.org/debian stable/main amd64 Packages                 
Игн:9 http://deb.debian.org/debian stable/main amd64 Packages                 
Сущ:14 http://deb.debian.org/debian stable/main Translation-ru                 
Игн:14 http://deb.debian.org/debian stable/main Translation-ru                 
Сущ:16 http://deb.debian.org/debian stable/main Translation-en                 
Сущ:17 http://deb.debian.org/debian stable/main amd64 DEP-11 Metadata         
Сущ:18 http://deb.debian.org/debian stable/contrib amd64 Packages             
Сущ:19 http://deb.debian.org/debian stable/contrib Translation-en             
Сущ:20 http://deb.debian.org/debian stable/contrib amd64 DEP-11 Metadata       
Сущ:21 http://deb.debian.org/debian stable/non-free amd64 Packages             
Игн:16 http://deb.debian.org/debian stable/main Translation-en                 
Игн:17 http://deb.debian.org/debian stable/main amd64 DEP-11 Metadata         
Игн:18 http://deb.debian.org/debian stable/contrib amd64 Packages             
Игн:19 http://deb.debian.org/debian stable/contrib Translation-en             
Игн:20 http://deb.debian.org/debian stable/contrib amd64 DEP-11 Metadata       
Игн:21 http://deb.debian.org/debian stable/non-free amd64 Packages             
Сущ:22 http://deb.debian.org/debian stable/non-free Translation-en             
Игн:22 http://deb.debian.org/debian stable/non-free Translation-en             
Сущ:23 http://deb.debian.org/debian stable/non-free amd64 DEP-11 Metadata     
Игн:9 http://deb.debian.org/debian stable/main amd64 Packages                 
Игн:23 http://deb.debian.org/debian stable/non-free amd64 DEP-11 Metadata     
Ошк:14 http://deb.debian.org/debian stable/main Translation-ru                 
  BZ2_bzread: /var/lib/apt/lists/partial/deb.debian.org_debian_dists_stable_main_i18n_Translation-ru.bz2 Ошибка чтения (-5: DATA_ERROR_MAGIC)
Игн:16 http://deb.debian.org/debian stable/main Translation-en                 
Сущ:17 http://deb.debian.org/debian stable/main amd64 DEP-11 Metadata         
Сущ:18 http://deb.debian.org/debian stable/contrib amd64 Packages             
Игн:19 http://deb.debian.org/debian stable/contrib Translation-en             
Сущ:20 http://deb.debian.org/debian stable/contrib amd64 DEP-11 Metadata       
Сущ:21 http://deb.debian.org/debian stable/non-free amd64 Packages             
Игн:22 http://deb.debian.org/debian stable/non-free Translation-en             
Игн:9 http://deb.debian.org/debian stable/main amd64 Packages                 
Сущ:23 http://deb.debian.org/debian stable/non-free amd64 DEP-11 Metadata     
Получено 2.434 Б за 6с (361 Б/c)                                               
Чтение списков пакетов… Готово
E: Не удалось получить http://deb.debian.org/debian/dists/stable/main/i18n/Translation-ru  BZ2_bzread: /var/lib/apt/lists/partial/deb.debian.org_debian_dists_stable_main_i18n_Translation-ru.bz2 Ошибка чтения (-5: DATA_ERROR_MAGIC)
E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

sudo apt-get upgrade
Spoiler: ShowHide
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Пакеты, которые будут оставлены в неизменном виде:
  gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly libasound2-plugins
  libavcodec57 libavformat57 libavresample3 libavutil55 libchromaprint1
  libgegl-0.3-0 libgstreamer-plugins-bad1.0-0 libswresample2 libswscale4
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 12 пакетов не обновлено.

cat /etc/apt/sources.list
Spoiler: ShowHide
#------------------------------------------------------------------------------#
#                   OFFICIAL DEBIAN REPOS                   
#------------------------------------------------------------------------------#

###### Debian Main Repos
deb http://deb.debian.org/debian/ stable main contrib non-free

deb http://deb.debian.org/debian/ stable-updates main contrib non-free

deb http://deb.debian.org/debian-security stable/updates main

#------------------------------------------------------------------------------#
#                      UNOFFICIAL  REPOS                       
#------------------------------------------------------------------------------#

###### 3rd Party Binary Repos
###Debian Multimedia
deb [arch=amd64,i386] https://www.deb-multimedia.org stable main non-free

###Google Chrome Browser
# deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

###Opera
# deb [arch=amd64,i386] https://deb.opera.com/opera-stable/ stable non-free

###Skype
# deb [arch=amd64] https://repo.skype.com/deb stable main

###Steam
# deb [arch=i386,amd64] http://repo.steampowered.com/steam/ precise steam

###Virtualbox
# deb [arch=i386,amd64] http://download.virtualbox.org/virtualbox/debian stretch contrib

###Wine
# deb [arch=i386] https://dl.winehq.org/wine-builds/debian/ stretch mai

все, что в в /etc/apt/sources.list.d закомментировано
« Последнее редактирование: 29 Января 2018, 10:25:11 от dd4 »
 

Оффлайн endru

Re: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)
« Ответ #6 : 29 Января 2018, 10:33:33 »
BZ2_bzread - больше похоже на то, что файл битый. Сделаю предположение -  либо интернет не стабильный, либо диск сбоит.
команду покажи на всякий случай:
free -mp.s.
apt-get upgrade - обновляет не все приложения. dist-upgrade обновит все приложения, но лучше прочитать в чем разница - подробнее описано в man apt-get


Оффлайн Susumo

Re: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)
« Ответ #7 : 29 Января 2018, 12:56:48 »
Заметил нечто интересное - если открыть браузером http://deb.debian.org/debian/dists/stable/main/i18n/Translation-en то выдаст 404, а если http://deb.debian.org/debian/ и ручками дойти до того файла, то он даже скачивается.
 


Оффлайн dd4

Re: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)
« Ответ #9 : 29 Января 2018, 15:34:39 »
free -m              total        used        free      shared  buff/cache   available
Mem:           3866        2350         394         684        1121         600
Swap:          4005          80        3925

интернет стабильный

пользуемся тегами, ogost
« Последнее редактирование: 29 Января 2018, 15:42:20 от ogost »
 

Оффлайн dd4

Re: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)
« Ответ #10 : 10 Февраля 2018, 10:28:54 »
http://repo.steampowered.com/steam precise
  отключил
все что в в /etc/apt/sources.list.d - закоментировано
ошибка прежняя
что еще можно сделать?

 

Оффлайн qupl

Re: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)
« Ответ #11 : 10 Февраля 2018, 11:12:56 »
Отмечали такой bug. Там есть совет очистить списки в var, попробуйте. Раз он наблюдается не у всех, то , возможно, из-за смешения источников уже что-то сломалось и не чинится "автоматом" после их исправления.

Оффлайн dd4

Re: apt-get update - Ошибка чтения (-5: DATA_ERROR_MAGIC)
« Ответ #12 : 10 Февраля 2018, 11:42:30 »
Спасибо за Ваше участие в решение этой проблемы.
Я в репозиториях поменял http://deb.debian.org на другое зеркало, запустил команду sudo apt-get update - такой ошибки не было. После это вернул, как все было в начале этой темы - и ошибки нет.
Подожду немного и если ошибка не появится, то поставлю отметку "РЕШЕНО".
 

Теги: