Debian не видит wi-fi

Автор Erentsen, 17 февраля 2018, 18:52:04

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Erentsen

Всем привет!

OS Debian Gnome. Ceтевая карта broadcom. Сеть не отображается в настройках. Пробовал разными способами, вот один из них:

Debian install Broadcom

1. Add contrib and non-free to your sources.

2. Then enter in terminal : sudo apt-get update (This updates your package lists)

3. Then enter in terminal: sudo apt-get install broadcom-sta-dkms (This installs the broadcom drivers)

4. Reboot then your wifi networks should be visible.


------------------

root@er:/home/er# sudo apt-get update                         
Err:1 http://mirror.mephi.ru/debian stretch InRelease
  Could not resolve 'mirror.mephi.ru'
Err:2 http://security.debian.org/debian-security stretch/updates InRelease
  Could not resolve 'security.debian.org'
Reading package lists... Done         
W: Failed to fetch http://mirror.mephi.ru/debian/dists/stretch/InRelease  Could not resolve 'mirror.mephi.ru'
W: Failed to fetch http://security.debian.org/debian-security/dists/stretch/updates/InRelease  Could not resolve 'security.debian.org'
W: Some index files failed to download. They have been ignored, or old ones used instead.
root@er:/home/er# sudo apt-get install broadcom-sta-dkms
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package broadcom-sta-dkms
root@er:/home/er#

Что мне нужно сделать дальше, чтобы наладить сеть? Заранее благодарю.
  •  

qupl

У Вас должно быть подключение к интернету (провод?) чтобы обновиться. 

ecc83

Скачиваешь браузером или чем умеешь файл по ссылке:

http://ftp.de.debian.org/debian/pool/non-free/b/broadcom-sta/broadcom-sta-dkms_6.30.223.271-5_all.deb

Затем в терминале выполняешь команду:

sudo dpkg -i broadcom-sta-dkms_6.30.223.271-5_all.deb
  •  

Erentsen

#3
Цитата: ecc83 от 17 февраля 2018, 19:16:24Затем в терминале выполняешь команду:

Файл скачал, он загрузился в папку загрузки. Выполнил команду, но система не нашла его. Я так понимаю, его нужно было поместить в определённое мест, что мне сделать?

-------------

root@er:/home/er# sudo dpkg -i broadcom-sta-dkms_6.30.223.271-5_all.deb
dpkg: error: cannot access archive 'broadcom-sta-dkms_6.30.223.271-5_all.deb': No such file or directory
root@er:/home/er#
  •  

yoric

Перейти в папку загрузки или указывать полный путь.
  •  

ecc83

Цитата: Erentsen от 17 февраля 2018, 20:04:49что мне сделать?

сначала перейти в каталог "Загрузки" и оттуда запускать команду.

cd ~/Загрузки && sudo dpkg -i broadcom-sta-dkms_6.30.223.271-5_all.deb
  •  

Erentsen

#6
Цитата: ecc83 от 17 февраля 2018, 21:08:44сначала перейти в каталог "Загрузки" и оттуда запускать команду.

Методом тыка пробовал разными способами, размещал файл в разных директориях. Не получилось :-[

root@er:~# sudo apt-get update
Ign:1 http://mirror.mephi.ru/debian stretch InRelease
Hit:2 http://mirror.mephi.ru/debian stretch Release     
Hit:4 http://security.debian.org/debian-security stretch/updates InRelease
Reading package lists... Done
root@er:~# /home/er# sudo apt-get install broadcom-sta-dkms
bash: /home/er#: No such file or directory
root@er:~# /home/er# sudo apt-get install broadcom-sta-dkms_6.30.223.271-5_all.deb
bash: /home/er#: No such file or directory
root@er:~# /home/er sudo apt-get install broadcom-sta-dkms_6.30.223.271-5_all.debbash: /home/er: Is a directory
root@er:~# /home/er && sudo apt-get install broadcom-sta-dkms_6.30.223.271-5_all.deb
bash: /home/er: Is a directory
root@er:~# /home/er# && sudo dpkg -i broadcom-sta-dkms_6.30.223.271-5_all.deb
bash: /home/er#: No such file or directory
root@er:~# /home/er && sudo dpkg -i broadcom-sta-dkms_6.30.223.271-5_all.deb
bash: /home/er: Is a directory
root@er:~#

Что я не правильно пишу?

* Используйте теги код, для оформления сообщения, ihammers.
  •  

ecc83

Цитата: Erentsen от 17 февраля 2018, 22:22:32Методом тыка пробовал

То есть ты просто так развлекаешься? Прочитать синтаксис командной строки, переход по директориям, ты оставляешь на самый крайний случай?
Вообще то я написал тебе команду установки, рассмотри её внимательно.
  •  

moreplavatel

  •  

Erentsen

Цитата: ecc83 от 17 февраля 2018, 22:34:41То есть ты просто так развлекаешься? Прочитать синтаксис командной строки, переход по директориям, ты оставляешь на самый крайний случай?
Вообще то я написал тебе команду установки, рассмотри её внимательно.

Ок, благодарю за критику) вы заставляете меня думать). Вот, попробовал более аккуратно подойти к делу:

root@er:/home/er# sudo dpkg -i broadcom-sta-dkms_6.30.223.271-5_all.deb
(Reading database ... 296738 files and directories currently installed.)
Preparing to unpack broadcom-sta-dkms_6.30.223.271-5_all.deb ...

------------------------------
Deleting module version: 6.30.223.271
completely from the DKMS tree.
------------------------------
Done.
Unpacking broadcom-sta-dkms (6.30.223.271-5) over (6.30.223.271-5) ...
Setting up broadcom-sta-dkms (6.30.223.271-5) ...
Loading new broadcom-sta-6.30.223.271 DKMS files...
Building for 4.9.0-2-amd64
Module build for kernel 4.9.0-2-amd64 was skipped since the
kernel headers for this kernel does not seem to be installed.
root@er:/home/er# sudo dkms autoinstall -k 4.9.0-2-amd64
Error! Your kernel headers for kernel 4.9.0-2-amd64 cannot be found.
Please install the linux-headers-4.9.0-2-amd64 package,
or use the --kernelsourcedir option to tell DKMS where it's located
root@er:/home/er# uname -r
4.9.0-2-amd64
root@er:/home/er# sudo apt-get install linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-headers-4.9.0-2-amd64
E: Couldn't find any package by glob 'linux-headers-4.9.0-2-amd64'
E: Couldn't find any package by regex 'linux-headers-4.9.0-2-amd64'
root@er:/home/er#


пробовал установить linux-headers-4.9.0-2-amd64 package, но получил вот это

root@er:/home/er# sudo apt-get install linux-headers-4.9.0-2-common-grsec_4.9.18-1+grsec201703261106+1~bpo8+1_all.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-headers-4.9.0-2-common-grsec_4.9.18-1+grsec201703261106+1~bpo8+1_all.deb
E: Couldn't find any package by glob 'linux-headers-4.9.0-2-common-grsec_4.9.18-1+grsec201703261106+1~bpo8+1_all.deb'
E: Couldn't find any package by regex 'linux-headers-4.9.0-2-common-grsec_4.9.18-1+grsec201703261106+1~bpo8+1_all.deb'
root@er:/home/er#


но я скачал пакет по вот тут и установил его в нужную директорию. Как быть?
  •  

moreplavatel

apt ищит и ставит пакеты из сети (из репозиториев).
локальная установка покетов dpkg или gdebi
sudo dpkg -i linux-headers-4.9.0-2-common-grsec_4.9.18-1+grsec201703261106+1~bpo8+1_all.deb

ecc83

Цитата: Erentsen от 18 февраля 2018, 11:54:23вы заставляете меня думать

Это непривычное для тебя состояние? Просто ты как то неуверенно и осторожно входишь в это состояние...

Цитата: Erentsen от 18 февраля 2018, 11:54:23Как быть?

У тебя какая версия Debian? Ты скачал пакет для Debian 8 Jessie. Если всё правильно, тогда из каталога, в котором лежат оба скачанных тобой пакета, нужно выполнить команды:

cd ~/Загрузки && sudo dpkg -i linux-headers-4.9.0-2-common-grsec_4.9.18-1+grsec201703261106+1~bpo8+1_all.deb

cd ~/Загрузки && sudo dpkg -i broadcom-sta-dkms_6.30.223.271-5_all.deb

  •  
    Users thanked this post: Grasp

Erentsen

Цитата: moreplavatel от 18 февраля 2018, 12:15:27apt ищит и ставит пакеты из сети (из репозиториев).
локальная установка покетов dpkg или gdebi
sudo dpkg -i linux-headers-4.9.0-2-common-grsec_4.9.18-1+grsec201703261106+1~bpo8+1_all.deb

спасибо большое, уже запомнил.

но, вот снова попробовал установить, но на этот раз уже видит пакет, вроде как пошла установка, но остановилась и ничего не предлагает. Что ему надо?

root@er:/home/er# sudo dpkg -i broadcom-sta-dkms_6.30.223.271-5_all.deb
(Reading database ... 301803 files and directories currently installed.)
Preparing to unpack broadcom-sta-dkms_6.30.223.271-5_all.deb ...

------------------------------
Deleting module version: 6.30.223.271
completely from the DKMS tree.
------------------------------
Done.
Unpacking broadcom-sta-dkms (6.30.223.271-5) over (6.30.223.271-5) ...
Setting up broadcom-sta-dkms (6.30.223.271-5) ...
Loading new broadcom-sta-6.30.223.271 DKMS files...
Building for 4.9.0-2-amd64
Module build for kernel 4.9.0-2-amd64 was skipped since the
kernel headers for this kernel does not seem to be installed.
root@er:/home/er# sudo dpkg -i linux-headers-4.9.0-2-common-grsec_4.9.18-1+grsec201703261106+1~bpo8+1_all.deb
(Reading database ... 301803 files and directories currently installed.)
Preparing to unpack linux-headers-4.9.0-2-common-grsec_4.9.18-1+grsec201703261106+1~bpo8+1_all.deb ...
Unpacking linux-headers-4.9.0-2-common-grsec (4.9.18-1+grsec201703261106+1~bpo8+1) over (4.9.18-1+grsec201703261106+1~bpo8+1) ...
Setting up linux-headers-4.9.0-2-common-grsec (4.9.18-1+grsec201703261106+1~bpo8+1) ...
root@er:/home/er#
  •  

ecc83

#13
Цитата: Erentsen от 18 февраля 2018, 12:38:42Что ему надо?

Ему надо, что бы ты не нарушал порядок установки. Второй пакет нужно устанавливать после первого, а не наоборот.
Но тебе похоже всё равно и ты ставишь в том порядке, куда проще дотянуться мышкой. Тут так не получится.

sudo dpkg --force-overwrite -i broadcom-sta-dkms_6.30.223.271-5_all.deb

ek-nfn

#14
 ;D ;D от винды человек еще не отошел. Это в ней вырабатывается стойкий рефлекс - сначала кликаешь, затем пытаешься думать
Debian 11 xfce
  •