Как правильно удалить старое ядро?

Автор dmitry1903, 25 февраля 2018, 10:00:44

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

dmitry1903

Доброе утро.
Как правильно удалить старое ядро?

dpkg --list | grep linux-image
ii  linux-image-3.2.0-4-686-pae          3.2.96-2                           i386         Linux 3.2 for modern PCs
ii  linux-image-3.2.0-5-686-pae          3.2.96-3                           i386         Linux 3.2 for modern PCs
ii  linux-image-686-pae                  3.2+46+deb7u1                      i386         Linux for modern PCs (meta-package)

qupl

1) Нет большого смысла
2) aptitude purge linux-image-3.2.0-4-686-pae

yoric

И поотм ещё возможно linux-headers той же версии, и linux-kbuild-vers, если стоит и не снеслось.
ls -l /usr/src
И руками снести /lib/modules-kern-vers

dmitry1903

#3
Цитата: yoric от 25 февраля 2018, 17:40:11И поотм ещё возможно linux-headers той же версии, и linux-kbuild-vers, если стоит и не снеслось.
Код: [Выделить]

ls -l /usr/src

И руками снести /lib/modules-kern-vers
ls -l /usr/src
итого 0

Что осталось удалить в таком случае и как правильно это сделать?

yoric


dmitry1903


Vlad

Удалить крайнее ядро?
После обновления на новое ядро, выяснилось что оно на моей системе вызывает перезагрузку спустя 5-10 мин. работы. Решил его удалить:
root@home-router:/etc/default# apt purge linux-image-4.15.0-60-generic
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  amd64-microcode intel-microcode iucode-tool libdbus-glib-1-2 linux-headers-4.15.0-54 linux-headers-4.15.0-54-generic
  linux-headers-4.15.0-55 linux-headers-4.15.0-55-generic linux-image-4.15.0-54-generic linux-image-4.15.0-55-generic
  linux-modules-4.15.0-54-generic linux-modules-4.15.0-55-generic linux-modules-extra-4.15.0-54-generic
  linux-modules-extra-4.15.0-55-generic thermald
Для их удаления используйте «apt autoremove».
Будут установлены следующие дополнительные пакеты:
  linux-image-unsigned-4.15.0-60-generic
Предлагаемые пакеты:
  fdutils linux-doc-4.15.0 | linux-source-4.15.0 linux-tools
Следующие пакеты будут УДАЛЕНЫ:
  linux-generic* linux-generic-hwe-16.04* linux-image-4.15.0-60-generic* linux-image-generic* linux-image-generic-hwe-16.04*
  linux-modules-extra-4.15.0-60-generic* linux-signed-generic* linux-signed-image-generic*
Следующие НОВЫЕ пакеты будут установлены:
  linux-image-unsigned-4.15.0-60-generic
Обновлено 0 пакетов, установлено 1 новых пакетов, для удаления отмечено 8 пакетов, и 1 пакетов не обновлено.
Необходимо скачать 8 127 kB архивов.
После данной операции объём занятого дискового пространства уменьшится на 169 MB.
Хотите продолжить? [Д/н] ^C

Напрягает что тут же нужно установить такое же ядро, только unsigned. Хочу просто удалить ядро и оставить то что было перед этим. Пока в grub изменил последовательность выбора пункта меню, но это временное решение, нужно удалить и пункты в grub вернуть как было. Как нужно удалить что не было предложений об установки левых ядер?


ferum

Цитата: ogost от 12 сентября 2019, 03:59:29не вижу такое ядро в репах
Вангую у клиента astra linux
[offtopic]я уже тестировал 3 релиза этой системы.... Я понимаю что когда тебе её навязывают с верху то ни куда не денешься, придётся терпеть, но если по честноку то поделие сляпано на коленке на скорую руку. В пакетной базе перемешаны бэкпорты пакетов с разных релизов debian  и ubuntu плюс наваяли чего то своего. Бывают случаи когда при попытке обновления оказывается что и зависимости пары тройки пакетов в репозитории сломаны. Вроде позицианируют себя как серьёзная команда.... но Вася Пупкин делает сборку на основе ubuntu гораздо качественнее.[/offtopic]
Русские дебианщики против цифрового слабоумия !

sidbar

Цитата: Vlad от 11 сентября 2019, 23:27:27Хочу просто удалить ядро и оставить то что было перед этим
Какую версию хотите оставить? Покажите:
aptitude search linux-
Devuan GNU/Linux 4 Chimaera x86_64

Vlad

Извиняюсь что не упомянул ОС, Ubuntu Server 18.04 LTS. Нужно оставить 4.15.0-58-generic.

ogost

Цитата: Vlad от 12 сентября 2019, 21:42:55
Извиняюсь что не упомянул ОС, Ubuntu Server 18.04 LTS. Нужно оставить 4.15.0-58-generic.
Где карту открывали, туда и идите Либо спрашивайте на форуме убунты (убунта не дебиан, чтобы вам не говорили), либо в разделе "Обо всём", поскольку здесь обсуждается только дебиан.