Автор Тема: Пакеты firmware-linux-free, firware-linux-nonfree нужны ли?  (Прочитано 2631 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Листик

Темку для простых вопросов закрыли - создаю новую.

Все работает, в принципе. А вот сейчас обнаружил, что их не установил, но во многих статьях по настройке Дебиан после установки рекомендуют. Так нужны ли они, если все работает?



 

Оффлайн ferum

Если при загрузке система не выдаёт сообщений о необходимых прошивках значит не нужны, поздравляю ваше железо хорошо совместимо с дистрибутивом.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Листик

ferum,

Спасибо за ответ.

А вот это случаем не оно?

debian kernel: ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 3


debian kernel: ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000429-0x0000000000000429 (\PM2S) (20160831/utaddress-247)
debian kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
debian kernel: ACPI Warning: SystemIO range 0x00000000000004B0-0x00000000000004BF conflicts with OpRegion 0x00000000000004B8-0x00000000000004BB (\GPO2) (20160831/utaddress-247)
ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
debian kernel: ACPI Warning: SystemIO range 0x0000000000000480-0x00000000000004AF conflicts with OpRegion 0x000000000000048C-0x000000000000048F (\GPO) (20160831/utaddress-247)

intel_rng: FWH not detected

debian kernel: lpc_ich: Resource conflict(s) found affecting gpio_ich
В принципе, особых проблем тоже не доставляет. Один раз, правда, словил system is halted при загрузке (собственно, эти сообщения тогда и прочитал в логах, но решил ничего не делать, т.к. проблема древняя, что-то вроде конфликта биоса и линуксовского ядра, если правильно понял).

И сразу вопрос: если устанавливать, то свободное или несвободное? Или и тот, и другой?


« Последнее редактирование: 16 Мая 2018, 04:11:12 от ogost »
 

Оффлайн yoric

Установите тот и другой, потом проконтролируйте на счёт этих ошибок, а может и какое новое железо найдётся :-) Снести потом недолго, если не понадобится.
 

Оффлайн qupl

Так нужны ли они, если все работает?
Нет, а так да.

Оффлайн ferum

Дело не   в firmware, можно поковырять настройки  биос, как вариант даже обновить его до последней версии, если сообщение раздражает можно убрать его в настройках загрузчика.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Ogis1975

Дело не   в firmware
А в чем? В dmesg ясно говорится, что
If an ACPI driver is available for this device, you should use it instead of the native driver
 

Оффлайн Листик

Ogis1975,

Вот и я так считаю. Я сначала даже эти строки жирным цветом выделил, чтобы акцентировать внимание, но кто-то подправил.

Дело не   в firmware, можно поковырять настройки  биос, как вариант даже обновить его до последней версии, если сообщение раздражает можно убрать его в настройках загрузчика.

Да там даже не в загрузчике, это я логи читал, оттуда скопировал. Загрузка быстро происходит. Все работает. Вроде как правило есть: работает - не трогай.

Уже на этом Дебиане заскок появился: хочется сделать систему вообще идеальной. Мда.



Cообщение объединено 16 Мая 2018, 17:41:19
Не, биос перепрошивать не вариант. Это уже крайняя стадия.
« Последнее редактирование: 16 Мая 2018, 17:41:52 от Листик »
 

Оффлайн Ogis1975

Вот и я так считаю.
У меня это сообщение тоже проскакивает (Debian 9.4), но только один раз. Выглядит вот так
ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x000000000000042C-0x000000000000042D (\GP2C) (20160831/utaddress-247)
ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Все работает прекрасно, так что не обращаю внимания, руководствуюсь золотым правилом-работает - не трогай.
 

Теги:
     

    Не все обновляются пакеты

    Автор sidbar

    Ответов: 10
    Просмотров: 2793
    Последний ответ 23 Марта 2017, 22:14:59
    от sidbar
    Предлагаемые пакеты при установке

    Автор mexx

    Ответов: 0
    Просмотров: 252
    Последний ответ 11 Октября 2020, 13:30:37
    от mexx
    Сломались пакеты при обновлении.

    Автор APL

    Ответов: 6
    Просмотров: 2346
    Последний ответ 20 Апреля 2012, 22:09:22
    от vladimir_ar
    Как удалить лишние пакеты?

    Автор Самир

    Ответов: 3
    Просмотров: 1959
    Последний ответ 11 Мая 2014, 06:01:35
    от varius
    [Решено] Ищу пакеты: linux-compiler-gcc-4.6-x86_3.12.9-1~bpo70+1_i386.deb и ...

    Автор Aalexeey

    Ответов: 2
    Просмотров: 1971
    Последний ответ 08 Июля 2015, 15:27:54
    от Aalexeey