Автор Тема: Невозможно обновить ключи apt get на старичке Lenny  (Прочитано 2189 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Serge_I

  • Новичок форума
  • Topic Author
  • Сообщений: 3
Когда делаешь aptitude update выходит следующее

# aptitude update
Получить:1 http://archive.debian.org lenny Release.gpg [1034B]
Из кеша: http://archive.debian.org lenny/main Translation-ru
Игн http://archive.debian.org lenny/contrib Translation-ru
Игн http://archive.debian.org lenny/non-free Translation-ru
Получить:2 http://archive.debian.org lenny/updates Release.gpg [836B]
Игн http://archive.debian.org lenny/updates/main Translation-ru
Игн http://archive.debian.org lenny/updates/contrib Translation-ru
Игн http://archive.debian.org lenny/updates/non-free Translation-ru


Из кеша: http://archive.debian.org lenny Release
Из кеша: http://archive.debian.org lenny/updates Release
Ош http://archive.debian.org lenny Release

Получить:3 http://archive.debian.org lenny Release [99,6kB]
Игн http://archive.debian.org lenny Release
Получить:4 http://archive.debian.org lenny/updates Release [92,4kB]
Игн http://archive.debian.org lenny/updates Release
Игн http://archive.debian.org lenny/main Packages/DiffIndex
Игн http://archive.debian.org lenny/contrib Packages/DiffIndex
Игн http://archive.debian.org lenny/non-free Packages/DiffIndex
Игн http://archive.debian.org lenny/updates/main Packages/DiffIndex
Игн http://archive.debian.org lenny/updates/contrib Packages/DiffIndex
Игн http://archive.debian.org lenny/updates/non-free Packages/DiffIndex
Из кеша: http://archive.debian.org lenny/main Packages
Из кеша: http://archive.debian.org lenny/contrib Packages
Из кеша: http://archive.debian.org lenny/non-free Packages
Из кеша: http://archive.debian.org lenny/updates/main Packages
Из кеша: http://archive.debian.org lenny/updates/contrib Packages
Из кеша: http://archive.debian.org lenny/updates/non-free Packages
Получено 194kБ в 1s (140kБ/с)
Чтение списков пакетов... Готово
W: GPG error: http://archive.debian.org lenny Release: Следующие подписи неверные: KEYEXPIRED 1520281423 KEYEXPIRED 1337087218
W: GPG error: http://archive.debian.org lenny/updates Release: Следующие подписи неверные: KEYEXPIRED 1356982504
После этого сделал apt-key list | grep "[expired|просрочен]"

и обновил все ключи из списка при помощи
apt-key adv --keyserver keys.gnupg.net --recv-keys [KEY]

но получил следующее:
apt-key adv --keyserver keys.gnupg.net --recv-keys A26FF456

pub   4096R/473041FA 2010-08-27 [отозван: 2018-06-09]
uid                  Debian Archive Automatic Signing Key (6.0/squeeze) <ftpmaster@debian.org>
pub   4096R/B98321F9 2010-08-07 [просрочен с: 2017-08-05]
uid                  Squeeze Stable Release Key <debian-release@lists.debian.org>
pub   1024D/F42584E6 2008-04-06 [просрочен с: 2012-05-15]
uid                  Lenny Stable Release Key <debian-release@lists.debian.org>
pub   4096R/55BE302B 2009-01-27 [отозван: 2018-06-09]
uid                  Debian Archive Automatic Signing Key (5.0/lenny) <ftpmaster@debian.org>
pub   2048R/6D849617 2009-01-24 [просрочен с: 2013-01-23]
uid                  Debian-Volatile Archive Automatic Signing Key (5.0/lenny)
pub   1024D/A26FF456 2006-02-22 [годен до: 2019-03-14]
uid                  Skolelinux Archive Automatic Signing Key <ftpmaster@skolelinux.org>
pub   1024D/97BB3B58 2007-04-30
uid                  Emdebian Archive Signing Key
По всей видимости ключи для старых релизов разработчики уже не обновляют.
Можно ли как то обновить сервер без переустановки при помощи apt-get update ?
Еще нашкодил пробуя перепрописать ключ F42584E6, удалил его а вот добавить назад не смог, не совсем понимал принцип работы apt-key add.
Плиз направьте в какую сторону копать.

* Используйте теги для оформления сообщения, ihammers.
« Последнее редактирование: 08 Август 2018, 08:20:44 от ihammers »
 


Оффлайн sidbar

  • Старожил
  • ****
  • Сообщений: 619
  • Debian 7, lxde
Новые обновления не выходят, нечего подписывать ключами, или вы хотите обновиться до актуального релиза?
Devuan GNU/Linux 3 (beowulf) i686, LXDE
 

Оффлайн Serge_I

  • Новичок форума
  • Topic Author
  • Сообщений: 3
да хотел бы обновиться до актуального релиза, бэкап системы сделал.
 

Оффлайн ChubaDuba

  • Старожил
  • ****
  • Сообщений: 762
  • Debian 9 & Xmonad
    • Бλог
  • Jabber: achubakov@jabber.ru
... на старичке Lenny... хотел бы обновиться до актуального релиза
ИМХО, дело конечно хорошее, но попахивает тухлятиной. Я бы переустановил.
« Последнее редактирование: 06 Август 2018, 16:57:56 от ChubaDuba »
Бλог   @chuba_duba
 

Оффлайн yoric

  • Старожил
  • ****
  • Сообщений: 733
  • gentoo
  • Jabber: yoric@jabber.ru
Не настолько это тухлый метод, насколько муторный. По одному четыре (или сколько там выпусков прошло) обновлять, попутно разгребая неувязки - можно и загрустить. Сразу с ленни на бустера - авось повезёт, попробовать ради интереса :-) Переустановить с нуля будет быстрее однозначно, но что там с Вашими сервисами будет, у которых четыре же раза могли поменяться конфиги - одному богу известно.
Отсюда мораль: не так уж и трудно обновляться своевременно, сразу решая возникшие проблемы, коих гораздо меньше (или вообще нет), чем при массовом обновлении :-)
 

Оффлайн Serge_I

  • Новичок форума
  • Topic Author
  • Сообщений: 3
Спасибо.
Всех услышал, склоняюсь тоже к переустановке.. Своевременно обновлять только если ты локальный админ на зп и обладаешь рут правами, ну и чуть больше знаний чем это наш впн сервак..
 

Теги:
 

[РЕШЕНО] Debian 8. Невозможно копировать-удалять файлы с флешки

Автор panzerfaust

Ответов: 15
Просмотров: 4461
Последний ответ 08 Май 2015, 17:35:46
от panzerfaust
Перенесено: E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты

Автор endru

Ответов: 0
Просмотров: 991
Последний ответ 01 Октябрь 2019, 04:31:54
от endru
E: Невозможно исправить ошибки,у вас отложены (held) битые пакеты

Автор sockrat

Ответов: 1
Просмотров: 5209
Последний ответ 20 Апрель 2015, 11:40:41
от endru
Невозможно удалить файл

Автор chvf

Ответов: 4
Просмотров: 1560
Последний ответ 30 Октябрь 2015, 11:00:31
от chvf