[Решено] policykit-1 - Неудовлетворенные зависимости

Автор alterak, 26 января 2019, 09:44:48

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

alterak

Доброго времени суток. Помогите решить проблему при обновлении...
Открыть содержимое (спойлер)
root@FS01:~# apt-get update && apt-get -y upgrade
Игн:1 http://mirror.yandex.ru/debian stretch InRelease
Сущ:2 http://mirror.yandex.ru/debian stretch-updates InRelease
Сущ:3 http://mirror.yandex.ru/debian stretch Release
Сущ:4 http://security.debian.org stretch/updates InRelease
Сущ:6 https://apt.syncthing.net syncthing InRelease
Чтение списков пакетов... Готово
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
policykit-1 : Зависит: libpolkit-agent-1-0 (= 0.105-18) но 0.105-18+deb9u1 уже установлен
               Зависит: libpolkit-backend-1-0 (= 0.105-18) но 0.105-18+deb9u1 уже установлен
               Зависит: libpolkit-gobject-1-0 (= 0.105-18) но 0.105-18+deb9u1 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
root@FS01:~#
[свернуть]
Далее делаю как рекомендуют...

Открыть содержимое (спойлер)
root@FS01:~# apt-get -f install
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Исправление зависимостей... Готово
Будут установлены следующие дополнительные пакеты:
  policykit-1
Пакеты, которые будут обновлены:
  policykit-1
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 21 пакетов не обновлено.
Необходимо скачать 0 B/63,5 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить? [Д/н] y
Чтение журнала изменений... Выполнено
(Чтение базы данных ... на данный момент установлено 52757 файлов и каталогов.)
Подготовка к распаковке .../policykit-1_0.105-18+deb9u1_amd64.deb ...
Failed to reload daemon: Refusing to reload, not enough space available on /run/systemd. Currently, 14.3M are free, but a safety buffer of 16.0M is enforced.
dpkg: ошибка при обработке архива /var/cache/apt/archives/policykit-1_0.105-18+deb9u1_amd64.deb (--unpack):
подпроцесс новый сценарий pre-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
/var/cache/apt/archives/policykit-1_0.105-18+deb9u1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@FS01:~#
[свернуть]
А если делать так то тоже ошибка...
Открыть содержимое (спойлер)
root@FS01:~# apt --fix-broken install
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Исправление зависимостей... Готово
Будут установлены следующие дополнительные пакеты:
  policykit-1
Пакеты, которые будут обновлены:
  policykit-1
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 21 пакетов не обновлено.
Необходимо скачать 0 B/63,5 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить? [Д/н] y
Чтение журнала изменений... Выполнено
(Чтение базы данных ... на данный момент установлено 52757 файлов и каталогов.)
Подготовка к распаковке .../policykit-1_0.105-18+deb9u1_amd64.deb ...
Failed to reload daemon: Refusing to reload, not enough space available on /run/systemd. Currently, 14.3M are free, but a safety buffer of 16.0M is enforced.
dpkg: ошибка при обработке архива /var/cache/apt/archives/policykit-1_0.105-18+deb9u1_amd64.deb (--unpack):
подпроцесс новый сценарий pre-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
/var/cache/apt/archives/policykit-1_0.105-18+deb9u1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@FS01:~#
[свернуть]

Подскажите куда капнуть? Пробовал удалять этот пакет - проблема не решается-(


ferum

Сразу встречные вопросы: что прописано в источниках, что ставили из сторонних источников или бэкпортов?
Просто так в этом дистрибутиве зависимости не ломаются.
Русские дебианщики против цифрового слабоумия !

qupl

Цитироватьfailed to reload daemon: Refusing to reload, not enough space available on /run/systemd. Currently, 14.3M are free, but a safety buffer of 16.0M is enforced.
df -h
fdisk -l

ferum

Отказ от перезагрузки, недостаточно места
Не ужели место закончилось на разделе
Русские дебианщики против цифрового слабоумия !

alterak

Цитата: ferum от 26 января 2019, 11:14:57Не ужели место закончилось на разделе
да не может быть... если что, названия разделов заменил на "..."
Открыть содержимое (спойлер)
root@FS01:~# df -h
Файловая система            Размер Использовано  Дост Использовано% Cмонтировано в
udev                          109M            0  109M            0% /dev
tmpfs                          25M         9,7M   15M           41% /run
/dev/vda1                     4,6G         2,3G  2,1G           52% /
tmpfs                         121M            0  121M            0% /dev/shm
tmpfs                         5,0M            0  5,0M            0% /run/lock
tmpfs                         121M            0  121M            0% /sys/fs/cgroup
/dev/mapper/archive-...       20G         8,6G   11G           46% /mnt/...
/dev/mapper/archive-...      472G         400G   53G           89% /mnt/...
/dev/mapper/archive-...     9,8G         697M  8,6G            8% /mnt/...
/dev/mapper/archive-...   148G          99G   42G           71% /mnt/...
/dev/mapper/archive-...     4,9G         1,1G  3,6G           23% /mnt/...
/dev/mapper/archive-...     9,8G          37M  9,3G            1% /mnt/...
/dev/mapper/archive-...     295G         215G   68G           77% /mnt/...
/dev/mapper/archive-...     492G         379G   91G           81% /mnt/...
tmpfs                          25M            0   25M            0% /run/user/1000
root@FS01:~#
[свернуть]

alterak

#5
Цитата: ferum от 26 января 2019, 11:03:29Сразу встречные вопросы: что прописано в источниках, что ставили из сторонних источников или бэкпортов?
Просто так в этом дистрибутиве зависимости не ломаются.
В основной файл ничего не добавлял...
Открыть содержимое (спойлер)
root@FS01:~# cat /etc/apt/sources.list
# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official Multi-architecture amd64/i386 NETINST #1 20160917-18:46]/ stretch main

#deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official Multi-architecture amd64/i386 NETINST #1 20160917-18:46]/ stretch main

deb http://mirror.yandex.ru/debian/ stretch main
deb-src http://mirror.yandex.ru/debian/ stretch main

deb http://security.debian.org/ stretch/updates main
deb-src http://security.debian.org/ stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://mirror.yandex.ru/debian/ stretch-updates main
deb-src http://mirror.yandex.ru/debian/ stretch-updates main
root@FS01:~#
[свернуть]

Но есть
Открыть содержимое (спойлер)
root@FS01:~# cat /etc/apt/sources.list.d/syncthing.list
deb https://apt.syncthing.net/ syncthing stable
root@FS01:~#
[свернуть]

svtv1

Подчисти тут:
ls /var/cache/apt/archives/ --просмотр кэшированных
потом если много:
sudo apt-get autoclean

"Если достаточно долго сидеть возле реки - мимо проплывет труп твоего врага"

alterak

#7
Цитата: svtv1 от 26 января 2019, 11:44:26/var/cache/apt/archives/
Цитата: svtv1 от 26 января 2019, 11:44:26Подчисти тут:
ls /var/cache/apt/archives/ --просмотр кэшированных
потом если много:
sudo apt-get autoclean
Не помогло... полностью почистил папку, снова обновил пакеты и пытаюсь установить... всё то же самое
В папке /var/cache/apt/archives/ снова создается


Попробовал ребутнуть вручную, ничего не поменялось
root@FS01:~# apt update && apt upgrade
Сущ:1 http://security.debian.org stretch/updates InRelease
Игн:2 http://mirror.yandex.ru/debian stretch InRelease
Сущ:3 http://mirror.yandex.ru/debian stretch-updates InRelease
Сущ:4 http://mirror.yandex.ru/debian stretch Release
Сущ:6 https://apt.syncthing.net syncthing InRelease
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Может быть обновлено 22 пакета. Запустите «apt list --upgradable» для их показа.
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
policykit-1 : Зависит: libpolkit-agent-1-0 (= 0.105-18) но 0.105-18+deb9u1 уже установлен
               Зависит: libpolkit-backend-1-0 (= 0.105-18) но 0.105-18+deb9u1 уже установлен
               Зависит: libpolkit-gobject-1-0 (= 0.105-18) но 0.105-18+deb9u1 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
root@FS01:~#


sidbar

tmpfs                          25M         9,7M   15M          41% /run
but a safety buffer of 16.0M
Devuan GNU/Linux 4 Chimaera x86_64

alterak

#9
сделал так, правда все равно не помогло
Открыть содержимое (спойлер)
root@FS01:~# mount -o remount,size=100M /run
root@FS01:~# df -h
Файловая система            Размер Использовано  Дост Использовано% Cмонтировано в
udev                          109M            0  109M            0% /dev
tmpfs                         100M         1,9M   99M            2% /run
/dev/vda1                     4,6G         2,1G  2,3G           48% /
tmpfs                         121M            0  121M            0% /dev/shm
tmpfs                         5,0M            0  5,0M            0% /run/lock
tmpfs                         121M            0  121M            0% /sys/fs/cgroup
tmpfs                          25M            0   25M            0% /run/user/1000
root@FS01:~# apt update && apt upgrade
Игн:1 http://mirror.yandex.ru/debian stretch InRelease
Сущ:2 http://mirror.yandex.ru/debian stretch-updates InRelease
Сущ:3 http://security.debian.org stretch/updates InRelease
Сущ:4 http://mirror.yandex.ru/debian stretch Release
Сущ:6 https://apt.syncthing.net syncthing InRelease
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Может быть обновлено 22 пакета. Запустите «apt list --upgradable» для их показа.
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
policykit-1 : Зависит: libpolkit-agent-1-0 (= 0.105-18) но 0.105-18+deb9u1 уже установлен
               Зависит: libpolkit-backend-1-0 (= 0.105-18) но 0.105-18+deb9u1 уже установлен
               Зависит: libpolkit-gobject-1-0 (= 0.105-18) но 0.105-18+deb9u1 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
root@FS01:~#
[свернуть]

Упс, пардон... после того как после этого выполнил apt-get -f install все стало норм обновляться...
Спасибо огромное sidbar за идею увеличить размер папки /run

svtv1

"Если достаточно долго сидеть возле реки - мимо проплывет труп твоего врага"

ogost

svtv1, что за некропост и что вы хотели этим сказать? В 10 амарока нет, если вы об этом. Тема закрыта.