Автор Тема: Не могу установить VLC (((  (Прочитано 3504 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yurbod

  • Новичок форума
  • Сообщений: 9
Не могу установить VLC (((
« : 28 Октября 2011, 23:07:53 »
Доброго времени суток!
 Не могу установить VLC :
uran@debian:~$ sudo apt-get install vlc
[sudo] password for uran:
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 vlc : Зависит: vlc-nox (= 1:1.1.12-0.1) но 1.1.3-1squeeze6 будет установлен
       Зависит: libavcodec53 (>= 5:0.8.5) но он не будет установлен
       Зависит: libavutil51 (>= 5:0.8.5) но он не будет установлен
       Зависит: libqtcore4 (>= 4:4.7.0~beta1) но 4:4.6.3-4+squeeze1 будет установлен
       Зависит: libstdc++6 (>= 4.6) но 4.4.5-8 будет установлен
       Зависит: libtar0 но он не может быть установлен
       Зависит: libva-x11-1 (> 1.0.12~) но 1.0.7-0.0 будет установлен
       Зависит: libva1 (> 1.0.12~) но 1.0.7-0.0 будет установлен
       Зависит: libxcb-keysyms1 (>= 0.3.8) но он не будет установлен
       Рекомендует: vlc-plugin-notify (= 1:1.1.12-0.1) но он не будет установлен
       Рекомендует: vlc-plugin-pulse (= 1:1.1.12-0.1) но он не будет установлен
       Ломает: vlc-nox (< 1.1.5-1) но 1.1.3-1squeeze6 будет установлен
E: Сломанные пакеты
uran@debian:~$
Sudo apt-apt-get update -f не помогает!"
 

Оффлайн osanve

  • Пользователь
  • *
  • Сообщений: 10
  • Jabber: osanve@jabber.ru
Re: Не могу установить VLC (((
« Ответ #1 : 29 Октября 2011, 00:04:24 »
/etc/apt/sources.list представте пожалуйста.
 

Оффлайн Yurbod

  • Новичок форума
  • Сообщений: 9
Re: Не могу установить VLC (((
« Ответ #2 : 29 Октября 2011, 09:08:51 »
Вот список репозиториев:
#

# deb cdrom:[Debian GNU/Linux 6.0.2.1 _Squeeze_ - Official i386 DVD Binary-1 20110626-15:45]/ squeeze contrib main

# deb cdrom:[Debian GNU/Linux 6.0.2.1 _Squeeze_ - Official i386 DVD Binary-1 20110626-15:45]/ squeeze contrib main


# Line commented out by installer because it failed to verify:
# deb http://security.debian.org/ squeeze/updates main contrib
# Line commented out by installer because it failed to verify:
# deb-src http://security.debian.org/ squeeze/updates main contrib

# squeeze-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
 deb http://ftp.debian.org/debian/ squeeze-updates main contrib
 deb-src http://ftp.debian.org/debian/ squeeze-updates main contrib



deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free
deb ftp://ftp.debian-multimedia.org squeeze main non-free
   
deb http://ftp.debian.org.ua/debian/ squeeze non-free

deb http://qutim.org/debian/stable/ stable main
deb-src http://qutim.org/debian/stable/ stable main
deb http://qutim.org/debian/testing/ testing main
deb-src http://qutim.org/debian/testing/ testing main
deb http://qutim.org/debian/unstable/ unstable main
deb-src http://qutim.org/debian/unstable/ unstable main
deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main
deb http://www.debian-multimedia.org squeeze non-free main
 
deb http://http.us.debian.org/debian/ squeeze main contrib non-free
deb-src http://http.us.debian.org/debian/ squeeze main contrib non-free


deb-src http://http.us.debian.org/debian/ squeeze/updates main contrib non-free

deb http://volatile.debian.org/debian-volatile squeeze/volatile main
deb http://http.us.debian.org/debian/ squeeze-proposed-updates main

deb http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu lucid main
deb-src http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu lucid main

Ранее все нормально было по этому списку,но недавно переустановил Дебиан и вот ничего не получается с VLC!
 

Оффлайн Lum

  • Пользователь
  • *
  • Сообщений: 29
Re: Не могу установить VLC (((
« Ответ #3 : 29 Октября 2011, 09:38:43 »
Сломанные зависимости из-за этой строчки
deb http://www.debian-multimedia.org testing main non-free
 

Оффлайн Ghostdmn

Re: Не могу установить VLC (((
« Ответ #4 : 29 Октября 2011, 10:06:12 »
Зачем подключены ветки Тестинга и Анстейбла? Не проще ли тогда на них и сидеть? И да, ко всему прочему еще и Убунтовский Firefox... Разбирайтесь с репами. Не надо все вподряд  пихать в sources.list!
8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100
 

Оффлайн osanve

  • Пользователь
  • *
  • Сообщений: 10
  • Jabber: osanve@jabber.ru
Re: Не могу установить VLC (((
« Ответ #5 : 29 Октября 2011, 16:04:08 »
Мде...
Не могу понять для чего прописывать несколько раз одно и то же, а также для чего с одного сервера тянуть и stable, и testing, и unstable.

Для начала определитесь в какой ветке Вы будете и уже их прописывайте в sources.list.
Мне, например, хватает
Цитировать
deb http://ftp.ru.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.ru.debian.org/debian/ squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib
deb-src http://security.debian.org/ squeeze/updates main contrib
VLC по этим репам поставится.

Если учитывать еще Вас список, то добавляем (за работоспособность не отвечаю - не проверял):
Цитировать
deb ftp://ftp.debian-multimedia.org squeeze main non-free
deb http://qutim.org/debian/stable/ stable main
deb-src http://qutim.org/debian/stable/ stable main
deb http://volatile.debian.org/debian-volatile squeeze/volatile main

Убунтовские репозитории выкинте, имхо.

В итоге получается красивый и работающий sources.list
 

Оффлайн Malaheenee

Re: Не могу установить VLC (((
« Ответ #6 : 29 Октября 2011, 18:44:51 »
Или если уж так хочется пакеты из тестинга, создавайте /etc/apt-preferences.conf с указанием нужных пакетов и будет Вам счастье :)
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн Yurbod

  • Новичок форума
  • Сообщений: 9
Re: Не могу установить VLC (((
« Ответ #7 : 29 Октября 2011, 20:59:19 »
Мде...
Не могу понять для чего прописывать несколько раз одно и то же, а также для чего с одного сервера тянуть и stable, и testing, и unstable.

Для начала определитесь в какой ветке Вы будете и уже их прописывайте в sources.list.
Мне, например, хватает
Цитировать
deb http://ftp.ru.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.ru.debian.org/debian/ squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib
deb-src http://security.debian.org/ squeeze/updates main contrib
VLC по этим репам поставится.

Если учитывать еще Вас список, то добавляем (за работоспособность не отвечаю - не проверял):
Цитировать
deb ftp://ftp.debian-multimedia.org squeeze main non-free
deb http://qutim.org/debian/stable/ stable main
deb-src http://qutim.org/debian/stable/ stable main
deb http://volatile.debian.org/debian-volatile squeeze/volatile main

Убунтовские репозитории выкинте, имхо.

В итоге получается красивый и работающий sources.list
Спасибо за помощь и участие!Всё получилось!  ;)
Такой бардак развел при установке драйверов для Nvidia -все чего-то не хватало!Убунтовские репы вписывал для установки DockbarX и Firefox 7!Не опытный я еще ! ::)
 

Оффлайн Ben-zin

  • Активный пользователь
  • **
  • Сообщений: 74
  • Jabber: benzinnn@jabber.ru
Re: Не могу установить VLC (((
« Ответ #8 : 29 Октября 2011, 21:49:43 »
После установки нужных левых пакетов не забывай отключать лишние репозитории ;).
Можно просто закомментировать символом # в sources.list, или в синаптике убиранием флажка в соответствующем списке.
 

Теги:
     

    Не могу войти в систему

    Автор svtv1

    Ответов: 5
    Просмотров: 2294
    Последний ответ 25 Октября 2018, 16:06:58
    от ecc83
    [РЕШЕНО] Не могу русифицировать LiveCD Wheezy

    Автор SuperGeek256

    Ответов: 4
    Просмотров: 1803
    Последний ответ 31 Декабря 2013, 20:17:08
    от SuperGeek256
    локальный репозиторий. не могу обновиться

    Автор Анастасия

    Ответов: 2
    Просмотров: 1150
    Последний ответ 04 Апреля 2019, 16:34:37
    от Анастасия
    grub-install - не могу переустановить...

    Автор redkino

    Ответов: 3
    Просмотров: 1194
    Последний ответ 19 Февраля 2015, 05:26:58
    от ihammers
    [Решено] Не могу сравнить файлы (debian 10, kde, krusader, kdiff3)

    Автор Eugene1976

    Ответов: 0
    Просмотров: 792
    Последний ответ 19 Июля 2019, 16:07:59
    от Eugene1976