Автор Тема: Не работает бридж  (Прочитано 1208 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн bedman

  • Новичок форума
  • Topic Author
  • Сообщений: 1
  • Jabber: 777019
Не работает бридж
« : 27 Март 2019, 12:06:36 »
Добрый день.
Установлен proxmox 5.3
На сервере 1 активная сетевая карта (enp11s0f1) с внешним ip 79.64.
Через proxmox создал Linux Bridge vmbr0.
Установил виртуальную машину ​​VM Cent OS 7.
Прописал на ней внешний ip адрес 78.79 в настройках Cent OS.
И вот что получается.
Если в настройках vmbr0 указать «bridge-ports enp11s0f1», основной ip 79.64 (enp11s0f1) перестанет отвечать, а 78.79 (vmbr0) начнет пинговаться.
Если я поставлю «bridge-ports none», то, наоборот, ip 79.64 (enp11s0f1) начнет пинговаться, но 78.79 (vmbr0) перестанет работать.
Подскажите что делать.
Спасибо.

« Последнее редактирование: 27 Март 2019, 12:08:56 от bedman »
 

Оффлайн gardarea51

  • Старожил
  • ****
  • Сообщений: 737
  • Jabber: gard.area51@jabber.ru
Re: Не работает бридж
« Ответ #1 : 27 Март 2019, 14:34:14 »
Могу дико ошибаться.. но.. ip_forward у вас разрешен?

ps: хотя, наверное таки ошибаюсь, это ж бридж..
« Последнее редактирование: 27 Март 2019, 14:52:40 от gardarea51 »
 

Оффлайн Walter_322

  • Активный пользователь
  • **
  • Сообщений: 78
  • Jabber: walterd@jabber.ru
Re: Не работает бридж
« Ответ #2 : 27 Март 2019, 18:30:17 »
Все настройки порта (адрес, маска, шлюз, днс) надо прописывать для бриджа, а не для порта, добавленного в бридж.
 


Оффлайн endru

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1915
  • Новосибирск
  • Jabber: endru@jabber.ru
Re: Не работает бридж
« Ответ #3 : 28 Март 2019, 04:39:44 »
Ссылку читал?

Оффлайн Bitkovski

  • И таки да!!!
  • Модератор
  • Активный пользователь
  • *****
  • Сообщений: 65
  • большой тухес тоже нахес
Re: Не работает бридж
« Ответ #4 : 18 Ноябрь 2019, 13:12:49 »
Добрый день.
Установлен proxmox 5.3
На сервере 1 активная сетевая карта (enp11s0f1) с внешним ip 79.64.
Через proxmox создал Linux Bridge vmbr0.
Установил виртуальную машину ​​VM Cent OS 7.
Прописал на ней внешний ip адрес 78.79 в настройках Cent OS.
И вот что получается.
Если в настройках vmbr0 указать «bridge-ports enp11s0f1», основной ip 79.64 (enp11s0f1) перестанет отвечать, а 78.79 (vmbr0) начнет пинговаться.
Если я поставлю «bridge-ports none», то, наоборот, ip 79.64 (enp11s0f1) начнет пинговаться, но 78.79 (vmbr0) перестанет работать.
Подскажите что делать.
Спасибо.


https://debianforum.ru/index.php/topic,15331.0.html
Вам надо было другой интерфейс прописать. Ну и вторую карту подключить кабелем.
Таки не думайте, что ви самый умный. Здесь все Евреи!!!
 

Теги: bridge proxmox