Автор Тема: remmina после обновления  (Прочитано 1539 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн KellyDink

  • Новичок форума
  • Topic Author
  • Сообщений: 9
remmina после обновления
« : 13 Май 2019, 21:20:52 »
Вот говорила же мне мама - обновления это зло. Но я ж умная, я ж лучше всех знаю.
У меня debian stretch 9.9 (уже). После того, как я психанула и сделала apt upgrade у меня remmina перестала подключаться к серверу по rdp. До обновления было все хорошо, а сейчас пишет unable to connect. Причем я думала, что это мои руки кривые, но нет, на соседнем сделала то же самое - результат тот же. Ныне remmina там стоит 1.3.3, до версии 1.3.4 у меня не вышло обновиться.
 
Я удаляла конфиги, переустанавливала ее с remove и purge, во вкладке security выставляла rdp и что только не делала, чтобы это исправить.
в backreport'e есть только версия 1.3.3 и она как шарик у ослика иа-иа и устанавливается и удаляется. а вот с репозиторием реминовским бяда. Вот делала как тут:
https://remmina.org/how-to-install-remmina/#binary-distributions


sudo apt-add-repository ppa:remmina-ppa-team/remmina-next
sudo apt update
(вот на этом этапе говорит, что я буду игнорировать твои соурсы и вообще это не секьюрно)
Spoiler: ShowHide
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable Release                                                                                                                             
Hit:3 http://security.debian.org/debian-security stretch/updates InRelease                                                                                                             
Ign:4 http://deb.debian.org/debian stretch InRelease                                                                                                                                   
Hit:5 http://deb.debian.org/debian stretch-updates InRelease                                                                           
Hit:6 http://deb.debian.org/debian stretch Release                                                               
Ign:7 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan InRelease   
Hit:9 http://ppa.launchpad.net/webupd8team/java/ubuntu disco InRelease                                                             
Hit:10 http://linux.teamviewer.com/deb stable InRelease                                                                           
Ign:11 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan Release
Ign:12 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main amd64 Packages
Ign:14 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main all Packages
Ign:15 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en
Ign:16 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en_US
Ign:12 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main amd64 Packages
Ign:14 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main all Packages
Ign:15 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en
Ign:16 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en_US
Ign:12 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main amd64 Packages
Ign:14 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main all Packages
Ign:15 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en
Ign:16 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en_US
Ign:12 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main amd64 Packages
Ign:14 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main all Packages
Ign:15 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en
Ign:16 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en_US
Ign:12 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main amd64 Packages
Ign:14 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main all Packages
Ign:15 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en
Ign:16 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en_US
Err:12 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main amd64 Packages
  404  Not Found
Ign:14 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main all Packages
Ign:15 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en
Ign:16 http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan/main Translation-en_US
Reading package lists... Done
W: The repository 'http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu eoan Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://ppa.launchpad.net/remmina-ppa-team/remmina-next/ubuntu/dists/eoan/main/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

sudo apt install remmina remmina-plugin-rdp remmina-plugin-secret remmina-plugin-spice
ну а тут соответственно не ищет ее.


Причем к десктопу он подключается нормально (может у него аллергия на сервера? или в винде какие-нибудь настройки стоят), в обоих случаях в настройках рдп стоит разрешать всем, даже если небезопасно. А по xfreerdp подключается ко всем :(

Если отмести вывод - использовать xfreerdp (патамушто я девочка и мне нравится гуишечка), куда можно еще посмотреть?
 


Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3663
  • Buster TDE & KDE
Re: remmina после обновления
« Ответ #1 : 13 Май 2019, 22:15:04 »
Вот говорила же мне мама - обновления это зло. Но я ж умная, я ж лучше всех знаю.
Мама конечно права, но не совсем. Все мы грешны но есть золотое правило использовать сторонние репозитории только один раз, поставил программу и # перед источником.
Что же делать теперь? Вангую что репозиторий ubuntu должен  должен быть убран совсем, это даже не обсуждается. Неработоспособность программы вызвана обновлением пакетов libfreerdp2-2 и его зависимостей. Вспоминайте по времени установки программы какие пакеты были по дате ( можно посмотреть в /var/cache/apt/archives )  если не почистили конечно или на https://snapshot.debian.org/binary/libfreerdp2-2/ скачивать все пакеты и ставить их на замещение с понижением версии через  dpkg -i
Русские дебианщики против цифрового слабоумия !
 

Оффлайн KellyDink

  • Новичок форума
  • Topic Author
  • Сообщений: 9
Re: remmina после обновления
« Ответ #2 : 13 Май 2019, 22:49:26 »
Мама конечно права,
надо слушаться  маму :(
Вангую что репозиторий ubuntu должен  должен быть убран совсем, это даже не обсуждается.
дело в том, что remmin'ы под дебиан в принципе не существует, а ядро у них одно, поэтому вроде как смело можно устаавливать все из убунтовских репозиториев. Но я удалила и оставила только backports и оттуда установила remmina
Вспоминайте по времени установки программы какие пакеты были по дате ( можно посмотреть в /var/cache/apt/archives )  если не почистили конечно или на https://snapshot.debian.org/binary/libfreerdp2-2/ скачивать все пакеты и ставить их на замещение с понижением версии через  dpkg -i
Spoiler: ShowHide
root@KaterinaDeb:/home/katerina/Downloads# ls -la /var/cache/apt/archives/libfreerdp*
-rw-r--r-- 1 root root 877110 Nov 29 01:12 /var/cache/apt/archives/libfreerdp2-2_2.0.0~git20181120.1.e21b72c95+dfsg1-1~bpo9+1_amd64.deb
-rw-r--r-- 1 root root 892396 Mar 24 06:26 /var/cache/apt/archives/libfreerdp2-2_2.0.0~git20190204.1.2693389a+dfsg1-1~bpo9+1_amd64.deb
-rw-r--r-- 1 root root 168168 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-cache1.1_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb
-rw-r--r-- 1 root root 202764 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-client1.1_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb
-rw-r--r-- 1 root root 671900 Nov 29 01:12 /var/cache/apt/archives/libfreerdp-client2-2_2.0.0~git20181120.1.e21b72c95+dfsg1-1~bpo9+1_amd64.deb
-rw-r--r-- 1 root root 685818 Mar 24 06:26 /var/cache/apt/archives/libfreerdp-client2-2_2.0.0~git20190204.1.2693389a+dfsg1-1~bpo9+1_amd64.deb
-rw-r--r-- 1 root root 213280 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-codec1.1_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb
-rw-r--r-- 1 root root 167022 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-common1.1.0_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb
-rw-r--r-- 1 root root 300464 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-core1.1_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb
-rw-r--r-- 1 root root 175448 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-crypto1.1_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb
-rw-r--r-- 1 root root 181800 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-gdi1.1_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb
-rw-r--r-- 1 root root 185226 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-locale1.1_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb
-rw-r--r-- 1 root root 252300 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-plugins-standard_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb
-rw-r--r-- 1 root root 166244 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-primitives1.1_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb
-rw-r--r-- 1 root root 163060 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-rail1.1_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb
-rw-r--r-- 1 root root 170210 Feb 10 06:25 /var/cache/apt/archives/libfreerdp-utils1.1_1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3_amd64.deb

вот эти все пакеты понижать до последней рабочей версии?

просто зависимостей у него тьма >_< я ж устану, пока каждую буду проверять
Spoiler: ShowHide
 libfreerdp2-2
  Depends: libavcodec-extra57 (>= 7:3.2.12)
  Depends: libavcodec57 (>= 7:3.2.12)
  Depends: libavutil55 (>= 7:3.2.12)
  Depends: libc6 (>= 2.14)
  Depends: libgsm1 (>= 1.0.13)
  Depends: libjpeg62-turbo (>= 1.3.1)
  Depends: libssl1.1 (>= 1.1.0)
  Depends: libswresample2 (>= 7:3.2.12)
  Depends: libwinpr2-2 (>= 2.0.0~git20181120.1.e21b72c95+dfsg1)
  Depends: libx11-6
  Depends: libxkbfile1
libavcodec-extra57
  Depends: libavutil55 (>= 7:3.2.12)
  Depends: libc6 (>= 2.14)
  Depends: libcrystalhd3 (>= 1:0.0~git20110715.fdd2f19)
  Depends: libgsm1 (>= 1.0.13)
  Depends: liblzma5 (>= 5.1.1alpha+20120614)
  Depends: libmp3lame0
  Depends: libopencore-amrnb0
  Depends: libopencore-amrwb0
  Depends: libopenjp2-7 (>= 2.0.0)
  Depends: libopus0 (>= 1.1)
  Depends: libshine3 (>= 3.1.0)
  Depends: libsnappy1v5
  Depends: libspeex1 (>= 1.2~beta3-1)
  Depends: libswresample2 (>= 7:3.2.12)
  Depends: libtheora0 (>= 1.0)
  Depends: libtwolame0 (>= 0.3.10)
  Depends: libva1 (>= 1.7.3)
  Depends: libvo-amrwbenc0
  Depends: libvorbis0a (>= 1.1.2)
  Depends: libvorbisenc2 (>= 1.1.2)
  Depends: libvpx4 (>= 1.6.0)
  Depends: libwavpack1 (>= 4.40.0)
  Depends: libwebp6 (>= 0.5.1)
  Depends: libwebpmux2 (>= 0.5.1)
  Depends: libx264-148
  Depends: libx265-95 (>= 2.1)
  Depends: libxvidcore4 (>= 1.2.2)
  Depends: libzvbi0 (>= 0.2.35)
  Depends: zlib1g (>= 1:1.2.0)
libavutil55
  Depends: libc6 (>= 2.17)
  Depends: libva-drm1 (>= 1.1.0)
  Depends: libva-x11-1 (>= 1.0.3)
  Depends: libva1 (>= 1.2.0)
  Depends: libvdpau1 (>= 0.2)
  Depends: libx11-6
libc6
  Depends: libgcc1
libgcc1
  Depends: gcc-6-base (= 6.3.0-18+deb9u1)
  Depends: libc6 (>= 2.14)
gcc-6-base
libva-drm1
  Depends: libc6 (>= 2.4)
  Depends: libdrm2 (>= 2.4.16)
  Depends: libva1 (<< 1.7.3.1)
libdrm2
  Depends: libc6 (>= 2.17)
  Depends: libdrm-common (>= 2.4.95-1~bpo9+1)
libdrm-common
libva1
  Depends: libc6 (>= 2.4)
libva-x11-1
  Depends: libc6 (>= 2.4)
  Depends: libdrm2 (>= 2.3.1)
  Depends: libva1 (<< 1.7.3.1)
  Depends: libx11-6 (>= 2:1.4.99.1)
  Depends: libxext6
  Depends: libxfixes3
libx11-6
  Depends: libc6 (>= 2.15)
  Depends: libx11-data
  Depends: libxcb1 (>= 1.11.1)
libx11-data
libxcb1
  Depends: libc6 (>= 2.14)
  Depends: libxau6
  Depends: libxdmcp6
libxau6
  Depends: libc6 (>= 2.4)
  PreDepends: multiarch-support
multiarch-support
  Depends: libc6 (>= 2.3.6-2)
libxdmcp6
  Depends: libbsd0 (>= 0.2.0)
  Depends: libc6 (>= 2.4)
libbsd0
  Depends: libc6 (>= 2.16)
libxext6
  Depends: libc6 (>= 2.14)
  Depends: libx11-6 (>= 2:1.6.0)
libxfixes3
  Depends: libc6 (>= 2.14)
  Depends: libx11-6 (>= 2:1.6.0)
libvdpau1
  Depends: libc6 (>= 2.17)
  Depends: libx11-6 (>= 2:1.4.99.1)
  Depends: libxext6
libcrystalhd3
  Depends: libc6 (>= 2.14)
  Depends: libgcc1 (>= 1:3.0)
  Depends: libstdc++6 (>= 4.1.1)
libstdc++6
  Depends: gcc-6-base (= 6.3.0-18+deb9u1)
  Depends: libc6 (>= 2.18)
  Depends: libgcc1 (>= 1:4.2)
libgsm1
  Depends: libc6 (>= 2.2.5)
liblzma5
  Depends: libc6 (>= 2.17)
libmp3lame0
  Depends: libc6 (>= 2.14)
libopencore-amrnb0
  Depends: libc6 (>= 2.4)
libopencore-amrwb0
  Depends: libc6 (>= 2.14)
libopenjp2-7
  Depends: libc6 (>= 2.14)
libopus0
  Depends: libc6 (>= 2.14)
libshine3
  Depends: libc6 (>= 2.14)
libsnappy1v5
  Depends: libc6 (>= 2.14)
  Depends: libgcc1 (>= 1:3.0)
  Depends: libstdc++6 (>= 5.2)
libspeex1
  Depends: libc6 (>= 2.14)
libswresample2
  Depends: libavutil55 (>= 7:3.2.12)
  Depends: libc6 (>= 2.14)
  Depends: libsoxr0 (>= 0.1.0)
libsoxr0
  Depends: libc6 (>= 2.14)
  Depends: libgomp1 (>= 4.9)
libgomp1
  Depends: gcc-6-base (= 6.3.0-18+deb9u1)
  Depends: libc6 (>= 2.17)
libtheora0
  Depends: libc6 (>= 2.14)
  Depends: libcairo2 (>= 1.2.4)
  Depends: libogg0 (>= 1.1.0)
libcairo2
  Depends: libc6 (>= 2.14)
  Depends: libfontconfig1 (>= 2.11)
  Depends: libfreetype6 (>= 2.3.5)
  Depends: libpixman-1-0 (>= 0.30.0)
  Depends: libpng16-16 (>= 1.6.2-1)
  Depends: libx11-6
  Depends: libxcb-render0
  Depends: libxcb-shm0
  Depends: libxcb1 (>= 1.6)
  Depends: libxext6
  Depends: libxrender1
  Depends: zlib1g (>= 1:1.1.4)
libfontconfig1
  Depends: fontconfig-config (>= 2.11.0-6.7)
  Depends: libc6 (>= 2.14)
  Depends: libexpat1 (>= 2.0.1)
  Depends: libfreetype6 (>= 2.2.1)
fontconfig-config
  Depends: debconf (>= 0.5)
  Depends: debconf-2.0
  Depends: fonts-dejavu-core
  Depends: fonts-freefont
  Depends: fonts-liberation
  Depends: ttf-bitstream-vera
  Depends: ucf (>= 0.29)
debconf
  PreDepends: perl-base (>= 5.20.1-3~)
perl-base
  PreDepends: dpkg (>= 1.17.17)
  PreDepends: libc6 (>= 2.23)
dpkg
  Depends: tar (>= 1.28-1)
  PreDepends: libbz2-1.0
  PreDepends: libc6 (>= 2.14)
  PreDepends: liblzma5 (>= 5.2.2)
  PreDepends: libselinux1 (>= 2.3)
  PreDepends: zlib1g (>= 1:1.1.4)
tar
  PreDepends: libacl1 (>= 2.2.51-8)
  PreDepends: libc6 (>= 2.17)
  PreDepends: libselinux1 (>= 1.32)
libacl1
  Depends: libattr1 (>= 1:2.4.46-8)
  Depends: libc6 (>= 2.14)
libattr1
  Depends: libc6 (>= 2.4)
libselinux1
  Depends: libc6 (>= 2.14)
  Depends: libpcre3
libpcre3
  Depends: libc6 (>= 2.14)
  PreDepends: multiarch-support
libbz2-1.0
  Depends: libc6 (>= 2.4)
zlib1g
  Depends: libc6 (>= 2.14)
debconf-2.0
fonts-dejavu-core
fonts-freefont
fonts-liberation
ttf-bitstream-vera
ucf
  Depends: coreutils (>= 5.91)
  Depends: debconf (>= 1.5.19)
coreutils
  PreDepends: libacl1 (>= 2.2.51-8)
  PreDepends: libattr1 (>= 1:2.4.46-8)
  PreDepends: libc6 (>= 2.17)
  PreDepends: libselinux1 (>= 2.1.13)
libexpat1
  Depends: libc6 (>= 2.14)
libfreetype6
  Depends: libc6 (>= 2.14)
  Depends: libpng16-16 (>= 1.6.2-1)
  Depends: zlib1g (>= 1:1.1.4)
libpng16-16
  Depends: libc6 (>= 2.14)
  Depends: zlib1g (>= 1:1.2.3.4)
libpixman-1-0
  Depends: libc6 (>= 2.14)
libxcb-render0
  Depends: libc6 (>= 2.14)
  Depends: libxcb1 (>= 1.8)
libxcb-shm0
  Depends: libc6 (>= 2.4)
  Depends: libxcb1 (>= 1.12)
libxrender1
  Depends: libc6 (>= 2.14)
  Depends: libx11-6 (>= 2:1.6.0)
libogg0
  Depends: libc6 (>= 2.14)
  PreDepends: multiarch-support
libtwolame0
  Depends: libc6 (>= 2.4)
libvo-amrwbenc0
  Depends: libc6 (>= 2.14)
  PreDepends: multiarch-support
libvorbis0a
  Depends: libc6 (>= 2.15)
  Depends: libogg0 (>= 1.1.0)
libvorbisenc2
  Depends: libc6 (>= 2.4)
  Depends: libogg0 (>= 1.0rc3)
  Depends: libvorbis0a (= 1.3.5-4+deb9u2)
libvpx4
  Depends: libc6 (>= 2.14)
  Depends: libgcc1 (>= 1:3.0)
  Depends: libstdc++6 (>= 4.1.1)
libwavpack1
  Depends: libc6 (>= 2.14)
libwebp6
  Depends: libc6 (>= 2.14)
libwebpmux2
  Depends: libc6 (>= 2.14)
  Depends: libwebp6 (>= 0.5.1)
libx264-148
  Depends: libc6 (>= 2.15)
libx265-95
  Depends: libc6 (>= 2.15)
  Depends: libnuma1 (>= 2.0.11)
  Depends: libstdc++6 (>= 4.1.1)
libnuma1
  Depends: libc6 (>= 2.14)
libxvidcore4
  Depends: libc6 (>= 2.14)
libzvbi0
  Depends: libc6 (>= 2.15)
  Depends: libpng16-16 (>= 1.6.2-1)
  Depends: libzvbi-common (= 0.2.35-13)
  Depends: zlib1g (>= 1:1.1.4)
libzvbi-common
libavcodec57
  Depends: libavutil55 (>= 7:3.2.12)
  Depends: libc6 (>= 2.14)
  Depends: libcrystalhd3 (>= 1:0.0~git20110715.fdd2f19)
  Depends: libgsm1 (>= 1.0.13)
  Depends: liblzma5 (>= 5.1.1alpha+20120614)
  Depends: libmp3lame0
  Depends: libopenjp2-7 (>= 2.0.0)
  Depends: libopus0 (>= 1.1)
  Depends: libshine3 (>= 3.1.0)
  Depends: libsnappy1v5
  Depends: libspeex1 (>= 1.2~beta3-1)
  Depends: libswresample2 (>= 7:3.2.12)
  Depends: libtheora0 (>= 1.0)
  Depends: libtwolame0 (>= 0.3.10)
  Depends: libva1 (>= 1.7.3)
  Depends: libvorbis0a (>= 1.1.2)
  Depends: libvorbisenc2 (>= 1.1.2)
  Depends: libvpx4 (>= 1.6.0)
  Depends: libwavpack1 (>= 4.40.0)
  Depends: libwebp6 (>= 0.5.1)
  Depends: libwebpmux2 (>= 0.5.1)
  Depends: libx264-148
  Depends: libx265-95 (>= 2.1)
  Depends: libxvidcore4 (>= 1.2.2)
  Depends: libzvbi0 (>= 0.2.35)
  Depends: zlib1g (>= 1:1.2.0)
libjpeg62-turbo
  Depends: libc6 (>= 2.14)
libssl1.1
  Depends: debconf (>= 0.5)
  Depends: debconf-2.0
  Depends: libc6 (>= 2.17)
libwinpr2-2
  Depends: libc6 (>= 2.15)
  Depends: libicu57 (>= 57.1-1~)
  Depends: libssl1.1 (>= 1.1.0)
  Depends: libsystemd0
libicu57
  Depends: libc6 (>= 2.14)
  Depends: libgcc1 (>= 1:3.0)
  Depends: libstdc++6 (>= 5.2)
libsystemd0
  PreDepends: libc6 (>= 2.17)
  PreDepends: libgcrypt20 (>= 1.7.0)
  PreDepends: liblz4-1 (>= 0.0~r122)
  PreDepends: liblzma5 (>= 5.1.1alpha+20120614)
libgcrypt20
  Depends: libc6 (>= 2.15)
  Depends: libgpg-error0 (>= 1.14)
libgpg-error0
  Depends: libc6 (>= 2.15)
liblz4-1
  Depends: libc6 (>= 2.14)
libxkbfile1
  Depends: libc6 (>= 2.14)
  Depends: libx11-6


вообще если я правильно понимаю, то конкретно у пакетика libfreerdp2-2 дата последняя стоит марта месяца, а апгрейдилась я вчера (
Но я его еще ниже установила от ноября, но собственно и это не спасло
Spoiler: ShowHide
 root@KaterinaDeb:/home/katerina/Downloads# dpkg -s libfreerdp2-2 | grep Version
Version: 2.0.0~git20190204.1.2693389a+dfsg1-1~bpo9+1
root@KaterinaDeb:/home/katerina/Downloads# dpkg -i /var/cache/apt/archives/libfreerdp2-2_2.0.0~git20181120.1.e21b72c95+dfsg1-1~bpo9+1_amd64.deb
dpkg: warning: downgrading libfreerdp2-2:amd64 from 2.0.0~git20190204.1.2693389a+dfsg1-1~bpo9+1 to 2.0.0~git20181120.1.e21b72c95+dfsg1-1~bpo9+1
(Reading database ... 173427 files and directories currently installed.)
Preparing to unpack .../libfreerdp2-2_2.0.0~git20181120.1.e21b72c95+dfsg1-1~bpo9+1_amd64.deb ...
Unpacking libfreerdp2-2:amd64 (2.0.0~git20181120.1.e21b72c95+dfsg1-1~bpo9+1) over (2.0.0~git20190204.1.2693389a+dfsg1-1~bpo9+1) ...
Setting up libfreerdp2-2:amd64 (2.0.0~git20181120.1.e21b72c95+dfsg1-1~bpo9+1) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...

и собственно это не помогло, а вот после перезагрузки, окошечко подключения даже не открывалось. После обновления его обратно, хотя бы появлется окошечко, которое мне говорит, что он паровозик, который не смог(
« Последнее редактирование: 13 Май 2019, 23:22:30 от KellyDink »
 

Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 3149
  • Linux Registered User #547151
Re: remmina после обновления
« Ответ #3 : 14 Май 2019, 12:19:50 »
дело в том, что remmin'ы под дебиан в принципе не существует,
это чем же я тогда пользуюсь? O_o

Оффлайн Ogis1975

  • OS: Debian 9.4 / WM: Xmonad
  • Местный житель
  • ***
  • Сообщений: 473
  • Debian 10.1 notion wm
    • Мой репозиторий на Github
Re: remmina после обновления
« Ответ #4 : 14 Май 2019, 16:54:15 »
sudo apt-add-repository ppa
Ppa не совместимы с Дебиан...радуйтесь, что всю систему не грохнули.
 

Оффлайн KellyDink

  • Новичок форума
  • Topic Author
  • Сообщений: 9
Re: remmina после обновления
« Ответ #5 : 17 Май 2019, 17:41:26 »
дело в том, что remmin'ы под дебиан в принципе не существует,
это чем же я тогда пользуюсь? O_o
я имела ввиду, что в stable нет remmina, только backports.

Ppa не совместимы с Дебиан...радуйтесь, что всю систему не грохнули.
ну раньше вродь на дебиан я ставила с ppa и все было хорошо. Только в этот раз пошло что-то не так.
и учитывая, что ppa у меня не доступно, то я думаю обновился как раз с дебиановского репозитория


А еще сегодня еще раз ставила эксперименты. Ситуация следующая - единственный сервер, куда теперь не хочет подключаться это удаленный сервер, все сервера в локальной сети он кушает хорошо. Игнорирует только тот, к которому надо лезть в интернет. Доступ к нему есть, по имени он пингуется, через другие устройства к нему подключиться могу( может нужна какая-то дополнительная настройка безопасности?
 

Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 3149
  • Linux Registered User #547151
Re: remmina после обновления
« Ответ #6 : 18 Май 2019, 19:31:11 »
ну раньше вродь на дебиан я ставила с ppa и все было хорошо. Только в этот раз пошло что-то не так.
я имела ввиду, что в stable нет remmina, только backports
backports он как раз безопасен, а ppa - вообще несовместим. это как в русскую рулетку играть - может и пронесёт

Оффлайн KellyDink

  • Новичок форума
  • Topic Author
  • Сообщений: 9
Re: remmina после обновления
« Ответ #7 : 20 Май 2019, 13:51:49 »
backports он как раз безопасен, а ppa - вообще несовместим. это как в русскую рулетку играть - может и пронесёт
Окай! спасибо! буду знать и не буду ничего устанавливать больше оттуда.
 

Теги:
 

remmina вход только со второй попытки, как лечить? Решено

Автор deb720

Ответов: 10
Просмотров: 5144
Последний ответ 14 Декабрь 2013, 13:58:18
от deb720
Подвисает Remmina, задолбала!

Автор PbI6A

Ответов: 13
Просмотров: 3122
Последний ответ 05 Июль 2017, 05:02:37
от PbI6A
Проблема с раскладками при подключении remmina по RDP.

Автор DedMoroz

Ответов: 4
Просмотров: 400
Последний ответ 08 Июль 2020, 11:04:25
от DedMoroz