[Решено] 0 A.D. стратегия

Автор Листик, 15 мая 2019, 00:20:09

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Листик

Привет! Можно ли как-то установить последнюю версию от разработчиков и не поломать систему?

G_r_i_g_a

#1
Да, можно, как и всегда.
Для этого в файле /etc/apt/sources.list Заменяешь во всех раскомментированных строках stretch на buster, а дальше
sudo apt update
sudo apt upgrade
sudo apt dist-upgrade

Во время обновления надо будет отвечать на вопросы, в числе которых какой конфиг оставить, я почти всегда оставляю локальный, чтобы не слетали настройки.
Конечно, есть вероятность что что-нибудь сломается, но будем надеяться что все пройдет хорошо.
Главное смотри чтобы во время обновления серьезных ошибок не было. Если ошибки будут, то лучше систему не перезагружать, а попытаться их решить.

Команды выше - это инструкции по обновлению системы с 9 (stretch) до 10 (buster), который на данный момент является тестингом. Ogost

Walter_322

Или, если нет желания обновляться до тестинг, можно установить 0AD в виде самодостаточного пакета flatpak. 0AD есть в репозитории flathub

Листик

#3
Griga, Вы хоть предупреждали бы, что советуете обновиться до testing, а то новичок какой-нибудь почитает тему и скопирует бездумно команды. Нет, хочу на стабильной остаться, могу и подождать. Кстати, сами играли, сильно версия отличается от той, которая в репе Stretch?

С другой стороны, Tor же я устанавливал из тестовой версии без обновления дистрибутива. А здесь ругается.

Пробовал раскомментировать строку
deb http://deb.debian.org/debian stretch-backports main contrib


Далее



sudo apt update
sudo apt install 0ad=0.0.23-1~bpo9+1


Пишет:

Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
0ad : Зависит: 0ad-data (>= 0.0.23) но 0.0.21-1 будет установлен
       Зависит: 0ad-data-common (>= 0.0.23) но 0.0.21-1 будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.


Walter_322, В песочнице типа запустить? Боюсь, у меня комп не потянет, там требования к производительности, наверное, увеличатся.

Ладно, подождем. Игрушка, судя по всему, интересная. В английской Википедии пишут, что в декабре 2018 года у них вышел стабильный альфа-релиз (?). А когда бета-то (это же, вроде, по-настоящему готовым продуктом считается)?

Walter_322

В бэкпортах есть 0.0.23. После подключения репозитория с бекпортами, можно просто обновить список пакетов и установить пакет 0ad. Там же есть пакеты 0ad-data и 0ad-common необходимых версий

ogost

Взял на себя наглость отредактировать сообщение уважаемого Грига.

Листик

Walter_322,

Так не получается ее из бэкпорта установить - я в спойлере разместил вывод. А обновлений там много. Хотелось бы поставить только пакеты, связанные с игрой.

endru

Очень странно что он ставит не те пакеты. Возможно показывается вывод не той команды которая есть на самом деле?

Можно скачать нужные пакеты вручную с репа: http://ftp.debian.org/debian/pool/main/0/
Далее установить эти пакеты командой:

dpkg -i /путь/до/0ad*.deb


G_r_i_g_a

Цитата: ogost от 15 мая 2019, 09:40:01Взял на себя наглость отредактировать сообщение
Огромное спасибо, удалите его совсем тогда, думаю, так будет лучше. Шутки с утра это совсем не шутки) Виноват, исправлюсь.
Цитата: Листик от 15 мая 2019, 10:23:10Так не получается ее из бэкпорта установить
Установи сначала отдельно эти два пакета, а потом основной. Бывает такая штука у меня периодически, почему то не подтягивает нужные пакеты. Приходилось делать примерно так:
sudo apt update
sudo apt install -t stretch-backports 0ad-data
sudo apt install -t stretch-backports 0ad-data-common
sudo apt install -t stretch-backports 0ad

Листик

G_r_i_g_a,

Так установилась, спасибо.

Эх, все равно немного устаревшая версия - альфа-релиз от мая 2018 года. Дождусь беты, пожалуй, не буду портить впечатления от игры. Но играть уже можно.

G_r_i_g_a

#10
Цитата: Листик от 15 мая 2019, 13:46:07альфа-релиз от мая 2018 года
Так как я предлагал сделать изначально получил бы самую последнюю (по версии вики последний резиз альфа 23б от декабря 2018). В buster сейчас, судя по версиии пакета, альфа 23б от декабря 2018, могу поставить и посмотреть. Поставил и посмотрел, там сейчас от 9 января 2019г, 21946 P-release...
Цитата: Листик от 15 мая 2019, 13:46:07Дождусь беты, пожалуй
Если смотреть год начала разработки, то боюсь что не дождешься) В вики указано что в 2019 выйдет только альфа 24...
А просто так взять и поставить пакеты из buster в stretch не получится, там glibc6 в зависимости версии 2.28, а в strech версия 2.24. Если уж обновлять что то, то сразу дистрибутив.

Листик

G_r_i_g_a,

Не, я на Stretch до окончания срока длительной поддержки оставаться планирую. Какие-то веские причины должны быть, не только игра, для перехода. Пока в freeciv погамаю -).

G_r_i_g_a

Цитата: Листик от 15 мая 2019, 16:39:35я на Stretch до окончания срока длительной поддержки
Ого) Я бы так долго не смог(
Цитата: Листик от 15 мая 2019, 16:39:35Пока в freeciv погамаю -).
Тогда, наверное, тему пометить как решенную.

ek-nfn

Цитата: Листик от 15 мая 2019, 09:11:37sudo apt install 0ad=0.0.23-1~bpo9+1
насколько помню, из stretch-backports ставится так:
sudo apt install -t stretch-backports 0ad
Debian 11 xfce