Автор Тема: Проблема установки libpq-dev  (Прочитано 1565 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн penapisemnet

  • Новичок форума
  • Topic Author
  • Сообщений: 5
Проблема установки libpq-dev
« : 16 Июнь 2019, 20:16:55 »
тема уже была, но свою комбинацию я в ней не нашла поэтому выкладываю свое
обновила УБУНТУ с 16.4 версиии на 18.4 и пытаюсь поставить питон из сорсов для среды разработки
прописываю зависимости
все установилось за исключением вот этого
$ sudo apt-get install libpq-dev
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 libpq-dev : Зависит: libpq5 (= 10.8-0ubuntu0.18.04.1) но 11.3-1.pgdg16.04+1 должен быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

далее я устанавливаю пакет  на который все ругается и пишет мне система что все ОК
sudo apt-get install libpq5
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлен пакет libpq5 самой новой версии (11.3-1.pgdg16.04+1).
Следующие пакеты устанавливались автоматически и больше не требуются:
  apt-xapian-index python-apt python-aptdaemon python-aptdaemon.gtk3widgets
  python-babel python-babel-localedata python-debian python-defer
  python-dirspec python-httplib2 python-piston-mini-client python-twisted-web
  python-xapian python3-piston-mini-client python3-xapian
  software-center-aptdaemon-plugins
Для их удаления используйте «sudo apt autoremove».
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.


и так по кругу
всякие апдейты и абгрейты не помогли

Куда копать не знаю. Уважаемые форумчане - не оставьте в беде....
 

Оффлайн ecc83

  • Ветеран
  • *****
  • Сообщений: 1362
  • Debian, Openbox, macOS
Re: Проблема установки libpq-dev
« Ответ #1 : 16 Июнь 2019, 20:25:45 »
обновила УБУНТУ с 16.4 версиии на 18.4 и пытаюсь поставить питон из сорсов для среды разработки

Вас интересует поставить питон из репозитория Debian?
 

Оффлайн penapisemnet

  • Новичок форума
  • Topic Author
  • Сообщений: 5
Re: Проблема установки libpq-dev
« Ответ #2 : 16 Июнь 2019, 20:49:50 »
обновила УБУНТУ с 16.4 версиии на 18.4 и пытаюсь поставить питон из сорсов для среды разработки

Вас интересует поставить питон из репозитория Debian?

я хочу изучить ODOO 12 пытаюсь его поставить как описано в книге cookbook  там последовательность шагов но не получается
В Ubuntu я новичек
 

Оффлайн ecc83

  • Ветеран
  • *****
  • Сообщений: 1362
  • Debian, Openbox, macOS
Re: Проблема установки libpq-dev
« Ответ #3 : 16 Июнь 2019, 21:05:30 »
В Ubuntu я новичек

Поздравляю Вас с выбором дистрибутива.
Но обратите внимание на название данного форума и попробуйте сопоставить с названием Вашего дистрибутива.

Что бы развеять непонимание относительно того, что: "Все линуксы одинаковые!", хочу обратить Ваше внимание, что Ubuntu и Debian похожи друг на друга, как мальчик и девочка. Руки и ноги есть и там и там, но некоторые детали всё же отличаются.
Другими словами у многих схожих пакетов разные названия.
Исходя из вышесказанного, Вам лучше всего искать ответы на свои вопросы не на форумах по Windows или Debian, а непосредственно по Ubuntu.
 

Оффлайн G_r_i_g_a

  • Местный житель
  • ***
  • Сообщений: 303
Re: Проблема установки libpq-dev
« Ответ #4 : 16 Июнь 2019, 21:28:45 »
libpq-dev : Зависит: libpq5 (= 10.8-0ubuntu0.18.04.1) но 11.3-1.pgdg16.04+1 должен быть установлен
Тут жесткая зависимость от версии 10.8-0ubuntu0.18.04.1, а ты ставишь 11.3-1.pgdg16.04+1
версиии на 18.4
В 18.04 как раз версия указанная в зависимости пакета. Так чего там у тебя подключено и какая версия убунты?
Иными словами тебе надо поставить версию 10.8-0ubuntu0.18.04.1, а не 11.3-1.pgdg16.04+1
« Последнее редактирование: 16 Июнь 2019, 21:31:12 от G_r_i_g_a »
 
Пользователи, которые поблагодарили этот пост: penapisemnet

Оффлайн penapisemnet

  • Новичок форума
  • Topic Author
  • Сообщений: 5
Re: Проблема установки libpq-dev
« Ответ #5 : 16 Июнь 2019, 21:36:39 »
Тут жесткая зависимость от версии 10.8-0ubuntu0.18.04.1, а ты ставишь 11.3-1.pgdg16.04+1


а как мне ее заставить поставить нужную версию?

sudo apt-get install libpq5 - вот команда - где здесь версию указывать?
 

Оффлайн G_r_i_g_a

  • Местный житель
  • ***
  • Сообщений: 303
Re: Проблема установки libpq-dev
« Ответ #6 : 16 Июнь 2019, 21:38:26 »
а как мне ее заставить поставить нужную версию?
Посмотри какие версии есть в репах
sudo apt search libpq5
 
Пользователи, которые поблагодарили этот пост: penapisemnet

Оффлайн penapisemnet

  • Новичок форума
  • Topic Author
  • Сообщений: 5
Re: Проблема установки libpq-dev
« Ответ #7 : 16 Июнь 2019, 21:59:30 »
а как мне ее заставить поставить нужную версию?
Посмотри какие версии есть в репах
sudo apt search libpq5

libpq-dev/bionic-updates,bionic-security 10.8-0ubuntu0.18.04.1 amd64
  заголовочные  файлы для libpq5 (библиотеки PostgreSQL)

libpq5/now 11.3-1.pgdg16.04+1 amd64 [установлен, локальный]
  клиентская С-библиотека для PostgreSQL
 

Оффлайн G_r_i_g_a

  • Местный житель
  • ***
  • Сообщений: 303
Re: Проблема установки libpq-dev
« Ответ #8 : 16 Июнь 2019, 22:20:23 »
libpq5/now 11.3-1.pgdg16.04+1 amd64 [установлен, локальный]
У тебя этот пакет помечен как локальный и для версии 16.04. Но в стандартных репах его вообще нет.
Удали его, и снова проверь.
sudo apt purge libpq5
sudo apt update
sudo apt autoremove
sudo apt search libpq5
Выхлоп терминала сюда выложи, только заключи его в тег кода - символ решетки на панели форматирования текста
 
Пользователи, которые поблагодарили этот пост: penapisemnet

Оффлайн penapisemnet

  • Новичок форума
  • Topic Author
  • Сообщений: 5
Re: Проблема установки libpq-dev
« Ответ #9 : 16 Июнь 2019, 22:56:33 »
libpq5/now 11.3-1.pgdg16.04+1 amd64 [установлен, локальный]
У тебя этот пакет помечен как локальный и для версии 16.04. Но в стандартных репах его вообще нет.
Удали его, и снова проверь.
sudo apt purge libpq5
sudo apt update
sudo apt autoremove
sudo apt search libpq5
Выхлоп терминала сюда выложи, только заключи его в тег кода - символ решетки на панели форматирования текста

Спасибо огромное все встало
« Последнее редактирование: 16 Июнь 2019, 23:03:27 от penapisemnet »
 

Теги: libpq-dev 
 

AMD Phenom II X6 1100T Black / FX-8150 : проблема выбора

Автор Alexey_F

Ответов: 0
Просмотров: 1889
Последний ответ 04 Декабрь 2011, 04:37:01
от Alexey_F
Проблема с руским языком Knoppix 7.6

Автор Grig96

Ответов: 6
Просмотров: 2514
Последний ответ 11 Июль 2016, 19:55:27
от Grig96
Проблема с USB.

Автор 99942

Ответов: 3
Просмотров: 1016
Последний ответ 25 Октябрь 2017, 12:57:18
от sidbar
Проблема с установкой библиотек

Автор КрастерПерегретый

Ответов: 10
Просмотров: 1117
Последний ответ 12 Декабрь 2019, 15:41:33
от КрастерПерегретый
Проблема со шрифтами

Автор Ferus

Ответов: 10
Просмотров: 2291
Последний ответ 05 Июнь 2014, 20:03:40
от vladimir_ar