Автор Тема: не могу установить программы  (Прочитано 1360 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн yr34

  • Новичок форума
  • Сообщений: 6
не могу установить программы
« : 10 Июля 2019, 23:11:16 »
доброе время суток, установил debian себе на пк, все классно работает, но есть проблема не могу установить прогу. Пытаюсь через bed- нет файла, через терминал- команда не найдена. помогите разобраться !!!!! 
« Последнее редактирование: 11 Июля 2019, 20:34:59 от yr34 »
 

Оффлайн sidbar

Re: новичок
« Ответ #1 : 11 Июля 2019, 01:33:41 »
установить прогу
Как называется?
Devuan GNU/Linux 4 Chimaera x86_64
 

Оффлайн G_r_i_g_a

Re: новичок
« Ответ #2 : 11 Июля 2019, 05:00:38 »
ерез терминал- команда не найдена. помогите разобраться
Что ты вводишь в терминале?
Пытаюсь через bed- нет файла
В обоих случаях одна причина - ты допускаешь ошибки при вводе команд. Даже deb умудрился неправильно написать. Линукс этого не прощает.
« Последнее редактирование: 11 Июля 2019, 05:02:11 от G_r_i_g_a »
 
Пользователи, которые поблагодарили этот пост: Gamliel

Оффлайн yoric

Re: новичок
« Ответ #3 : 11 Июля 2019, 05:53:15 »
ЗАбудьте пока про deb, почитайте про менеджер пакетов apt. И забудьте пока про левые программы.
 
Пользователи, которые поблагодарили этот пост: Gamliel

Оффлайн Листик

Re: новичок
« Ответ #4 : 11 Июля 2019, 06:49:48 »
Команда от пользователя с правами администратора должна быть (перед командой пишется su или sudo).
 
apt install название пакета

P.S.

sudo (рекомендуется) нужно сначала установить и настроить:

apt install sudo

После добавить себя в группу (тоже от суперпользователя)

usermod -a -G sudo вашеимявсистеме
« Последнее редактирование: 11 Июля 2019, 08:42:05 от Листик »
 

Оффлайн Листик

Re: новичок
« Ответ #5 : 11 Июля 2019, 06:52:11 »
Перед этим должен быть настроен sources list (список репозиториев).
 

Оффлайн qupl

Re: новичок
« Ответ #6 : 11 Июля 2019, 07:41:04 »
Исправьте название темы на более информативное или она отправится в корзину.
 
Пользователи, которые поблагодарили этот пост: Gamliel

Оффлайн yr34

  • Новичок форума
  • Сообщений: 6
Re: новичок
« Ответ #7 : 11 Июля 2019, 20:33:22 »
Не могу установить оперу, хром о более я пока и не думал.
Через приложение для установки прог  пробую не видит.
терминал то файла не видит, то команды 
 

Оффлайн yr34

  • Новичок форума
  • Сообщений: 6
Re: не могу установить программы
« Ответ #8 : 11 Июля 2019, 20:41:03 »
через sudo делаю и .... ничего , команда не найдена.
на ноутбуке стоит ubuntu  были танцы с бубном и всё получилось.
и извините за мою орфографию
 

Оффлайн Листик

Re: не могу установить программы
« Ответ #9 : 11 Июля 2019, 21:08:55 »
Для этих программ специальные репозитории нужны. Выкладывайте здесь свой sources list; команды, которые вводили; вывод (из терминала).

Чтобы проверить, есть ли в репозитории нужный пакет, можно предварительно ввести: apt-cache show имя пакета.
 

Оффлайн yr34

  • Новичок форума
  • Сообщений: 6
Re: не могу установить программы
« Ответ #10 : 11 Июля 2019, 21:49:35 »
$ wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
$ sudo dpkg -i google-chrome-stable_current_amd64.deb

потом пытался
 
 su -
 wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
 sudo dpkg -i google-chrome-stable_current_amd64.deb
 
может у меня проблема с настройками? или пробовать ещё через PPA
 

Оффлайн G_r_i_g_a

Re: не могу установить программы
« Ответ #11 : 11 Июля 2019, 22:07:24 »
может у меня проблема с настройками? или пробовать ещё через PPA
Ты сможешь выложить весь ответ терминала?
Предполагаю что у тебя нет ни wget, ни sudo.
Сделай так (вставляй построчно:)
su
apt install wget
wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
dpkg -i google-chrome-stable_current_amd64.deb

« Последнее редактирование: 11 Июля 2019, 22:13:41 от G_r_i_g_a »
 

Оффлайн yr34

  • Новичок форума
  • Сообщений: 6
Re: не могу установить программы
« Ответ #12 : 11 Июля 2019, 23:23:22 »
СПС помогло, были проблемы с зависимостями, мне еще много учить.
 

Оффлайн yr34

  • Новичок форума
  • Сообщений: 6
Re: не могу установить программы
« Ответ #13 : 11 Июля 2019, 23:26:46 »
и возникла куча новых вопросов о debian
 

Оффлайн Kato

Re: не могу установить программы
« Ответ #14 : 12 Июля 2019, 02:35:25 »
и возникла куча новых вопросов о debian
для каждого вопроса отдельная тема :)
 
Пользователи, которые поблагодарили этот пост: Gamliel

Теги:
     

    ati -fglrx не могу поставить

    Автор kroko

    Ответов: 21
    Просмотров: 5959
    Последний ответ 27 Февраля 2014, 15:01:47
    от kroko
    Не могу записать изменения в утилите rcconf в Debian 9

    Автор pavlar

    Ответов: 9
    Просмотров: 2668
    Последний ответ 11 Декабря 2018, 00:22:32
    от svtv1
    Jessie, не могу обновить 2 пакета

    Автор Selkup

    Ответов: 6
    Просмотров: 1805
    Последний ответ 20 Октября 2014, 07:48:40
    от Selkup
    Не могу записать файлы на флешку в EXT4 (Доспуп запрещен)

    Автор Винсент

    Ответов: 5
    Просмотров: 1573
    Последний ответ 28 Апреля 2020, 19:29:01
    от Винсент
    Не могу загрузиться.

    Автор nomad

    Ответов: 7
    Просмотров: 1516
    Последний ответ 14 Марта 2015, 19:46:31
    от vovan--vovan