Автор Тема: не удалось установить grub  (Прочитано 2830 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн n.pavka

не удалось установить grub
« : 05 Августа 2019, 20:48:06 »
Добрый день.
Возникла проблема с установкой Debian10 рядом с win10.

Как понимаю конфликт с uefi винды
imgonline-com-ua-Resize-xraJBIUkwblTHnK.jpg
imgonline-com-ua-Resize-65Ti3wOrtVyeEsi.jpg
« Последнее редактирование: 05 Августа 2019, 20:50:59 от n.pavka »
 

Оффлайн deb

Re: не удалось установить grub
« Ответ #1 : 06 Августа 2019, 04:57:40 »
Добрый день.
Возникла проблема с установкой Debian10 рядом с win10.
Как понимаю конфликт с uefi винды

Необязательно конфликт с uefi винды. Как-то при установке debian 9 на пустой диск была копия вашей проблемы. Решением стало отключение в биос поддержки совместимости CSM. В биос оставил только uefi. После этого установка системы прошла штатно.
Попробуйте, вдруг и вам поможет.
 

Оффлайн n.pavka

Re: не удалось установить grub
« Ответ #2 : 07 Августа 2019, 09:50:56 »
Добрый день.
Возникла проблема с установкой Debian10 рядом с win10.
Как понимаю конфликт с uefi винды

Необязательно конфликт с uefi винды. Как-то при установке debian 9 на пустой диск была копия вашей проблемы. Решением стало отключение в биос поддержки совместимости CSM. В биос оставил только uefi. После этого установка системы прошла штатно.
Попробуйте, вдруг и вам поможет.

Перевёл Биос в uefi, после перезагрузки ком стартует но зависает на стадии загрузки биоса. Ни del не F1 не работает. только ctri+alt+del
 
« Последнее редактирование: 07 Августа 2019, 09:53:21 от n.pavka »
 

Оффлайн deb

Re: не удалось установить grub
« Ответ #3 : 07 Августа 2019, 23:45:21 »
Здравствуйте.
Создайте загрузочную флешку с помощью Universal-USB-Installer или rufus. Загрузочный usb будет поддерживать загрузку в uefi.
И загрузитесь с него.

На моем компе два жестких диска один с разметкой gpt, второй с ms-dos. На первом установлена debian 10 с згрузчиком efi. На втором винда соответственно с mbr. Если я отключаю CSM, то загружается только debian. Параметр CSM предоставляет выбор загрузки той или иной ОС. Обычно жму на  f12.
Создайте флешку с дебиан, как написано выше. И попробуйте загрузиться.
"Перевёл Биос в uefi,". Что вы поменяли в биос, не помните?
"зависает на стадии загрузки биоса." На логотипе или до его появления? На экране что-нибудь написано?

p.s.
В качестве защиты от некорректных настроек биос предусмотрен сброс к заводским. Как это сделать узнайте на сайте производителя или из инструкции вашей мат.платы.
« Последнее редактирование: 08 Августа 2019, 08:20:51 от deb »
 

Оффлайн n.pavka

Re: не удалось установить grub
« Ответ #4 : 09 Августа 2019, 21:19:32 »
Здравствуйте.
Создайте загрузочную флешку с помощью Universal-USB-Installer или rufus. Загрузочный usb будет поддерживать загрузку в uefi.
И загрузитесь с него.

На моем компе два жестких диска один с разметкой gpt, второй с ms-dos. На первом установлена debian 10 с згрузчиком efi. На втором винда соответственно с mbr. Если я отключаю CSM, то загружается только debian. Параметр CSM предоставляет выбор загрузки той или иной ОС. Обычно жму на  f12.
Создайте флешку с дебиан, как написано выше. И попробуйте загрузиться.
"Перевёл Биос в uefi,". Что вы поменяли в биос, не помните?
"зависает на стадии загрузки биоса." На логотипе или до его появления? На экране что-нибудь написано?

p.s.
В качестве защиты от некорректных настроек биос предусмотрен сброс к заводским. Как это сделать узнайте на сайте производителя или из инструкции вашей мат.платы.
Добрый день. Биос стартует загружается логотип затем темный экран, система ищет агрузочныые сектора , затем через минуту стартует винда но экран как будто  работает как при сломанной видюхе(все в квадратиках).  Ниже фото настроек Биоса и фото старта загрузчика дебиан
Биос кстати запустился после его обнулиния (перемены перемычки)
« Последнее редактирование: 09 Августа 2019, 21:59:39 от n.pavka »
 

Оффлайн n.pavka

Re: не удалось установить grub
« Ответ #5 : 09 Августа 2019, 21:50:27 »
1
imgonline-com-ua-Resize-ZTx18Fe3LLiW2YHR.jpg
 

Оффлайн n.pavka

Re: не удалось установить grub
« Ответ #6 : 09 Августа 2019, 21:54:15 »
2
imgonline-com-ua-Resize-qA4xKuQfK316.jpg
 

Оффлайн deb

Re: не удалось установить grub
« Ответ #7 : 09 Августа 2019, 23:26:09 »
Добрый день. Биос стартует загружается логотип затем темный экран, система ищет агрузочныые сектора , затем через минуту стартует винда но экран как будто  работает как при сломанной видюхе(все в квадратиках).  Ниже фото настроек Биоса и фото старта загрузчика дебиан
Биос кстати запустился после его обнулиния (перемены перемычки)

Здравствуйте.
Относительно "винды в квадратиках":
У вас встроенная графика или дискретная видеокарта?
Вам нужно включить параметр вашего графического устройства.
Если у вас дискретная видеокарта, то этот параметр PCIe. А если у встроенная графика процессора, то другой параметр. У меня он IGFX. Моя материнка gigabyte.
В моей плате эта настройка находится в периферии "peripherals" --> выбор видеовыхода "initial display output". Далее выбор на IGFX или PCIe 1, PCIe 2.
« Последнее редактирование: 10 Августа 2019, 03:23:48 от deb »
 

Оффлайн n.pavka

Re: не удалось установить grub
« Ответ #8 : 22 Августа 2019, 09:08:55 »
Добрый день. Биос стартует загружается логотип затем темный экран, система ищет агрузочныые сектора , затем через минуту стартует винда но экран как будто  работает как при сломанной видюхе(все в квадратиках).  Ниже фото настроек Биоса и фото старта загрузчика дебиан
Биос кстати запустился после его обнулиния (перемены перемычки)

Здравствуйте.
Относительно "винды в квадратиках":
У вас встроенная графика или дискретная видеокарта?
Вам нужно включить параметр вашего графического устройства.
Если у вас дискретная видеокарта, то этот параметр PCIe. А если у встроенная графика процессора, то другой параметр. У меня он IGFX. Моя материнка gigabyte.
В моей плате эта настройка находится в периферии "peripherals" --> выбор видеовыхода "initial display output". Далее выбор на IGFX или PCIe 1, PCIe 2.

Не помогло, менял настройки по графике. Все равно виснет. Думаю может что с БИОС .
Вот что нашел в http://www.cyberforum.ru/motherboards/thread2464573.html
цитирую:
" Нашел таки похожий запрос, короче тут возможная проблема в биосе, видюха просто не совместима в EFI режиме и надо обновлять биос на более новый, но самый новый и так стоит (06/06/2012) и более не предвидится.
Касательно сдвоенного режима UEFI+Legacy то на моей плате просто нет такого или одно, или другое.
Впрочем, при переключении в EFI Compatible ROM, новых пунктов не появляется, и нет CSM, вывод, пока так, а там замена на что-то поновее, когда будет возможность ессно.
"
« Последнее редактирование: 22 Августа 2019, 11:39:34 от n.pavka »
 

Оффлайн deb

Re: не удалось установить grub
« Ответ #9 : 23 Августа 2019, 20:12:29 »
Не помогло, менял настройки по графике. Все равно виснет. Думаю может что с БИОС .

Здравствуйте.
"Что делать, если после сброса настроек BIOS/UEFI компьютер не запускается":
ссылку удалил, какие-то проблемы с переходом.

Там  описывалось решение проблемы когда при сбросе биос диск определился как IDE вместо ACHI (SATA). И на оборот если ваш диск IDE.

« Последнее редактирование: 24 Августа 2019, 19:56:30 от deb »
 

Оффлайн n.pavka

Re: не удалось установить grub
« Ответ #10 : 26 Августа 2019, 09:59:35 »
Проблему решил.
Установил систему через Live CD. Разбил диск на разделы  в ручную, прописал точку монтирования boot/efi и флаг esp. И все заработало. Правда один минус у меня папка home в raid1. При установки с Live CD raid1 не определяет (видит только два диска), а вот при "обычной" установке видны два диска и и пункт что они в рейде. Теперь ломаю голову как вернуть старую паку home 
 

Оффлайн deb

Re: не удалось установить grub
« Ответ #11 : 27 Августа 2019, 01:48:08 »
пункт что они в рейде.

Здравствуйте.

Отключение RAID:
http://kak-otvet.imysite.ru/3268_kak_vyklyuchit_raid.htm
И на всякий случай посмотрите параметр OnChip Serial ATA. Для отключения контроллера должно быть значение SATA.

Советуют перед отключением RAID создать резервную копию всех данных на диске.
Возможно придется ос переустановить.
Сам с такой проблемой не сталкивался.

Решение за вами.
« Последнее редактирование: 27 Августа 2019, 02:08:34 от deb »
 

Теги:
     

    [Решено]Не удалось установить grub-pc в /target

    Автор JoePass

    Ответов: 2
    Просмотров: 30263
    Последний ответ 15 Апреля 2012, 15:58:55
    от JoePass
    не удалось установить grub

    Автор Ao-Lie

    Ответов: 1
    Просмотров: 2063
    Последний ответ 31 Мая 2016, 16:26:03
    от vadd