a2ensite не найден

Автор batan, 11 августа 2019, 21:40:53

« назад - далее »

0 Пользователи и 2 гостей просматривают эту тему.

batan

Товарищи человеки, вроди не первый раз устанавливаю LAMP, но столкнулся с проблемой в самом неожиданном месте. В общем после установки Debian 10 установил Apache, php, MariaDB, всё вроди как работает, всё крутится. Но при попытке добавить сайт - получаю ошибку:
root@QbPk: # a2ensite qb.conf
bash: a2ensite: команда не найдена


Собственно установка была как обычно:
apt install apache2
apt install mariadb-server
apt install php libapache2-mod-php php-mysql


Сам Apache работает, phpinfo страницу выдаёт без проблем:
Открыть содержимое (спойлер)
[свернуть]

Весь вечер гуглю, единственное, что нашёл - это на каком то форуме упоминалось, что установка этого пакета должна решить проблему: https://packages.debian.org/jessie/apache2.2-common
Но при попытке установки получаю ошибку:
root@QbPk: # apt install apache2.2-common
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Пакет apache2.2-common недоступен, но упомянут в списке зависимостей другого
пакета. Это может означать, что пакет отсутствует, устарел или
доступен из источников, не упомянутых в sources.list
Однако следующие пакеты могут его заменить:
  apache2

E: Для пакета «apache2.2-common» не найден кандидат на установку


sources.list у меня с основного сервера Debian, сомневаюсь, что пакета там может не быть (да, я выполнял update), а apache2 уже установлен. В общем уже глаз начал дёргаться от этой  :-[, может подскажете, что ещё может быть?
  •  

endru


ecc83

#2
Покажи вывод:

ls /usr/sbin | grep a2

cat /etc/environment


Вместо команды команды a2ensite попробуй команду a2enmod


  •  

ogost

надо войти под рутом командой
su - root
не?

batan

Цитата: ecc83 от 12 августа 2019, 07:06:35
Покажи вывод:

ls /usr/sbin | grep a2

cat /etc/environment


Вместо команды команды a2ensite попробуй команду a2enmod




пробовал a2enmod, результат аналогичен, команда не найдена.

ls /usr/sbin | grep a2:
a2disconf
a2dismod
a2dissite
a2enconf
a2enmod
a2ensite
a2query


А вот файл /etc/environment имеет размер 0 байт...
  •  

batan

Цитата: ogost от 12 августа 2019, 09:47:10
надо войти под рутом командой
su - root
не?

Спасибо тебе, добрый человек! Прокатило, проблема решена!  ;D
  •  

ecc83

Странно. Вроде же под рутом сначала тоже запускал:

Цитировать
root@QbPk: # a2ensite qb.conf
bash: a2ensite: команда не найдена
  •  

qupl

Цитата: ecc83 от 12 августа 2019, 18:25:44Странно. Вроде же под рутом сначала тоже запускал:
Какая разница?
Уже 10-ая тема и народ никак не поймет, что переменные окружения могут быть разными и для одного пользователя.
Достаточно запомнить, что абсолютные пути всегда верны и тогда "проблемы" как бы и не существует.

batan

Цитата: qupl от 12 августа 2019, 18:35:18
Какая разница?
Уже 10-ая тема и народ никак не поймет, что переменные окружения могут быть разными и для одного пользователя.
Достаточно запомнить, что абсолютные пути всегда верны и тогда "проблемы" как бы и не существует.
Вроди не первый раз устанавливаю и раньше на подобные грабли не наступал...
Сочту это как +1 в копилку знаний)
  •  

ecc83

Цитата: qupl от 12 августа 2019, 18:35:18Уже 10-ая тема и народ никак не поймет, что переменные окружения могут быть разными и для одного пользователя.

Сообщение автора №1
Он запускает команду от root и "команда не найдена".


Сообщение автора №5
Он запускает ту же команду от root и "проблема решена".

Если мне одному это кажется странным, то я переживу :)
  •  

qupl

Цитата: ecc83 от 12 августа 2019, 19:26:37Если мне одному это кажется странным, то я переживу :)
да