Автор Тема: Нет звука на виртуальной машине  (Прочитано 2308 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mark-v

  • Пользователь
  • *
  • Сообщений: 41
Нет звука на виртуальной машине
« : 30 Октября 2019, 02:21:03 »
Debian GNU/Linux 10 (buster). При проверке динамиков тишина. Аппаратная проблема исключена, поскольку стоит на виртуальной машине и на других виртуальных машинах звук есть. В каком направлении копать?
 

Оффлайн Gamliel

Re: Нет звука на виртуальной машине
« Ответ #1 : 30 Октября 2019, 05:55:39 »
Может быть, ошибка в настройках виртуальной машины?

Гамлиэль Фишкин, Linux user since 2009
⮫ Личный     веб-сайт Гамлиэля Фишкина — https://fishk.in/ru/
⮫ Личный гофер-сайт Гамлиэля Фишкина — gopher://eyeblea.ch/1/~gamliel/ru/
 

Оффлайн sidbar

Re: Нет звука на виртуальной машине
« Ответ #2 : 30 Октября 2019, 19:37:38 »
В каком направлении копать?
Проверить подцепился драйвер или нет. Проверить настройки вывода в микшере.
Devuan GNU/Linux 4 Chimaera x86_64
 

Оффлайн mark-v

  • Пользователь
  • *
  • Сообщений: 41
Re: Нет звука на виртуальной машине
« Ответ #3 : 30 Октября 2019, 23:36:15 »
Проверить подцепился драйвер или нет
Как?
 

Оффлайн mark-v

  • Пользователь
  • *
  • Сообщений: 41
Re: Нет звука на виртуальной машине
« Ответ #4 : 30 Октября 2019, 23:55:44 »
Может быть, ошибка в настройках виртуальной машины?
Где там может быть ошибка?
 

Оффлайн Whowka

Re: Нет звука на виртуальной машине
« Ответ #5 : 30 Октября 2019, 23:57:42 »
Как?
Копать в указанном направлении ;)
 

Оффлайн mark-v

  • Пользователь
  • *
  • Сообщений: 41
Re: Нет звука на виртуальной машине
« Ответ #6 : 31 Октября 2019, 00:31:34 »
Копать в указанном направлении
Каким образом?
 

Оффлайн sidbar

Re: Нет звука на виртуальной машине
« Ответ #7 : 31 Октября 2019, 01:04:37 »
Проверить подцепился драйвер или нет
Как?
sudo lspci -knn
Devuan GNU/Linux 4 Chimaera x86_64
 

Оффлайн mark-v

  • Пользователь
  • *
  • Сообщений: 41
Re: Нет звука на виртуальной машине
« Ответ #8 : 31 Октября 2019, 02:04:05 »
sudo lspci -knn
$ sudo lspci -knn
[sudo] пароль для user:
00:00.0 Host bridge [0600]: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge [8086:7190] (rev 01)
Subsystem: VMware Virtual Machine Chipset [15ad:1976]
Kernel driver in use: agpgart-intel
00:01.0 PCI bridge [0604]: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge [8086:7191] (rev 01)
00:07.0 ISA bridge [0601]: Intel Corporation 82371AB/EB/MB PIIX4 ISA [8086:7110] (rev 08)
Subsystem: VMware Virtual Machine Chipset [15ad:1976]
00:07.1 IDE interface [0101]: Intel Corporation 82371AB/EB/MB PIIX4 IDE [8086:7111] (rev 01)
Subsystem: VMware Virtual Machine Chipset [15ad:1976]
Kernel driver in use: ata_piix
Kernel modules: ata_piix, ata_generic
00:07.3 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 08)
Subsystem: VMware Virtual Machine Chipset [15ad:1976]
Kernel modules: i2c_piix4
00:07.7 System peripheral [0880]: VMware Virtual Machine Communication Interface [15ad:0740] (rev 10)
Subsystem: VMware Virtual Machine Communication Interface [15ad:0740]
Kernel driver in use: vmw_vmci
Kernel modules: vmw_vmci
00:0f.0 VGA compatible controller [0300]: VMware SVGA II Adapter [15ad:0405]
Subsystem: VMware SVGA II Adapter [15ad:0405]
Kernel driver in use: vmwgfx
Kernel modules: vmwgfx
00:10.0 SCSI storage controller [0100]: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI [1000:0030] (rev 01)
Subsystem: VMware LSI Logic Parallel SCSI Controller [15ad:1976]
Kernel driver in use: mptspi
Kernel modules: mptspi
00:11.0 PCI bridge [0604]: VMware PCI bridge [15ad:0790] (rev 02)
00:15.0 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:15.1 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:15.2 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:15.3 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:15.4 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:15.5 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:15.6 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:15.7 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:16.0 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:16.1 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:16.2 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:16.3 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:16.4 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:16.5 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:16.6 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:16.7 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:17.0 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:17.1 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:17.2 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:17.3 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:17.4 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:17.5 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:17.6 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:17.7 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:18.0 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:18.1 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:18.2 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:18.3 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:18.4 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:18.5 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:18.6 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
00:18.7 PCI bridge [0604]: VMware PCI Express Root Port [15ad:07a0] (rev 01)
Kernel driver in use: pcieport
02:00.0 USB controller [0c03]: VMware USB1.1 UHCI Controller [15ad:0774]
Subsystem: VMware USB1.1 UHCI Controller [15ad:1976]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
02:01.0 Ethernet controller [0200]: Intel Corporation 82545EM Gigabit Ethernet Controller (Copper) [8086:100f] (rev 01)
Subsystem: VMware PRO/1000 MT Single Port Adapter [15ad:0750]
Kernel driver in use: e1000
Kernel modules: e1000
02:02.0 Multimedia audio controller [0401]: Ensoniq ES1371/ES1373 / Creative Labs CT2518 [1274:1371] (rev 02)
Subsystem: Ensoniq Audio PCI 64V/128/5200 / Creative CT4810/CT5803/CT5806 [Sound Blaster PCI] [1274:1371]
Kernel driver in use: snd_ens1371
Kernel modules: snd_ens1371
02:03.0 USB controller [0c03]: VMware USB2 EHCI Controller [15ad:0770]
Subsystem: VMware USB2 EHCI Controller [15ad:0770]
Kernel driver in use: ehci-pci
Kernel modules: ehci_pci
 

Онлайн ogost

Re: Нет звука на виртуальной машине
« Ответ #9 : 31 Октября 2019, 07:03:15 »
Если установлен pavucontrol, то проверить настройки/ползунки.
Если не установлен - проверить то же самое в alsamixer.
Если оба не установлены - установить одно из двух. Где моя лодка?

Оффлайн mark-v

  • Пользователь
  • *
  • Сообщений: 41
Re: Нет звука на виртуальной машине
« Ответ #10 : 31 Октября 2019, 22:18:01 »
проверить настройки/ползунки

* Снимок экрана от 2019-10-31 22-16-44.png (Filesize: 83.16 КБ, Dimensions: 2300x1096)

Цитировать
проверить то же самое в alsamixer.

* Снимок экрана от 2019-10-31 22-21-05.png (Filesize: 79.36 КБ, Dimensions: 1468x1222)
« Последнее редактирование: 31 Октября 2019, 22:23:01 от mark-v »
 

Оффлайн mark-v

  • Пользователь
  • *
  • Сообщений: 41
Re: Нет звука на виртуальной машине
« Ответ #11 : 01 Ноября 2019, 03:40:03 »
Заметил одну особенность. Сразу после перезагрузки звук присутствует. Но стоит зайти в параметры звука, как выдается сообщение об ошибке: The default sound device cannot be opened: Undefined external error. И после этого звук пропадает. Это всплывающее сообщение VMWare
 

Теги:
     

    После установки/удаления cairo-dock нет звука (Решено)

    Автор alastor

    Ответов: 4
    Просмотров: 2491
    Последний ответ 30 Октября 2013, 11:49:40
    от alastor
    Настройка звука.

    Автор Sergey

    Ответов: 2
    Просмотров: 2138
    Последний ответ 07 Января 2019, 14:20:06
    от Sergey
    При записи на диск громкость звука увеличивается до максимума

    Автор Лесьяр

    Ответов: 3
    Просмотров: 1963
    Последний ответ 12 Сентября 2014, 14:31:07
    от Лесьяр
    Качество звука, pulse & SoX

    Автор Modigar

    Ответов: 4
    Просмотров: 607
    Последний ответ 14 Декабря 2020, 10:20:24
    от Modigar
    настройка одновременного вывода звука с нескольких программ

    Автор SeHELLioN

    Ответов: 4
    Просмотров: 2288
    Последний ответ 30 Мая 2011, 17:58:18
    от SeHELLioN