ошибка при установке yEd Grath Editor

Автор draccar, 05 ноября 2019, 18:37:32

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

draccar

Здравствуйте!
Прошу помощи у знатоков Дебиан.
Debian 10, пытаюсь обходиться без Винды. Юзер я вроде опытный (в Винде), но, как выясняется, не очень.
очень нужно установить программу для создания диаграмм. Поиском нашел yEd. Симпатичные диаграммы на картинках, заказчику должны понравиться. И вот, в предвкушении красоты на диаграммах, скачиваю пакет, разными способами пытаюсь его установить (прошу не ржать, я юзер виндоус так-то, в линуксе читаю и в Интернете ищу), каким-то образом инсталляция запускается, но ...Could not display the GUI. This application needs access to an X Server
а теперь и вообще не могу вспомнить, какой же командой я запускал эту гребаную инсталляцию, так как терминал закрыл, а при попытке использовать сохраненные в памяти команды,  инсталляция не запускается...воот...и беда эта уже несколько часов как...а роскоши неделю искать ответ нету. какая вообще логика решения? поиск по всяким результатам поиска выдал причину, что конфликтуют 64-разрядная операционка и какие-то 32-битные библиотеки. Но мне это как медведю калькулятор...
  •  

Modigar

скачал yEd-3.19.1.1_with-JRE13_64-bit_setup.sh выставил ему права на выполнение
запустил, указал путь, куда он распакуется и установится, он установился в указанной папке появился исполняемый файл "yEd"
2 клика по нему в "проводнике" (в моем случае это Долфин, и запустилось все.
Виндоподход в абсолюте, и рутовых прав не надо.
  •  
    Users thanked this post: draccar

draccar

#2
Так не получалось. Это был один из вариантов. При запуске по умолчанию открывает в текстовом редакторе, поэтому открывал в центре приложений, получил ответ "не удалось установить файл:не поддерживается". Права на выполнение галочкой установлены. Вот скопировал:


root@123:/home/123/Загрузки# sudo sh yEd-3.19.1.1_with-JRE13_64-bit_setup.sh
Unpacking JRE ...
Starting Installer ...
No protocol specified
Could not display the GUI. This application needs access to an X Server.
root@123:/home/123/Загрузки#
  •  

draccar

Установил. Благодаря этому форуму. Не из-под рута пошла инсталляция! Как я рад! Полвечера убил! Подсказка в ответе пользователя kobzar
Искренне благодарен!
  •  

draccar

#4
 [attach=1,msg116657]


Вот что значит виндовое мышление. Как может приложение не запуститься под рутом, а запуститься под юзером!
  •  

Gamliel

Цитата: draccar от 05 ноября 2019, 20:51:01Установил.
Рад, что всё получилось. На всякий случай посмотри́те ещё одну программу: редактор диаграмм Dia.

«Dia – редактор диаграмм, графиков, схем и т.д. Есть поддержка диаграмм статических структур UML (диаграммы классов), диаграмм отношений, сетевых диаграмм и многих других. Возможен экспорт в postscript и многие другие форматы». Несколько скриншотов.

Установка:
sudo apt-get install dia dia-shapes

Удаление:
sudo apt-get remove dia dia-shapes
sudo apt-get autoremove
  •  
    Users thanked this post: draccar

draccar

Dia загрузил. Забавный факт -- диаграммы, которые уже создал в yed, dia не может открыть - форматы разные!
  •  

Gamliel

Цитата: draccar от 08 ноября 2019, 18:44:22Dia загрузил. Забавный факт -- диаграммы, которые уже создал в yed, dia не может открыть - форматы разные!
А наоборот? Или каждый из них поддерживает только по одному формату?

draccar

В yed есть экспорт в разные типы файлов. Уже смотрел -- там все основные есть, таким образом, предполагаю, и в dia можно будет перекинуть файлик. Не читается лишь формат по умолчанию.
  •