Как установить Viber на компьютер с Debian 10.2

Автор n0m4d, 22 ноября 2019, 00:34:24

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

n0m4d

Сперва скачиваем с сайта VIBER https://www.viber.com/ru/download/, к сожалению он только убунту, но что делать, нужен. При попытки установке разумеется возникает неразрешённая зависимость в виде файла libssl1.0.0, а он был замечен в Дебиане 8.
В /etc/apt/sources.list на всякий случай добавляем строки для stretch и jessie в конец, чтоб потом задокументировать, на всякие пожарные.

nano /etc/apt/sources.list


deb http://ftp.se.debian.org/debian/ jessie main contrib non-free
deb http://ftp.se.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free


После сохранения и делаем
apt update
apt install libssl1.0.0


Не забываем после поправить файл /etc/apt/sources.list.
После всех этих манипуляций Вайбер встаёт, вот только при входе на вопрос используете ли вы его на мобильном кнопки да и нет не активны, после нажатия нижних ссылок кнопки стали активны и он заработал в полую силу.
Telegram - конференция: https://t.me/DebianForumRu

Udachnik


Ogis1975

Цитата: n0m4d от 22 ноября 2019, 00:34:24В /etc/apt/sources.list на всякий случай добавляем строки для stretch и jessie в конец,
И имеем фиг знает что, только не Debian 10...

endru

Цитата: n0m4d от 22 ноября 2019, 00:34:24В /etc/apt/sources.list на всякий случай добавляем строки для stretch и jessie в конец, чтоб потом задокументировать, на всякие пожарные.
Что мешает скачать конкретно этот пакет через браузер? Зачем выкачивать старые репозитории чтобы поставить 1 маленький пакет?

Butch

#4
Устанавливаем multiarch-support
sudo apt install multiarch-support

Скачиваем и устанавливаем пакет libssl1.0.0_1.0.1t-1+deb8u12_amd64.deb: wget http://security.debian.org/debian-security/pool/updates/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u12_amd64.deb && sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u12_amd64.deb

Скачиваем и устанавливаем вИбер: wget https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb && sudo dpkg -i viber.deb

PROFIT



debianforum@conference.jabber.ru

Veritas Vestas

Butch,

Цитата: Butch от 04 января 2020, 22:15:29Устанавливаем multiarch-support

А разве это обязательно? Там же есть библиотека как для x64, так и для x86. Можно просто выбрать нужную.

Gamliel

Раз уж подняли ноябрьскую тему... Полагаю, главный вопрос не «как», а «зачем». Viber'у есть немало альтернатив.
apt-cache show telegram-desktop revolt qtox | less
(читайте, сюда копировать не надо) — это то, что есть в официальном репозитории.

А прежде чем подключать сторонние репозитории, советую прочитать статью «Совет новым пользователям, как не сломать их Debian-систему» (на английском, испанском, каталанском и французском языках; русской версии пока нет). Под спойлером небольшая цитата оттуда (в моём переводе с английского).
Открыть содержимое (спойлер)
Debian — крепкая и надёжная система, но новым пользователям всё же легко сломать их системы, поступая не Debian-овским способом... Одним из важнейших преимуществ Debian'а является его центральный репозиторий с тысячами пакетов программного обеспечения. Если вы перешли на Debian с другой операционной системы, вы, возможно, привыкли устанавливать программное обеспечение, которое вы нашли на случайных веб-сайтах. В Debian'е установка программного обеспечения со случайных веб-сайтов является плохой привычкой. Лучше использовать программное обеспечение из официальных репозиториев Debian'а всегда, когда это возможно. Пакеты в репозиториях Debian'а хорошо работают и правильно устанавливаются. Использование программного обеспечения только из репозиториев Debian'а также намного безопаснее, чем установка со случайных веб-сайтов, которые могут нести с собой вредоносные программы и другие риски для безопасности.
[свернуть]

lyalyoman

#7
Debian 10.5 buster xfce,  у меня вот так работает:
   
   sudo apt-get install multiarch-support
   wget http://security.debian.org/debian-security/pool/updates/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u12_amd64.deb
   sudo dpkg -i *.deb
   wget https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb
   sudo dpkg -i *.deb
   sudo apt-get install qt5ct

qwertKI

Цитата: n0m4d от 22 ноября 2019, 00:34:24В /etc/apt/sources.list на всякий случай добавляем строки для stretch и jessie в конец, чтоб потом задокументировать, на всякие пожарные.

... лучше сразу винду поставте там тоже 10-ка
Я знаю только то, что ничего не знаю ...

ek-nfn

Цитата: Gamliel от 02 февраля 2020, 01:52:58Полагаю, главный вопрос не «как», а «зачем». Viber'у есть немало альтернатив.

В таких делах альтернатив, как правило, не существует -выбирают тот софт, где сидит общность людей, к которой и хочешь подключиться. Как к этому коллективу подключиться через альтернативу где его нет ?
Debian 11 xfce

Gamliel

Цитата: ek-nfn от 15 августа 2020, 10:41:01В таких делах альтернатив, как правило, не существует -выбирают тот софт, где сидит общность людей, к которой и хочешь подключиться. Как к этому коллективу подключиться через альтернативу где его нет ?
Бывает ситуация, когда заставляют (государство или работодатель) — тогда действительно нет выбора. Точно также ребёнок лишён возможности выбирать круг общения: с кем он оказался в одном детском саду и далее в одной школе, с теми он и вынужден общаться. И если умный ребёнок оказывается помещён в среду детей сколь глупых, столь агрессивных, то ему ради своей безопасности (негарантированной) приходится притворяться дураком. Взрослый же человек сам выбирает круг общения (помимо случаев принуждения со стороны государства и работодателя).

Меня порой зовут в Skype, Viber и WhatsApp. Я отвечаю, что не использую их. «Человек благоразумный подстраивается под окружающий мир, тогда как безрассудный упорно подстраивает этот мир под самого́ себя. Так что весь прогресс движут вперёд люди безрассудные» (Джордж Бернард Шоу; The reasonable man adapts himself to the world: the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man).

ek-nfn

#11
Цитата: Gamliel от 16 августа 2020, 04:30:53Меня порой зовут в Skype, Viber и WhatsApp. Я отвечаю, что не использую их.

А я делаю ровно наоборот, так как основной задачей любого средства коммуникаций считаю возможность контакта с теми, ради чего оно и приобретается. Поэтому на первом месте возможность удобно и быстро иметь выход на нужных людей, а выбор софта уже второстепенен. Мне зачем софт, который я не смогу использовать для решения своих основных задач? Для понтов? Поэтому альтернативой может служить лишь тот софт, который дает возможность более удобно решать мою основную задачу, а не простаивать по причине отсутствия в нем нужных мне контактов.
Debian 11 xfce

Vasiliy

#12
Приветствую. Скачал viber с оф.сайта (оказался только для ubuntu), установил через установщик пакетов, но viber не запускается, при этом, в установщике не было сообщений об неудовлетворенных зависимостях. Попытался запустить viber через терминал, но пишет, что нет такой команды!

ferum


[Desktop Entry]
Name=Viber
Comment=Viber VoIP and messenger
Exec=/opt/viber/Viber %u
Icon=/usr/share/pixmaps/viber.png
Terminal=false
Type=Application
Categories=Network;InstantMessaging;P2P;
MimeType=x-scheme-handler/viber;

Русские дебианщики против цифрового слабоумия !

Vasiliy

#14
Цитата: ferum от 03 января 2022, 16:09:08[Desktop Entry]
Name=Viber
Comment=Viber VoIP and messenger
Exec=/opt/viber/Viber %u
Icon=/usr/share/pixmaps/viber.png
Terminal=false
Type=Application
Categories=Network;InstantMessaging;P2P;
MimeType=x-scheme-handler/viber;
простите, не нашел где это надо изменить? Это конфиг вайбера? Возможно это qt.conf в /opt/viber или в /opt/viber/libexec? Попробую добавить эту секцию...