Автор Тема: Не работает обновление  (Прочитано 1223 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн simonflex

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 210
  • Bullseye x64 SID GNU XFCE
Не работает обновление
« : 09 Январь 2020, 09:59:48 »
Всем доброго времени суток.
Помогите вернуть в нормальный режим. Стояла Debian Stretch, 9мес назад имел неосторожность с раннего утра неверно настроил pin после чего ОС стала sid . Но все это работало просто отлично без каких-то либо отказов. Вчера решил обновить ntopng, ругалась по зависимостям, после чего вход пошел aptitude, после update, перезапуск так как что-то было не все ок. После делал это:
Debian 9 (stretch)
wget http://apt.ntop.org/stretch/all/apt-ntop.deb
apt install ./apt-ntop.deb
После apt update. Короче пришел к тому что какой-то небольшой пи***ц пришел.                                                                                                                       
Ошб:1 http://repo.vivaldi.com/stable/deb stable InRelease                                                                                                               
  Не удалось разрешить «repo.vivaldi.com»                                                                                                                               
Ошб:2 http://security.debian.org/debian-security stretch/updates InRelease                                                                                             
  Не удалось разрешить «security.debian.org»                                                                                                                           
Ошб:3 https://download.docker.com/linux/debian stretch InRelease                                                                                                       
  Не удалось разрешить «download.docker.com»                                                                                                                           
Ошб:4 http://deb.debian.org/debian stretch InRelease                                                                                                                   
  Не удалось разрешить «deb.debian.org»                                                                                                                                 
Ошб:5 https://dl.winehq.org/wine-builds/debian stretch InRelease                                                                                                       
  Не удалось разрешить «dl.winehq.org»                                                                                                                                 
Ошб:6 http://deb.debian.org/debian stretch-updates InRelease                                                                                                           
  Не удалось разрешить «deb.debian.org»                                                                                                                                 
Ошб:7 http://deb.debian.org/debian unstable InRelease                                                                                                                   
  Не удалось разрешить «deb.debian.org»                                                                                                                                 
Чтение списков пакетов… Готово                                                                                                                                         
Построение дерева зависимостей                                                                                                                                         
Чтение информации о состоянии… Готово                                                                                                                                   
Может быть обновлено 14 пакетов. Запустите «apt list --upgradable» для их показа.                                                                                       
W: Не удалось получить http://deb.debian.org/debian/dists/stretch/InRelease  Не удалось разрешить «deb.debian.org»                                                     
W: Не удалось получить http://security.debian.org/debian-security/dists/stretch/updates/InRelease  Не удалось разрешить «security.debian.org»                           
W: Не удалось получить http://deb.debian.org/debian/dists/stretch-updates/InRelease  Не удалось разрешить «deb.debian.org»                                             
W: Не удалось получить https://dl.winehq.org/wine-builds/debian/dists/stretch/InRelease  Не удалось разрешить «dl.winehq.org»                                           
W: Не удалось получить https://download.docker.com/linux/debian/dists/stretch/InRelease  Не удалось разрешить «download.docker.com»                                     
W: Не удалось получить http://deb.debian.org/debian/dists/unstable/InRelease  Не удалось разрешить «deb.debian.org»                                                     
W: Не удалось получить http://repo.vivaldi.com/stable/deb/dists/stable/InRelease  Не удалось разрешить «repo.vivaldi.com»                                               
W: Некоторые индексные файлы скачать не удалось. Они были проигнорированы, или вместо них были использованы старые версии.
sources.listdeb http://deb.debian.org/debian/ stretch main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
#deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch-updates main

#wine
deb https://dl.winehq.org/wine-builds/debian/ stretch main

#i2p
#deb https://deb.i2p2.de/ stretch main

#Docker
deb [arch=amd64] https://download.docker.com/linux/debian stretch stable

update-initramfs: Generating /boot/initrd.img-5.4.0-2-amd64
W: Possible missing firmware /lib/firmware/i915/skl_dmc_ver1_27.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1_04.bin for module i915
W: Possible missing firmware /lib/firmware/i915/glk_dmc_ver1_04.bin for module i915
W: Possible missing firmware /lib/firmware/i915/cnl_dmc_ver1_07.bin for module i915
W: Possible missing firmware /lib/firmware/i915/icl_dmc_ver1_07.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_dmc_ver2_04.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_huc_ver01_07_1398.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_huc_ver01_8_2893.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_huc_ver02_00_1810.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/glk_huc_ver03_01_2893.bin for module i915
W: Possible missing firmware /lib/firmware/i915/glk_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_huc_ver02_00_1810.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/icl_huc_ver8_4_3238.bin for module i915
W: Possible missing firmware /lib/firmware/i915/icl_guc_33.0.0.bin for module i915
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_Gn4EyG/lib/modules/5.4.0-2-amd64/modules.builtin.bin'
Что делать в таком случае? С чего начать ремонт ?
« Последнее редактирование: 09 Январь 2020, 10:09:30 от simonflex »
Я всегда с пониманием оцениваю любую помощь !
 


Онлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 5012
  • memento mori
  • Jabber: qupl@jabber.ru
Re: Не работает обновление
« Ответ #1 : 09 Январь 2020, 10:11:16 »
Как обычно, с наведения порядка в sources.list

Оффлайн endru

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1983
  • Новосибирск
Re: Не работает обновление
« Ответ #2 : 09 Январь 2020, 10:34:29 »
Цитировать
Не удалось разрешить «deb.debian.org»
либо интернет либо DNS не работает.
 
Пользователи, которые поблагодарили этот пост: simonflex, Butch

Оффлайн simonflex

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 210
  • Bullseye x64 SID GNU XFCE
Re: Не работает обновление
« Ответ #3 : 09 Январь 2020, 11:34:30 »
либо интернет либо DNS не работает.
Да была косячина. После рестарта у меня resolv.conf происходит изменение на ipv6-dns. Сразу чет не догнал, очень редко делаю рестарт в 3-5 мес 1раз :)) подзабыл что да как работает. Пинг проверил есть, а резолв не проверил
Я всегда с пониманием оцениваю любую помощь !
 

Оффлайн simonflex

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 210
  • Bullseye x64 SID GNU XFCE
Re: Не работает обновление
« Ответ #4 : 09 Январь 2020, 11:54:58 »
Как обычно, с наведения порядка в sources.list
Подскажи пожалуста, а что в нем над еще сделать. До сегодняшнего дня ни на что внимания не обращал, год назад 17 января произвел установку, и все работает как автомат калашников. Это и есть плата Debian за любовь к нему :) Потому никуда не лез и не разбирался, установил и забыл. Если бы не полез разбираться с зависимостями то и еще год не знал бы проблем, хотя что-то было, даже и не помню.
/etc/apt/prefences.d/limit-unstablepackage: *\nPin: release a=unstable\nPin-Priority: 90\n/etc/apt/sources.list.d/unstable.listdeb http://deb.debian.org/debian/ unstable main
« Последнее редактирование: 09 Январь 2020, 11:59:34 от simonflex »
Я всегда с пониманием оцениваю любую помощь !
 

Онлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 5012
  • memento mori
  • Jabber: qupl@jabber.ru
Re: Не работает обновление
« Ответ #5 : 09 Январь 2020, 11:59:32 »
Не, если осмысленно добавлены разные stable / unstable / stretch, то проблем нет. Судя по выводу еще помимо основного списка есть файлы (vivaldi)

Оффлайн simonflex

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 210
  • Bullseye x64 SID GNU XFCE
Re: Не работает обновление
« Ответ #6 : 09 Январь 2020, 12:06:47 »
/etc/apt/sources.list.d/vivaldi.list
deb http://repo.vivaldi.com/stable/deb/ stable mainПосле как слегка разрешилась проблема с резолвом то подключил/etc/apt/sources.list.d/ntop.listdeb [arch=amd64] http://packages.ntop.org/apt/stretch x64/
#deb [arch=amd64] http://packages.ntop.org/stratch/ all/
ntopng вроде как встала 3.8 и запустилась
Я всегда с пониманием оцениваю любую помощь !
 

Оффлайн simonflex

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 210
  • Bullseye x64 SID GNU XFCE
Re: Не работает обновление
« Ответ #7 : 09 Январь 2020, 12:28:56 »
Не, если осмысленно добавлены разные stable / unstable / stretch, то проблем нет.
В том все и дело, что не совсем осмысленно. Когда-то давно добавил /etc/apt/prefences где что-то не так сделал. Подгонял чтоб предлагались свежие релизы на выбор, после чего обновился полностью unstable. щас его нет вообще /etc/apt/prefences но появился этот конфиг
/etc/apt/prefences.d/limit-unstable
package: *\nPin: release a=unstable\nPin-Priority: 90\n
и вот этот /etc/apt/sources.list.d/unstable.list и я думаю что это имеет более высокий приоритет, хз. Есть вопрос сюда надо добавить non-free contrib ?
deb http://deb.debian.org/debian/ unstable main
Я всегда с пониманием оцениваю любую помощь !
 

Оффлайн Gamliel

  • Гамлиэль Фишкин
  • Местный житель
  • ***
  • Сообщений: 162
  • Linux user since 2009
    • Гамлиэль Фишкин
  • Jabber: fishkin@jabber.ru
Re: Не работает обновление
« Ответ #8 : 09 Январь 2020, 21:20:27 »
Ошб:1 http://repo.vivaldi.com/stable/deb stable InRelease
  Не удалось разрешить «repo.vivaldi.com»
Ошб:2 http://security.debian.org/debian-security stretch/updates InRelease
  Не удалось разрешить «security.debian.org»
Ошб:3 https://download.docker.com/linux/debian stretch InRelease
  Не удалось разрешить «download.docker.com»
Ошб:4 http://deb.debian.org/debian stretch InRelease
  Не удалось разрешить «deb.debian.org»
Ошб:5 https://dl.winehq.org/wine-builds/debian stretch InRelease
  Не удалось разрешить «dl.winehq.org»
Ошб:6 http://deb.debian.org/debian stretch-updates InRelease
  Не удалось разрешить «deb.debian.org»
Ошб:7 http://deb.debian.org/debian unstable InRelease
  Не удалось разрешить «deb.debian.org»
Если это произошло при нормально работающей сети, то проблема лечится явным указанием серверов имён в файле /etc/network/interfaces.

У меня он выглядит примерно так:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto enp1s0
allow-hotplug enp1s0

# IPv4
iface enp1s0 inet dhcp
        address 192.168.1.33/24
        netmask 255.255.255.0
        gateway 192.168.1.1
        dns-nameserver 89.233.43.71
        dns-nameserver 192.168.1.1

# IPv6
iface enp1s0 inet6 dhcp
        address 1111:2222:3333:4444::/64
        netmask 64
        gateway 1111:2222:3333:4444:5555:6666:7777:8888
        dns-nameserver 2a01:3a0:53:53::
(цифры 1111:2222:3333:4444 и 5555:6666:7777:8888 условные, вместо настоящих; насколько я понимаю, если  IPv6 gateway  указать fe80::5555:6666:7777:8888, IPv6 будет работать только локально).
Можно и несколько по-другому; в частности, не dhcp, а static. Подробности в  man interfaces.
Я использую сервера́ имён от CensurfriDNS aka UncensoredDNS.

⮫ Личный веб-сайт Гамлиэля Фишкина — https://fishk.in/ru/
⮫ Личный гофер-сайт Гамлиэля Фишкина — gopher://eyeblea.ch/1/~gamliel/ru/
 

Теги: debian 
 

не полностью работает тачпад в sony vaio

Автор Kirra

Ответов: 5
Просмотров: 2058
Последний ответ 22 Апрель 2015, 09:21:45
от mikyman388
Не работает Skype

Автор DarkOrion

Ответов: 3
Просмотров: 2356
Последний ответ 22 Апрель 2013, 01:01:09
от DarkOrion
Без iBus не везде работает клавиатура

Автор AlexBezz

Ответов: 6
Просмотров: 3044
Последний ответ 01 Сентябрь 2017, 10:56:47
от qupl
Обновление системы

Автор Извращенец

Ответов: 21
Просмотров: 3250
Последний ответ 14 Март 2011, 17:14:00
от Максимыч
Автоматическое обновление Debian Desktop

Автор abrasum

Ответов: 25
Просмотров: 5238
Последний ответ 01 Ноябрь 2015, 18:42:16
от vacka