Автор Тема: Установка monodevelop .NET на debian 10  (Прочитано 2419 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Митяй675

  • Новичок форума
  • Сообщений: 4
Установка monodevelop .NET на debian 10
« : 16 Февраля 2020, 13:03:25 »
Всем доброго времени суток! Очень надеюсь на ВАШУ помощь!! Мучаюсь с этим уже несколько дней!!!!!

ДАНО:
Операционная система
Operating System: Debian GNU/Linux 10 (buster) ТУТ ВЕРСИЯ 10.3
Kernel: Linux 4.19.0-8-amd64
Architecture: x86-64

ЗАДАЧА: наладить веб-разработку ASP.NET в нашем DEBIAN при помощи monodevelop, apache, pgSQL. Т.е. установить эти компоненты.
___________________________________ ___________________________________ ___________________________________

Захожу на официальный сайт https://www.monodevelop.com/download...oad-lin-debian

Во вкладке Linux-Debian 10 нахожу необходимые команды и выполняю их в терминале от имени root:
sudo apt install apt-transport-https dirmngr
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D 831EF
echo "deb https://download.mono-project.com/repo/debian vs-buster main" | sudo tee /etc/apt/sources.list.d/mono-official-vs.list
sudo apt update
sudo apt-get install mono-complete

После чего выдаёт следующее!!!!! ???

Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
mono-complete : Зависит: mono-runtime (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: mono-runtime-sgen (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: mono-llvm-support (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: mono-utils (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: mono-devel (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: mono-mcs (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: mono-roslyn (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: mono-csharp-shell (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: mono-4.0-gac (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: mono-4.0-service (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: monodoc-base (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: monodoc-manual (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: libmono-cil-dev (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
Зависит: referenceassemblies-pcl но он не будет установлен
Зависит: msbuild но он не будет установлен
Зависит: ca-certificates-mono (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Что делать???? >:( >:( :o Уже пытался apt clean, apt -f install и прочее
Вот также нашёл сайт, но он также не помог (там ubuntu вроде) http://streletzcoder.ru/ustanovka-mo...elop-v-ubuntu/
ПОМОГИТЕ, ПОЖАЛУЙСТА!!!!! ОЧЕНЬ НУЖНО!!!! ОТБЛАГОДАРЮ!!
« Последнее редактирование: 16 Февраля 2020, 17:29:19 от Митяй675 »
 

Оффлайн Susumo

Re: УСТАНОВКА monodevelop .NET на debian 10
« Ответ #1 : 16 Февраля 2020, 13:42:31 »
Ммм.. А вы случаем не замечали что на том же сайте команда установки выглядит немого иначе? Synaptic данные пакеты находит? Попробуйте sudo apt install mono-complete или sudo apt install monodevelop
« Последнее редактирование: 16 Февраля 2020, 13:45:26 от Susumo »
 

Оффлайн ChubaDuba

Re: Установка monodevelop .NET на debian 10
« Ответ #2 : 16 Февраля 2020, 15:39:08 »
Содержимое /etc/apt/sources.list покажите.
Бλог   @chuba_duba
 

Оффлайн Митяй675

  • Новичок форума
  • Сообщений: 4
Re: УСТАНОВКА monodevelop .NET на debian 10
« Ответ #3 : 16 Февраля 2020, 16:32:08 »
Ммм.. А вы случаем не замечали что на том же сайте команда установки выглядит немого иначе? Synaptic данные пакеты находит? Попробуйте sudo apt install mono-complete или sudo apt install monodevelop

1) Synaptic у меня нет. Пробовал apt list --upgradable  без результата.
2) Вот ответ на sudo apt install mono-complete:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 mono-complete : Зависит: mono-runtime (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: mono-runtime-sgen (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: mono-llvm-support (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: mono-utils (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: mono-devel (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: mono-mcs (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: mono-roslyn (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: mono-csharp-shell (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: mono-4.0-gac (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: mono-4.0-service (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: monodoc-base (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: monodoc-manual (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: libmono-cil-dev (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
                 Зависит: referenceassemblies-pcl но он не будет установлен
                 Зависит: msbuild но он не будет установлен
                 Зависит: ca-certificates-mono (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

3)  А вот ответ на sudo apt install monodevelop:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 monodevelop : Зависит: pkg-config но он не может быть установлен
               Зависит: mono-runtime-sgen но он не будет установлен
               Зависит: fsharp но он не будет установлен
               Зависит: mono-runtime (>= 3.0~) но он не будет установлен
               Зависит: libfsharp-core4.5-cil (>= 4.5) но он не будет установлен
               Зависит: libglade2.0-cil (>= 2.12.45) но он не будет установлен
               Зависит: libglib2.0-cil (>= 2.12.45) но он не будет установлен
               Зависит: libgtk2.0-0 (>= 2.24.0) но он не может быть установлен
               Зависит: libgtk2.0-cil (>= 2.12.45) но он не будет установлен
               Зависит: libmono-cairo4.0-cil (>= 3.2.1) но он не будет установлен
               Зависит: libmono-corlib4.5-cil (>= 4.0.0~alpha1) но он не будет установлен
               Зависит: libmono-microsoft-csharp4.0-cil (>= 1.0) но он не будет установлен
               Зависит: libmono-microsoft-web-infrastructure1.0-cil (>= 1.0) но он не будет установлен
               Зависит: libmono-posix4.0-cil (>= 4.0.0~alpha1) но он не будет установлен
               Зависит: libmono-system-componentmodel-composition4.0-cil (>= 3.0.6) но он не будет установлен
               Зависит: libmono-system-componentmodel-dataannotations4.0-cil (>= 4.0.0~alpha1) но он не будет установлен
               Зависит: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) но он не будет установлен
               Зависит: libmono-system-core4.0-cil (>= 4.0.0~alpha1) но он не будет установлен
               Зависит: libmono-system-data-entity4.0-cil (>= 1.0) но он не будет установлен
               Зависит: libmono-system-data-linq4.0-cil (>= 1.0) но он не будет установлен
               Зависит: libmono-system-data4.0-cil (>= 4.0.0~alpha1) но он не будет установлен
               Зависит: libmono-system-design4.0-cil (>= 1.0) но он не будет установлен
               Зависит: libmono-system-drawing4.0-cil (>= 3.0.6) но он не будет установлен
               Зависит: libmono-system-identitymodel4.0-cil (>= 4.0.0~alpha1) но он не будет установлен
               Зависит: libmono-system-io-compression4.0-cil (>= 3.2.1) но он не будет установлен
               Зависит: libmono-system-net-http4.0-cil (>= 1.0) но он не будет установлен
               Зависит: libmono-system-numerics4.0-cil (>= 1.0) но он не будет установлен
               Зависит: libmono-system-runtime-caching4.0-cil (>= 4.0.0~alpha1) но он не будет установлен
               Зависит: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) но он не будет установлен
               Зависит: libmono-system-runtime4.0-cil (>= 2.10.1) но он не будет установлен
               Зависит: libmono-system-security4.0-cil (>= 1.0) но он не будет установлен
               Зависит: libmono-system-servicemodel4.0a-cil (>= 3.2.3) но он не будет установлен
               Зависит: libmono-system-web-extensions4.0-cil (>= 2.10.3) но он не будет установлен
               Зависит: libmono-system-web-services4.0-cil (>= 1.0) но он не будет установлен
               Зависит: libmono-system-web4.0-cil (>= 2.10.3) но он не будет установлен
               Зависит: libmono-system-windows-forms4.0-cil (>= 1.0) но он не будет установлен
               Зависит: libmono-system-xaml4.0-cil (>= 1.0) но он не будет установлен
               Зависит: libmono-system-xml-linq4.0-cil (>= 3.0.6) но он не будет установлен
               Зависит: libmono-system-xml4.0-cil (>= 3.12.0) но он не будет установлен
               Зависит: libmono-system4.0-cil (>= 4.0.0~alpha1) но он не будет установлен
               Зависит: libmono-windowsbase4.0-cil (>= 3.0.6) но он не будет установлен
               Зависит: monodoc-base (>= 3.2.1) но он не будет установлен
               Зависит: msbuild но он не будет установлен
               Рекомендует: libgtk2.0-cil-dev но он не будет установлен
               Рекомендует: mono-devel но он не будет установлен
               Рекомендует: xamarin-gtk-theme но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

4)ОБРАЩАЮ ВАШЕ ВНИМАНИЕ НА ТО, ЧТО операционную систему debian 10 я установил недавно и на голую систему на эту ставлю сейчас то, о чём идёт речь. Так что я могу немного не понимать, что нужно установить. Имейте ввиду, что система чистая, только что установленная.

5) Содержимое sourse.list на данный момент:
#

# deb cdrom:[Debian GNU/Linux 10.3.0 _Buster_ - Official amd64 DVD Binary-1 20200208-12:08]/ buster contrib main

#deb cdrom:[Debian GNU/Linux 10.3.0 _Buster_ - Official amd64 DVD Binary-1 20200208-12:08]/ buster contrib main

#deb http://security.debian.org/debian-security buster/updates main contrib
#deb-src http://security.debian.org/debian-security buster/updates main contrib
#deb [trusted=yes] file:/home/dmitry/Загрузки/gnome-icon-theme_3.12.0-3_all.deb
# buster-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
 deb http://deb.debian.org/debian/ buster-updates main contrib
 deb-src http://deb.debian.org/debian/ buster-updates main contrib

Coдержимое папки sourse.list.d:
- mono-official-vs.list:
deb https://download.mono-project.com/repo/debian buster main
-mono-xamarin.list:
deb http://download.mono-project.com/repo/debian wheezy main
deb http://download.mono-project.com/repo/debian wheezy-apache24-compat main
« Последнее редактирование: 16 Февраля 2020, 17:33:40 от Митяй675 »
 

Оффлайн Митяй675

  • Новичок форума
  • Сообщений: 4
Re: Установка monodevelop .NET на debian 10
« Ответ #4 : 16 Февраля 2020, 16:32:46 »
Содержимое /etc/apt/sources.list покажите.

CМОТРИТЕ ОТВЕТ ЧУТЬ ВЫШЕ!

КСТАТИ НА САЙТЕ deb https://download.mono-project.com/repo/debian
Не пускает в папку /Incoming, может это как-то поможет, но мне кажется, что проблема в репозиториях, а именно в их подключении.
« Последнее редактирование: 16 Февраля 2020, 16:38:26 от Митяй675 »
 

Оффлайн qupl

Re: Установка monodevelop .NET на debian 10
« Ответ #5 : 16 Февраля 2020, 16:39:46 »
Исправьте форматирование сообщений или тема будет закрыта.

Оффлайн ChubaDuba

Re: Установка monodevelop .NET на debian 10
« Ответ #6 : 16 Февраля 2020, 17:13:32 »
5) Содержимое sourse.list на данный момент:
#

# deb cdrom:[Debian GNU/Linux 10.3.0 _Buster_ - Official amd64 DVD Binary-1 20200208-12:08]/ buster contrib main

#deb cdrom:[Debian GNU/Linux 10.3.0 _Buster_ - Official amd64 DVD Binary-1 20200208-12:08]/ buster contrib main

#deb http://security.debian.org/debian-security buster/updates main contrib
#deb-src http://security.debian.org/debian-security buster/updates main contrib
#deb [trusted=yes] file:/home/dmitry/Загрузки/gnome-icon-theme_3.12.0-3_all.deb
# buster-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
 deb http://deb.debian.org/debian/ buster-updates main contrib
 deb-src http://deb.debian.org/debian/ buster-updates main contrib
так а где у вас главная ветка Main???
Добавьте:
deb http://deb.debian.org/debian buster main contrib non-free
Бλог   @chuba_duba
 

Оффлайн ferum

Re: Установка monodevelop .NET на debian 10
« Ответ #7 : 17 Февраля 2020, 09:59:14 »
мне кажется, что проблема в репозиториях, а именно в их подключении.
Мне тоже так кажется.
-mono-xamarin.list:
Код: [Выделить]
deb http://download.mono-project.com/repo/debian wheezy main
deb http://download.mono-project.com/repo/debian wheezy-apache24-compat main
При чём тут wheezy   когда в условии buster ?
Русские дебианщики против цифрового слабоумия !
 

Оффлайн qupl

Re: Установка monodevelop .NET на debian 10
« Ответ #8 : 17 Февраля 2020, 10:06:11 »
При чём тут wheezy   когда в условии buster ?
Именование веток в сторонних репозиториях еще тот зоопарк.

Оффлайн ferum

Re: Установка monodevelop .NET на debian 10
« Ответ #9 : 17 Февраля 2020, 10:44:40 »
Именование веток в сторонних репозиториях еще тот зоопарк
Там действительно от ночных сборок до типа релиза. В принципе раз есть исходники можно определиться со срезом и всё перелопатить, сделав что бы работало.... вот только нет уже былого энтузазизма....
Русские дебианщики против цифрового слабоумия !
 

Оффлайн mrgoodvin

Re: Установка monodevelop .NET на debian 10
« Ответ #10 : 17 Февраля 2020, 17:37:22 »
Проверьте доступные версии mono-complete, возможно конфликт зависимостей
apt search mono-complete"mono-runtime (= 6.8.0.105-0xamarin3+debian10b1) но он не будет установлен", такие же пакеты есть в дистрибутиве mono-complete/stable 5.18.0.240+dfsg-3, так же зависящий от mono-runtime/stable 5.18.0.240+dfsg-3.
Либо ставить текущую версии из дистрибутива (убрав deb https://download.mono-project.com/repo/debian vs-buster main или явно указав версию дистрибутива), либо повышать mono если получиться:
sudo apt-get install mono-complete=6.8.0.105-0xamarin3+debian10b1 -V
 

Теги:
 

установка пакетов

Автор Тхакур

Ответов: 14
Просмотров: 1970
Последний ответ 12 Августа 2018, 19:23:18
от Тхакур
Установка ZendFraemwork: проблемка с zf.sh!

Автор Babay

Ответов: 4
Просмотров: 1611
Последний ответ 24 Августа 2012, 22:53:19
от Babay
Установка Team viewer

Автор sky

Ответов: 2
Просмотров: 2410
Последний ответ 17 Июня 2019, 17:51:36
от sky
Установка nvidia драйвера

Автор user-k

Ответов: 4
Просмотров: 1721
Последний ответ 26 Января 2013, 10:50:12
от Brainey
установка пакетов

Автор surfer

Ответов: 15
Просмотров: 2650
Последний ответ 06 Июля 2019, 01:27:33
от lionet