Автор Тема: [Решено] Nvidia X Server не запускается на Intel+Nvidia  (Прочитано 2166 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн error_0x40

  • Новичок форума
  • Topic Author
  • Сообщений: 4
Nvidia X Server отказывается запускаться, хотя драйвера установлены.

Что пробовал и какой  результат:
  • Переустанавливал  драйвера - не помогает
  • Отключал Secure Boot - не запускался, так как не нашел wifi модуль(Intel 9560), теперь черный экран
  • прописывал вручную конфиг в xorg.conf - игнорируется
  • отключал свободный драйвер - при перезагрузке запуск с него
  • устанавливал Bumblebee - не загружается система

Model:    Lenovo IdeaPad S540-14IWL
CPU:    i5-8265u
GPU:    Intel UHD 620 + Nvidia MX250
Ram:    8 Gb
System: Debian 10(Linux debian 4.19.0-8-amd64 #1 SMP Debian 4.19.98-1 (2020-01-26) x86_64 GNU/Linux, актуальное состояние)
Bios: Secure Boot=Enable, Boot mode=UEFI
Video Drivers: 418.74-1 (установлен методом sudo apt-get install nvidia-driver)

/etc/X11/xorg.conf: ShowHide
Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver     "modesetting"
    Option     "AccelMethod" "none"
    BusID      "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID  "1:0:0"
    Option "AllowEmptyInitialConfiguration"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device     "nvidia"
    Option     "UseDisplayDevice" "none"
EndSection

вывод консоли: ShowHide
dima@debian:~$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2020-02-23 10:40:11 MSK; 26min ago
     Docs: man:systemd-modules-load.service(8 )
           man:modules-load.d(5)
  Process: 452 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 452 (code=exited, status=1/FAILURE)
=============================================================================================================================
dima@debian:~$ sudo journalctl -u systemd-modules-load.service
-- Logs begin at Sun 2020-02-23 10:40:10 MSK, end at Sun 2020-02-23 10:59:35 MSK. --
фев 23 10:40:10 debian systemd-modules-load[268]: Inserted module 'lp'
фев 23 10:40:10 debian systemd-modules-load[268]: Inserted module 'ppdev'
фев 23 10:40:10 debian systemd-modules-load[268]: Inserted module 'parport_pc'
фев 23 10:40:10 debian systemd-modules-load[268]: modprobe: ERROR: could not insert 'nvidia_current': Required key not availa
фев 23 10:40:10 debian systemd-modules-load[268]: modprobe: ERROR: ../libkmod/libkmod-module.c:979 command_do() Error running
фев 23 10:40:10 debian systemd-modules-load[268]: modprobe: ERROR: could not insert 'nvidia': Operation not permitted
фев 23 10:40:10 debian systemd-modules-load[268]: modprobe: ERROR: could not insert 'nvidia_current_modeset': Required key no
фев 23 10:40:10 debian systemd-modules-load[268]: modprobe: ERROR: ../libkmod/libkmod-module.c:979 command_do() Error running
фев 23 10:40:10 debian systemd-modules-load[268]: modprobe: ERROR: could not insert 'nvidia_modeset': Operation not permitted
фев 23 10:40:10 debian systemd-modules-load[268]: modprobe: ERROR: could not insert 'nvidia_current_drm': Required key not av
фев 23 10:40:10 debian systemd-modules-load[268]: Error running install command for nvidia_drm
фев 23 10:40:10 debian systemd-modules-load[268]: Failed to insert module 'nvidia_drm': Operation not permitted
фев 23 10:40:10 debian systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
фев 23 10:40:10 debian systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
фев 23 10:40:10 debian systemd[1]: Failed to start Load Kernel Modules.
фев 23 10:40:11 debian systemd[1]: Starting Load Kernel Modules...
фев 23 10:40:11 debian systemd-modules-load[452]: modprobe: ERROR: could not insert 'nvidia_current': Required key not availa
фев 23 10:40:11 debian systemd-modules-load[452]: modprobe: ERROR: ../libkmod/libkmod-module.c:979 command_do() Error running
фев 23 10:40:11 debian systemd-modules-load[452]: modprobe: ERROR: could not insert 'nvidia': Operation not permitted
фев 23 10:40:11 debian systemd-modules-load[452]: modprobe: ERROR: could not insert 'nvidia_current_modeset': Required key no
фев 23 10:40:11 debian systemd-modules-load[452]: modprobe: ERROR: ../libkmod/libkmod-module.c:979 command_do() Error running
фев 23 10:40:11 debian systemd-modules-load[452]: modprobe: ERROR: could not insert 'nvidia_modeset': Operation not permitted
фев 23 10:40:11 debian systemd-modules-load[452]: modprobe: ERROR: could not insert 'nvidia_current_drm': Required key not av
фев 23 10:40:11 debian systemd-modules-load[452]: Error running install command for nvidia_drm
фев 23 10:40:11 debian systemd-modules-load[452]: Failed to insert module 'nvidia_drm': Operation not permitted
фев 23 10:40:11 debian systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
фев 23 10:40:11 debian systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
фев 23 10:40:11 debian systemd[1]: Failed to start Load Kernel Modules.
=============================================================================================================================
dima@debian:~$ lspci | grep '3D\|VGA'
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (Whiskey Lake) (rev 02)
01:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX250] (rev a1)
=============================================================================================================================
dima@debian:~$ nvidia-settings

ERROR: Unable to find display on any available system
« Последнее редактирование: 28 Февраль 2020, 20:07:23 от error_0x40 »
 

Оффлайн Olej

  • Старожил
  • ****
  • Сообщений: 521
 
Пользователи, которые поблагодарили этот пост: error_0x40

Оффлайн error_0x40

  • Новичок форума
  • Topic Author
  • Сообщений: 4
Re: Nvidia X Server не запускается на Intel+Nvidia
« Ответ #2 : 23 Февраль 2020, 19:14:08 »
Вот ход моих действии:
  • Удалил полностью драйвера Nvidia
  • Перезагрзился, попутно в bios установил Secure boot=False
  • Нажал комбинацию ctl+alt+f3
  • Ввел команду init 3
  • Установил драйвера повторно Nvidia ( sudo apt-get install linux-headers-$(uname -r) nvidia-driver )
  • Перезагрузка и снова черный экран

Прикрепил лог Xorg
« Последнее редактирование: 23 Февраль 2020, 20:53:11 от error_0x40 »
 

Оффлайн error_0x40

  • Новичок форума
  • Topic Author
  • Сообщений: 4
Re: Nvidia X Server не запускается на Intel+Nvidia
« Ответ #3 : 28 Февраль 2020, 20:05:03 »
Решение найдено, выполнил согласно этой инструкции:
https://wiki.archlinux.org/index.php/NVIDIA_Optimus#No_screens_found_on_a_laptop/NVIDIA_Optimus
 

Теги: nvidia kernel 
 

[Решено]Как настроить не рабочий вывод звука HDMI

Автор Vacka

Ответов: 11
Просмотров: 8945
Последний ответ 04 Ноябрь 2013, 14:16:19
от Malaheenee
*Решено* Проблемы с ALSA

Автор Balagansky

Ответов: 14
Просмотров: 9868
Последний ответ 25 Апрель 2016, 18:22:19
от Balagansky
xfce4 (4.8), gnome-mplayer ,xscreensaver [РЕШЕНО]

Автор vladimirse

Ответов: 14
Просмотров: 3624
Последний ответ 13 Март 2012, 10:32:18
от vladimirse
[РЕШЕНО] не работает flash

Автор fry

Ответов: 26
Просмотров: 5874
Последний ответ 07 Июнь 2014, 19:55:42
от nik.ilim
[Решено] Регулировка звука

Автор Butch

Ответов: 4
Просмотров: 461
Последний ответ 07 Январь 2020, 09:53:13
от Butch