Автор Тема: Установка драйверов для ГП Adreno  (Прочитано 1992 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Oknolaz

Установка драйверов для ГП Adreno
« : 24 Февраля 2020, 08:56:50 »
Я использую debian buster на своём девайсе с архитектурой arm64 там отсутствует графический процессор (точнее он есть, но драйверов на него в линуксе нет), и хочу использовать программную эмуляцию с помощью libgl1-mesa-swx11. НО этот пакет есть только в sid для arm64 (информация с оффициального сайта). Я добавлял этот репозиторий, НО при установке данного пакета тоже самое: этот пакет отсутствует, но упомянут в sources.list. Затем я искал этот пакет в интернете, но для arm64 его нигде нет. Вопрос: шо делать? :-[
« Последнее редактирование: 01 Апреля 2020, 17:59:04 от Oknolaz »
 

Оффлайн Oknolaz

Re: Установка libgl1-mesa-swx11 на arm64
« Ответ #1 : 24 Февраля 2020, 09:09:48 »
Репозиторий, который я добавлял:
deb http://ftp.debian.org/debian/ sid main
deb-src http://ftp.debian.org/debian/ sid main
 


Оффлайн qupl

Re: Установка libgl1-mesa-swx11 на arm64
« Ответ #3 : 24 Февраля 2020, 09:48:57 »
Возможно он в ветках contrib или non-free

Оффлайн Oknolaz

Re: Установка libgl1-mesa-swx11 на arm64
« Ответ #4 : 24 Февраля 2020, 09:54:08 »
qupl, при добавлении contrib и non-free репозиториев то же самое: пакет недоступен, но упомянут в списке зависимостей другого пакета.
« Последнее редактирование: 24 Февраля 2020, 09:55:48 от Oknolaz »
 

Оффлайн qupl

Re: Установка libgl1-mesa-swx11 на arm64
« Ответ #5 : 24 Февраля 2020, 12:34:59 »
Там нет всей ветки pool-arm64. Видимо убрали по какой-то причине.

Оффлайн Oknolaz

Re: Установка libgl1-mesa-swx11 на arm64
« Ответ #6 : 24 Февраля 2020, 13:27:37 »
пакет недоступен, но упомянут в списке зависимостей другого пакета.
Можеть быть попытаться найти этот пакет, у которого есть эта зависимость от libgl1-mesa-swx11?
 

Оффлайн Oknolaz

Re: Установка libgl1-mesa-swx11 на arm64
« Ответ #7 : 24 Февраля 2020, 14:50:34 »
Мне удалось установить его, но с ошибками. Я добавил в dpkg архитектуру amd64, скачал deb пакет для amd64 jessie, установил его, и... он установился, НО после этого поломался dpkg. Для исправления ошибки он удаляет этот пакет и устанавливает libgl1. ???
 

Оффлайн Oknolaz

Re: Установка libgl1-mesa-swx11 на arm64
« Ответ #8 : 24 Февраля 2020, 14:53:52 »
Вот лог:
root@localhost:/home/android/Downloads# dpkg -i libgl1-mesa-swx11_10.3.2-1+deb8u2_amd64.deb
Выбор ранее не выбранного пакета libgl1-mesa-swx11:amd64.
dpkg: рассматривается удаление libgl1:arm64, вместо которого будет использован libgl1-mesa-swx11:amd64 …
dpkg: да, пакет libgl1:arm64 будет удалён, чтобы можно было установить libgl1-mesa-swx11:amd64
dpkg: предупреждение: список файлов пакета «libnet-ssleay-perl» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libexiv2-14:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libxdmcp6:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libwww-perl» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «liblzma5:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libssl1.1:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libhtml-tree-perl» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «dconf-service» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libpaper-utils» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libgomp1:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libpython3.7-minimal:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «xfce4-power-manager-data» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libflac8:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libnotify4:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libgmp10:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libdbus-1-3:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libncursesw6:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libxshmfence1:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libvdpau1:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libavcodec58:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libgtk2.0-common» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libkrb5-3:arm64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «openssl» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libpam-runtime» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
(Чтение базы данных … на данный момент установлено 131657 файлов и каталогов.)
Подготовка к распаковке libgl1-mesa-swx11_10.3.2-1+deb8u2_amd64.deb …
Распаковывается libgl1-mesa-swx11:amd64 (10.3.2-1+deb8u2) …
Настраивается пакет libgl1-mesa-swx11:amd64 (10.3.2-1+deb8u2) …
Обрабатываются триггеры для libc-bin (2.28-10) …
root@localhost:/home/android/Downloads# apt install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 x11-utils : Зависит: libgl1 но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
root@localhost:/home/android/Downloads#
P.S. Я так понял, что при установке libgl1-mesa-swx11 удаляется libgl1, который является зависимостью для x11-utils.
« Последнее редактирование: 24 Февраля 2020, 16:21:14 от Oknolaz »
 

Оффлайн Oknolaz

Re: Установка libgl1-mesa-swx11 на arm64
« Ответ #9 : 24 Февраля 2020, 16:34:39 »
Прочитав описание к x11-utils, становится понятно, что удалив этот пакет, похерится графическая оболочка.
 

Оффлайн qupl

Re: Установка libgl1-mesa-swx11 на arm64
« Ответ #10 : 24 Февраля 2020, 16:58:26 »
Смысла ставить один пакет другой архитектуры нет.
 
Пользователи, которые поблагодарили этот пост: Oknolaz

Оффлайн Oknolaz

Re: Установка libgl1-mesa-swx11 на arm64
« Ответ #11 : 24 Февраля 2020, 17:07:40 »
qupl, значит не судьба.
 

Оффлайн Oknolaz

Re: Установка libgl1-mesa-swx11 на arm64
« Ответ #12 : 01 Апреля 2020, 17:57:18 »
Может кому пригодится.

Я нашёл драйвера для моего Adreno ГП - freedreno. После его установки всё замечательно работает.
Установка:
apt-get install libdrm-freedreno1
 

Теги:
     

    Установка программ ? OpenShot

    Автор denes

    Ответов: 2
    Просмотров: 626
    Последний ответ 13 Июня 2021, 09:55:35
    от mexx
    Установка пакета

    Автор incognito15

    Ответов: 10
    Просмотров: 3477
    Последний ответ 09 Мая 2015, 17:38:59
    от Leo
    Минимальная установка под веб сервер и компиляцию ?

    Автор mraksoll

    Ответов: 2
    Просмотров: 923
    Последний ответ 05 Июля 2017, 23:44:41
    от mraksoll
    Установка свежих версий Libreoffice и Mozilla из репозитория

    Автор sakura_al_rim

    Ответов: 102
    Просмотров: 66829
    Последний ответ 26 Мая 2017, 23:49:56
    от Deportivo
    Установка ffmpeg на debian

    Автор ilyha123

    Ответов: 14
    Просмотров: 5769
    Последний ответ 23 Марта 2015, 21:14:21
    от ilyha123