Автор Тема: Ошибка при обновлении x86_64-linux-gnu/perl/5.28  (Прочитано 1558 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн shlihta

Здравствуйте! Помогите пожалуйста, может кто сталкивался. Установлена система MX-Linux KDE 19.3. Стоит (продублирована) на двух компьютерах. Ноутбук Lenovo B570e и персоналка на процессоре Athlon 240GE. При обновлении начали сыпаться ошибки.  И их количество постоянно растёт. При обновлении выскакивает:
Spoiler: ShowHide
debconf: Perl may be unconfigured (Can't load '/usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so' for module re: /usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so: файл слишком мал at /usr/share/perl/5.28/XSLoader.pm line 93.
 at /usr/lib/x86_64-linux-gnu/perl/5.28/re.pm line 89.
Compilation failed in require at /usr/share/perl/5.28/Text/Wrap.pm line 58.
BEGIN failed--compilation aborted at /usr/share/perl/5.28/Text/Wrap.pm line 58.
Compilation failed in require at /usr/share/perl5/Debconf/Template.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at (eval 1) line 4.
BEGIN failed--compilation aborted at (eval 1) line 4.
) -- aborting

однако дальше идёт обновление. Правда оно заканчивается с ошибками.
Spoiler: ShowHide
Следующие пакеты будут обновлены:               
  libssl1.1 libssl1.1:i386 openssl
Следующие частично установленные пакеты будут настроены:
  cups cups-bsd
3 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 3 918 kБ архивов. После распаковки 0 Б будет занято.
Хотите продолжить? [Y/n/?] y
Получить: 1 http://deb.debian.org/debian-security buster/updates/main i386 libssl1.1 i386 1.1.1d-0+deb10u4 [1 537 kB]
Получить: 2 http://deb.debian.org/debian-security buster/updates/main amd64 libssl1.1 amd64 1.1.1d-0+deb10u4 [1 538 kB]
Получить: 3 http://deb.debian.org/debian-security buster/updates/main amd64 openssl amd64 1.1.1d-0+deb10u4 [843 kB]
Получено 3 918 kБ в 2с (2 046 kБ/с)
debconf: Perl may be unconfigured (Can't load '/usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so' for module re: /usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so: файл слишком мал at /usr/share/perl/5.28/XSLoader.pm line 93.
 at /usr/lib/x86_64-linux-gnu/perl/5.28/re.pm line 89.
Compilation failed in require at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
BEGIN failed--compilation aborted at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
Compilation failed in require at /usr/share/perl5/Debconf/Template.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at (eval 1) line 4.
BEGIN failed--compilation aborted at (eval 1) line 4.
) -- aborting
(Чтение базы данных … на данный момент установлено 414976 файлов и каталогов.)
Подготовка к распаковке …/libssl1.1_1.1.1d-0+deb10u4_i386.deb …
Деконфигурируется libssl1.1:amd64 (1.1.1d-0+deb10u3) …
Распаковывается libssl1.1:i386 (1.1.1d-0+deb10u4) на замену (1.1.1d-0+deb10u3) …
Подготовка к распаковке …/libssl1.1_1.1.1d-0+deb10u4_amd64.deb …
Распаковывается libssl1.1:amd64 (1.1.1d-0+deb10u4) на замену (1.1.1d-0+deb10u3) …
Подготовка к распаковке …/openssl_1.1.1d-0+deb10u4_amd64.deb …
Распаковывается openssl (1.1.1d-0+deb10u4) на замену (1.1.1d-0+deb10u3) …
Настраивается пакет cups (2.2.10-6+deb10u4) …
Can't load '/usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so' for module re: /usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so: файл слишком мал at /usr/share/perl/5.28/XSLoader.pm line 93.
 at /usr/lib/x86_64-linux-gnu/perl/5.28/re.pm line 89.
Compilation failed in require at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
BEGIN failed--compilation aborted at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
Compilation failed in require at /usr/share/perl5/Debconf/Template.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: ошибка при обработке пакета cups (--configure):
 installed cups package post-installation script subprocess returned error exit status 2
Настраивается пакет cups-bsd (2.2.10-6+deb10u4) …
Can't load '/usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so' for module re: /usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so: файл слишком мал at /usr/share/perl/5.28/XSLoader.pm line 93.
 at /usr/lib/x86_64-linux-gnu/perl/5.28/re.pm line 89.
Compilation failed in require at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
BEGIN failed--compilation aborted at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
Compilation failed in require at /usr/share/perl5/Debconf/Template.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: ошибка при обработке пакета cups-bsd (--configure):
 installed cups-bsd package post-installation script subprocess returned error exit status 2
Настраивается пакет libssl1.1:amd64 (1.1.1d-0+deb10u4) …
Can't load '/usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so' for module re: /usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so: файл слишком мал at /usr/share/perl/5.28/XSLoader.pm line 93.
 at /usr/lib/x86_64-linux-gnu/perl/5.28/re.pm line 89.
Compilation failed in require at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
BEGIN failed--compilation aborted at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
Compilation failed in require at /usr/share/perl5/Debconf/Template.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: ошибка при обработке пакета libssl1.1:amd64 (--configure):
 installed libssl1.1:amd64 package post-installation script subprocess returned error exit status 2
Настраивается пакет libssl1.1:i386 (1.1.1d-0+deb10u4) …
Can't load '/usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so' for module re: /usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so: файл слишком мал at /usr/share/perl/5.28/XSLoader.pm line 93.
 at /usr/lib/x86_64-linux-gnu/perl/5.28/re.pm line 89.
Compilation failed in require at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
BEGIN failed--compilation aborted at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
Compilation failed in require at /usr/share/perl5/Debconf/Template.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: ошибка при обработке пакета libssl1.1:i386 (--configure):
 installed libssl1.1:i386 package post-installation script subprocess returned error exit status 2
dpkg: зависимости пакетов не позволяют настроить пакет openssl:
 openssl зависит от libssl1.1 (>= 1.1.1), однако:
  Пакет libssl1.1:amd64 пока не настроен.

dpkg: ошибка при обработке пакета openssl (--configure):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для man-db (2.8.5-2) …
Обрабатываются триггеры для libc-bin (2.28-10) …
При обработке следующих пакетов произошли ошибки:
 cups
 cups-bsd
 libssl1.1:amd64
 libssl1.1:i386
 openssl
E: Sub-process /usr/bin/dpkg returned an error code (1)
Настраивается пакет cups (2.2.10-6+deb10u4) …
Can't load '/usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so' for module re: /usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so: файл слишком мал at /usr/share/perl/5.28/XSLoader.pm line 93.
 at /usr/lib/x86_64-linux-gnu/perl/5.28/re.pm line 89.
Compilation failed in require at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
BEGIN failed--compilation aborted at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
Compilation failed in require at /usr/share/perl5/Debconf/Template.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: ошибка при обработке пакета cups (--configure):
 installed cups package post-installation script subprocess returned error exit status 2
Настраивается пакет cups-bsd (2.2.10-6+deb10u4) …
Can't load '/usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so' for module re: /usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so: файл слишком мал at /usr/share/perl/5.28/XSLoader.pm line 93.
 at /usr/lib/x86_64-linux-gnu/perl/5.28/re.pm line 89.
Compilation failed in require at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
BEGIN failed--compilation aborted at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
Compilation failed in require at /usr/share/perl5/Debconf/Template.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: ошибка при обработке пакета cups-bsd (--configure):
 installed cups-bsd package post-installation script subprocess returned error exit status 2
Настраивается пакет libssl1.1:amd64 (1.1.1d-0+deb10u4) …
Can't load '/usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so' for module re: /usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so: файл слишком мал at /usr/share/perl/5.28/XSLoader.pm line 93.
 at /usr/lib/x86_64-linux-gnu/perl/5.28/re.pm line 89.
Compilation failed in require at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
BEGIN failed--compilation aborted at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
Compilation failed in require at /usr/share/perl5/Debconf/Template.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: ошибка при обработке пакета libssl1.1:amd64 (--configure):
 installed libssl1.1:amd64 package post-installation script subprocess returned error exit status 2
Настраивается пакет libssl1.1:i386 (1.1.1d-0+deb10u4) …
Can't load '/usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so' for module re: /usr/lib/x86_64-linux-gnu/perl/5.28/auto/re/re.so: файл слишком мал at /usr/share/perl/5.28/XSLoader.pm line 93.
 at /usr/lib/x86_64-linux-gnu/perl/5.28/re.pm line 89.
Compilation failed in require at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
BEGIN failed--compilation aborted at /usr/lib/x86_64-linux-gnu/perl-base/Text/Wrap.pm line 58.
Compilation failed in require at /usr/share/perl5/Debconf/Template.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: ошибка при обработке пакета libssl1.1:i386 (--configure):
 installed libssl1.1:i386 package post-installation script subprocess returned error exit status 2
dpkg: зависимости пакетов не позволяют настроить пакет openssl:
 openssl зависит от libssl1.1 (>= 1.1.1), однако:
  Пакет libssl1.1:amd64 пока не настроен.

dpkg: ошибка при обработке пакета openssl (--configure):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для libc-bin (2.28-10) …
При обработке следующих пакетов произошли ошибки:
 cups
 cups-bsd
 libssl1.1:amd64
 libssl1.1:i386
 openssl
                                                 
Текущее состояние: 0 (-3) может быть обновлено.


Перед обновлением были с ошибками только  cups, cups-bsd.

Есть снапшот до обновления, в котором по приложениям ошибок пока нет, однако первый сплоер уже выскакивает. И doublecmd на qt завершается с ошибкой при закрытии.
Подскажите как лечить пожалуйста.

 

Оффлайн ogost

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #1 : 09 Декабря 2020, 12:39:41 »
Spoiler: ShowHide

Перенёс, потому что не Дебиан

Возможно сторонние пакеты и источники прописаны, но поскольку MX не пользуюсь, затрудняюсь ответить.

Оффлайн shlihta

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #2 : 09 Декабря 2020, 13:36:07 »
Почему не дебиан? Дебиан, только чуть прилизаный вроде.

Spoiler: ShowHide
Kernel: 5.8.0-3-amd64 x86_64 bits: 64 compiler: N/A
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8.0-3-amd64
  root=UUID=<filter> ro quiet splash
  Desktop: KDE Plasma 5.14.5 tk: Qt 5.11.3 wm: kwin_x11 dm: SDDM
  Distro: MX-19.3_KDE_x64 patito feo November 11 2020
  base: Debian GNU/Linux 10 (buster)


Всё ставил только со стабильного репозитория через встроенную утилиту. Вот вывод реп:

Spoiler: ShowHide
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
  1: deb http://deb.debian.org/debian buster-updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/debian.list
  1: deb http://deb.debian.org/debian buster main contrib non-free
  2: deb http://deb.debian.org/debian-security buster/updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
  1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/mx.list
  1: deb https://mirror.yandex.ru/mirrors/MX-Linux/MX-Packages/mx/repo/ buster main non-free
  2: deb https://mirror.yandex.ru/mirrors/MX-Linux/MX-Packages/mx/repo/ buster ahs
  Active apt repos in: /etc/apt/sources.list.d/opera-stable.list
  1: deb https://deb.opera.com/opera-stable/ stable non-free
  Active apt repos in: /etc/apt/sources.list.d/teamviewer.list
  1: deb https://linux.teamviewer.com/deb stable main
  No active apt repos in: /etc/apt/sources.list.d/various.list


Косяк какой то, даже самый первый снапшот и то с таким косяком... Не хотелось бы заново с установкой начинать. Реально perl переставить?  Я пробовал пакеты проблемные в /var/lib/dpkg/status удалить но что то совсем систему сломал.
 

Оффлайн ferum

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #3 : 09 Декабря 2020, 14:36:38 »
Почему не дебиан?
Это распиаренная говносборка где применена часть пакетов из репозитория стабильного debian а весь передовой софтсобран на коленке и не протестирован должным образом.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн shlihta

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #4 : 09 Декабря 2020, 18:23:43 »
Ну хз, может и говносборка. Я сначала делал на Q4OS, всё же хоть чуть прилизана. Но хочется инструменты с MX Linux, особенно для создания снапшотов любого размера и так по мелочи хорошие утилиты есть. Если переходишь с винды это критично. Не хватает только установке в суб дирректорию, timeshift с btrfs не работает... Всё же вид загрузчика нравится, не то что в q4os или лысом debian, да и утилиты огонь. Альтернатива "МХ снимок системы" только SystemBack и то он если система разрастается, начинает глючить..
Вот как этот косяк выличить с perrl хз... Откуда это вообще выскочило не пойму.
 

Оффлайн ferum

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #5 : 10 Декабря 2020, 09:46:34 »
Есть мнение что linux очень гибок в настройках, и это так. Стоит правда помнить что в отличии от варезных форточек или хакинтоша продукт изначально бесплатный от чего подаётся пользователю таким как есть .... кому надо допилят сами. Разумеется когда пользуешься этими чудесами 12+ лет ваших хотелок уже не понять. На youtube  есть блогер и разряда пингвинусов, он клепает свои сборки на тему debian +XFCE, там у него эти утилиты присутствуют, за то нет конфликтов при обновлении системы. В общем то всё объяснимо, человек проявил желание взять исходники этих программ в том же MX и собрал их для  debian. Я вам скажу больше, можно самостоятельно сделать эксклюзивную кастомную систему персонально для себя но нужно желание и время.
По этому достаточно многие переходят на linux и спустя какое то время возвращаются обратно.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн shlihta

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #6 : 10 Декабря 2020, 11:11:31 »
Это всё хорошо когда досконально разбираешься в системе. Когда только начинаешь хочется всё потрогать и чтоб была возможность для отката. У меня после использования линукс начинает казаться что все обновления это зло. И любое из них может неожиданно выйти боком и что нибудь сломать в системе. То есть, установил и потом только доустонавливай необходимые программы. Всё ж хорошо было, пока не обновил...
Ладно, по моей проблеме какие нибудь мысли будут? Или только устанавливать систему начисто и заново устанавливать необходимое и на каждом шаге проверять?
 

Оффлайн ferum

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #7 : 10 Декабря 2020, 11:56:00 »
По вашей проблеме, в принципе она решаема но не для новичка . Вызвана она источниками по смещанными от разных дистрибутивов . К сожалению в говносборках так задумано. Вы получаете  из коробки рабочий дистрибутив но пои установке дополнительного софта ииеете проблемы с зависимостями. Есть некоторый шанс , если удалить приложения поставленные вручную и убрать их источники ( я видел у вас )  так же вернуть из кэша старые версии проблемных пакетов  и плставить их через  dpkg с понижением версий. Дам добрый совет, не ведитесб на пиар, не всё золото...
Русские дебианщики против цифрового слабоумия !
 
Пользователи, которые поблагодарили этот пост: Gamliel

Оффлайн Amper

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #8 : 10 Декабря 2020, 12:02:31 »
Почему не дебиан? Дебиан, только чуть прилизаный вроде.

Spoiler: ShowHide
Kernel: 5.8.0-3-amd64 x86_64 bits: 64 compiler: N/A
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8.0-3-amd64
  root=UUID=<filter> ro quiet splash
  Desktop: KDE Plasma 5.14.5 tk: Qt 5.11.3 wm: kwin_x11 dm: SDDM
  Distro: MX-19.3_KDE_x64 patito feo November 11 2020
  base: Debian GNU/Linux 10 (buster)


Всё ставил только со стабильного репозитория через встроенную утилиту. Вот вывод реп:

Spoiler: ShowHide
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
  1: deb http://deb.debian.org/debian buster-updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/debian.list
  1: deb http://deb.debian.org/debian buster main contrib non-free
  2: deb http://deb.debian.org/debian-security buster/updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
  1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/mx.list
  1: deb https://mirror.yandex.ru/mirrors/MX-Linux/MX-Packages/mx/repo/ buster main non-free
  2: deb https://mirror.yandex.ru/mirrors/MX-Linux/MX-Packages/mx/repo/ buster ahs
  Active apt repos in: /etc/apt/sources.list.d/opera-stable.list
  1: deb https://deb.opera.com/opera-stable/ stable non-free
  Active apt repos in: /etc/apt/sources.list.d/teamviewer.list
  1: deb https://linux.teamviewer.com/deb stable main
  No active apt repos in: /etc/apt/sources.list.d/various.list


Косяк какой то, даже самый первый снапшот и то с таким косяком... Не хотелось бы заново с установкой начинать. Реально perl переставить?  Я пробовал пакеты проблемные в /var/lib/dpkg/status удалить но что то совсем систему сломал.
Откуда такой sources.list ? Сам замостырил?

вот мой, не тронутый, одна строчка там и та закомменчена:
#this file is empty by default.  Sources are under /etc/apt/souces.list.d

дальше по дебиан, /media/amper/rootMX19/etc/apt/sources.list.d/debian.list
Spoiler: ShowHide

# Debian Stable.
deb http://deb.debian.org/debian buster main contrib non-free
#deb http://deb.debian.org/debian-security buster/updates main contrib non-free
#deb-src http://deb.debian.org/debian buster main contrib non-free

#buster backports
#deb http://deb.debian.org/debian buster-backports main contrib non-free
deb http://mirrors.kernel.org/debian/ buster main contrib non-free


debian-stable-updates.list
Spoiler: ShowHide

# Debian buster Updates
deb http://deb.debian.org/debian buster-updates main contrib non-free


mx.list
Spoiler: ShowHide

# MX Community Main and Test Repos
deb http://mirror.truenetwork.ru/mxlinux/mx/repo/ buster main non-free
#deb http://mirror.truenetwork.ru/mxlinux/mx/testrepo/ buster test

#ahs hardware stack repo
#deb http://mirror.truenetwork.ru/mxlinux/mx/repo/ buster ahs



various.list
Spoiler: ShowHide

# opera
#deb http://deb.opera.com/opera/ stable non-free

# virtualbox
deb http://download.virtualbox.org/virtualbox/debian buster contrib

# Установка пакетов WineHQ
deb https://dl.winehq.org/wine-builds/debian/ buster main


ahs - вылавливал оттуда ошибки, отключи. А перл снести и переставить, с исправлеными листами.

почистить чуток от лишнего:
sudo dpkg -l | awk '/^rc/ {print $2}'
sudo apt purge $(dpkg -l | awk '/^rc/ { print $2 }')

Cообщение объединено 10 Декабря 2020, 13:01:16
Здравствуйте! Помогите пожалуйста, может кто сталкивался. Установлена система MX-Linux KDE 19.3..

Есть снапшот до обновления, в котором по приложениям ошибок пока нет, однако первый сплоер уже выскакивает. И doublecmd на qt завершается с ошибкой при закрытии.
Подскажите как лечить пожалуйста.
Будь добр, поясни почему KDE? В нем все зло! имхо. )
« Последнее редактирование: 10 Декабря 2020, 13:01:16 от Amper »
 

Оффлайн ferum

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #9 : 10 Декабря 2020, 15:32:37 »
Будь добр, поясни почему KDE? В нем все зло! имхо. )
Хотя бы по тому что это классический рабочий стол,  одно из древнейших окружений в linux, наверное самое гибкое по настройкам окружение. Плюс к тому теперь оно жрёт ресурсов не больше других.
З.Ы Крыса в MX  вообще беспонтовая, то есть она не дефолтная, но кого ныньче удивишь коньками и панелько сбоку. Бывали времена, крысу пилили круче в том же dream linux и даже в sparky. В прочем все эти дистрибутивы - игрушки однодневки, хить на них не комфортно.
Скажете я помешан на debian, вовсе нет. Можно взять с тем же успехом CentOS 8 и настроить под себя. Всё будет так же безотказно и надёжно работать, а аппаратная поддержка точно не хуже. Единственное времени уйдёт побольше, загрузчик винды при необходимости придётся прописать вручную, да и с источниками берега то же надо знать.
Русские дебианщики против цифрового слабоумия !
 
Пользователи, которые поблагодарили этот пост: shlihta

Оффлайн Amper

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #10 : 10 Декабря 2020, 16:12:25 »
Хотя бы по тому что это классический рабочий стол,  одно из древнейших окружений в linux, наверное самое гибкое по настройкам окружение. Плюс к тому теперь оно жрёт ресурсов не больше других.
По-моему кде - виндусятина. Имхо конечно. Тот же "мате" и "xfce" не приходиться допиливать пока настраиваешь систему. KDE изначально тугой для управления и массивный по пакетам. Пока парень в теме с видеокартой TU116 бился, я все дистрибы поскачивал и попереустанавливал. "Завелись": стандарт (естественно); мате; хfce; - без манипуляций, а "cinnamon; kde; gnome"; - нет. И так практически со всеми дистрами linux... кроме Арча, он легко поднимается на всем похоже, если это 64бит. )

зы. На мой взгляд, чтобы исключить ошибки, которые могут проявляться при установке системы, лучше накатывать ее постепенно. Масса дистров не загружаются сразу после скачивания, то двд им дай (инитрд менять приходится), то поставь драйвер со своего диска. Хотя лежат как полноценные установочные. Альфы1-2 тоже с причудами кстати. )

Я к тому, что "кеды" и все подобное, лучше ставить уже после как есть снимок системы. А устанавливать изначально на чем либо легковесном, либо "стандарт". Здесь автор топика говорит, что заметил после установки траблы... мой вывод, перезалить систему на дефолтном "флю-блю" как ее там, а потом уже "рубашки мерять", с уже имеющемся снимком системы, рабочим и "чистым".
 

Оффлайн shlihta

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #11 : 10 Декабря 2020, 17:34:24 »
Источники на правил и не добавлял. Все стандартное в МХ. Стараюсь лишнего совсем не ставить. КДЕ реально нравился, ещё мате более менее, но кде для меня по ощущениям лучше) если я переустановлю perl сейчас, без изменения источников может помочь? И как это правильно сделать? Буду дома, займусь.
 

Оффлайн Amper

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #12 : 10 Декабря 2020, 20:20:15 »
Источники на правил и не добавлял. Все стандартное в МХ. Стараюсь лишнего совсем не ставить. КДЕ реально нравился, ещё мате более менее, но кде для меня по ощущениям лучше) если я переустановлю perl сейчас, без изменения источников может помочь? И как это правильно сделать? Буду дома, займусь.
Понимаешь дело в чем... я отношусь ко всем ОС как к Dos v6.20, количество файлов только меняется, мне снести половину и восстановить, как любую другую прогу поставить. Сносил бы наверняка как: perl* , а дальше глядеть нужно что зацепило и нужно ли оно вообще. Думая о МХ19 как о Debian, обломался... пакеты далеко не все подходят и те репозитории, указанные изначально - не подлежат изменению. ) Это я о дебиановских. У тебя там лишнии прописаны (разлочены), стал быть система сломана.

Получается галочек наставил, там утилита этим занимается, вроде как "простая установка пакетов" или "управление источниками", ahs - разбивает систему, проверено. KDE дистр когда ставил, ошибки были и сложно стартовала, выправлять нужно было. XFCE без проблем и танцев.

зы. Лично мне всегда легче контролировать после чего именно сваливается система, поэтому ставлю минимум, далее снимок и наращиваю поэтапно.

зы. Забыл... для начала пользую dpkg-reconfigure "paket" и конечно "реинсталл", если не помогает, то под корень. )
« Последнее редактирование: 10 Декабря 2020, 20:22:11 от Amper »
 

Оффлайн shlihta

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #13 : 10 Декабря 2020, 23:52:53 »
Хочу систему с красивым загрузчиком, окружением кде на файловой системе бтрфс с рабочим timeshift и с драйверами на борту чтоб и на ноуте с интегрированой интел графикой работал и на персрналке с нормальной нвидиа и на амд со встроенной в процессор графикой.. И ещё чтоб вайн более-менее работал. Уже пол года не могу ума дать. Вроде тут почти всё, что хочу. Лишнее конечно есть, даже много.
Дебиан реально работает быстрее убунты на одном и том же железе. Не понял почему. Лмде где то по производительности между убунту и дебианом. Хз, может правда надо начинать с минимальной установки. Не научился переносить установленную систему в суб директорию. Устанавливаю Systemback,в ней сохраняю и уже с неё устанавливается в суб директорию.
Сейчас всё же мх с нуля гляну. Может там изначально косяк.
Что то не могу вылечить,
E: Ошибка: pkgProblemResolver::Resolve привёл к появлению сломанных пакетов. Это может быть вызвано зафиксированными пакетами.
и т.д.  ничего не помогает.
 

Оффлайн Amper

Re: Ошибка при обновлении x86_64-linux-gnu/perl/5.28
« Ответ #14 : 11 Декабря 2020, 01:47:26 »
Что то не могу вылечить,
E: Ошибка: pkgProblemResolver::Resolve привёл к появлению сломанных пакетов. Это может быть вызвано зафиксированными пакетами.
и т.д.  ничего не помогает.
Это как раз репозитории... не нужно в МХ19 ничего менять по репозиториям. А ломаные пакеты завсегда посмотреть можно, убрать их.

зы. Вайн в ней работает на ура, в бунте проблемы были. С Дебиан так же повозиться пришлось чтоб мой софт запустить, но отдать должное, удалось и все стабильно. AHS - сырая на мой взгляд, RC ставил, все норм, даже лучше чем в стандарте, имхо. И ставь уж с дефолтовым окружением flu-box или что-то такое, потом легко накатишь kde в том виде, в котором захочешь.

При установке источники не щелкай, всякие там нон-фри и т.п. Это все потом.
« Последнее редактирование: 11 Декабря 2020, 01:49:22 от Amper »
 

Теги:
     

    Ошибка в репозиториях

    Автор kex

    Ответов: 2
    Просмотров: 1461
    Последний ответ 23 Декабря 2015, 01:00:44
    от kex
    Ошибка 404... с изюминкой

    Автор Leo

    Ответов: 11
    Просмотров: 3183
    Последний ответ 30 Июля 2012, 12:45:51
    от rezedent12
    Ошибка в /etc/apt/preferences

    Автор CommanderG6

    Ответов: 9
    Просмотров: 2588
    Последний ответ 13 Марта 2016, 23:56:31
    от vic5710
    Ошибка (wxWidgets must be installed on your system.) -помогите разобраться.

    Автор temakonkin

    Ответов: 1
    Просмотров: 2699
    Последний ответ 21 Февраля 2015, 04:25:51
    от ihammers
    Ошибка [ -x /usr/lib/php5/sessionclean ] && /usr/lib/php5/sessionclean

    Автор qwers

    Ответов: 1
    Просмотров: 1591
    Последний ответ 05 Августа 2016, 12:05:59
    от ogost