Установка пакетов с ошибкой No schema files found: doing nothing

Автор v1rtual, 24 февраля 2021, 17:21:46

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

v1rtual

Здравствуйте.
Пытаюсь развернуть ansible awx.
Нужно предварительно установить пакеты.

apt install git python3-pip docker docker-compose

python3-pip docker docker-compose ставятся, но с ошибкой. No schema files found: doing nothing.

cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"

uname -a
Linux srvyawx01 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux

cat /etc/apt/sources.list
deb http://deb.debian.org/debian/ buster main
deb-src http://deb.debian.org/debian/ buster main
deb http://security.debian.org/debian-security buster/updates main contrib
deb-src http://security.debian.org/debian-security buster/updates main contrib

dzhoser

#1
Попробуйте по этому мануалу
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

v1rtual

Цитата: dzhoser от 24 февраля 2021, 17:43:39
apt-get install python3-pip pwgen python3-docker -y
pip3 install requests==2.14.2

update-alternatives --install /usr/bin/python python /usr/bin/python2.7 1
update-alternatives --install /usr/bin/python python /usr/bin/python3 2

Такая же ошибка, во время установки.
....
Setting up libglib2.0-0:amd64 (2.58.3-2+deb10u2) ...
No schema files found: doing nothing.
Setting up binutils-common:amd64 (2.31.1-16) ...

....

он ставятся, но криво

pip3 install ansible

из-за этого тоже не ставится

Failed building wheel for ansible

dzhoser

Я отредактировал пост попробуйте переустановить по инструкции в сылке.
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

v1rtual

#4
Цитата: dzhoser от 24 февраля 2021, 17:43:39
Попробуйте по этому мануалу

Всё так же ошибка... :-X


apt-get install software-properties-common


The following additional packages will be installed:
  gir1.2-glib-2.0 gir1.2-packagekitglib-1.0 libappstream4 libgirepository-1.0-1
  libglib2.0-0 libglib2.0-bin libglib2.0-data libgstreamer1.0-0 libpackagekit-glib2-18
  libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libstemmer0d libyaml-0-2
  packagekit packagekit-tools policykit-1 python3-dbus python3-distro-info python3-gi
  python3-software-properties shared-mime-info unattended-upgrades xdg-user-dirs
Suggested packages:
  gstreamer1.0-tools appstream python-dbus-doc python3-dbus-dbg bsd-mailx default-mta
  | mail-transport-agent needrestart
The following NEW packages will be installed:
  gir1.2-glib-2.0 gir1.2-packagekitglib-1.0 libappstream4 libgirepository-1.0-1
  libglib2.0-0 libglib2.0-bin libglib2.0-data libgstreamer1.0-0 libpackagekit-glib2-18
  libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libstemmer0d libyaml-0-2
  packagekit packagekit-tools policykit-1 python3-dbus python3-distro-info python3-gi
  python3-software-properties shared-mime-info software-properties-common
  unattended-upgrades xdg-user-dirs

....
Setting up xdg-user-dirs (0.17-2) ...
Setting up libyaml-0-2:amd64 (0.2.1-1) ...
Setting up libglib2.0-0:amd64 (2.58.3-2+deb10u2) ...
No schema files found: doing nothing.
Setting up libpackagekit-glib2-18:amd64 (1.1.12-5) ...
Setting up libglib2.0-data (2.58.3-2+deb10u2) ...
Setting up python3-software-properties (0.96.20.2-2) ...
Setting up shared-mime-info (1.10-1) ...
....



Я так понимаю какой-то пакет общий есть у всего этого и с ним проблемы

dzhoser

#5
Попробуйте кэш удалить
sudo apt clean
Починить сломанные зависимости
sudo apt install -f
sudo dpkg configure -a
apt-get install software-properties-common
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

v1rtual

Цитата: dzhoser от 26 февраля 2021, 07:44:14
Попробуйте кэш удалить
sudo apt clean
Починить сломанные зависимости
sudo apt install -f
sudo dpkg configure -a
apt-get install software-properties-common

Не понял к чему некоторые команды, но всё сделал и не помогло.

Вся соль в том, что я уже недели 3 назад развернул на этом образе awx в виртуальной среде и всё работает.
Решил заново раскатать этот образ и повторить всё, ошибка.
Думаю, раскатаю на снапшот на рабочем варианте, до установки пакетов и тоже ошибка.

Буду сейчас тогда на убунте поднимать.