[Вопрос закрыт] Ошибка wrong ELF class: ELFCLASS32 при выполнении команды

Автор Demetrum24579, 01 марта 2021, 19:51:58

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Demetrum24579

Решил я, значит, ввести команду lspci | grep 3D && vulkaninfo | grep deviceName и обнаружил, что терминал мне выбивает следующее:
Открыть содержимое (спойлер)
04:00.0 3D controller: NVIDIA Corporation GK208BM [GeForce 920M] (rev a1)
ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_intel.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_lvp.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : loader_scanned_icd_add: ICD libnv_vulkan_wrapper.so.1 doesn't support interface version compatible with loader, skip this ICD.
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

WARNING: lavapipe is not a conformant vulkan implementation, testing use only.
        deviceName     = Intel(R) HD Graphics 5500 (BDW GT2)
        deviceName     = llvmpipe (LLVM 11.0.1, 256 bits)
[свернуть]
Судя по названиям файлов, жалоба на vulkan, хотя в играх он вроде как работает, да и при выполнении vkcube тоже нормально всё. Исправить можно как-то?

gardarea51

Варнинг не ошибка, если все работает - забить.

Demetrum24579

gardarea51, да вроде бы и работает всё.. По крайней мере сейчас. Но меня просто смущают именно ERROR'ы, которые ссылаются на 32 битные библиотеки Vulkan, а не предупреждения

dzhoser

Не добавлена 32 битная архитектура
sudo dpkg --add-architecture i386
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

Demetrum24579

dzhoser, в том и дело, что как раз поддержка 32-х битных пакетов включена и она была активирована ещё с того момента, как я установил систему.. Даже 32-х битные пакеты Mesa стоят

ChubaDuba

Если не обновляли Vulkan, попробуйте обновить из backports

Demetrum24579

ChubaDuba, вулкан последней версии стоит. Ветка Bullseye, кстати, забыл сказать. Но в принципе, раз уж всё на нём работает, то думаю, что топик можно закрывать :)