Автор Тема: Возможно ли установить Dragonfire на Debian 10.9?  (Прочитано 748 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн CodeBash

Здравствуйте!
Командой sudo dpkg -i dragonfire_1.1.1_amd64.deb пытаюсь установить Dragonfire по этой ссылке https://github.com/DragonComputer/Dragonfire
При установке возникают ошибки:
Spoiler: ShowHide

a@a-pc:~/Downloads$ sudo dpkg -i ./dragonfire_1.1.1_amd64.deb
[sudo] пароль для a:
Выбор ранее не выбранного пакета dragonfire.
(Чтение базы данных … на данный момент установлено 286204 файла и каталога.)
Подготовка к распаковке ./dragonfire_1.1.1_amd64.deb …
Распаковывается dragonfire (1.1.1) …
dpkg: зависимости пакетов не позволяют настроить пакет dragonfire:
 dragonfire зависит от python3 (<< 3.7), однако:
  Версия python3 в системе — 3.7.3-1.
 dragonfire зависит от flite, однако:
  Пакет flite не установлен.
 dragonfire зависит от portaudio19-dev, однако:
  Пакет portaudio19-dev не установлен.
 dragonfire зависит от python3-all-dev, однако:
  Пакет python3-all-dev не установлен.
 dragonfire зависит от python3-lxml, однако:
  Пакет python3-lxml не установлен.
 dragonfire зависит от python3-nltk, однако:
  Пакет python3-nltk не установлен.
 dragonfire зависит от python3-pyaudio, однако:
  Пакет python3-pyaudio не установлен.
 dragonfire зависит от python3-httplib2, однако:
  Пакет python3-httplib2 не установлен.
 dragonfire зависит от libgstreamer1.0-dev, однако:
  Пакет libgstreamer1.0-dev не установлен.
 dragonfire зависит от gstreamer1.0-tools, однако:
  Пакет gstreamer1.0-tools не установлен.
 dragonfire зависит от subversion, однако:
  Пакет subversion не установлен.
 dragonfire зависит от libatlas-base-dev, однако:
  Пакет libatlas-base-dev не установлен.

dpkg: ошибка при обработке пакета dragonfire (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.23-4) …
Обрабатываются триггеры для mime-support (3.62) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
Обрабатываются триггеры для man-db (2.8.5-2) …
При обработке следующих пакетов произошли ошибки:
 dragonfire
a@a-pc:~/Downloads$ cat /etc/debian_version
10.9


Очень хочется посмотреть на что способна эта программа. Можно ли исправить эти ошибки и установить ее без них? Пакт-то вроде не древний 19 года.  :)
 

Оффлайн ferum

Re: Возможно ли установить Dragonfire на Debian 10.9?
« Ответ #1 : 12 Апреля 2021, 14:08:50 »
На гитхабе исходники, собираем  для debian с учетом зависимостей и ставим.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн CodeBash

Re: Возможно ли установить Dragonfire на Debian 10.9?
« Ответ #2 : 13 Апреля 2021, 14:21:21 »
Пробовал собирать из исходников. Тоже не удачно.
Зеленым текстом пишет: ...Удачно установлено.
А программы нет.

Тема закрыта. Не возможно установить. Хотя и пишется что работает на Дебиане.  :'(
 

Оффлайн ChubaDuba

Re: Возможно ли установить Dragonfire на Debian 10.9?
« Ответ #3 : 13 Апреля 2021, 14:42:40 »
Хотя и пишется что работает на Дебиане.  :'(
С другой стороны нигде не упоминается что будет работать на python 3.7.3-1.
Бλог   @chuba_duba
 

Оффлайн wwnet

Re: Возможно ли установить Dragonfire на Debian 10.9?
« Ответ #4 : 13 Апреля 2021, 14:57:19 »
пытаюсь установить Dragonfire по этой ссылке https://github.com/DragonComputer/Dragonfire
При установке возникают ошибки:
Насколько мне известно-утилита dpkg понятия не имеет о зависимостях, и просто ставит пакет (если поставит), и этот же dpkg является составной частью утилиты apt. Тоесть, сначала апт конфигурирует и притягует все пакеты, и только после этого дпкг ставит все эти пакеты. В связке. Вы же пытаетесь втулить этот пакет нахрапом. Во-первых, пакеты из не репозитория надо ставить через sudo apt-get install package, во-вторых, достать или скомпилировать недостающие библиотеки, в-третьих-переделать файл CONTROL, "занизив" версии пакетов, или переписав на похожие, если предыдущее не помогло.
А вообще б я зачрутился, и скомпилировал ))
:) если не сложно-загляните на мой сайт. С вас не убудет, а мне-трафик  тыц
 

Оффлайн wwnet

Re: Возможно ли установить Dragonfire на Debian 10.9?
« Ответ #5 : 13 Апреля 2021, 15:00:28 »
Во-первых, пакеты из не репозитория надо ставить через sudo apt-get install package,
sudo apt-get install /home/download/package  :)
:) если не сложно-загляните на мой сайт. С вас не убудет, а мне-трафик  тыц
 

Оффлайн wwnet

Re: Возможно ли установить Dragonfire на Debian 10.9?
« Ответ #6 : 13 Апреля 2021, 15:14:55 »
К тому же в системных требованиях установлена поддержка технологии Cuda от богомерзкой Nvidia, на странице которой ясно сказано, что для того чтоб эта неземная голосовая благодать у вас работала, то надо установить их деб-пакет  8)  https://developer.nvidia.com/cuda-downloads?target_os=Linux&target_arch=x86_64&target_distro=Debian&target_version=10&target_type=deblocal
:) если не сложно-загляните на мой сайт. С вас не убудет, а мне-трафик  тыц
 

Оффлайн ferum

Re: Возможно ли установить Dragonfire на Debian 10.9?
« Ответ #7 : 13 Апреля 2021, 17:49:05 »
Пробовал собирать из исходников. Тоже не удачно.
Зеленым текстом пишет: ...Удачно установлено.
А программы нет.
Так вы куда её собирали? по дефолту быть в /usr/local ? А ldconfig по путям делали?
Русские дебианщики против цифрового слабоумия !
 

Теги:
     

    Приостановка вывода сообщений при загрузке - возможно ли?

    Автор Sferg

    Ответов: 6
    Просмотров: 1537
    Последний ответ 09 Марта 2014, 19:45:24
    от ogost
    Не возможно запустить программы через sudo

    Автор Xialtal

    Ответов: 10
    Просмотров: 2173
    Последний ответ 15 Февраля 2020, 18:06:24
    от Xialtal
    Deb - пакет, возможно ли переделать?

    Автор izamoo

    Ответов: 6
    Просмотров: 2731
    Последний ответ 10 Января 2014, 10:46:19
    от Malaheenee
    Не возможно закачать файлы на жесткий диск

    Автор Lord_Markus

    Ответов: 8
    Просмотров: 1423
    Последний ответ 29 Сентября 2017, 23:46:30
    от Вадим
    Сохранение введённых команд в .bash_history в реальном времени - возможно ли?

    Автор Sferg

    Ответов: 1
    Просмотров: 1530
    Последний ответ 17 Марта 2014, 15:24:53
    от endru