apt-get не обновляются пакеты [РЕШЕНО]

Автор evil_pixi, 16 июня 2021, 21:38:08

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

evil_pixi

Добрый вечер.  вчера обновился с седьмой версии на девятую.
но не все гладко,
обновляются не все пакеты. выдает что то наподобии
Ignoring Provides line with DepCompareOp for package libapt-pkg
в инете пишут нужно обновить apt (у меня она не обновлена, версия от 2014 года)
пытаюсь обновить
root@ts1035b:~# apt-get install apt
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
apt : Depends: libapt-pkg5.0 (>= 1.3~rc2) but it is not going to be installed
       Breaks: apt-utils (< 1.3~exp2~) but 0.9.7.9+deb7u7 is to be installed
libalgorithm-diff-xs-perl : Depends: perlapi-5.14.2 but it is not installable
libapache2-mod-perl2 : Depends: apache2-api-20120211
                        Depends: apache2-bin (>= 2.4.16) but it is not going to be installed
libbsd-resource-perl : Depends: perlapi-5.14.2 but it is not installable
libdbd-mysql-perl : Depends: perlapi-5.14.2 but it is not installable
libdbi-perl : Depends: perlapi-5.14.2 but it is not installable
libfile-fcntllock-perl : Depends: perlapi-5.14.2 but it is not installable
libhtml-parser-perl : Depends: perlapi-5.14.2 but it is not installable
liblist-moreutils-perl : Depends: perlapi-5.14.2 but it is not installable
liblocale-gettext-perl : PreDepends: perlapi-5.14.2 but it is not installable
libnet-ssleay-perl : Depends: perlapi-5.14.2 but it is not installable
libperl5.14 : Depends: perl-base (= 5.14.2-21+deb7u6) but 5.24.1-3+deb9u7 is to be installed
libsnmp-perl : Depends: perlapi-5.14.2 but it is not installable
libterm-readkey-perl : Depends: perlapi-5.14.2 but it is not installable
libtext-charwidth-perl : Depends: perlapi-5.14.2 but it is not installable
libtext-iconv-perl : Depends: perlapi-5.14.2 but it is not installable
libuuid-perl : Depends: perlapi-5.14.2 but it is not installable
util-linux-locales : Depends: util-linux (< 2.20.1.0-0) but 2.29.2-1+deb9u1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


если выполнить apt-get -f install , заканчивает ошибкой

Processing triggers for install-info (4.13a.dfsg.1-10) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Errors were encountered while processing:
/var/cache/apt/archives/apache2-bin_2.4.25-3+deb9u9_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

как это разрулить, подскажите пожалуйста

dzhoser

apt --version покажите

Если версия ниже или равна 1.0.1 обновить можно так
wget http://snapshot.debian.org/archive/debian/20150821T213547Z/pool/main/a/apt/apt_1.0.10.2.tar.xz
tar -xvf apt_1.0.10.2.tar.xz
cd apt-1.0.10.2
./configure
make
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

evil_pixi

apt команды вообще нет.

apt-get --version
apt 0.9.7.9 for amd64 compiled on Oct 17 2014 09:15:56

спасибо, попробую сделать так как вы написали

evil_pixi

ошибку вывалил checking for gtest/gtest.h... no
configure: error: failed: I need gtest to build tests

endru

Цитата: evil_pixi от 16 июня 2021, 21:38:08вчера обновился с седьмой версии на девятую
нужно было обновлять в 2 этапа, с 7 на 8, и с 8 на 9.

evil_pixi

Так и делал.  возможно проблема в том, что у меня isp manager 4 стоял. может что с него

evil_pixi

#6
Решил этот момент удалением  apache. из  /var/lib/dpkg/info

сейчас возникает похожая ошибка, но с libmagickcore-dev и libmagickwand-dev
трюк с удалением с ними не прокатывает

subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libmagickwand-dev_8%3a6.9.7.4+dfsg-11+deb9u13_all.deb
/var/cache/apt/archives/libmagickcore-dev_8%3a6.9.7.4+dfsg-11+deb9u13_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

когда я удаляю из папки info всё что с ними связано.  архивы все равно подгружаются в кэш, откуда - непонятно  ???

dzhoser

Цитата: evil_pixi от 17 июня 2021, 05:01:14огда я удаляю из папки info всё что с ними связано.  архивы все равно подгружаются в кэш, откуда - непонятно
Очевидно с репозитория
Покажите  less /etc/apt/sources.list
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

evil_pixi


deb http://repo.mongodb.org/apt/debian/ stretch/mongodb-org/4.4 main
#deb http://ftp.debian.org/debian jessie-backports main

deb http://ftp.debian.org/debian/ stretch main
deb-src http://ftp.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main

deb http://security.debian.org/ stretch/updates main
deb-src http://security.debian.org/ stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://ftp.debian.org/debian/ stretch-updates main
deb-src http://ftp.debian.org/debian/ stretch-updates main

dzhoser

Попробуйте source.list привести к виду:
Цитироватьdeb http://deb.debian.org/debian/ oldstable main contrib non-free
deb-src http://deb.debian.org/debian/ oldstable main contrib non-free

deb http://deb.debian.org/debian/ oldstable-updates main contrib non-free
deb-src http://deb.debian.org/debian/ oldstable-updates main contrib non-free

deb http://deb.debian.org/debian-security oldstable/updates main
deb-src http://deb.debian.org/debian-security oldstable/updates main

deb http://ftp.debian.org/debian stretch-backports main
deb-src http://ftp.debian.org/debian stretch-backports main
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

evil_pixi

#10
Победил.   8)
подсказали поменять репозитории.
deb http://deb.debian.org/debian/ stretch main
#deb-src http://deb.debian.org/debian/ stretch main

deb http://deb.debian.org/debian/ stretch-updates main
#deb-src http://deb.debian.org/debian/ stretch-updates main

deb http://security.debian.org/debian-security/ stretch/updates main
#deb-src http://security.debian.org/debian-security/ stretch/updates main


руками вычистил файл  /var/lib/dpkg/status. всё что связано с ImageMagick
после это ещё несколько заходов на обновление. 
по итогу отвалился Апач.

переустановил, руками перебрал (так как в нем от isp manager конфиг) . модули поустанавливал.
осталось только как прикрутить возможность смены версии php для отдельного сайта  ;D



evil_pixi

Цитата: evil_pixi от 17 июня 2021, 14:25:37Попробуйте source.list привести к виду:
это ImageMagick мешался. 

dzhoser

Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

evil_pixi

А как пометить подскажите? я на этом форуме впервые. не вижу кнопки