Автор Тема: [РЕШЕНО]помогите плиз решить проблему с зависимостями.  (Прочитано 2936 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн user~21

  • Новичок форума
  • Topic Author
  • Сообщений: 5
Поставил пакет build-essential, и стали нужны заголовочные файлы ядра.
Начал ставить. но оно только и ругается на зависимости
# aptitude install linux-headers-2.6.32-5-686
Следующие НОВЫЕ пакеты будут установлены:       
  cpp-4.3{a} gcc-4.3{a} gcc-4.3-base{a} linux-headers-2.6.32-5-686 linux-headers-2.6.32-5-common{a} linux-kbuild-2.6.32{a}
0 пакетов обновлено, 6 установлено новых, 0 пакетов отмечено для удаления, и 7 пакетов не обновлено.
Необходимо получить 10,6 MB архивов. После распаковки 40,9 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  libgcc1: Ломает: gcc-4.3 (< 4.3.6-1) но устанавливается 4.3.5-4.
открыто: 12; закрыто: 114; отброшено: 7; конфликтует: 7                                                            .Следующие действия разрешат зависимости:

     Сохранить для следующих пакетов их текущие версии:
1)     gcc-4.3 [Не установлен]                         
2)     linux-headers-2.6.32-5-686 [Не установлен]     



Принять данное решение? [Y/n/q/?] y
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 7 пакетов не обновлено.
Необходимо получить 0 B архивов. После распаковки 0 B будет занято.
                                                 
# aptitude install gcc-4.3
Следующие НОВЫЕ пакеты будут установлены:       
  cpp-4.3{a} gcc-4.3 gcc-4.3-base{a}
0 пакетов обновлено, 3 установлено новых, 0 пакетов отмечено для удаления, и 7 пакетов не обновлено.
Необходимо получить 5 938 kB архивов. После распаковки 12,4 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  libgcc1: Ломает: gcc-4.3 (< 4.3.6-1) но устанавливается 4.3.5-4.
открыто: 62; закрыто: 159; отброшено: 5; конфликтует: 5                                                            .Следующие действия разрешат зависимости:

     Сохранить для следующих пакетов их текущие версии:
1)     gcc-4.3 [Не установлен]                         



Принять данное решение? [Y/n/q/?] y
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 7 пакетов не обновлено.
Необходимо получить 0 B архивов. После распаковки 0 B будет занято.
                                                 
# apt-get install gcc-4.3
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 default-jre-headless : Зависит: openjdk-6-jre-headless (>= 6b14) но он не будет установлен
 gcc-4.3 : Зависит: binutils (>= 2.19.1) но он не будет установлен
 libgcc1 : Ломает: gcc-4.3 (< 4.3.6-1) но 4.3.5-4 будет установлен
E: Сломанные пакеты
# apt-get install binutils
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Уже установлена самая новая версия binutils.
binutils установлен вручную.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 7 пакетов не обновлено.
Можно ли как-то проще их решить?

ps.
# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 6.0-updates (squeeze)
Release: 6.0-updates
Codename: squeeze
« Последнее редактирование: 14 Декабрь 2011, 00:19:12 от Metrix »
 


Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
Смотри пример офрмления /etc/apt/sources.list в howto.
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн user~21

  • Новичок форума
  • Topic Author
  • Сообщений: 5
Спасибо
 

Теги:
 

[Решено] Skype 7.*

Автор Tammy

Ответов: 5
Просмотров: 2259
Последний ответ 28 Октябрь 2018, 15:24:14
от dmitry1903
[Решено] Перемонтирование диска

Автор jidckii

Ответов: 5
Просмотров: 1575
Последний ответ 15 Январь 2014, 14:23:50
от jidckii
[РЕШЕНО] Как установить флешплеер?

Автор Babay

Ответов: 20
Просмотров: 7174
Последний ответ 03 Июнь 2015, 14:09:55
от ferum
Установка пакета без обновления системы из Synaptic [РЕШЕНО]

Автор Linuxnoob

Ответов: 9
Просмотров: 2128
Последний ответ 03 Май 2015, 15:49:55
от Linuxnoob
[Решено] Настройка Bugzilla

Автор bv7

Ответов: 5
Просмотров: 1946
Последний ответ 27 Январь 2013, 12:17:57
от bv7