Проблема с установкой пакетов (Unable to locate package)

Автор vasaiziza, 25 июля 2021, 13:02:39

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

vasaiziza

Добрый день!

Столкнулся с проблемой установкой пакетов на debian 10(buster), после попытки установить пакет получаю ошибку «Unable to locate package»
С данной проблемой столкнулся после замены материнской платы с h81m-e на h81i-plus, по характеристикам они одинаковые отличаются только по фарм-фактору.

sudo apt-get install lm-sensors
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package lm-sensors


Содержимое /etc/apt/sources.list

deb http://deb.debian.org/debian/ buster main
deb-src http://deb.debian.org/debian/ buster main

deb http://security.debian.org/debian-security buster/updates main
deb-src http://security.debian.org/debian-security buster/updates main

deb http://deb.debian.org/debian/ buster-updates main
deb-src http://deb.debian.org/debian/ buster-updates main


apt-get update && apt-get upgrade - не помогает.
Скажите, пожалуйста, с чем это может быть связанно и как устранить?

ihammers

Покажите вывод команды:
~# apt update

PS: если Вы не планируете собирать пакеты из исходников, то deb-src можно закоментиировать в файле.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

vasaiziza

Цитата: ihammers от 25 июля 2021, 15:12:21Покажите вывод команды:

Hit:1 http://deb.debian.org/debian buster InRelease
Hit:2 http://security.debian.org/debian-security buster/updates InRelease
Hit:3 http://deb.debian.org/debian buster-updates InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
5 packages can be upgraded. Run 'apt list --upgradable' to see them.


Цитата: ihammers от 25 июля 2021, 15:12:21PS: если Вы не планируете собирать пакеты из исходников, то deb-src можно закоментиировать в файле.
Спасибо, буду иметь ввиду, закоментировал.

ihammers

Ничего критичного нет. Как вариант попробуйте временно закомментировать все репозитарии и добавить один другой (например: https://mirror.yandex.ru/debian/). Обновить список пакетов с него и попытаться установить пакет, если получится закомментировать его и вернуть старые на прежнее место. Если нет, то проверяйте сеть, кеш apt.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

dzhoser

#4
Попробуйте с этими репозиториями
deb http://deb.debian.org/debian/ stable main contrib non-free
deb-src http://deb.debian.org/debian/ stable main contrib non-free

deb http://deb.debian.org/debian/ stable-updates main contrib non-free
deb-src http://deb.debian.org/debian/ stable-updates main contrib non-free

Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

vasaiziza

Цитата: dzhoser от 25 июля 2021, 23:01:54Попробуйте с этими репозитория и

Добрый вечер!
Это помогло.
Скажите, пожалуйста, а где можно ознакомиться чем отличаются эти репозитории?

dzhoser

Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков